Автор Тема: Непонятные проблемы с разрешением монитора в RUNTU  (Прочитано 539 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pcrepair

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 9
Добрый день.
Есть следующая ситуация:
- РС старый (775 сокет), встроенная в МВ видеокарта
- RUNTU 20 (клаун убунту)

при сборке (короткий(1 м) и тонкий видеокабель svga) разрешение экрана в автомате встало 1920х1080 и все было в норме

у пользователя пришлось использовать более длинный (1.8 м) и толстый кабель, в результате в автомате разрешение экрана упало 1024х768 и монитор определился как vga

Вопрос: как такое возможно с ядром линюкс 5(с копейками). ВЫНьХР и то лучше работает. что с этим делать в принципе

З.Ы. про xrandr уже читал, но еще не пробовал. это единственный вариант?

Заранее всем спасибо

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 2965
как такое возможно с ядром линюкс 5(с копейками). ВЫНьХР и то лучше работает. что с этим делать в принципе
Это не имеет отношения к версии ядра. Возможно, в кабеле отсутствует или повреждён контакт, передающий информацию EDID. Попробуйте заменить кабель на другой, заведомо исправный.

Оффлайн Pcrepair

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 9
кабелей было много опробованно. штук 8. и только два подошли
один самый первый (короткий и тонкий)
второй тоже тонкий, 2.5 м но дает "тень" на мониторе, не пойдет

все остальные были новые, чОрные, толстые(ну как толстые? просто потолще первого), гдето 1.8м

кстати под ВЫНьХР ВСЕ! кабели работали отлично. отсюда и замечание про версию ядра линюкс.
уже пятая! а по прежнему хуже чем ВЫНьХР. доколе?

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 2965
Pcrepair , приведите конкретные названия моделей материнской платы и монитора. В некоторых случаях можно обойти проблему, задав параметры разрешения в явном виде через xrandr.

кстати под ВЫНьХР ВСЕ! кабели работали отлично. отсюда и замечание про версию ядра линюкс.
Для "относительно не нового" оборудования не рекомендуется использовать последние версии ядер Linux. Возможно, стоит попробовать линейку ядер 3.х и дистрибутив версий 16.04-18.04.