Автор Тема: Вопрос по "битым пакетам"...  (Прочитано 1352 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lstt2005

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 4
Вопрос по "битым пакетам"...
« : Октябрь 17, 2019, 08:00:25 »
Доброго времени суток! Дистрибутив XFCE 18.04 x64..Сдуру задал обновления, не помню каких библиотек, сейчас при любых манипуляциях с пакетами одна и таже проблема:
Подготовка к распаковке …/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb …
Распаковывается xfce4-settings (4.12.4-0ubuntu0.18.04.1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb (--unpack):
 попытка перезаписать «/usr/share/locale/ru/LC_MESSAGES/xfce4-settings.mo», который уже имеется в пакете lite-mime-settings 0.1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb
Перепробовал все известные команды типа apt --fix-broken install, apt-get autoremove, чистил кэш пакетов, ничего не помогает...Кто что может подсказать?

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3174
Re: Вопрос по "битым пакетам"...
« Ответ #1 : Октябрь 17, 2019, 09:22:26 »

    Lstt2005, пакет  lite-mime-settings устанавливался только в версии LITE 18.04. Как он попал в Runtu XFCE? Уточните название образа дистрибутива, из которого устанавливали систему. В текущей ситуации для правки достаточно выполнить команды:
sudo aptitude purge lite-mime-settings
sudo apt-get update
sudo aptitude full-upgrade

Оффлайн Lstt2005

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 4
Re: Вопрос по "битым пакетам"...
« Ответ #2 : Октябрь 17, 2019, 09:49:26 »

    Lstt2005, пакет  lite-mime-settings устанавливался только в версии LITE 18.04. Как он попал в Runtu XFCE? Уточните название образа дистрибутива, из которого устанавливали систему. В текущей ситуации для правки достаточно выполнить команды:
sudo aptitude purge lite-mime-settings
sudo apt-get update
sudo aptitude full-upgrade
Спасибо за оперативный ответ! Да, Вы правы, перепутал название дистрибутива, конечно, LITE...Увы, вот полный лог полсе каждой команды -

~$ sudo aptitude purge lite-mime-settings
[  0%] Построение дерева зависимостей
Следующие пакеты будут УДАЛЕНЫ:                  
  lite-mime-settings{ap}
Следующие частично установленные пакеты будут настроены:
  desktop-file-utils hicolor-icon-theme mime-support xfce4{b} xfce4-session{b}
0 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки освободится 106 kБ.
Следующие пакеты имеют неудовлетворённые зависимости:
 xfce4-session : Зависит: xfce4-settings (>= 4.10.0) но его установка не запланирована
 xfce4 : Зависит: xfce4-settings (>= 4.12.0) но его установка не запланирована
Следующие действия разрешат зависимости:

     Установить следующие пакеты:                              
1)     xfce4-settings [4.12.4-0ubuntu0.18.04.1 (bionic-updates)]



Принять данное решение? [Y/n/q/?] Следующие НОВЫЕ пакеты будут установлены:
  xfce4-settings{a}
Следующие пакеты будут УДАЛЕНЫ:
  lite-mime-settings{ap}
Следующие частично установленные пакеты будут настроены:
  desktop-file-utils hicolor-icon-theme mime-support xfce4 xfce4-session
Следующие пакеты РЕКОМЕНДОВАНЫ, но установлены НЕ БУДУТ:
  greybird-gtk-theme xubuntu-icon-theme
0 пакетов обновлено, 1 установлено новых, 1 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 Б/481 kБ архивов. После распаковки 2 742 kБ будет занято.
Хотите продолжить? [Y/n/?]
(Чтение базы данных … на данный момент установлено 214066 файлов и каталогов.)
Подготовка к распаковке …/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb …
Распаковывается xfce4-settings (4.12.4-0ubuntu0.18.04.1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb (--unpack):
 попытка перезаписать «/usr/share/locale/ru/LC_MESSAGES/xfce4-settings.mo», который уже имеется в пакете lite-mime-settings 0.1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: зависимости пакетов не позволяют настроить пакет xfce4-session:
 xfce4-session зависит от xfce4-settings (>= 4.10.0), однако:
  Пакет xfce4-settings не установлен.

dpkg: ошибка при обработке пакета xfce4-session (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xfce4:
 xfce4 зависит от xfce4-settings (>= 4.12.0), однако:
  Пакет xfce4-settings не установлен.
 xfce4 зависит от xfce4-session (>= 4.12.0), однако:
  Пакет xfce4-session пока не настроен.

dpkg: ошибка при обработке пакета xfce4 (--configure):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.23-1ubuntu3.18.04.2) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Обрабатываются триггеры для mime-support (3.60ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 xfce4-session
 xfce4

$ sudo apt-get update
Сущ:1 http://ru.archive.ubuntu.com/ubuntu bionic InRelease
Сущ:2 http://ru.archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                                                          
Сущ:3 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic InRelease                                                                                                    
Сущ:4 http://ru.archive.ubuntu.com/ubuntu bionic-backports InRelease                                                                                                                        
Сущ:5 http://security.ubuntu.com/ubuntu bionic-security InRelease                                                                                                                          
Игн:6 http://download.webmin.com/download/repository sarge InRelease                                                                                                                        
Сущ:7 http://ppa.launchpad.net/eivnaes/network-manager-sstp/ubuntu bionic InRelease                                                                                      
Сущ:8 http://ppa.launchpad.net/fsnow/ppa/ubuntu bionic InRelease                                                                                                                            
Сущ:9 http://download.webmin.com/download/repository sarge Release                                                                                                                          
Сущ:10 http://ppa.launchpad.net/libreoffice/ppa/ubuntu bionic InRelease                                                                                                                    
Сущ:11 https://deb.nodesource.com/node_10.x bionic InRelease                                                                    
Сущ:12 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease                                                              
Сущ:13 http://ppa.launchpad.net/starws-box/deadbeef-player/ubuntu bionic InRelease      
Чтение списков пакетов… Готово                                                  

sudo aptitude full-upgrade
Следующие частично установленные пакеты будут настроены:
  xfce4{b} xfce4-session{b}
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки 0 Б будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 xfce4-session : Зависит: xfce4-settings (>= 4.10.0) но его установка не запланирована
 xfce4 : Зависит: xfce4-settings (>= 4.12.0) но его установка не запланирована
Следующие действия разрешат зависимости:

     Установить следующие пакеты:                               
1)     xfce4-settings [4.12.4-0ubuntu0.18.04.1 (bionic-updates)]



Принять данное решение? [Y/n/q/?]
Следующие НОВЫЕ пакеты будут установлены:
  xfce4-settings{a}
Следующие частично установленные пакеты будут настроены:
  xfce4 xfce4-session
Следующие пакеты РЕКОМЕНДОВАНЫ, но установлены НЕ БУДУТ:
  greybird-gtk-theme xubuntu-icon-theme
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 Б/481 kБ архивов. После распаковки 2 849 kБ будет занято.
Хотите продолжить? [Y/n/?]
(Чтение базы данных … на данный момент установлено 214066 файлов и каталогов.)
Подготовка к распаковке …/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb …
Распаковывается xfce4-settings (4.12.4-0ubuntu0.18.04.1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb (--unpack):
 попытка перезаписать «/usr/share/locale/ru/LC_MESSAGES/xfce4-settings.mo», который уже имеется в пакете lite-mime-settings 0.1
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/xfce4-settings_4.12.4-0ubuntu0.18.04.1_amd64.deb
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: зависимости пакетов не позволяют настроить пакет xfce4-session:
 xfce4-session зависит от xfce4-settings (>= 4.10.0), однако:
  Пакет xfce4-settings не установлен.

dpkg: ошибка при обработке пакета xfce4-session (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xfce4:
 xfce4 зависит от xfce4-settings (>= 4.12.0), однако:
  Пакет xfce4-settings не установлен.
 xfce4 зависит от xfce4-session (>= 4.12.0), однако:
  Пакет xfce4-session пока не настроен.

dpkg: ошибка при обработке пакета xfce4 (--configure):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.23-1ubuntu3.18.04.2) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Обрабатываются триггеры для mime-support (3.60ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 xfce4-session
 xfce4

Получается, ничего не изменилось..((
« Последнее редактирование: Октябрь 17, 2019, 09:57:30 от Lstt2005 »

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3174
Re: Вопрос по "битым пакетам"...
« Ответ #3 : Октябрь 17, 2019, 10:14:25 »

    Lstt2005, приведите вывод:
sudo aptitude purge xfce4-session xfce4 xfce4-settingsТакже выполните
dpkg -l > packages.txtполучившийся файл разместите на внешнем ресурсе и дайте ссылку.

Оффлайн Lstt2005

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 4
Re: Вопрос по "битым пакетам"...
« Ответ #4 : Октябрь 17, 2019, 11:31:34 »

    Lstt2005, приведите вывод:
sudo aptitude purge xfce4-session xfce4 xfce4-settingsТакже выполните
dpkg -l > packages.txtполучившийся файл разместите на внешнем ресурсе и дайте ссылку.
Это помогло..Спасибо!
Ещё позволю вопрос - как правильно и проще организовать удаленный доступ к этому рабочему столы x11vnc - плюс UltraVNC  viewer на стороне Windows или как-то по-другому, Не подскажите?