Автор Тема: Не запускается Runtu Lxde 10.04 после апгрейта ядра (решено)  (Прочитано 4436 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн radist_serg

  • Новичок
  • **
  • Автор темы
  • Сообщений: 90
Пару часов назад поимел "стресс на шару"...
Обновился в т.ч. и по ядру (до 2.6.32.-27.49) и впервые (та что там проерять, должно быть все нормально) снес предыдущее ядро, не проверив работу системы с новым...
Перезагрузка... и после картинки Рунту черный экран с надписью о проверке батареи... Перезагрузка в режим восстановления - ноль эффекта от всех манипуляций.
Как решил: загрузился под убунтой 9.04 сына (у нас общий системник), думаю, сгодился бы и live-cd, скачал старое ядро с http://kernel.ubuntu.com/~kernel-ppa/mainline/ (скачал -23), создал в своей домашней папке Рунту папку kernel, в нее слил эти 3 пакета, перегрузился, выбрал режим восстановления, в нем - обычную загрузку.
Ну а дальше - залогинился, потом перешел в папку kernel, в моем случае cd /home/sergey/kernelну а потом проинсталировал ядро sudo dpkg -i *.debПроапгрейдил груб sudo update-grubперезагрузился и выбрал вновь установленное старое ядро. И система загрузилась...
Мораль очевидна: не все обновления одинаково полезны, а уж ядра предыдущие так точно не торопитесь сносить! :)
Коды привел для таких же как я "знатоков" (самому гуглить пришлось :) )...Вдруг кому пригодится...
ЗЫ Да, система - Атлон на Nvidia, видеокарта - GF-7600, подозреваю проблему именно с иксами...
« Последнее редактирование: Декабрь 11, 2010, 02:22:48 от radist_serg »

Оффлайн imp

  • Новичок
  • **
  • Сообщений: 27
 :) :) :) Не дай господь обновлять ядро, даже врагу!

Оффлайн Universe

  • Global Moderator
  • *****
  • Сообщений: 270
:) :) :) Не дай господь обновлять ядро, даже врагу!
К чему здесь эти высказывания?
Я нормально обновляюсь, и все работает.
Тем более, в grub всегда есть вариант загрузки старого ядра. Надо просто помнить, что сносить старое ядро следует только после неоднократного тестирования работоспособности системы на новом.

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Ваша проблема, скорее всего, в том, что вы не установили headers для нового ядра. (пакет linux-headers-2.6...)
В результате не перекомпилировались модули nvidia.
Я тоже наступал на эти грабли.
Что-бы процесс автоматизировался нужно присутствие пакета linux-headers-generic

Оффлайн radist_serg

  • Новичок
  • **
  • Автор темы
  • Сообщений: 90
vmf

Не думаю, ядро ведь ставилось через обновление (синаптик).
Кстати сегодня для эксперимента попробовал 2.6.36 - на форуме убунту.ру народ ставил его на 10.04 - результат такой же...
Видно 7600 agp по нынешним временам слишком старая видеокарта...

Оффлайн maksipes

  • Global Moderator
  • *****
  • Сообщений: 116
Не думаю, ядро ведь ставилось через обновление (синаптик).
headers могут и не поставиться.
Видно 7600 agp по нынешним временам слишком старая видеокарта...
Не agp, но nvidia 7600 GS + kernel 2.6.36 + nvidia 260.19.21

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Не думаю, ядро ведь ставилось через обновление (синаптик).
Если в системе отсутствовал пакет linux-headers-generic, то linux-headers-2.6.35 не обновится.
Как и, если нет пакета linux-generic, то ядро (linux-image...) обновляться не будет.
Сами пакеты linux-generic и linux-headers-generic для работы системы не нужны, они просто тянут при обновлении по зависимостям новое ядро и его header-ы.