Автор Тема: lucid-backports+nvidia=problem  (Прочитано 6618 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Slip

  • Новичок
  • **
  • Автор темы
  • Сообщений: 93
  • UNIX никогда не скажет „пожалуйста“.
    • NetLife
lucid-backports+nvidia=problem
« : Ноябрь 19, 2010, 20:21:28 »


Система Ubuntu 10.04, ядро 2.6.32.
Подключил lucid-backports, установил 2.6.35

linux-headers-2.6.35-22_2.6.35-22.34~lucid1_all.deb
linux-headers-2.6.35-22-generic_2.6.35-22.34~lucid1_i386.deb
linux-image-2.6.35-22-generic_2.6.35-22.34~lucid1_i386.deb

Проприетарные драйвера, естественно, работать перестали. Снес их, попытался поставить. jockey-gtk драйвер скачивает, но вылетает с ошибкой
SystemError: installArchives() failed

Синаптик при установке тех же драйверов выдает:

Система Ubuntu 10.04, ядро 2.6.32.
Подключил lucid-backports, установил 2.6.35

linux-headers-2.6.35-22_2.6.35-22.34~lucid1_all.deb
linux-headers-2.6.35-22-generic_2.6.35-22.34~lucid1_i386.deb
linux-image-2.6.35-22-generic_2.6.35-22.34~lucid1_i386.deb

Проприетарные драйвера, естественно, работать перестали. Снес их, попытался поставить. jockey-gtk драйвер скачивает, но вылетает с ошибкой
SystemError: installArchives() failed

Синаптик при установке тех же драйверов выдает:
E: nvidia-173: подпроцесс установлен сценарий post-installation возвратил код ошибки 10

Выбор ранее не выбранного пакета nvidia-173.
(Чтение базы данных ... на данный момент установлено 159700 файлов и каталогов.)
Распаковывается пакет nvidia-173 (из файла .../nvidia-173_173.14.22-0ubuntu11_i386.deb)...
Выбор ранее не выбранного пакета nvidia-173-modaliases.
Распаковывается пакет nvidia-173-modaliases (из файла .../nvidia-173-modaliases_173.14.22-0ubuntu11_i386.deb)...
Обрабатываются триггеры для man-db ...
Настраивается пакет nvidia-173 (173.14.22-0ubuntu11) ...
Loading new nvidia-173-173.14.22 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.35-22-generic
Building for architecture i686
Building initial module for 2.6.35-22-generic

Error! Bad return status for module build on kernel: 2.6.35-22-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-173/173.14.22/build/ for more information.
dpkg: не удалось обработать параметр nvidia-173 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Настраивается пакет nvidia-173-modaliases (173.14.22-0ubuntu11) ...
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_UA.utf8.cache...
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-173
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ошибка установки пакета. Попытка восстановления:
Настраивается пакет nvidia-173 (173.14.22-0ubuntu11) ...
Removing old nvidia-173-173.14.22 DKMS files...

------------------------------
Deleting module version: 173.14.22
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-173-173.14.22 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.35-22-generic
Building for architecture i686
Building initial module for 2.6.35-22-generic

Error! Bad return status for module build on kernel: 2.6.35-22-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-173/173.14.22/build/ for more information.
dpkg: не удалось обработать параметр nvidia-173 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_UA.utf8.cache...
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-173


Содержимое /var/lib/dkms/nvidia-173/173.14.22/build/make.log :

DKMS make.log for nvidia-173-173.14.22 for kernel 2.6.35-22-generic (i686)
Птн Ноя 19 18:57:59 EET 2010
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Ошибка 1


Установил linux-source-2.6.35_2.6.35-22.35_all.deb
Выбор ранее не выбранного пакета linux-source-2.6.35.
(Чтение базы данных ... на данный момент установлено 159790 файлов и каталогов.)
Распаковывается пакет linux-source-2.6.35 (из файла linux-source-2.6.35_2.6.35-22.35_all.deb)...
Настраивается пакет linux-source-2.6.35 (2.6.35-22.35) ...


Попробовал еще раз поставить драйвера. Результат тот же.

Что еще можно сделать, установить?


Оффлайн Feduka

  • Активист
  • ****
  • Сообщений: 428
  • Меняю путина на Ходорковского
Re: lucid-backports+nvidia=problem
« Ответ #1 : Ноябрь 19, 2010, 20:35:00 »
почти наверняка можно скачть бинарник с сайта нвидии и установить по инструкции - прибить х-сервер, запустить бинарник, дождаться, пока оно скомпилирует модули, снова поднять Х-ы. Правда при смене ядра все заново :)
Ну и для удачной компиляции нужны пакеты с компиляторами и хидерами ядра.
2:5020/655.11

Оффлайн Slip

  • Новичок
  • **
  • Автор темы
  • Сообщений: 93
  • UNIX никогда не скажет „пожалуйста“.
    • NetLife
Re: lucid-backports+nvidia=problem
« Ответ #2 : Ноябрь 19, 2010, 20:49:23 »
почти наверняка можно скачть бинарник с сайта нвидии и установить по инструкции - прибить х-сервер, запустить бинарник, дождаться, пока оно скомпилирует модули, снова поднять Х-ы. Правда при смене ядра все заново :)

Ставить с бинарника - не Ubuntu way

Ну и для удачной компиляции нужны пакеты с компиляторами и хидерами ядра.

dkms, make, хидеры и исходники ядра установлены. Пробовал ставить build-essential, результат прежний.



Оффлайн butjapka

  • Местный
  • *****
  • Сообщений: 1143
  • Компьютер думает так, как думает его хозяин.
Re: lucid-backports+nvidia=problem
« Ответ #3 : Ноябрь 20, 2010, 17:00:28 »
 а что за видео карточка у вас? Может она как и моя (радеон 9600 про) не поддерживается уже в этом дистрибутиве

Оффлайн Slip

  • Новичок
  • **
  • Автор темы
  • Сообщений: 93
  • UNIX никогда не скажет „пожалуйста“.
    • NetLife
Re: lucid-backports+nvidia=problem
« Ответ #4 : Ноябрь 20, 2010, 18:39:59 »
NVIDIA GeForce FX 5500.
Если загрузиться в 10.10 в ЛайвСД, то драйвера находятся и ставятся, требует перезагрузиться. Т.е., получается, что карточка поддерживается.


Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
Re: lucid-backports+nvidia=problem
« Ответ #5 : Ноябрь 20, 2010, 20:21:18 »
У меня до сентября этого года была FX5700LE, работала на тех же дровах 173 под 10.04 прекрасно.
Поменял в результате апгрейда.
Но не с 35 ядром, конечно
Возможно, она перестала поддерживаться в новом ядре? Хотя маловероятно
А с предыдущими ядрами все ОК? Может, имеет смысл вернуться на предыдущую версию ядра?
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)

Оффлайн Slip

  • Новичок
  • **
  • Автор темы
  • Сообщений: 93
  • UNIX никогда не скажет „пожалуйста“.
    • NetLife
Re: lucid-backports+nvidia=problem
« Ответ #6 : Ноябрь 21, 2010, 13:18:22 »
А с предыдущими ядрами все ОК? Может, имеет смысл вернуться на предыдущую версию ядра?
Да, с 2.6.32 все ок, да и с 2.6.35, но только если в 10.10 (livecd). А вот в 10.04 с 2.6.35 не хочет, по ходу модуль не собирается, не знаю почему. Вернулся на 2.6.32.