Автор Тема: Проблема с системой после установки пакетов  (Прочитано 3207 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dedok

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Установил фаервол Firestarter, добавил его в автозагрузку, перезагрузился,
В результате, меню автозагрузки в панели не открывается (просто никакой реакции),
из автозагрузки "выпало" несколько установленных программ, интернет (GPRS) не подключается и не настраивается (выдаёт "ошибка открытия редактора")
 Удалял фаервол через синаптик, но всё по прежнему хреново.
Поскольку недавно (ввиду слабости компа) перешел с виндовс, то могу сказать,
что в винде, при загрузке с установочного диска можно проверить (восстановить) систему без геморроя (правда установленные обновления пропадут)
Скажите, как с установочного диска Рунту можно проверить (восстановить) систему.
Есть ли вообще такая возможность.
Спасибо
« Последнее редактирование: Сентябрь 30, 2013, 11:38:38 от dedok »

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3210
Re: Проблема с системой после установки пакетов
« Ответ #1 : Сентябрь 30, 2013, 13:02:58 »

  Уточните, какой дистрибутив используете? При установке Firestarter были сообщения об ошибках (конфликт пакетов, удаление других программ)? Сколько свободного места на диске? Под другим пользователем (гостем) система загружается нормально?

Оффлайн dedok

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Re: Проблема с системой после установки пакетов
« Ответ #2 : Сентябрь 30, 2013, 13:25:27 »
Дистрибутив Runtu LITE 10.04, примерно неделю назад установил обновления, новое ядро,
всё до установки  Firestarter было отлично, при установке фаервола ошибок, и др. не было, под старым ядром загружался, тоже не работает.
Свободного места на диске 16 гиг.
Гостевой записи нет, я единственный пользователь.
Если что то сложное то  я уж лучше переустановлю систему, скажите не стесняйтесь  ;D
« Последнее редактирование: Сентябрь 30, 2013, 14:00:55 от dedok »

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3210
Re: Проблема с системой после установки пакетов
« Ответ #3 : Сентябрь 30, 2013, 16:41:21 »

       Приведите вывод выполнения:
uname -a
lsb_release -a
sudo aptitude update
sudo aptitude full-upgrade

Оффлайн dedok

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Re: Проблема с системой после установки пакетов
« Ответ #4 : Сентябрь 30, 2013, 19:02:36 »
....  сейчас включил комп ... установилось соединение с интернетом  :o
 в терминале ввёл " ob-autostart "  написало вот
Цитировать (выделенное)
shalom@shalom-desktop:~$ ob-autostart
Traceback (most recent call last):
  File "/usr/bin/ob-autostart", line 404, in <module>
    execfile("%s/.config/ob-autostart/config" % home)
  File "/home/shalom/.config/ob-autostart/config", line 5
    ("Firestarter","sudo /usr/sbin/firestarter --start-hidden
                                                            ^
SyntaxError: EOL while scanning string literal

shalom@shalom-desktop:~$
ввёл  " sudo ob-autostart " ,  открылось окно "автозагрузка программ" но в нём нет ничего, хотя раньше чего то там было...  ::)

... в общем благодарю, интернет работает, для знакомства с системой вполне достаточно.


 
 

 

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3210
Re: Проблема с системой после установки пакетов
« Ответ #5 : Сентябрь 30, 2013, 23:33:53 »

   Firestarter при установке автоматически добавляется в автозагрузку (/etc/init.d/firestarter), дополнтельно ничего делать не нужно.

    ("Firestarter","sudo /usr/sbin/firestarter --start-hidden
  Для графических приложений нужно использовать не sudo, а gksu/gksudo. Авторизация с помощью sudo производится в текстовом терминале.
  Добавлять таким образом приложения в пользовательскую автозагрузку не нужно.

ввёл  " sudo ob-autostart " ,  открылось окно "автозагрузка программ" но в нём нет ничего, хотя раньше чего то там было...  ::)
  Потому-что у вас открылся конфиг пользователя root, который по-умолчанию отсутствует (пустой).

  Откройте через текстовый редактор (без sudo) файл ~/.config/ob-autostart/config и удалите строку, содержащую команду запуска Firestarter :
leafpad ~/.config/ob-autostart/config  Сохраните изменения и перелогиньтесь.

Оффлайн dedok

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Re: Проблема с системой после установки пакетов
« Ответ #6 : Сентябрь 30, 2013, 23:58:19 »
 О, великий и всемогущий Админ, ... всё заработало   :o  Вы просто кудесник програмных кодов  ;D