Автор Тема: Совместимость пакетов между дистрибутивами???  (Прочитано 3351 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн monstrman

  • Новичок
  • **
  • Автор темы
  • Сообщений: 39
 Скажите пожалуйста, на примере таком, поставил рунту 9.04, чтобы поставить на нее оперу, нужен был пакет libcurl3.deb ранее скачивал такой пакет для рунту 8.04, попробовал установить - проканало, и опера поставилась. Скачивал с пакагес.убунту.ком, там для каждого дистрибутива поиск. Я думал что пакеты только к своему дистрибутиву подходят, а оказалось что и к другим тоже. так объясните можно ли так делать, т.е. ставить пакеты от другого устаревшего или наоборот более нового дистрибутива и чем это черевато?

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Если система управления пакетами пропускает по зависимостям, можно не беспокоиться, имхо.

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3173
Я думал что пакеты только к своему дистрибутиву подходят, а оказалось что и к другим тоже.
     Зависимости для установки определяются в файле DEBIAN/control - там указаны названия и версии требующихся пакетов. Версии могут указываться в виде <<,  <=,  =,  >=, >> ("строго меньше", "меньше или равно", "строго равно", "больше или равно", "строго больше" ).

   Если все требования версий зависимостей удовлетворяются, то пакет может быть установлен.

можно ли так делать, т.е. ставить пакеты от другого устаревшего или наоборот более нового дистрибутива и чем это черевато?
     Рекомендуется устанавливать пакеты штатных для текущего дистрибутива версий, так как наличие в системе более новых или старых пакетов может привести к конфликту пакетной базы. Необходимо очень внимательно читать сообщения пакетного менеджера при установке нештатных версий перед принятием изменений.