Автор Тема: Проблема с расширением Web-eId в Runtu XFCE 22.04 x64  (Прочитано 1609 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн unaednik

  • Новичок
  • **
  • Автор темы
  • Сообщений: 42
Скрипт ID-расширений отрабатывает установку без проблем, но в браузере FireFox расширение Web-eId не отображается, что не позволяет использовать подпись online :о(

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3486
Скрипт ID-расширений отрабатывает установку без проблем
Покажите полный вывод выполнения скрипта в терминале - скопировать текст вывода и вставить в сообщение с тегом "Код".

Оффлайн unaednik

  • Новичок
  • **
  • Автор темы
  • Сообщений: 42
Вот этот вывод:

runtu@runtu:~$ cd Загрузки
runtu@runtu:~/Загрузки$ ls
install-open-eid.sh
runtu@runtu:~/Загрузки$ sh install-open-eid.sh
Adding RIA repository to APT sources list (/etc/apt/sources.list.d/ria-repository.list)
deb [signed-by=/usr/share/keyrings/ria-repository.gpg] https://installer.id.ee/media/ubuntu/ jammy main
Adding key to trusted key set
0xC6C83D68 'RIA Software Signing Key <signing@ria.ee>'
Installing software (apt-get update && apt-get install open-eid)
Пол:1 https://installer.id.ee/media/ubuntu jammy InRelease [3 134 B]
Пол:2 http://archive.ubuntu.com/ubuntu jammy InRelease [270 kB]                         
Пол:3 https://installer.id.ee/media/ubuntu jammy/main amd64 Packages [6 277 B]           
Пол:4 http://archive.canonical.com/ubuntu jammy InRelease [11,4 kB]                     
Пол:5 https://ppa.launchpadcontent.net/alex-p/deadbeef/ubuntu jammy InRelease [17,6 kB] 
Пол:6 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]   
Пол:7 http://archive.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                 
Пол:8 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [108 kB]               
Пол:9 https://ppa.launchpadcontent.net/eivnaes/network-manager-sstp/ubuntu jammy InRelease [18,1 kB]
Пол:10 http://archive.ubuntu.com/ubuntu jammy/main amd64 Packages [1 395 kB]
Пол:11 https://ppa.launchpadcontent.net/helkaluin/webp-pixbuf-loader/ubuntu jammy InRelease [17,6 kB]
Пол:12 http://archive.ubuntu.com/ubuntu jammy/main Translation-ru [344 kB]               
Пол:13 http://archive.ubuntu.com/ubuntu jammy/main amd64 c-n-f Metadata [30,3 kB]       
Пол:14 http://archive.ubuntu.com/ubuntu jammy/restricted amd64 Packages [129 kB]         
Пол:15 http://archive.ubuntu.com/ubuntu jammy/restricted Translation-ru [896 B]         
Пол:16 http://archive.ubuntu.com/ubuntu jammy/restricted amd64 c-n-f Metadata [488 B]   
Пол:17 http://archive.ubuntu.com/ubuntu jammy/universe amd64 Packages [14,1 MB]         
Пол:18 https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu jammy InRelease [23,8 kB]
Пол:19 https://ppa.launchpadcontent.net/alex-p/deadbeef/ubuntu jammy/main amd64 Packages [1 784 B]
Пол:20 http://archive.ubuntu.com/ubuntu jammy/universe Translation-ru [1 369 kB]         
Пол:21 https://ppa.launchpadcontent.net/eivnaes/network-manager-sstp/ubuntu jammy/main amd64 Packages [1 344 B]
Пол:22 https://ppa.launchpadcontent.net/helkaluin/webp-pixbuf-loader/ubuntu jammy/main amd64 Packages [532 B]
Пол:23 https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu jammy/main amd64 Packages [33,9 kB]
Пол:24 http://archive.ubuntu.com/ubuntu jammy/universe amd64 c-n-f Metadata [286 kB]     
Пол:25 http://archive.ubuntu.com/ubuntu jammy/multiverse amd64 Packages [217 kB]
Пол:26 http://archive.ubuntu.com/ubuntu jammy/multiverse Translation-ru [68,5 kB]
Пол:27 http://archive.ubuntu.com/ubuntu jammy/multiverse amd64 c-n-f Metadata [8 372 B]
Пол:28 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages [579 kB]
Пол:29 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 c-n-f Metadata [14,4 kB]
Пол:30 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 Packages [226 kB]
Пол:31 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 c-n-f Metadata [604 B]
Пол:32 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 Packages [887 kB]
Пол:33 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 c-n-f Metadata [18,8 kB]
Пол:34 http://archive.ubuntu.com/ubuntu jammy-updates/multiverse amd64 Packages [35,3 kB]
Пол:35 http://archive.ubuntu.com/ubuntu jammy-updates/multiverse amd64 c-n-f Metadata [468 B]
Пол:36 http://archive.ubuntu.com/ubuntu jammy-security/main amd64 Packages [363 kB]
Пол:37 http://archive.ubuntu.com/ubuntu jammy-security/main amd64 c-n-f Metadata [9 732 B]
Пол:38 http://archive.ubuntu.com/ubuntu jammy-security/restricted amd64 Packages [225 kB]
Пол:39 http://archive.ubuntu.com/ubuntu jammy-security/restricted amd64 c-n-f Metadata [604 B]
Пол:40 http://archive.ubuntu.com/ubuntu jammy-security/universe amd64 Packages [709 kB]
Пол:41 http://archive.ubuntu.com/ubuntu jammy-security/universe amd64 c-n-f Metadata [14,3 kB]
Пол:42 http://archive.ubuntu.com/ubuntu jammy-security/multiverse amd64 Packages [30,2 kB]
Пол:43 http://archive.ubuntu.com/ubuntu jammy-security/multiverse amd64 c-n-f Metadata [252 B]
Пол:44 http://archive.ubuntu.com/ubuntu jammy-backports/restricted amd64 c-n-f Metadata [116 B]
Пол:45 http://archive.ubuntu.com/ubuntu jammy-backports/main amd64 Packages [40,9 kB]
Пол:46 http://archive.ubuntu.com/ubuntu jammy-backports/main amd64 c-n-f Metadata [388 B]
Пол:47 http://archive.ubuntu.com/ubuntu jammy-backports/multiverse amd64 c-n-f Metadata [116 B]
Пол:48 http://archive.ubuntu.com/ubuntu jammy-backports/universe amd64 Packages [22,2 kB]
Пол:49 http://archive.ubuntu.com/ubuntu jammy-backports/universe amd64 c-n-f Metadata [548 B]
Получено 21,9 MB за 6с (3 941 kB/s)                               
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово         
Будут установлены следующие дополнительные пакеты:
  firefox-pkcs11-loader gir1.2-nautilus-3.0 jq libccid libdigidocpp-common libdigidocpp1
  libjq1 libnss3-tools libonig5 libqt6core5compat6 libqt6core6 libqt6dbus6 libqt6gui6
  libqt6network6 libqt6opengl6 libqt6printsupport6 libqt6svg6 libqt6svgwidgets6
  libqt6widgets6 libts0 libxalan-c112 libxerces-c3.2 libxml-security-c20 opensc-pkcs11
  pcscd python3-nautilus qdigidoc4 qt6-qpa-plugins web-eid web-eid-native
Рекомендуемые пакеты:
  qt6-gtk-platformtheme libdigidocpp-tools web-eid-firefox web-eid-chrome
Следующие НОВЫЕ пакеты будут установлены:
  firefox-pkcs11-loader gir1.2-nautilus-3.0 jq libccid libdigidocpp-common libdigidocpp1
  libjq1 libnss3-tools libonig5 libqt6core5compat6 libqt6core6 libqt6dbus6 libqt6gui6
  libqt6network6 libqt6opengl6 libqt6printsupport6 libqt6svg6 libqt6svgwidgets6
  libqt6widgets6 libts0 libxalan-c112 libxerces-c3.2 libxml-security-c20 open-eid opensc
  opensc-pkcs11 pcscd python3-nautilus qdigidoc4 qt6-qpa-plugins web-eid web-eid-native
Обновлено 0 пакетов, установлено 32 новых пакетов, для удаления отмечено 0 пакетов, и 347 пакетов не обновлено.
Необходимо скачать 17,8 MB архивов.
После данной операции объём занятого дискового пространства возрастёт на 60,2 MB.
Хотите продолжить? [Д/н]
Пол:1 https://installer.id.ee/media/ubuntu jammy/main amd64 libdigidocpp-common all 3.15.0.1436-2204 [20,9 kB]
Пол:2 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libccid amd64 1.5.0-2 [83,1 kB]
Пол:3 https://installer.id.ee/media/ubuntu jammy/main amd64 libxml-security-c20 amd64 2.0.4-4RIA0 [316 kB]
Пол:4 https://installer.id.ee/media/ubuntu jammy/main amd64 libdigidocpp1 amd64 3.15.0.1436-2204 [526 kB]
Пол:5 http://archive.ubuntu.com/ubuntu jammy/universe amd64 pcscd amd64 1.9.5-3 [57,8 kB]
Пол:6 https://installer.id.ee/media/ubuntu jammy/main amd64 firefox-pkcs11-loader all 3.13.6.1084-2004 [14,6 kB]
Пол:7 https://installer.id.ee/media/ubuntu jammy/main amd64 web-eid-native amd64 2.3.0.619-2204 [982 kB]
Пол:8 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 gir1.2-nautilus-3.0 amd64 1:42.2-0ubuntu2.1 [5 332 B]
Пол:9 http://archive.ubuntu.com/ubuntu jammy/main amd64 libonig5 amd64 6.9.7.1-2build1 [172 kB]
Пол:10 http://archive.ubuntu.com/ubuntu jammy/main amd64 libjq1 amd64 1.6-2.1ubuntu3 [133 kB]
Пол:11 http://archive.ubuntu.com/ubuntu jammy/main amd64 jq amd64 1.6-2.1ubuntu3 [52,5 kB]
Пол:12 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libxerces-c3.2 amd64 3.2.3+debian-3build1 [930 kB]
Пол:13 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libxalan-c112 amd64 1.12-6build1 [720 kB]
Пол:14 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libnss3-tools amd64 2:3.68.2-0ubuntu1.2 [565 kB]
Пол:15 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libqt6core6 amd64 6.2.4+dfsg-2ubuntu1.1 [1 789 kB]
Пол:16 https://installer.id.ee/media/ubuntu jammy/main amd64 web-eid all 2.3.0.619-2204 [2 016 B]
Пол:17 https://installer.id.ee/media/ubuntu jammy/main amd64 qdigidoc4 amd64 4.3.0.4438-2204 [2 266 kB]
Пол:18 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libqt6core5compat6 amd64 6.2.4-1 [144 kB]
Пол:19 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libqt6dbus6 amd64 6.2.4+dfsg-2ubuntu1.1 [292 kB]
Пол:20 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libqt6gui6 amd64 6.2.4+dfsg-2ubuntu1.1 [2 577 kB]
Пол:21 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libqt6network6 amd64 6.2.4+dfsg-2ubuntu1.1 [645 kB]
Пол:22 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libqt6opengl6 amd64 6.2.4+dfsg-2ubuntu1.1 [236 kB]
Пол:23 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libqt6widgets6 amd64 6.2.4+dfsg-2ubuntu1.1 [2 627 kB]
Пол:24 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 libqt6printsupport6 amd64 6.2.4+dfsg-2ubuntu1.1 [227 kB]
Пол:25 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libqt6svg6 amd64 6.2.4-1ubuntu1 [159 kB]
Пол:26 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libqt6svgwidgets6 amd64 6.2.4-1ubuntu1 [19,4 kB]
Пол:27 http://archive.ubuntu.com/ubuntu jammy/universe amd64 libts0 amd64 1.22-1 [62,0 kB]
Пол:28 http://archive.ubuntu.com/ubuntu jammy/universe amd64 opensc-pkcs11 amd64 0.22.0-1ubuntu2 [933 kB]
Пол:29 http://archive.ubuntu.com/ubuntu jammy/universe amd64 opensc amd64 0.22.0-1ubuntu2 [346 kB]
Пол:30 http://archive.ubuntu.com/ubuntu jammy/universe amd64 python3-nautilus amd64 1.2.3-3.1build1 [19,4 kB]
Пол:31 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 qt6-qpa-plugins amd64 6.2.4+dfsg-2ubuntu1.1 [867 kB]
Пол:32 https://installer.id.ee/media/ubuntu jammy/main amd64 open-eid all 23.3.0.1936-2204 [3 264 B]
Получено 17,8 MB за 4с (4 702 kB/s)       
Извлекаются шаблоны из пакетов: 100%
Выбор ранее не выбранного пакета libccid.
(Чтение базы данных … на данный момент установлено 165138 файлов и каталогов.)
Подготовка к распаковке …/00-libccid_1.5.0-2_amd64.deb …
Распаковывается libccid (1.5.0-2) …
Выбор ранее не выбранного пакета pcscd.
Подготовка к распаковке …/01-pcscd_1.9.5-3_amd64.deb …
Распаковывается pcscd (1.9.5-3) …
Выбор ранее не выбранного пакета gir1.2-nautilus-3.0:amd64.
Подготовка к распаковке …/02-gir1.2-nautilus-3.0_1%3a42.2-0ubuntu2.1_amd64.deb …
Распаковывается gir1.2-nautilus-3.0:amd64 (1:42.2-0ubuntu2.1) …
Выбор ранее не выбранного пакета libonig5:amd64.
Подготовка к распаковке …/03-libonig5_6.9.7.1-2build1_amd64.deb …
Распаковывается libonig5:amd64 (6.9.7.1-2build1) …
Выбор ранее не выбранного пакета libjq1:amd64.
Подготовка к распаковке …/04-libjq1_1.6-2.1ubuntu3_amd64.deb …
Распаковывается libjq1:amd64 (1.6-2.1ubuntu3) …
Выбор ранее не выбранного пакета jq.
Подготовка к распаковке …/05-jq_1.6-2.1ubuntu3_amd64.deb …
Распаковывается jq (1.6-2.1ubuntu3) …
Выбор ранее не выбранного пакета libdigidocpp-common.
Подготовка к распаковке …/06-libdigidocpp-common_3.15.0.1436-2204_all.deb …
Распаковывается libdigidocpp-common (3.15.0.1436-2204) …
Выбор ранее не выбранного пакета libxerces-c3.2:amd64.
Подготовка к распаковке …/07-libxerces-c3.2_3.2.3+debian-3build1_amd64.deb …
Распаковывается libxerces-c3.2:amd64 (3.2.3+debian-3build1) …
Выбор ранее не выбранного пакета libxalan-c112:amd64.
Подготовка к распаковке …/08-libxalan-c112_1.12-6build1_amd64.deb …
Распаковывается libxalan-c112:amd64 (1.12-6build1) …
Выбор ранее не выбранного пакета libxml-security-c20:amd64.
Подготовка к распаковке …/09-libxml-security-c20_2.0.4-4RIA0_amd64.deb …
Распаковывается libxml-security-c20:amd64 (2.0.4-4RIA0) …
Выбор ранее не выбранного пакета libdigidocpp1:amd64.
Подготовка к распаковке …/10-libdigidocpp1_3.15.0.1436-2204_amd64.deb …
Распаковывается libdigidocpp1:amd64 (3.15.0.1436-2204) …
Выбор ранее не выбранного пакета libnss3-tools.
Подготовка к распаковке …/11-libnss3-tools_2%3a3.68.2-0ubuntu1.2_amd64.deb …
Распаковывается libnss3-tools (2:3.68.2-0ubuntu1.2) …
Выбор ранее не выбранного пакета libqt6core6:amd64.
Подготовка к распаковке …/12-libqt6core6_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается libqt6core6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета libqt6core5compat6:amd64.
Подготовка к распаковке …/13-libqt6core5compat6_6.2.4-1_amd64.deb …
Распаковывается libqt6core5compat6:amd64 (6.2.4-1) …
Выбор ранее не выбранного пакета libqt6dbus6:amd64.
Подготовка к распаковке …/14-libqt6dbus6_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается libqt6dbus6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета libqt6gui6:amd64.
Подготовка к распаковке …/15-libqt6gui6_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается libqt6gui6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета libqt6network6:amd64.
Подготовка к распаковке …/16-libqt6network6_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается libqt6network6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета libqt6opengl6:amd64.
Подготовка к распаковке …/17-libqt6opengl6_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается libqt6opengl6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета libqt6widgets6:amd64.
Подготовка к распаковке …/18-libqt6widgets6_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается libqt6widgets6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета libqt6printsupport6:amd64.
Подготовка к распаковке …/19-libqt6printsupport6_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается libqt6printsupport6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета libqt6svg6:amd64.
Подготовка к распаковке …/20-libqt6svg6_6.2.4-1ubuntu1_amd64.deb …
Распаковывается libqt6svg6:amd64 (6.2.4-1ubuntu1) …
Выбор ранее не выбранного пакета libqt6svgwidgets6:amd64.
Подготовка к распаковке …/21-libqt6svgwidgets6_6.2.4-1ubuntu1_amd64.deb …
Распаковывается libqt6svgwidgets6:amd64 (6.2.4-1ubuntu1) …
Выбор ранее не выбранного пакета libts0:amd64.
Подготовка к распаковке …/22-libts0_1.22-1_amd64.deb …
Распаковывается libts0:amd64 (1.22-1) …
Выбор ранее не выбранного пакета opensc-pkcs11:amd64.
Подготовка к распаковке …/23-opensc-pkcs11_0.22.0-1ubuntu2_amd64.deb …
Распаковывается opensc-pkcs11:amd64 (0.22.0-1ubuntu2) …
Выбор ранее не выбранного пакета opensc.
Подготовка к распаковке …/24-opensc_0.22.0-1ubuntu2_amd64.deb …
Распаковывается opensc (0.22.0-1ubuntu2) …
Выбор ранее не выбранного пакета firefox-pkcs11-loader.
Подготовка к распаковке …/25-firefox-pkcs11-loader_3.13.6.1084-2004_all.deb …
Распаковывается firefox-pkcs11-loader (3.13.6.1084-2004) …
Выбор ранее не выбранного пакета web-eid-native.
Подготовка к распаковке …/26-web-eid-native_2.3.0.619-2204_amd64.deb …
Распаковывается web-eid-native (2.3.0.619-2204) …
Выбор ранее не выбранного пакета web-eid.
Подготовка к распаковке …/27-web-eid_2.3.0.619-2204_all.deb …
Распаковывается web-eid (2.3.0.619-2204) …
Выбор ранее не выбранного пакета python3-nautilus.
Подготовка к распаковке …/28-python3-nautilus_1.2.3-3.1build1_amd64.deb …
Распаковывается python3-nautilus (1.2.3-3.1build1) …
Выбор ранее не выбранного пакета qt6-qpa-plugins:amd64.
Подготовка к распаковке …/29-qt6-qpa-plugins_6.2.4+dfsg-2ubuntu1.1_amd64.deb …
Распаковывается qt6-qpa-plugins:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Выбор ранее не выбранного пакета qdigidoc4.
Подготовка к распаковке …/30-qdigidoc4_4.3.0.4438-2204_amd64.deb …
Распаковывается qdigidoc4 (4.3.0.4438-2204) …
Выбор ранее не выбранного пакета open-eid.
Подготовка к распаковке …/31-open-eid_23.3.0.1936-2204_all.deb …
Распаковывается open-eid (23.3.0.1936-2204) …
Настраивается пакет libxerces-c3.2:amd64 (3.2.3+debian-3build1) …
Настраивается пакет libccid (1.5.0-2) …
Настраивается пакет libxalan-c112:amd64 (1.12-6build1) …
Настраивается пакет pcscd (1.9.5-3) …
Настраивается пакет libqt6core6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет libts0:amd64 (1.22-1) …
Настраивается пакет opensc-pkcs11:amd64 (0.22.0-1ubuntu2) …
Настраивается пакет gir1.2-nautilus-3.0:amd64 (1:42.2-0ubuntu2.1) …
Настраивается пакет libqt6core5compat6:amd64 (6.2.4-1) …
Настраивается пакет libdigidocpp-common (3.15.0.1436-2204) …
Настраивается пакет libonig5:amd64 (6.9.7.1-2build1) …
Настраивается пакет libnss3-tools (2:3.68.2-0ubuntu1.2) …
Настраивается пакет libqt6dbus6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет libxml-security-c20:amd64 (2.0.4-4RIA0) …
Настраивается пакет libjq1:amd64 (1.6-2.1ubuntu3) …
Настраивается пакет opensc (0.22.0-1ubuntu2) …
Настраивается пакет libqt6gui6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет python3-nautilus (1.2.3-3.1build1) …
Настраивается пакет libqt6network6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет jq (1.6-2.1ubuntu3) …
Настраивается пакет libdigidocpp1:amd64 (3.15.0.1436-2204) …
Настраивается пакет libqt6opengl6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет firefox-pkcs11-loader (3.13.6.1084-2004) …
Настраивается пакет libqt6widgets6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет libqt6svg6:amd64 (6.2.4-1ubuntu1) …
Настраивается пакет libqt6svgwidgets6:amd64 (6.2.4-1ubuntu1) …
Настраивается пакет web-eid-native (2.3.0.619-2204) …
Настраивается пакет libqt6printsupport6:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет qt6-qpa-plugins:amd64 (6.2.4+dfsg-2ubuntu1.1) …
Настраивается пакет web-eid (2.3.0.619-2204) …
Настраивается пакет qdigidoc4 (4.3.0.4438-2204) …
Настраивается пакет open-eid (23.3.0.1936-2204) …
Обрабатываются триггеры для mailcap (3.70+nmu1ubuntu1) …
Обрабатываются триггеры для desktop-file-utils (0.26-1ubuntu3) …
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Обрабатываются триггеры для libc-bin (2.35-0ubuntu3) …
Обрабатываются триггеры для man-db (2.10.2-1) …
Обрабатываются триггеры для shared-mime-info (2.1-2) …
Initializing new database
Found PKCS#11 library at: /lib/x86_64-linux-gnu/onepin-opensc-pkcs11.so
Enabling ID-card functionality in Google Chrome/Chromium via /lib/x86_64-linux-gnu/onepin-opensc-pkcs11.so
Module "opensc-pkcs11" added to database.

Thank you for using Estonian ID card!
runtu@runtu:~/Загрузки$


Оффлайн smik55

  • Местный
  • *****
  • Сообщений: 1117
unaednik,
Цитировать
После установки ПО расширение необходимо также активировать в браузере
https://www.id.ee/artikkel/paigalda-id-tarkvara/
Вы все сделали в соответствии с инструкцией?
https://www.id.ee/artikkel/veebibrauserite-seadistamine-id-kaardi-kasutamiseks/
Настройка веб-браузеров для использования ID-карты
Цитировать
В операционной системе Ubuntu должны быть установлены расширения « Web eID » и « загрузчик PKCS11 »

Оффлайн unaednik

  • Новичок
  • **
  • Автор темы
  • Сообщений: 42
to smik55 Да, конечно, знаю всё это  :-* Дело в том, что расширение Web-eId вообще-то не отображается в FireFox.
В инете есть упоминание об аналогичной проблеме в Debian 10.

Оффлайн unaednik

  • Новичок
  • **
  • Автор темы
  • Сообщений: 42
Но рекомендованный скрипт корректно не работает ни в одном из дистрибутивов Ubuntu: либо останавливается с выдачей ошибок, либо (при замене snap-версии FireFox на обычную) не выводит в браузере Web eID расширение.
Использую Ubuntu 20.04 с момента выхода первого её обновления. С помощью действовавшей тогда же версии скрипта, установил ID-расширения. По сию пору всё действует без проблем.
« Последнее редактирование: Май 21, 2023, 19:54:58 от unaednik »

Оффлайн unaednik

  • Новичок
  • **
  • Автор темы
  • Сообщений: 42
Re: Проблема с расширением Web-eId в Runtu XFCE 22.04 x64
« Ответ #6 : Июнь 07, 2023, 14:18:45 »
Но проблема, похоже, всё же в версии используемого браузера FireFox. В дистрибутиве KDE neon скрипт отрабатывает исправно: браузер  отображает все нужные ID-расширения.

Оффлайн unaednik

  • Новичок
  • **
  • Автор темы
  • Сообщений: 42
Re: Проблема с расширением Web-eId в Runtu XFCE 22.04 x64
« Ответ #7 : Июнь 18, 2023, 16:29:22 »
Уточню сказанное выше.
В KDE neon проблема не возникает при работе в режиме live. При переносе системы на диск устанавливаемые ID расширения не работают в FF online.
Пока без проблем, по крайней мере, Mint 21.1

Тему оставляю в забвении. Проблема для большинства едва ли актуальна.
« Последнее редактирование: Июнь 20, 2023, 19:37:23 от unaednik »