Автор Тема: Проблема с установкой Libreoffice 7.5 в Runtu LITE 18.04 x32 - 20220626  (Прочитано 2405 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vinogradoff

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 4
коллеги, скачал дистрибутив для наших старых компов, надеялся, что всё пойдёт по маслу, но при попытке установить офис выскакивает следующее:
......

Пол:18 http://archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [1 662 kB]
Получено 3 583 kB за 11с (324 kB/s)                                                     
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Все пакеты имеют последние версии.
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 libreoffice-pdfimport : Зависит: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.13) но 4:7.5.4~rc2-0ubuntu0.18.04.1~lo1 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

======================================================
          Нажмите клавишу Enter для выхода
======================================================

....

Вопрос - куда копать?
« Последнее редактирование: Июнь 17, 2023, 23:21:58 от vinogradoff »

Оффлайн jobless

  • Активист
  • ****
  • Сообщений: 252
Runtu Lite of this insight!!! ... она такая Lite !!!

Оффлайн RoDoN

  • Постоялец
  • ***
  • Сообщений: 238
    • RoDoN X
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Ну, так вроде бы ясно написано, что нужно исправить. Идем в синаптик, смотрим пакеты "С ошибками" - исправляем, смотрим "Закрепленные" - снимаем при необходимости фиксацию, исправляем ошибки, процесс творческий.
Lenovo B590 (i3-3110M, 8 Гб, GeForce 720M)
Runtu 18.04->20.04->22.04 x64 XFCE

Оффлайн kompilainenn

  • Местный
  • *****
  • Сообщений: 1068
  • Активно пропагандирую Runtu
при попытке установить офис
скачайте deb пакеты с сайта ЛибреОфис и установите их руками, это даст вам последнюю версию 7.5, а не протухший 6.0
https://www.libreoffice.org/donate/dl/deb-x86_64/7.5.4/ru/LibreOffice_7.5.4_Linux_x86-64_deb.tar.gz
Правда и Рунту Лайт бы вам взять 64 битную
Мы говорим Linux, подразумеваем Runtu

Оффлайн vinogradoff

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 4
очень смешно... Я про 64-х битную на машины в лучшем случае "коре-соло"

Вопрос тут - а будет ли подправляться дистрибутив 18-й 32-х разрядной?

Ну например коллеги из UALINUX тот же свой MINT - правят, таких ошибок там нет.


Оффлайн vinogradoff

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 4
Цитата: vinogradoff от Вчера в 23:19:15 E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты. Ну, так вроде бы ясно написано, что нужно исправить. Идем в синаптик, смотрим пакеты "С ошибками" - исправляем, смотрим "Закрепленные" - снимаем при необходимости фиксацию, исправляем ошибки, процесс творческий.

Спасибо. Вопрос стоит что рекомендовать максимально безгеморойное на замену WINXP и WIN2000. Их сейчас таких машин около 50-ти на различных узлах.

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3460
libreoffice-pdfimport : Зависит: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.13) но 4:7.5.4~rc2-0ubuntu0.18.04.1~lo1 должен быть установлен

Проблема вызвана тем, что в последних версиях пакет libreoffice-pdfimport является частью libreoffice-core и не поставляется отдельно (отсутствует в PPA). Обходное решение - отредактировать с правами администратора скрипт установки /usr/local/bin/lo_install, удалив из списка данный пакет (строка 37) в секции с 28 по 38 строку:

Было:
sudo sh -c  "apt update; apt install \
libreoffice-math \
libreoffice-writer \
libreoffice-impress \
libreoffice-calc \
libreoffice-draw \
libreoffice-l10n-ru libreoffice-help-ru \
libreoffice-gtk3 \
libreoffice-style-breeze libreoffice-style-sifr libreoffice-style-colibre \
libreoffice-pdfimport aspell-ru; \
if [ -f /usr/lib/libreoffice/program/soffice ]; then rm /var/lib/misc/lo_install; fi"

Должно стать:
sudo sh -c  "apt update; apt install \
libreoffice-math \
libreoffice-writer \
libreoffice-impress \
libreoffice-calc \
libreoffice-draw \
libreoffice-l10n-ru libreoffice-help-ru \
libreoffice-gtk3 \
libreoffice-style-breeze libreoffice-style-sifr libreoffice-style-colibre \
aspell-ru; \
if [ -f /usr/lib/libreoffice/program/soffice ]; then rm /var/lib/misc/lo_install; fi"
После этого повторно запустить скрипт установки из меню.

скачайте deb пакеты с сайта ЛибреОфис и установите их руками, это даст вам последнюю версию 7.5, а не протухший 6.0
В дистрибутиве подключен репозиторий Libreoffice Fresh PPA с актуальными версиями ПО.

Оффлайн vinogradoff

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 4
Подправил скрипт, проблема ушла. Спасибо.
Сразу установился русифицированный Либреоффис

Ещё бы такой же "скрипт из коробки" для установки русифицированного Файрфокса - было бы здорово.
Ну тоже по типу офиса заходишь во вкладку интернет а там - "установить файрфокс"
Или запустить "симонки", кому не надо.

Не, после установки из репозитория файрфокс таки спросил - "продолжать на русском", но я моделирую ситуацию, когда я поставлю всё это на множестве компов,за которыми работаю довольно пожилые женщины и мужчины на разных АТС, которые с английским мягко сказано - "не в ладах"
Всё что им надо для работы - браузер (для доступа к вебмордам центральных серверов того же техучёта, биллинга или техподдержки) и офис.

Вопрос - в диструбутиве скрипт будет подправлен?

- - -
HsH: Причина правки - удаление оверквотинга.
« Последнее редактирование: Июнь 24, 2023, 18:12:02 от HsH »

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3460
Ещё бы такой же "скрипт из коробки" для установки русифицированного Файрфокса - было бы здорово.

Именно для этой версии дистрибутива установка актуальной версии Firefox под вопросом, поскольку у него требования к ресурсам намного больше. Если на аппаратной конфигурации нормально функционирует Firefox выше v.52, то смысла ставить дистрибутив 18.04 х32 нет - можно использовать 22.04 х64.

Вопрос - в диструбутиве скрипт будет подправлен?
Возможно да, рассмотрю вариант обновления.

Оффлайн kompilainenn

  • Местный
  • *****
  • Сообщений: 1068
  • Активно пропагандирую Runtu
В дистрибутиве подключен репозиторий Libreoffice Fresh PPA с актуальными версиями ПО.
привычка ставить только ванильную версию офиса =)
Мы говорим Linux, подразумеваем Runtu