Автор Тема: Проблемы установки драйвера на старые карт от ATI  (Прочитано 5732 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн enslaver

  • Новичок
  • **
  • Автор темы
  • Сообщений: 46
Цитировать (выделенное)
HsH
спасибо, спасибо :)) раз уж многоуважаемый ссылается на "Калькулятор" то мне просто ничего не остается как все разложить по полочкам, сам на Gentoo сейчас.
1. Я сам пользовался драйверами для Ати 9.3, они работают с ядрами 2.6! но не помню до какого точно (2.6.??)
2. Белые экраны, черные экраны, это в первую очередь неправильная настройка, а не нерабочие драйвера.
3. Не нужно ничего откатывать, все можно заставить работать и на последней Runtu.

Что нужно делать?
1. просто откатить ядро на то что установлено... да хотя бы в Runtu3 и уже на него можно будет установить драйвера с сайта АМД, и не поверите но версия 9.3 встанет без проблем!!!!
2. Белые и черные экраны это все последствия в первую очередь компиза, думаю как его отключить вы найдете (в xorg.conf дописать в нужную секцию composite "off")

вот собственно и все :) спасибо за внимание.

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 2983
Я сам пользовался драйверами для Ати 9.3, они работают с ядрами 2.6! но не помню до какого точно (2.6.??)

Что нужно делать?
1. просто откатить ядро на то что установлено...

    Версия ядра в данном случае не имеет отношения к сути проблемы. Применительно к Ubuntu - версию драйвера ATI 9.3 (для карт младше 2ХХХ) штатно можно установить на дистрибутивы до Ubuntu 8.10 включительно, версию ATI 9.4 и более поздние (поддержка 2ХХХ и выше) можно установить на дистрибутивы Ubuntu начиная с 9.04.

    Определяющим фактором является версия Х-сервера, установленного в системе.

Оффлайн enslaver

  • Новичок
  • **
  • Автор темы
  • Сообщений: 46
возможно я немного поторопился, но отрицать причастность ядра тоже нельзя, так как в первых атишных скриптах было ограничение по версии ядра.

Оффлайн sunset

  • Постоялец
  • ***
  • Сообщений: 106
3. Не нужно ничего откатывать, все можно заставить работать и на последней Runtu.

Да уж. )))  Сейчас бы, все так и пользовались последним catalyst-9.3 драйвером, для карт ниже 2XXX, на
всех новейших linux дистрибутивах - если бы всё было так просто.

Xorg 7.4 (а конкретно 1.5.3-r6, потому-что под 7.4 - был целый ряд Xorg-ов) - последний,
с которым может работать catalyst-9.3.

(В Release Note к этому драйверу, прямо указан Xorg 7.4, как последний.)

На Calculate решил взглянуть в этом году, понравился.
А так использую Gentoo, начиная с 2004.0
Сейчас они у меня стоят вместе. Место на жёстком диске позволяет.

Вот только никак не получится поcтавить на Gentoo 2011.02, который у меня - драйвер 9.3
Всё дело в зависимостях. Которые не просто грамотно разруливать. И возможно это
только до тех пор, пока зависимости окончательно не заблокируют старые пакеты.

Точно так-же, не получится поставить, и на последние версии Runtu.

Так что спасибо фирме ATI, и лучше 100 раз подумать, прежде чем покупать
карту данного производителя - если вы используете linux.
Ведь прекращает поддержку она не первый раз.

Сначало ниже серии 9500, второй раз ниже HD2XXX.
Что они там надумают в третий - изветно только им.

Оффлайн enslaver

  • Новичок
  • **
  • Автор темы
  • Сообщений: 46
Ты так говоришь будто у НВ не такие проблемы, у моего друга видюха, и сайт выдает для нее драйвера 186-***.run в конечном счете оказалось что даже в самых последних драйверах есть поддержка его видеокарты, хотя официально и не заявлена!

Оффлайн enslaver

  • Новичок
  • **
  • Автор темы
  • Сообщений: 46
Кто нибудь пытался установить самые последние драйвера на свою видеокарту?
Что пишет при этом????

Распакуйте инстал и приведите свои логи скрипта
check.shкоторый будет в корне распакованной папки

Оффлайн sunset

  • Постоялец
  • ***
  • Сообщений: 106


Ты так говоришь будто у НВ не такие проблемы...

Обращение не самое лучшее :)
Я человек взрослый и не обидчивый. но не каждому это может понравиться (на заметку)



Если подходить конструктивно к данному вопросу, то для карт Nvidia есть поддержка
в новейших дистрибутивах начиная с Geforce 2 MX и выше.
Исключение (Geforce 2 TI/PRO/GTS)

Пример: ebuild-ы Gentoo, начало 2011 года: ПоказатьСкрыть




"Сайт Nvidia": ПоказатьСкрыть




Последний драйвер для карт TNT, Geforce 256 - был выпущен в августе 2010 года

Систему на основе августа 2010, достаточно легко обновить до текущего состояния.


К примеру ATI Catalyst™ 9.3 Release Date - 3/26/2009
И логично-ли сравнивать TNT и Radeon X1950 ?
Разница в поддержке очевидна.

Насчёт установки драйвера последней версии:
Что важнее иметь нормальное аппаратное ускорение или последнюю версию драйвера ?

Насчёт распаковки и chesk.sh - баловство всё это.

Я заглядываю на Bugzilla и форум Gentoo.org,
если бы там было решение проблемы с драйверами ATI, я бы знал его.

Оффлайн enslaver

  • Новичок
  • **
  • Автор темы
  • Сообщений: 46
ну как всегда, почикали темку.....  :P я понимаю что я слишком резок, но все же без помощь ничего тут не решишь, есть кое какие соображения почему и просил выполнить проверку, вероятно получится собрать драйвер для свежих систем...

В частности прочитав инструкцию оказалось что можно в ручную задать то для какой версии Х сервера будет проходить установка.

А так сам пакет состоит из папок которые в большинстве своем еще и линки на какую то одно, в которой просто лежат файлы, сама же папка является определителем версии Х сервера, то есть все можно решить добавлением нужной папочки... а инсталяционные скрипты взять от новой версии драйвера...

Вот как то так....

Оффлайн sunset

  • Постоялец
  • ***
  • Сообщений: 106
В gentoo, драйвер ATI устанавливается с помощью команды emerge
Происходит распаковка, компиляция того что еще недокомпилировано, и размещение
полученных файлов в системе. XXX-run - не запускается, chechk.sh - не используется.

Вот эта информация может помочь, в изучении проблемы:


http://zenwalk.pinguix.com/user-accounts/bip/EXTRA/x/fglrx/source/
http://bugs.gentoo.org/show_bug.cgi?id=264021
http://bugs.gentoo.org/attachment.cgi?id=187275&action=edit
http://bugs.gentoo.org/attachment.cgi?id=187275
http://forums.gentoo.org/viewtopic-t-798915-start-0.html

С помощью данных патчей возможна установка ATI Driver 9.3 на kernel 2.6.29
к примеру. У меня на ядре 2.6.29 драйвер работал, на других не пробовал.


Из личного опыта (у других тоже самое):

Драйвер 9.4 можно установить по команде emerge. Компиляция и установка пройдут успешно.
Но при запуске, или команде # modprobe fglrx
Модуль выдаст сообщение - в вашей системе нет видеокарты ATI.

Драйвер 9.3 при запуске на xorg-server выше 1.5.3-r6 ругается на версию xorg.
Говорит - у вас установлен Xorg 7.1.4.5 (по памяти) , а нужен 7.4
Это-же сообщение появляется, если обновлена хотя бы часть библиотек xorg-а
Вообщем путает всё :)

Оффлайн Feduka

  • Активист
  • ****
  • Сообщений: 428
  • Меняю путина на Ходорковского
Может и баян, но сегодня вдруг повезло с компизом на довольно несвежей карточке ATI Radeon X1300. Дополнительная засада  - AGP шина. С дровами от AMD все в курсе. Гентушники научились объезжать это дело - честь им и хвала. На убунтушных сборках не канает. Я пользовал "свободный" драйвер. Компиз запускался, но без слез глядеть невозможно. Судя по логу х-сервера проблемы возникали при загрузке модуля dri. Сегодня поставил обновления из репозитория https://launchpad.net/~xorg-edgers/+archive/ppa (кроме него раньше был подключен и https://launchpad.net/~ubuntu-x-swat/+archive/x-updates, но без толку). Компиз забегал вполне споро. И куб крутится шустро, и другие эффекты работают. Модуль dri грузится без ошибок. Где-то чего-то они там допилили.
2:5020/655.11