Автор Тема: Громкость в трее, чекбокс ВЫКЛ не включает обратно звук  (Прочитано 738 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sbrazh

  • Новичок
  • **
  • Автор темы
  • Сообщений: 41
Здравствуйте!
Runtu Lite - как всегда СУПЕР. Спасибо за Вашу работу)!

Но, возникла небольшая "шероховатость"(просто пользуюсь часто этим)...
В управлении громкостью(значок в трее) есть чекбокс "Выкл" для быстрого
откл звука... Отключает звук он нормально. А вот возврат к звуку, если убрать "галочку" в
чекбоксе - ВКЛ звука не происходит(. Надо заходить в
микшер pavucontrol и во вкладке Устройства Вывода "отжимать" иконку
"Заглушить звук". Возможно это особенность моего древнего, но еще
живого "железа"))? Есть ли решение? Спасибо.

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 2970
sbrazh, какая аппаратная конфигурация системы, на которую установлен дистрибутив? Работает ли включение/выключение звука с помощью хоткеев? Для ноутбуков и мультимедиа-клавиатур настроены соответствующие кнопки, для обычных - можно изменить настройки в соответствующем конфиге.

Оффлайн sbrazh

  • Новичок
  • **
  • Автор темы
  • Сообщений: 41
Здравствуйте! Спасибо за ответ.
Конфигурация бука:
inxi -Fz
System:
  Kernel: 5.4.0-73-generic x86_64 bits: 64 Desktop: Openbox 3.6.1
  Distro: Ubuntu 20.04.2 LTS (Focal Fossa)
Machine:
  Type: Laptop System: Acer product: Extensa 5220 v: 0100 serial: <filter>
  Mobo: Acer model: Columbia v: Rev serial: <filter> BIOS: Phoenix v: 1.32
  date: 02/01/2008
Battery:
  ID-1: BAT0 charge: 13.3 Wh condition: 13.3/44.4 Wh (30%)
CPU:
  Topology: Single Core model: Intel Celeron 550 bits: 64 type: MCP L2 cache: 1024 KiB
  Speed: 1995 MHz min/max: N/A Core speed (MHz): 1: 1995
Graphics:
  Device-1: Intel Mobile GM965/GL960 Integrated Graphics driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.9 driver: intel resolution: 1280x800~60Hz
  OpenGL: renderer: Mesa DRI Intel 965GM (CL) v: 2.1 Mesa 20.2.6
Audio:
  Device-1: Intel 82801H HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-73-generic
Network:
  Device-1: Broadcom and subsidiaries NetLink BCM5787M Gigabit Ethernet PCI Express
  driver: tg3
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter driver: ath5k
  IF: wlp4s0 state: up mac: <filter>
Drives:
  Local Storage: total: 74.53 GiB used: 13.62 GiB (18.3%)
  ID-1: /dev/sda vendor: Western Digital model: WD800BEVS-22RST0 size: 74.53 GiB
Partition:
  ID-1: / size: 10.66 GiB used: 4.73 GiB (44.3%) fs: ext4 dev: /dev/sda3
  ID-2: /home size: 9.41 GiB used: 2.57 GiB (27.3%) fs: ext4 dev: /dev/sda7
  ID-3: swap-1 size: 1.86 GiB used: 41.5 MiB (2.2%) fs: swap dev: /dev/sda5
Sensors:
  Missing: Required tool sensors not installed. Check --recommends
Info:
  Processes: 151 Uptime: 2h 55m Memory: 1.93 GiB used: 1.30 GiB (67.1%) Shell: bash
  inxi: 3.0.38


Мультимедийные кнопки работают нормально(чз функциональную кнопку Fn). Без проблем срабатывает как плавная регулировка громкости(+-) так и кнопки Mute - ВКЛ/ВЫКЛ(совмещенная с F8 и работает чз кн. Fn). В микшере pavucontrol кнопка "Заглушить звук" как на Вкл так и на Выкл работает штатно без проблем.

Т.е. визуально проблема просматривается только с логикой чекбокса  в апплете громкости в трее.
« Последнее редактирование: Май 31, 2021, 17:20:13 от sbrazh »

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4236
В Lxpanel регулятор громкости использует Alsa, поэтому надо настраивать Alsa.

Примерно так
https://askubuntu.com/questions/325623/lxpanel-volume-control-not-visible-plus-no-sound

Но какие настройки нужно указать тебе, не выяснил.

Оффлайн sbrazh

  • Новичок
  • **
  • Автор темы
  • Сообщений: 41
В Lxpanel регулятор громкости использует Alsa, поэтому надо настраивать Alsa.
Не знаю что в микшере можно "подкрутить"). Работает звук нормально и только чекбокс Mute в Апплете громкости как-бы подвисает в положении звука: Выкл(не включает звук обратно, хотя визуально чекбокс активируется/дезактивируется).  При этом функциональные кнопки клавиатуры Mute(Вкл/Выкл звука) работают как положено. Похоже на баг в работе апплета регулятора звука, в части чекбокса Mute. Баг не значимый и "зацепило" лишь потому что ранее на месте где сейчас Runtu20 стоял Дебиан9 с LXDE, на котором этого бага не было).