Автор Тема: Странное поведение аудио-подсистемы  (Прочитано 574 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн костя

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 7
День добрый
Установил рунту 18.04.ошибок при установке или каких-либо проблем при установке не было.
Но после, когда ничего не воспроизводится (аудио или видео)
В колонках гупает какой-то звук.
Раз в пару секунд раздается как будто удар в барабан...или иногда при включении компа ,когда во время загрузки ,загружается аудиоподсистема.что это может быть?
Как исправить это?
При включении какой-то песни или Ютуба например-звук пропадает,все нормально...
Голову сломал уже..если знаете решение - подскажите пожалуйста!

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 2979
Re: Странное поведение аудио-подсистемы
« Ответ #1 : Май 26, 2021, 13:28:26 »
костя,  какую версию дистрибутива установили (с XFCE4, LITE)? Какая аппаратная конфигурация оборудования? Приведите вывод выполнения команды (запустить и скопировать текст из терминала в сообщение):
inxi -v3
Динамики внешние или встроенные? Как они подключены? Вы уверены в их исправности - с другим источником звука проблем нет?

Оффлайн костя

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 7
Re: Странное поведение аудио-подсистемы
« Ответ #2 : Май 28, 2021, 19:51:25 »
добрый вечер!
я завтра доберусь до этого компа,с проблемой и смогу ответить на ваш вопрос..
прошу прощения за задержку

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4263
Re: Странное поведение аудио-подсистемы
« Ответ #3 : Май 28, 2021, 21:22:07 »
Хлопок - это отключение/подключение динамиков.

Походит на энергосберегающий режим работы аудиокарты.

Значит нужно определить название аудиокарты, потом искать как отключить энергосберегающий режим у неё.


Оффлайн костя

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 7
Re: Странное поведение аудио-подсистемы
« Ответ #4 : Май 30, 2021, 07:28:56 »
Динамики внешние или встроенные? Как они подключены? Вы уверены в их исправности - с другим источником звука проблем нет?
1-внешние(и гупает именно в них)2-исправны .проверял с телефоном .подклчены через 3.5мм вход для наушников сзади сист.блока
3 -
Цитировать (выделенное)
k0styan3@k0styan3-desktop:~$ inxi -v3
System:    Host: k0styan3-desktop Kernel: 5.4.0-73-generic x86_64
           bits: 64 gcc: 7.5.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Ubuntu 18.04.5 LTS
Machine:   Device: desktop Mobo: Gigabyte model: GA-K8N51GMF-9 serial: N/A
           BIOS: Award v: F7 date: 05/09/2006
CPU:       Single core AMD Athlon 64 3200+ (-UP-)
           arch: K8 rev.E cache: 512 KB
           flags: (lm nx sse sse2 sse3) bmips: 4018 speed: 2000 MHz (max)
Graphics:  Card: NVIDIA C51G [GeForce 6100] bus-ID: 00:05.0
           Display Server: x11 (X.Org 1.20.8 )
           drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: NV4E version: 2.1 Mesa 20.0.8 Direct Render: Yes
Network:   Card-1: NVIDIA MCP51 Ethernet Controller
           driver: forcedeth port: d000 bus-ID: 00:14.0
           IF: enp0s20 state: down mac: 00:16:e6:62:49:90
           Card-2: D-Link System DWA-110 Wireless G Adapter(rev.A1) [Ralink RT2571W]
           driver: rt73usb v: 2.3.0 usb-ID: 001-003
           IF: wlx002191520491 state: N/A mac: N/A
Drives:    HDD Total Size: 250.1GB (2.5% used)
           ID-1: model: ST3250310AS
Info:      Processes: 149 Uptime: 16 min Memory: 903.7/1955.5MB
           Init: systemd runlevel: 5 Gcc sys: 7.5.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56

---
HsH: причина редактирования - форматирование вывода терминала (тэг "Код").
« Последнее редактирование: Май 31, 2021, 10:47:33 от HsH »

Оффлайн костя

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 7
Re: Странное поведение аудио-подсистемы
« Ответ #5 : Май 30, 2021, 07:35:07 »
нужно определить название аудиокарты, потом искать как отключить энергосберегающий режим у неё
т.е звуковая карта может сама по себе перейти в этот режим?вот это для меня открытие!а как же вернуть ее в нормальный режим?и самое главное - как запретить ей переходить в этот энергосберегающий режим?

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4263
Re: Странное поведение аудио-подсистемы
« Ответ #6 : Май 30, 2021, 08:01:59 »
В выше указанном выводе терминала не вижу название аудиокарты.

Покажи вывод команды
inxi -A

Оффлайн костя

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 7
Re: Странное поведение аудио-подсистемы
« Ответ #7 : Май 30, 2021, 08:08:07 »
В выше указанном выводе терминала не вижу название аудиокарты.

Покажи вывод команды
inxi -A
k0styan3@k0styan3-desktop:~$ inxi -A
Audio:     Card NVIDIA MCP51 High Def. Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k5.4.0-73-generic
---
HsH: причина редактирования - форматирование вывода терминала (тэг "Код").
« Последнее редактирование: Май 31, 2021, 10:49:30 от HsH »

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4263
Re: Странное поведение аудио-подсистемы
« Ответ #8 : Май 30, 2021, 08:28:07 »
Аудиокарта: NVIDIA MCP51 High Def.
Драйвер: snd_hda_intel

Задал в гугле поиск:
Ubuntu 18.04 sound crackling snd_hda_intel

Получил много советов по решению проблемы, первый из них
https://askubuntu.com/questions/1135492/static-and-crackling-sound-coming-from-speakers-in-19-04

Там говорится открыть с правами администратора текстовый файл /etc/modprobe.d/alsa-base.conf
Добавить вконец
options snd-hda-intel power_save=0 power_save_controller=N
Это отключение энергосберегающего режима у аудиокарты.

Осталось испробовать.

Оффлайн костя

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 7
Re: Странное поведение аудио-подсистемы
« Ответ #9 : Май 30, 2021, 08:30:56 »
Извини меня что не сообразил про Гугл....
Спасибо тебе!
Через час - сделаю!
Там про Интел говориться(в команде),а у меня амд...или это не важно?
« Последнее редактирование: Май 30, 2021, 08:33:04 от костя »

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4263
Re: Странное поведение аудио-подсистемы
« Ответ #10 : Май 30, 2021, 10:09:46 »
Дравйвер у тебя используется этот, инструкция для него.

Пробуй, потом напиши что получилось после перезагрузки.
« Последнее редактирование: Май 30, 2021, 10:11:25 от Пользователь. »

Оффлайн костя

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 7
Re: Странное поведение аудио-подсистемы
« Ответ #11 : Май 30, 2021, 11:42:51 »
Пробуй, потом напиши
спасибо тебе,добрый человек!!
все вылечилось.до этого у меня была убунта с LXQT , так чего мне только не советовали:и в другое место подклчить, и просто не парится и сменить дистрибутив,и выключать-включать при надобности..
хорошего дня тебе!