Автор Тема: Runtu LITE 20.04.1 x64 - 202010  (Прочитано 1070 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн HsH

  • Administrator
  • *****
  • Автор темы
  • Сообщений: 2897
Runtu LITE 20.04.1 x64 - 202010
« : Октябрь 05, 2020, 23:23:34 »
    Представляю релиз 64-разрядного дистрибутива Runtu LITE 20.04.1 х64, собранный на пакетной базе релиза Focal Fossa 20.04.1 LTS. Сборка имеет базовый набор пользовательского ПО с возможностью установки на жёсткий диск.


    Основные элементы системы:

Менеджер дисплея               LightDM 1.30
Оконный менеджер               Openbox 3.6.1
Файловый менеджер             PCManFM 1.3.1
Панель рабочего стола         LXPanel 0.10.0
Менеджер сети                    NetworkManager 1.22.10 (pptp, l2tp, sstp, ssh, openvpn и vpnc)
Текстовый редактор             Geany 1.36
Браузер                              Firefox 81.0
Видеоплеер                         VLC 3.0.9
Аудиоплеер                         DeaDBeeF 1.8.3


Менеджер питания               xfce4-power-manager
Менеджер Bluetooth              Blueman
Звуковой сервер                  PulseAudio

Версия ядра:                       5.6.0-1028-oem и 5.4.0-48-generic
Версия Xorg:                       1.20.8
 

   Минимальные системные требования:

RAM - 1024Mb
CPU - x64
HDD - 5Gb

Логин:    runtu
Пароль:  пустой

   Внесённые изменения:

Для версии 20.04.1-amd64_202010:
- Применено ядро ветки linux-oem-20.04 (текущая версия v5.6);
- Пакетная база обновлена до версий 20.04.1 на 04.10.2020г;

Для версии 20.04.1-v5.4-amd64_20201010:
- Применено ядро ветки linux-generic (текущая версия v5.4);
- Пакетная база обновлена до версий 20.04.1 на 10.10.2020г;

Общие изменения:
- Добавлена утилита YAD  (вывод графических диалогов, программируемых пользователем);
- Добавлен модуль Xorg для работы с тачпадами Synaptics;
- Добавлен апплет Multiload-ng, позволяющий вывести системную информацию на панель;
- Исправлена ошибка создания кнопок запуска из контекстного меню;
- Устранена одна из причин долгого завершения работы при выключении.


   Скриншоты рабочего окружения:

===========================

       

       

===========================


    Служебные комментарии:

Состав сборок одинаковый, разница только в версиях установленных ядер - v5.4 и v5.6.

NVidia официально прекратила поддержку драйвера ветки 340.*, который предназначался для семейства видеокарт Tesla G8x, G9x, и GT2xx. Установить эти драйверы можно только на систему с  ядром до Linux v5.4 и Xorg 1.20 включительно. На сборку с ядром Linux 5.6 проприетарный драйвер nvidia-340 не установится.

Установку дистрибутива желательно проводить без доступа к Интернет, чтобы сократить время на загрузку списка пакетов в доступных репозиториях. Обновление производить после установки системы на жёсткий диск.

В меню "Офис" добавлены ярлыки для установки LibreOffice и подсистемы печати. Если установка данного ПО не планируется и они не нужны в меню, следует удалить файлы printinstall и lo_install в каталоге /var/lib/misc/.


 Ссылки на загрузку:

Версия с ядром Linux 5.4

Загрузить с Sourceforge.net

Загрузить с зеркала Яндекс (будет доступна после синхронизации с SF)

Файл:          runtu-lite-20.04.1-v5.4-amd64_20201010.iso

Размер:       749 Мб


md5:           9ea399bb068df2583e1c4e978c02f17a
sha1:          0afa585f3a1632a6dd09e20bad2abe939bd7e85f


Версия с ядром Linux 5.6

Загрузить с Sourceforge.net

Загрузить с зеркала Яндекс

Файл:          runtu-lite-20.04.1-amd64_202010.iso

Размер:       753 Мб


md5:           a1d93a9101d30f4ebc730af434349f5f
sha1:          117204c3a0f60a59864e93e22d8795e2f41979ac


Поддержать проект: ссылка на тему форума.
« Последнее редактирование: Октябрь 10, 2020, 19:15:08 от HsH »

Оффлайн jobless

  • Постоялец
  • ***
  • Сообщений: 195
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #1 : Октябрь 07, 2020, 09:07:22 »
На первый взгляд, как обычно всё идеально.
Я ветке 20.04 писал про gtk minwaita-vanilla и соответствующую тему OpenBox.
И у меня вопрос ко всем.
Мне единственному не нравится разномастное оформление окон в старом и новом стиле?

ИМХО выбрать согласованные, остальные удалить совсем. Если и иметь несколько на выбор то именно несколько имеющих согласованное оформление.
Или принципиально отказаться от GTK3 приложений в новом стиле, что с каждым днём всё трудней и трудней, ибо новые пишутся а старые перестают поддерживаться.
Runtu Lite of this insight!!! ... она такая Lite !!!

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4046
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #2 : Октябрь 07, 2020, 11:42:04 »
Вчера пытался загрузить эту сборку с флешки на старом стационарнике.
Не загрузилась, черный экран, параметр nomodeset не помогает.
Видеокарта Nvidia 9800GT.

В предыдущей сборке Runtu LITE 20.04 система загружалась на этом стационарнике, но разрешение экрана было 640*480.
Добиться нормального разрешения не получилось, но постараюсь поизучать. Использовался как я понимаю драйвер nouveau (хотя могу и ошибаться, помню видел в Hardinfo драйвер llvmpipe, а к чему он относится пока не вкурсе), проприетарный драйвер давно уже не подхватывает мою видеокарту, хотя она пошустрее современных интеловских.

Сейчас на этом системнике использую Runtu XFCE 16.04, в ней проприетарный драйвер nvidia-304 работает хорошо.
Обновить систему хотел ради установки новых версий программ.
« Последнее редактирование: Октябрь 07, 2020, 11:48:15 от Пользователь. »

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4046
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #3 : Октябрь 07, 2020, 22:21:58 »
Немного разобрался со своими проблемами.
llvmpipe - это часть Mesa, которая является прослойкой между OpenGL и драйвером видеокарты. Драйвер у меня использовался nouveau.

Заметил что в меню груба стоит параметр vga=788 это 800*600 16-bit, поменял на vga=795 и получил свое разрешение 1280*1024 24-bit. Но 3D игра не запустилась, пока только 2D (почти все программы, в том числе для видео, для веб серфинга).

Все это я сделал с предыдущей сборкой этой системы.

А именно эта сборка у меня не грузится, возможно из-за ядра.


Оффлайн smik55

  • Местный
  • *****
  • Сообщений: 987
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #4 : Октябрь 07, 2020, 23:34:50 »
 Runtu LITE 20.04.1 x64 - 202010 в общем и целом хорошая сборка, особо придраться не к чему. Собирал автор ее под свои задачи и предпочтения, поэтому остальное пользователь должен настроить и изменить набор программ сам для себя.
Подобный вариант с Runtu LITE 18.04x64 я описывал здесь: https://forum.runtu.org/index.php/topic,7574.0.html
Правда для 20.04.1 есть отличия. Кто имеет представление, тот может сам все сделать. Я в первую очередь выполнил для себя:
sudo apt install gnome-disk-utility usb-creator-gtk mousepad bleachbitзатем
sudo apt purge --remove firefox firefox-locale-ru numlockxи установил браузер Slimjet. numlockx автоматом включает всегда numlock, что мне не надо. Добавил выборочно пакеты lxde.
Удалил не нужные мне темы оформления и переключил на убунтовские .
В общем все работает, один раз упал PCmanfm, но перезапустился по значку на панели. Остальное все мелочи и легко настраивается под себя. Потребление памяти в установленной ОС сразу около 250-270 МБ.
Так что: спасибо автору за сборку!
--
Пользователь, я бы попробовал установить Runtu LITE 20.04.1 в Виртуал Бокс, заменил ядро на родное и упаковал по новой в ИСО. Из ВБокса образ можно вынуть на флешку и потом перенести на ПК для записи на ЮСБ.

« Последнее редактирование: Октябрь 07, 2020, 23:37:44 от smik55 »

Онлайн 9595

  • Постоялец
  • ***
  • Сообщений: 137
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #5 : Октябрь 08, 2020, 10:43:30 »
Есть ли какая-нибудь инструкция для тестирования дистрибутивов?
Что в новых сборках проверять куда обратить внимание?

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4046
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #6 : Октябрь 08, 2020, 11:42:00 »
Есть ли какая-нибудь инструкция для тестирования дистрибутивов?
Что в новых сборках проверять куда обратить внимание?

Инструкции по тестированию сборок нет.

А вот что проверять - в первую очередь работу оборудования с новым ядром, во вторую обратить внимание на указанные в описании сборки изменения, оценить как они работают, остальные наблюдения на свой вкус.

Пользователь, я бы попробовал установить Runtu LITE 20.04.1 в Виртуал Бокс, заменил ядро на родное и упаковал по новой в ИСО. Из ВБокса образ можно вынуть на флешку и потом перенести на ПК для записи на ЮСБ.

Пока 16.04 открывает сайты, буду использовать её. Когда перестанут открываться, тогда придется переползать на новые системы с nouveau. Я уже протестировал этот драйвер в предыдущей сборке на обычном ядре, и результат существенно хуже чем у проприетарного драйвера nvidia, так что на крайний случай сойдет, но пока этот крайний случай не наступил.

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4046
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #7 : Октябрь 08, 2020, 17:56:34 »
Поменял видеокарту на старом стационарнике с Nvidia 9800GT на Nvidia 710 (купил с рук за дешево).
Предыдущая сборка 20.04 установленая на жесткий диск работает, проприетарный драйвер установился и используется.

А эта сборка опять не загрузилась с флешки, может флешка криво записалась (хотя загрузочное меню появляется), либо попробовать параметр nomodeset.


Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4046
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #8 : Октябрь 08, 2020, 18:32:05 »
Попробовал с этой видеокартой грузиться по-разному.
Nomodeset не привел к загрузке.
Тогда убрал из команды запуска параметр vga=788
Вместо загрузки системы вышло сообщение об ошибке

Цитировать
Decoding failed
-- System halted

Так что эта версия ядра мне не подходит.

Оффлайн Alik29

  • Новичок
  • **
  • Сообщений: 51
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #9 : Октябрь 08, 2020, 23:02:44 »
С "заводским" vga-кабелем у меня грузится только 14.04 - не идет инфа о мониторе.
С самопаяным - грузится все.
HDMI монитора нет - проверить не могу.
20.04.1 - после загрузки потребление озу 250-320мб. Почему-то каждый раз разное.
Firefox с одной вкладкой youtube - 1.2гб. Работает шустро.
Иконки пока не "падают". Надеюсь вылечились.
Transmission привычно не работает. QBitTorrent почему-то привычно работает.
Очень не хватает "из каропки" хотя-бы просмотрщика odt. Хотя пока даже кандидатов
на эту роль не нашел.
На тяжелой pdf-ке evince ушел в свап. qpdfviewer - тоже. Видимо 2гб озу - прошлый век.
В остальном - как обычно. Благодарность автору.
Celeron Core 2 Duo E8400 3Gz RAM-2Gb nVidia GeForce 9500GT  MB-P5KPL-AM

Оффлайн smik55

  • Местный
  • *****
  • Сообщений: 987
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #10 : Октябрь 08, 2020, 23:48:23 »
Ну если с флешки грузиться в лайв-режиме, то возможности памяти сильно ограничены. Интересно, для каких случаев не работает Transmission? всегда им пользуюсь для закачки торент-файлов.
 "хотя-бы просмотрщик odt" - ведь можно установить LibreOffice просто тыкнув по пункту в Меню-Офис-установить...Сборка -LITE, поэтому не всем он нужен, а кому то нужен другой...
"Nomodeset не привел к загрузке". Обычно, если драйвер видео не подходит, то ОСЬ все равно грузится нормально и экран загорается, но с :1-артефактами, 2-с плохим разрешением, 3-не работает рег.яркости и т.д., а в Nomodeset подставляется свободные драйвер. Так же можно и в "Безопасном режиме" загрузиться со свободным драйвером.
тут дело видимо все же в самой флешке или битом образе. Можно отключить "no splash" при загрузке и посмотреть, когда зависает загрузка. Я использовал флешку с Ventoy и все загрузилось нормально (с Вентой флешка уже с гарантией что исправна и рабочая).

Оффлайн Alik29

  • Новичок
  • **
  • Сообщений: 51
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #11 : Октябрь 09, 2020, 03:57:58 »
Как понять "в каких случаях не работает transmission"?
torrent-файл в программу и...один случай из десяти, что заведется.
Причем отчего зависит определить не удалось.
Тот-же файл в qbittorrent - нормально грузится.
До qbittorrent грешил на связь - 3G свисток от Теле2. Но нет.

Насчет офиса - мне весь офис не нужен. Иногда просмотреть файл-инструкцию.
Раньше ставил Abiword + Gnumeric, сейчас abiword совсем криво открывает файлы с таблицами.
А править каждый файл -да ну его...)
Celeron Core 2 Duo E8400 3Gz RAM-2Gb nVidia GeForce 9500GT  MB-P5KPL-AM

Оффлайн Alik29

  • Новичок
  • **
  • Сообщений: 51
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #12 : Октябрь 09, 2020, 06:25:21 »
Поторопился, однако...
Попытка установить nvidia-340:
sudo apt-get install nvidia-340 nvidia-settings
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
  gcc-10-base lib32gcc-s1 lib32gcc1 libatomic1 libc6-i386 libcc1-0 libgcc-s1 libgomp1 libitm1 liblsan0 libquadmath0 libstdc++6 libtsan0
  libubsan1 libxnvctrl0 screen-resolution-extra xserver-xorg-legacy
Рекомендуемые пакеты:
  libcuda1-340 nvidia-opencl-icd-340
Следующие НОВЫЕ пакеты будут установлены:
  lib32gcc-s1 lib32gcc1 libc6-i386 libxnvctrl0 nvidia-340 nvidia-settings screen-resolution-extra xserver-xorg-legacy
Следующие пакеты будут обновлены:
  gcc-10-base libatomic1 libcc1-0 libgcc-s1 libgomp1 libitm1 liblsan0 libquadmath0 libstdc++6 libtsan0 libubsan1
Обновлено 11 пакетов, установлено 8 новых пакетов, для удаления отмечено 0 пакетов, и 27 пакетов не обновлено.
Необходимо скачать 57,3 MB архивов.
После данной операции объём занятого дискового пространства возрастёт на 294 MB.
Хотите продолжить? [Д/н] y
Пол:1 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libubsan1 amd64 10.2.0-5ubuntu1~20.04 [136 kB]
Пол:2 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libtsan0 amd64 10.2.0-5ubuntu1~20.04 [320 kB]
Пол:3 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 gcc-10-base amd64 10.2.0-5ubuntu1~20.04 [19,7 kB]
Пол:4 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libstdc++6 amd64 10.2.0-5ubuntu1~20.04 [503 kB]
Пол:5 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libquadmath0 amd64 10.2.0-5ubuntu1~20.04 [146 kB]
Пол:6 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 liblsan0 amd64 10.2.0-5ubuntu1~20.04 [144 kB]                           
Пол:7 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libitm1 amd64 10.2.0-5ubuntu1~20.04 [26,4 kB]                           
Пол:8 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgomp1 amd64 10.2.0-5ubuntu1~20.04 [102 kB]                           
Пол:9 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libcc1-0 amd64 10.2.0-5ubuntu1~20.04 [41,1 kB]                         
Пол:10 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libatomic1 amd64 10.2.0-5ubuntu1~20.04 [9 300 B]                       
Пол:11 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgcc-s1 amd64 10.2.0-5ubuntu1~20.04 [41,6 kB]                       
Пол:12 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libc6-i386 amd64 2.31-0ubuntu9.1 [2 721 kB]                           
Пол:13 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 lib32gcc-s1 amd64 10.2.0-5ubuntu1~20.04 [49,6 kB]                     
Пол:14 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 libxnvctrl0 amd64 440.82-0ubuntu0.20.04.1 [11,0 kB]                   
Пол:15 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 lib32gcc1 amd64 1:10.2.0-5ubuntu1~20.04 [1 132 B]                     
Пол:16 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 xserver-xorg-legacy amd64 2:1.20.8-2ubuntu2.4 [32,4 kB]               
Пол:17 http://ru.archive.ubuntu.com/ubuntu focal/restricted amd64 nvidia-340 amd64 340.108-0ubuntu2 [52,0 MB]                             
Пол:18 http://ru.archive.ubuntu.com/ubuntu focal/main amd64 screen-resolution-extra all 0.18build1 [4 456 B]                               
Пол:19 http://ru.archive.ubuntu.com/ubuntu focal-updates/main amd64 nvidia-settings amd64 440.82-0ubuntu0.20.04.1 [963 kB]                 
Получено 57,3 MB за 1мин 16с (749 kB/s)                                                                                                   
Предварительная настройка пакетов …
(Чтение базы данных … на данный момент установлен 135401 файл и каталог.)
Подготовка к распаковке …/libubsan1_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libubsan1:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/libtsan0_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libtsan0:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/gcc-10-base_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается gcc-10-base:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Настраивается пакет gcc-10-base:amd64 (10.2.0-5ubuntu1~20.04) …
(Чтение базы данных … на данный момент установлен 135401 файл и каталог.)
Подготовка к распаковке …/libstdc++6_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libstdc++6:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Настраивается пакет libstdc++6:amd64 (10.2.0-5ubuntu1~20.04) …
(Чтение базы данных … на данный момент установлен 135401 файл и каталог.)
Подготовка к распаковке …/0-libquadmath0_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libquadmath0:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/1-liblsan0_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается liblsan0:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/2-libitm1_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libitm1:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/3-libgomp1_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libgomp1:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/4-libcc1-0_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libcc1-0:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/5-libatomic1_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libatomic1:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Подготовка к распаковке …/6-libgcc-s1_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается libgcc-s1:amd64 (10.2.0-5ubuntu1~20.04) на замену (10-20200411-0ubuntu1) …
Настраивается пакет libgcc-s1:amd64 (10.2.0-5ubuntu1~20.04) …
Выбор ранее не выбранного пакета libc6-i386.
(Чтение базы данных … на данный момент установлен 135401 файл и каталог.)
Подготовка к распаковке …/0-libc6-i386_2.31-0ubuntu9.1_amd64.deb …
Распаковывается libc6-i386 (2.31-0ubuntu9.1) …
Выбор ранее не выбранного пакета lib32gcc-s1.
Подготовка к распаковке …/1-lib32gcc-s1_10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается lib32gcc-s1 (10.2.0-5ubuntu1~20.04) …
Выбор ранее не выбранного пакета libxnvctrl0:amd64.
Подготовка к распаковке …/2-libxnvctrl0_440.82-0ubuntu0.20.04.1_amd64.deb …
Распаковывается libxnvctrl0:amd64 (440.82-0ubuntu0.20.04.1) …
Выбор ранее не выбранного пакета lib32gcc1.
Подготовка к распаковке …/3-lib32gcc1_1%3a10.2.0-5ubuntu1~20.04_amd64.deb …
Распаковывается lib32gcc1 (1:10.2.0-5ubuntu1~20.04) …
Выбор ранее не выбранного пакета xserver-xorg-legacy.
Подготовка к распаковке …/4-xserver-xorg-legacy_2%3a1.20.8-2ubuntu2.4_amd64.deb …
Распаковывается xserver-xorg-legacy (2:1.20.8-2ubuntu2.4) …
Выбор ранее не выбранного пакета nvidia-340.
Подготовка к распаковке …/5-nvidia-340_340.108-0ubuntu2_amd64.deb …
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libGL.so.1 в /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libGL.so.1 в /usr/lib/i386-linux-gnu/libGL.so.1.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libGL.so в /usr/lib/x86_64-linux-gnu/libGL.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libGL.so в /usr/lib/i386-linux-gnu/libGL.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libEGL.so.1 в /usr/lib/x86_64-linux-gnu/libEGL.so.1.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libEGL.so.1 в /usr/lib/i386-linux-gnu/libEGL.so.1.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libEGL.so в /usr/lib/x86_64-linux-gnu/libEGL.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libEGL.so в /usr/lib/i386-linux-gnu/libEGL.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libGLESv2.so в /usr/lib/x86_64-linux-gnu/libGLESv2.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libGLESv2.so в /usr/lib/i386-linux-gnu/libGLESv2.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libGLESv2.so.2 в /usr/lib/x86_64-linux-gnu/libGLESv2.so.2.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libGLESv2.so.2 в /usr/lib/i386-linux-gnu/libGLESv2.so.2.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so в /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libGLESv1_CM.so в /usr/lib/i386-linux-gnu/libGLESv1_CM.so.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1 в /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1.distrib из-за nvidia-340»
Добавляется «отклонение /usr/lib/i386-linux-gnu/libGLESv1_CM.so.1 в /usr/lib/i386-linux-gnu/libGLESv1_CM.so.1.distrib из-за nvidia-340»
Распаковывается nvidia-340 (340.108-0ubuntu2) …
Выбор ранее не выбранного пакета screen-resolution-extra.
Подготовка к распаковке …/6-screen-resolution-extra_0.18build1_all.deb …
Распаковывается screen-resolution-extra (0.18build1) …
Выбор ранее не выбранного пакета nvidia-settings.
Подготовка к распаковке …/7-nvidia-settings_440.82-0ubuntu0.20.04.1_amd64.deb …
Распаковывается nvidia-settings (440.82-0ubuntu0.20.04.1) …
Настраивается пакет libgomp1:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет libxnvctrl0:amd64 (440.82-0ubuntu0.20.04.1) …
Настраивается пакет libquadmath0:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет libatomic1:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет libubsan1:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет screen-resolution-extra (0.18build1) …
Настраивается пакет libc6-i386 (2.31-0ubuntu9.1) …
Настраивается пакет nvidia-settings (440.82-0ubuntu0.20.04.1) …
Настраивается пакет xserver-xorg-legacy (2:1.20.8-2ubuntu2.4) …
Настраивается пакет libcc1-0:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет liblsan0:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет libitm1:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет libtsan0:amd64 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет lib32gcc-s1 (10.2.0-5ubuntu1~20.04) …
Настраивается пакет lib32gcc1 (1:10.2.0-5ubuntu1~20.04) …
Настраивается пакет nvidia-340 (340.108-0ubuntu2) …
dpkg: ошибка: version '-' has bad syntax: revision number is empty
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-340
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
Добавляется системный пользователь «nvidia-persistenced» (UID 113) ...
Добавляется новая группа «nvidia-persistenced» (GID 126) ...
Добавляется новый пользователь «nvidia-persistenced» (UID 113) в группу «nvidia-persistenced» ...
Не создаётся домашний каталог «/».
Loading new nvidia-340-340.108 DKMS files...
Building for 5.6.0-1028-oem
Building for architecture x86_64
Building initial module for 5.6.0-1028-oem
Error! Bad return status for module build on kernel: 5.6.0-1028-oem (x86_64)
Consult /var/lib/dkms/nvidia-340/340.108/build/make.log for more information.
dpkg: ошибка при обработке пакета nvidia-340 (--configure):
 installed nvidia-340 package post-installation script subprocess returned error exit status 10
Обрабатываются триггеры для mime-support (3.64ubuntu1) …
Обрабатываются триггеры для libc-bin (2.31-0ubuntu9.1) …
Обрабатываются триггеры для man-db (2.9.1-1) …
Обрабатываются триггеры для desktop-file-utils (0.24-1ubuntu3) …
Обрабатываются триггеры для initramfs-tools (0.136ubuntu6.3) …
update-initramfs: Generating /boot/initrd.img-5.6.0-1028-oem
I: The initramfs will attempt to resume from /dev/sda3
I: (UUID=34755865-2c17-45f7-b143-d26889aacb01)
I: Set the RESUME variable to override this.
При обработке следующих пакетов произошли ошибки:
 nvidia-340
localepurge: Disk space freed:      0 KiB in /usr/share/locale
localepurge: Disk space freed:      0 KiB in /usr/share/man
localepurge: Disk space freed:      0 KiB in /usr/share/gnome/help
localepurge: Disk space freed:      0 KiB in /usr/share/calendar
localepurge: Disk space freed:      0 KiB in /usr/share/aptitude
localepurge: Disk space freed:      0 KiB in /usr/share/help

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (1)

Соответственно, после перезагрузки - черный экран.
В recovery - 640x480.
Ну, хотя-бы в терминале удалось удалить.
В Debian 9 ставится таким образом:
# apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-340xx-driver
Но как это применить в Runtu - не знаю.

При установке пакетов в Synaptic:
  W: Загрузка выполняется от лица суперпользователя без ограничений песочницы,
  так как файл «/root/.synaptic/tmp//tmp_sh» недоступен для пользователя «_apt».
  - pkgAcquire::Run (13: Отказано в доступе)
Это так задумано? Или я опять уже что-то сломал...
« Последнее редактирование: Октябрь 09, 2020, 07:46:33 от Alik29 »
Celeron Core 2 Duo E8400 3Gz RAM-2Gb nVidia GeForce 9500GT  MB-P5KPL-AM

Оффлайн HsH

  • Administrator
  • *****
  • Автор темы
  • Сообщений: 2897
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #13 : Октябрь 09, 2020, 09:40:05 »
Попытка установить nvidia-340:
NVidia официально прекратила поддержку драйвера ветки 340.*, который предназначался для семейства видеокарт Tesla G8x, G9x, и GT2xx. Установить эти драйверы можно только на систему с  ядром до Linux v5.4 и Xorg 1.20 включительно.

Попробуйте установить в систему ядро linux-generic и поставить проприетарный драйвер NVidia.
Добавлю эту информацию в описание сборки. Похоже, нужно сделать ещё одну версию 20.04 LITE с ядром generic-5.4.

Оффлайн Alik29

  • Новичок
  • **
  • Сообщений: 51
Re: Runtu LITE 20.04.1 x64 - 202010
« Ответ #14 : Октябрь 09, 2020, 10:39:01 »
А можно в виде последовательности команд?
(боюсь корректно установить другое ядро не сумею..)
---
В Runtu 18.04 x32 при установке пакетов из Synaptic выдает такую-же ошибку.
Но там и там пакеты устанавливает.
Celeron Core 2 Duo E8400 3Gz RAM-2Gb nVidia GeForce 9500GT  MB-P5KPL-AM