Автор Тема: Управление пакетами (apt-get)  (Прочитано 2949 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RuntuLinux84

  • Новичок
  • **
  • Автор темы
  • Сообщений: 10
Управление пакетами (apt-get)
« : Июнь 23, 2018, 17:55:19 »
apt-get update – обновить базу пакетов   
apt-get upgrade – обновить все пакеты   
apt-get dist-upgrade – обновить версию Ubuntu   
apt-get install pkg – установить pkg   
apt-get remove pkg – удалить pkg   
apt-get autoremove – удалить устаревшие пакеты   
apt-get -f install – попытаться исправить сломаные пакеты(зависимости)   
dpkg --configure -a – попытаться исправить сломаные пакеты(зависимости)   
dpkg -i pkg.deb – установить пакет из файла pkg.deb   
(file) /etc/apt/sources.list – список репозиториев APT

Оффлайн gvitaly

  • Местный
  • *****
  • Сообщений: 516
Re: Управление пакетами (apt-get)
« Ответ #1 : Июнь 23, 2018, 21:49:56 »
apt-get upgrade – обновить все пакеты
Не все. Ядро, к примеру, не обновится. По крайней мере в 18.04 так.
apt-get dist-upgrade – обновить версию Ubuntu  
А это как раз обновляет ВСЕ пакеты. В том числе устанавливает новое ядро (старое остпется в системе).
А обновляет версию ubuntu команда
apt-get do-release-upgradeемнип.

Очистить кэш пакетов:
apt-get clean
Установить пакет из файла pkg.deb:
apt-get install ./pkg.debОтличается от dpkg -i pkg.deb тем, что устанавливает зависимости из репозитория. Но если они не удовлетворены, то пакет не установится.
« Последнее редактирование: Июнь 24, 2018, 14:12:38 от gvitaly »

Оффлайн ek-nfn

  • Местный
  • *****
  • Сообщений: 1422
Re: Управление пакетами (apt-get)
« Ответ #2 : Июнь 23, 2018, 22:24:42 »
дополню
заблокировать обновление пакета:
apt-mark hold package_name

разблокировать обновление пакета:
apt-mark unhold package_name

Проверить наличие обновлений без установки (естественно после apt-get update) :
apt-get --just-print upgrade

Вообще-то apt-get уже в прошлом, актуален второй интерфейс с исправлением ошибок первого - apt
знакомимся apt help

бывает важна расстановка приоритетов (pinning) между репозитариями, прописываем нужные уровни в  - /etc/apt/preferences
Devuan ASCII x32..x64