Автор Тема: Настройка горячих клавиш (управление громкостью) в Runtu XFCE 14.04  (Прочитано 10043 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Irshat

  • Новичок
  • **
  • Автор темы
  • Сообщений: 37
Поставил клиенту, тот попросил повесить изменение звука на горячие клавиши, думал все просто как в гноме, но не нашел  ???. В настройках клавиатуры - комбинация клавиш нет такого  :-\. Есть ли какая-нибудь команда для звука или это недостаток xfce и ничего не сделать.

Оффлайн CeperaDan

  • Новичок
  • **
  • Сообщений: 53
Поставил клиенту, тот попросил повесить изменение звука на горячие клавиши, думал все просто как в гноме, но не нашел  ???. В настройках клавиатуры - комбинация клавиш нет такого  :-\. Есть ли какая-нибудь команда для звука или это недостаток xfce и ничего не сделать.

У меня на клавиатуре "ручка-крутилка" для громкости (и много еще чего), ничего не ставил, крыска сама всё распознала и поноценно поддерживает... Думал что во всех Линуксах так... Озадачен...

На нетбуке тоже без проблемм, и яркость и громкость и блокировка тачпада и упрвление "вафлей", только-что проверил - всё работает...
« Последнее редактирование: Ноябрь 16, 2014, 16:26:42 от CeperaDan »

Оффлайн Irshat

  • Новичок
  • **
  • Автор темы
  • Сообщений: 37
Поставил клиенту, тот попросил повесить изменение звука на горячие клавиши, думал все просто как в гноме, но не нашел  ???. В настройках клавиатуры - комбинация клавиш нет такого  :-\. Есть ли какая-нибудь команда для звука или это недостаток xfce и ничего не сделать.

У меня на клавиатуре "ручка-крутилка" для громкости (и много еще чего), ничего не ставил, крыска сама всё распознала и поноценно поддерживает... Думал что во всех Линуксах так... Озадачен...

На нетбуке тоже без проблемм, и яркость и громкость и блокировка тачпада и упрвление "вафлей", только-что проверил - всё работает...
Компьютер у них стационар с обыкновеной клавиатурой, на гноме я звук обычно вешал на super вниз и super вверх, ну и super M для выкл. звука, жаль на xfce такого нет :(

Оффлайн FSnow

  • Global Moderator
  • *****
  • Сообщений: 689
на гноме я звук обычно вешал на super вниз и super вверх, ну и super M для выкл. звука, жаль на xfce такого нет :(
    Повешайте такие команды:
увеличить громкость
amixer -q sset Master 5+ unmuteуменьшить громкость
amixer -q sset Master 5- unmuteвкл./выкл. звук
amixer -D pulse  set Master toggle

Оффлайн Irshat

  • Новичок
  • **
  • Автор темы
  • Сообщений: 37
на гноме я звук обычно вешал на super вниз и super вверх, ну и super M для выкл. звука, жаль на xfce такого нет :(
    Повешайте такие команды:
увеличить громкость
amixer -q sset Master 5+ unmuteуменьшить громкость
amixer -q sset Master 5- unmuteвкл./выкл. звук
amixer -D pulse  set Master toggle

Работает только выключение, а на громкость пишет:
amixer: Unable to find simple control 'Master',0amixer scontrols выдает:
Simple mixer control 'IEC958',0Попробовал за место мастера поставить IEC958, все равно не видит.
В гугле вообще у многих такая проблема именно на IEC958.

Оффлайн FSnow

  • Global Moderator
  • *****
  • Сообщений: 689
amixer scontrolsчто выдает?

Оффлайн Irshat

  • Новичок
  • **
  • Автор темы
  • Сообщений: 37
amixer scontrolsчто выдает?

amixer scontrols выдает:
Simple mixer control 'IEC958',0Попробовал за место мастера поставить IEC958, все равно не видит.

Оффлайн Irshat

  • Новичок
  • **
  • Автор темы
  • Сообщений: 37
В общем на досуге тестировал другие дистрибутивы на XFCE: Debian, RFRemix и что странно, там команды горячих клавиш нормально срабатывают.
На таких командах:
amixer set Master 10%+ -q
amixer set Master 10%- -q
amixer set Master toggle -q
Ладно я бы подумал, что RFRemix не из нашего огорода и там возможно, есть такая функция. Но Debian то можно сказать свой.  ???
На обоих дистрах одни и те же команды нормально срабатывают. А на Рунту и в Убунту нет.  :-\
Думается мне, что это из-за ядра, так как их ядра по amixer scontrols выдает Master
а наш показывает пресловутый IEC958, из-за которго у многих такая же проблема.

Оффлайн helboof

  • Прохожий
  • *
  • Сообщений: 8
Может, конечно, уже слишком поздно :), но хотя бы для себя приведу (нагло скопипастю) сюда найденное решение на буржуйском форуме убунты:
https://askubuntu.com/questions/97936/terminal-command-to-set-audio-volume

__________________________________
 92
down vote
   

Parts of this answer comes from Setting microphone input volume using the command line?, placed here for your convenience.

Increase volume by 5%

amixer -D pulse sset Master 5%+

Decrease volume by 5%

amixer -D pulse sset Master 5%-

Set volume to 50%

amixer -D pulse sset Master 50%

    If you are using ALSA, amixer can be helpful for your script programming.

    When dropping the amixer --help command in a terminal you will see something like this:

    enter image description here

    Depending on your soundcard, levels may be different than mine, but you can use alsamixer in the terminal in order to check which levels and which features in your sound card you can call in a command to set the volume as you wish.

    enter image description here

    In my example, with my principal sound card (I have 2: the embedded and a PCI audio card), levels are from 0 to 100, this way I can change the volume of a desired input/output in my soundcard by dropping in a terminal the next command:

    amixer -c 0 set Front 50DB
    amixer -c 0 set Front 64DB

    In the first command, the result will set the Front panel output to 78% level and the second one will set the Front panel output to 100% level.

    In order to gather information related to your mixer controls, drop the amixer command with no parameters and you will get a list. Or indicate which audio device you wish to see a list of controls with amixer -c X (where "X" is the number of your audio device).

    BTW: Remember that DB values are calculated logarithmically and not linearly.

Remember that this command allow you to control parameters on whatever sound device you are currently using.

Good luck!
____________________________________________________

Оффлайн kompilainenn

  • Местный
  • *****
  • Сообщений: 1060
  • Активно пропагандирую Runtu
>Good luck!

Thank you very much! But it is Russian forum. Please translate your post to Russian, that people don't will curse you
Мы говорим Linux, подразумеваем Runtu