Автор Тема: проблема с кодировкой(?)  (Прочитано 3893 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ksi

  • Новичок
  • **
  • Автор темы
  • Сообщений: 12
  • Ашку! Fire!
проблема с кодировкой(?)
« : Август 12, 2014, 16:15:33 »
Здравствуйте форумчане!
На ниже приведенном скрине можно видеть окошко с сообщением, где вместо слов  символы вопросительного знака.

Как это разрешить?
И второй вопрос, при установке оригинального дистрибутива RUNTU устанавливается оч красивый анимированный загрузчик, однако при обновлении системы он был заменен.
Есть ли возможность восстановить тот, изначальный, и как это сделать?
ОС Runtu lite 14.04
Спасибо!

Оффлайн RoPP

  • Постоялец
  • ***
  • Сообщений: 218
Re: проблема с кодировкой(?)
« Ответ #1 : Август 13, 2014, 09:29:58 »
привет.
символы вопр.знака - это не ошибка в кодировке, а вопрос вам - а что нужно положить на даму бубен?(черного валета)
заставка при загрузке - наберите в синаптике plymouth-theme-solar-runtu - это и есть заставка. как-то вы обновились интересно, что она слетела(тема рунту была, видимо, заменена на другую).

Оффлайн Ksi

  • Новичок
  • **
  • Автор темы
  • Сообщений: 12
  • Ашку! Fire!
Re: проблема с кодировкой(?)
« Ответ #2 : Август 13, 2014, 10:50:58 »
привет.
символы вопр.знака - это не ошибка в кодировке, а вопрос вам - а что нужно положить на даму бубен?(черного валета)
заставка при загрузке - наберите в синаптике plymouth-theme-solar-runtu - это и есть заставка. как-то вы обновились интересно, что она слетела(тема рунту была, видимо, заменена на другую).

Да нет же, это окошко вызываемой подсказки.)))
Вопрос о том, какого фига там вопросительные знаки, вместо конкретной надписи.
Пакет называется Айслериот 3.10.2, и он нормально работает на другой машине с elementary ОС. Нормально, короче, подсказывает. А тут не хочет.

По поводу второго вопроса:
Указанный Вами пакет в системе установлен.
Обновление системы произвожу так:
sudo aptitude update
sudo aptitude upgrade
« Последнее редактирование: Август 13, 2014, 11:44:08 от Ksi »

Оффлайн RoPP

  • Постоялец
  • ***
  • Сообщений: 218
Re: проблема с кодировкой(?)
« Ответ #3 : Август 13, 2014, 11:44:34 »
да, сейчас проверил на дебиане(версия 3.4) - там все как вы говорите. попробуйте удалить эту версию и поставить ниже(например отсюда http://pkgs.org/ubuntu-13.10/ubuntu-main-i386/aisleriot_3.8.0-2_i386.deb.html ).
про плимуч - посмотрите в граб, может там настройки запуска изменились.

Оффлайн Ksi

  • Новичок
  • **
  • Автор темы
  • Сообщений: 12
  • Ашку! Fire!
Re: проблема с кодировкой(?)
« Ответ #4 : Август 13, 2014, 13:20:22 »
Откат до предыдущей версии не помог.

Какие конкретно настройки смотреть в грубе и на что их менять?

Оффлайн RoPP

  • Постоялец
  • ***
  • Сообщений: 218
Re: проблема с кодировкой(?)
« Ответ #5 : Август 13, 2014, 14:29:22 »
про пасьянс - помогла установка версии 3.4 из дебиан


про граб - вот что у меня стоит из плимуч


а вот настройки граб по пути /etc/default/grub

Оффлайн Ksi

  • Новичок
  • **
  • Автор темы
  • Сообщений: 12
  • Ашку! Fire!
Re: проблема с кодировкой(?)
« Ответ #6 : Август 13, 2014, 15:52:52 »
1)Да, старая версия 3.4 работает правильно. Спасибо друг!
2)Настройки GRUB имею совершенно аналогичные, однако...

Оффлайн RoPP

  • Постоялец
  • ***
  • Сообщений: 218
Re: проблема с кодировкой(?)
« Ответ #7 : Август 13, 2014, 16:04:00 »
если настройки граба и компоненты плимуча одинаковые - может с видео что не так? дрова ставили?

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3182
Re: проблема с кодировкой(?)
« Ответ #8 : Август 13, 2014, 16:18:01 »
вместо слов  символы вопросительного знака.
    Скорее всего, "намудрили" переводчики, которые некорректно указали значение фразы.

Есть ли возможность восстановить тот, изначальный, и как это сделать?
    Покажите вывод
update-alternatives --display default.plymouth
dpkg -l | grep plymouth

Оффлайн Irshat

  • Новичок
  • **
  • Сообщений: 37
Re: проблема с кодировкой(?)
« Ответ #9 : Август 13, 2014, 20:29:05 »
Цитировать
И второй вопрос, при установке оригинального дистрибутива RUNTU устанавливается оч красивый анимированный загрузчик, однако при обновлении системы он был заменен.
Скорей всего при  обновлении согласились на обновленный конфиг, если не ошибаюсь там врорде n надо нажимать, чтоб все нормально оставалось.

Оффлайн Ksi

  • Новичок
  • **
  • Автор темы
  • Сообщений: 12
  • Ашку! Fire!
Re: проблема с кодировкой(?)
« Ответ #10 : Август 14, 2014, 12:28:00 »
Цитировать
Скорей всего при  обновлении согласились на обновленный конфиг, если не ошибаюсь там врорде n надо нажимать, чтоб все нормально оставалось.
Да, так примерно и было. К сожалению на тот момент не знал последствий.

Цитировать
Покажите вывод
Код:
update-alternatives --display default.plymouth
dpkg -l | grep plymouth

Пожалуйста:

energy@energy-system:~$ update-alternatives --display default.plymouth
default.plymouth - автоматический режим
  ссылка сейчас указывает на /lib/plymouth/themes/solar/solar.plymouth
/lib/plymouth/themes/solar/solar.plymouth — приоритет 10
Текущая «лучшая» версия: «/lib/plymouth/themes/solar/solar.plymouth».
energy@energy-system:~$ dpkg -l | grep plymouth
ii  libplymouth2:i386                       0.8.8-0ubuntu17                       i386         graphical boot animation and logger - shared libraries
ii  plymouth                                0.8.8-0ubuntu17                       i386         graphical boot animation and logger - main package
ii  plymouth-label                          0.8.8-0ubuntu17                       i386         graphical boot animation and logger - label control
ii  plymouth-theme-solar-runtu              0.8.8-0ubuntu16                       i386         graphical boot animation and logger - Runtu theme
ii  plymouth-x11                            0.8.8-0ubuntu17                       i386         graphical boot animation and logger - X11 interface