Автор Тема: Спящий режим в Runtu XFCE 12.04 на Nforce2  (Прочитано 7220 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн snowman-fedya

  • Активист
  • ****
  • Автор темы
  • Сообщений: 335
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #15 : Май 18, 2013, 03:05:45 »
с шитьём биоса, как я и ожидал, начались проблемы. сперва потому, что нет уже давно у меня ни fdd, ни дискет. ладно, нашёл в мусорной свалке битого железа на работе. прошил, оппа! не запускается комп, чёрный экран, спикер не пищит.

к счастью, в загашнике нашлась похожая плата, только rev.2. биосы от них несовместимы. ну как в старые времена: загружаешь дос, вынимаешь на ходу микросхему биоса, ставишь другую, шьёшь. оппа! awdflash вычисляет, что образ не от этой ревизии платы и отказывается шить.

поиск awdflash более ранней версии, не такого умного. прошил биосом 2.7. Фигушки, не работает. Снова весь процесс по хот-свап перешивке, версия 2.6 прошла и комп начал грузиться. В биосе появилась опция CPU Disconnect, а mac сетевухи стал FF:FF:FF:FF:FF:FF. Ладно, это мелочи...

И таки комп стал входить в хибернейт по pm-hibernate! Но только входить, во время выхода виснет :(

Есть у кого соображения, куда копать?

Оффлайн snowman-fedya

  • Активист
  • ****
  • Автор темы
  • Сообщений: 335
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #16 : Май 19, 2013, 03:13:43 »
увы, недолго музыка играла. перестал выключаться, и всё стало как раньше :(((

неужели никто не сталкивался с такой проблемой?

Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1465
  • calambus@jabber.ru
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #17 : Май 19, 2013, 10:54:26 »
snowman-fedya , честно говоря я с  этими режимами на настольных станционарных аппаратах не экспериментировал . Обычно режим сна используется на переносных аппаратах с автономным питанием для снижения эноргопотребления в режиме простоя . На сайте http://debianforum.ru/ видел мельком обсуждение этой проблемы по отношению к нет/ноутбукам , но в этом случае в этих аппаратах эти режимы уже имеют поддержку на уровне BIOS и их алгоритмы работы прописаны в Системном ПО ...  
« Последнее редактирование: Май 19, 2013, 11:22:46 от calambus »
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум

Оффлайн snowman-fedya

  • Активист
  • ****
  • Автор темы
  • Сообщений: 335
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #18 : Май 19, 2013, 12:47:03 »
ранее у меня железо работало 24/7 и такой проблемы не возникало.

но теперь каждый день заново настраивать всё то, что было запущено, на нужном экране и в окне нужного размера...

конечно, это тоже скриптуется, но хотелось бы глобального решения проблемы. гибернул систему, в нужный момент включил и всё там как оставил. в винде это без проблем, и я уже привык :-/

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3172
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #19 : Май 19, 2013, 13:01:38 »

   Посмотрите здесь - http://help.ubuntu.ru/wiki/ubuntu_12.04_%D0%BF%D1%80%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC%D1%8B_%D1%82%D0%B2%D0%B8%D0%BA%D0%B8?s[#%D1%81%D0%BF%D1%8F%D1%89%D0%B8%D0%B9_%D1%80%D0%B5%D0%B6%D0%B8%D0%BC_suspend_to_disk

   Статья "Спящий режим".

Оффлайн snowman-fedya

  • Активист
  • ****
  • Автор темы
  • Сообщений: 335
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #20 : Май 19, 2013, 13:34:42 »
да это всё я находил...

проблема в том, что pm-hibernate не отрабатывает правильно.

Оффлайн snowman-fedya

  • Активист
  • ****
  • Автор темы
  • Сообщений: 335
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #21 : Май 20, 2013, 10:22:11 »
echo disk > /sys/power/state не выключает машину...

Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1465
  • calambus@jabber.ru
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #22 : Май 23, 2013, 15:08:24 »
http://compizomania.blogspot.ru/2013/05/ubuntu-1304_4.html
Цитировать
Начиная с релиза Ubuntu 12.04, теперь по умолчанию Спящий режим отключен.
Связано это с тем, что многие пользователи при установке Ubuntu, по незнанию, невнимательности,
а некоторые просто не захотели установить на жёстком диске раздел подкачки - SWAP,
что в конечном итоге приводит к неправильному выходу компьютера из "сна".
Если у вас есть раздел SWAP на жёстком диске, то включить Спящий режим можно следующим образом
Прежде всего нужно открыть файл hibernate.pkla в текстовом редакторе следующей командой:
sudo gedit /var/lib/polkit-1/localauthority/50-local.d/hibernate.pklaКогда редактор откроется с пустым файлом, скопируйте и вставьте в него следующий код:
[Re-enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes[/b][/quote]
« Последнее редактирование: Май 23, 2013, 16:08:55 от calambus »
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум

Оффлайн snowman-fedya

  • Активист
  • ****
  • Автор темы
  • Сообщений: 335
Re: Спящий режим в Runtu XFCE 12.04 на Nforce2
« Ответ #23 : Май 23, 2013, 21:17:42 »
Это включает доступность кнопок "спящего режима", а вовсе не сам режим. Даже если этого не делать, pm-hibernate и тем более echo disk > /sys/power/state должно загонять машину в него. а этого и не происходит... и нигде концов не найдёшь, за который потянуть можно, в логах всё гладко...