Автор Тема: polkit-gnome-authentication-agent нужен ли?  (Прочитано 8390 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн myth

  • Новичок
  • **
  • Автор темы
  • Сообщений: 23
polkit-gnome-authentication-agent нужен ли?
« : Апрель 21, 2013, 10:47:12 »
C какой целью в сборки рунту включены polkit-gnome-authentication-agent +  polkit + consolekit и можно ли от них избавится после установки дистрибутива?
Не вижу никакого смысла в использовании политик на домашнем компьютере, от кого мне закрывать доступ к монтированию флешек или печать на принтере, кроме того ощущение что линукс плавно мутирует в windows,  осталось добавить консоль ммс и оснатски управления групповыми политиками.

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3172
Re: polkit-gnome-authentication-agent нужен ли?
« Ответ #1 : Апрель 24, 2013, 22:37:43 »
C какой целью в сборки рунту включены polkit-gnome-authentication-agent
     Все текущие версии программ, требущие авторизации администратора, запускаются через pkexec. Для примера посмотрите ярлыки программ gparted и synaptic.

polkit
   В Runtu XFCE 12.04:
runtu@runtu:~$ apt-cache rdepends --installed policykit-1
policykit-1
Reverse Depends:
  grub-customizer
  python-aptdaemon
  blueman
  udisks
  python-aptdaemon
  policykit-1-gnome
  network-manager
  libpolkit-gobject-1-0
  libpolkit-backend-1-0
  jockey-common
  hplip
  colord
  synaptic
  blueman
  upower
  udisks
  python-aptdaemon
  policykit-desktop-privileges
  policykit-1-gnome
  network-manager
  libpolkit-gobject-1-0
  libpolkit-backend-1-0
  jockey-common
  hplip
  colord

consolekit
runtu@runtu:~$ apt-cache rdepends --installed consolekit
consolekit
Reverse Depends:
  xfce4-power-manager
  xfce4-session
  pulseaudio
  policykit-1
  acpi-support
  xfce4-session
  xfce4-power-manager
  pulseaudio
  policykit-1
  acpi-support

  В версиях Runtu GNOME и LITE аналогично.

Оффлайн myth

  • Новичок
  • **
  • Автор темы
  • Сообщений: 23
Re: polkit-gnome-authentication-agent нужен ли?
« Ответ #2 : Июнь 30, 2013, 13:27:56 »
HSH, спасибо за ответ. Сразу вспомнился анекдот про яблоко, однако, я всеже решил разобраться сам :) Для этого начал постепенно все выпиливать из дистра Runtu LXDE, выбирал самый маленький. polkit действительно тянет за собой кучу зависимостей, но это как правило не самый необходимый софт, к примеру насчет того же pkexec - удаляется gksu, gksudo еще чтото, все программки по-прежнему можно запускать через терминал, sudo и su работают, nm там и так не был установлен, но зависимости потянули за собой gvfs - какаято часть ее там всеже стояла наряду с hal, ну да как бы и боХ с ней, заодно снес hal - pcmanfm и без него прекрасно работает, флешки можно и вручную монтировать, другое дело отказался запускатся brasero пришлось замену для записи дисков, ну это тоже уже мелочи. Вообщем, много что я поудалял, система осталась рабочей, список процессов почещался на полэкрана, памяти использовалось по минимуму - точно уже не скажу цифру, но заметно меньше оригинального дистра, так вот - казалось бы система должна начать работать быстрее, НО этого не случилось, наоборот начались тормоза непередаваемые, не знаю почему, в session-errors новых ошибок не появилось, остальные логи я не смотрел, думаю что это произошло после сноса gvfs. Вообщем, дальше я экспериментировать не стал, другим советов давать не буду, можете проверить сами, я же завязываю с оптимизацией путем удалений казалось бы ненужных прог :)

Не знаю как закрыть, тему считаю решенной.

Оффлайн smik55

  • Местный
  • *****
  • Сообщений: 1015
Re: polkit-gnome-authentication-agent нужен ли?
« Ответ #3 : Июнь 30, 2013, 15:00:50 »
Цитировать
я же завязываю с оптимизацией путем удалений казалось бы ненужных прог
Я так думаю, что если какая то программа установлена, но она не запускается автоматом, то и пусть себе спокойно лежит где то в системе на ЖД. Другое дело- если она запускается, но не является жизненно важной для ОС, то каким способом ее процесс убрать из  автозагрузки. В Windows такие инструменты есть, а есть ли в Линукс подобное с графическим интерфейсом или хотя бы без для управления запуском процессов?

Оффлайн vita

  • Местный
  • *****
  • Сообщений: 971
  • Fiat lux! (Да будет Свет!)
    • Форум проекта Matuntu
Re: polkit-gnome-authentication-agent нужен ли?
« Ответ #4 : Июнь 30, 2013, 15:10:37 »
Я так думаю, что если какая то программа установлена, но она не запускается автоматом, то и пусть себе спокойно лежит где то в системе на ЖД. Другое дело- если она запускается, но не является жизненно важной для ОС, то каким способом ее процесс убрать из  автозагрузки. В Windows такие инструменты есть, а есть ли в Линукс подобное с графическим интерфейсом или хотя бы без для управления запуском процессов?
В ->Параметры системы->Запускаемые приложения (само название за себя говорит) надо проанализировать, что Вам нужно запускать в системе, а что отложить (снять галочки) или даже удалить из списка, а возможно и добавить, если есть необходимость в запуске отсутствующего процесса.
« Последнее редактирование: Июнь 30, 2013, 15:16:24 от vita »
Per aspera ad astra! (Через тернии к звездам!)

Оффлайн myth

  • Новичок
  • **
  • Автор темы
  • Сообщений: 23
Re: polkit-gnome-authentication-agent нужен ли?
« Ответ #5 : Июнь 30, 2013, 15:15:12 »
К словам Vita добавлю, что есть програмка для управления запуском служб/демонов - rcconf.

Оффлайн smik55

  • Местный
  • *****
  • Сообщений: 1015
Re: polkit-gnome-authentication-agent нужен ли?
« Ответ #6 : Июнь 30, 2013, 16:52:50 »
Цитировать
>Параметры системы->Запускаемые приложения
Я не это имел ввиду. Этот пункт аналогичен пункту Автозагрузка в Windows, но в ней еще есть возможность управлять запуском всех приложений и процессов, которых может быть около 120 и более.
myth, а что выводит эта программка rcconf? У меня ее нет, как поставить?

Оффлайн myth

  • Новичок
  • **
  • Автор темы
  • Сообщений: 23
Re: polkit-gnome-authentication-agent нужен ли?
« Ответ #7 : Июнь 30, 2013, 16:58:44 »
myth, а что выводит эта программка rcconf? У меня ее нет, как поставить?

Что делает:
$ aptitude show rcconf
Пакет: rcconf                                    
Состояние: установлен
Автоматически установлен: нет
Версия: 2.5ubuntu1
Приоритет: необязательный
Раздел: universe/admin
Сопровождающий: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Архитектура: all
Размер в распакованном виде: 135 k
Зависимости: whiptail | whiptail-provider | dialog, sysv-rc, perl, perl-modules
Конфликтует: file-rc
Описание: настройка уровней запуска в Debian
 Утилита настраивает запуск и остановку системных служб для различных уровней
 запуска операционной системы. Для запуска/остановки служб используются сценарии
 из директории /etc/init.d/. Rcconf предназначен для работы с системой
 инициализации System-V. Утилита является псевдографическим интерфейсом к
 команде update-rc.d


Как установить:
sudo apt-get install rcconf
Запускать через sudo rcconf
« Последнее редактирование: Июнь 30, 2013, 17:03:53 от myth »