Автор Тема: MUTE на панели не включает звук, только выключает.  (Прочитано 8974 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Wapr Old

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Дистр. Runtu Xfce 12.
При указанных на скриншоте preference, левый клюк по иконке в трее выключает звук, но повторный клюк его не включает, хотя визуально, судя по иконке в трее, звук включен.
Трек:
1. Нажимаю на иконку в трее -> иконка рисуется как mute, в AlsaMixer v1.0.25 мьютятся каналы Master и PCM, в "ALSA Mixer" мьютится канал Master, в PulseAudio мьютится выход "Аналоговое стерео". В итоге глушится звук.
2. Нажимаю повторно -> иконка рисуется как unmute, в AlsaMixer v1.0.25 включается только Master, PCM замьютирован, в "ALSA Mixer" и PulseAudio ничего не меняется. В итоге звук не включился.
3. В AlsaMixer v1.0.25 размьютирую канал PCM -> В других окнах ничего не меняется, звука нет.
4. В "ALSA Mixer" или PulseAudio клюкнуть по отмеченным кнопкам -> звук появляется.


Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1465
  • calambus@jabber.ru
Этот вопрос уже поднимался ранее в обсуждении дистрибутива Runtu XFCE 12-04 , лечится установкой регулятора громкости Volti из репозитория Ubuntu ...
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум

Оффлайн Wapr Old

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Пробовал я уже этот Volti... снёс через полчаса. Кривизна неимоверная.  :(

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3204

   Wapr Old, попробуйте доустановить xfce4-mixer и вынести его на панель, удалив из автозагрузки volumeicon.

Оффлайн Wapr Old

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Ну да, я так уже сделал, но странно, неужели это только у меня такой эффект? Опять из за матери?

Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1465
  • calambus@jabber.ru
Нет , железо здесь не причём , это баг Volumeicon ...
А регулятор громкости ALSA Volti я успешно применял на всех сборках Runtu , на различном железе и не было ни каких претензий , наоборот он имеет ряд неоспоримых преимуществ - на ASUS Eee PC 4G с его помощью заработали штатные функциональные клавиши регулировки и блокировки звука и всплвающие уведомления состяния регулятора громкости звука .
Установка :sudo aptitude install -y volti notify-osd
          
« Последнее редактирование: Ноябрь 26, 2012, 20:54:37 от calambus »
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум

Оффлайн Wapr Old

  • Прохожий
  • *
  • Автор темы
  • Сообщений: 8
Нет , железо здесь не причём , это баг Volumeicon
Тогда почему он до сих пор включается в дистрибутив, учитывая, что есть почти нормальные замены?

А глюки Volti у меня выражались в том, что во первых он отображал не все регуляторы (хотя основные были), а во вторых зависимость громкости от положения ручки была адски нелинейная. Грубо говоря 10% где-то в середине верхней части закрывали весь диапазон громкости. Причём вверх и вниз по разному регулировалось. Я вообще не понял, как такое возможно реализовать  ???
Есть ещё и в третьих, но владельцам мониторов 16:9 это может и не критично  ;)

Оффлайн divgyice4

  • Новичок
  • **
  • Сообщений: 16
  • debian wheezy / windows XP SP1
Здравствуйте всем!
Хочу сообщить довольно неприятный баг в runtu XFCE 12.04.
Если на панели задач нажать два раза на значок громкости то активируется режим "приглушить звук"
и звук пропадает. Чтобы отключить этот режим приходится открывать микшер.
Это не удобно. Как исправить?

Ладно я, Мне то, открыть микшер и оключить приглушения звука очень просто.
А вот мои близкие в компьютерах не очень сильны. Случайно нажмут повторно на значек и все!!!

Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1465
  • calambus@jabber.ru
Эта проблема уже известна давно , обсуждалась не однократно , решается установкой регулятора громкости Volti ...
sudo aptitde install volti
« Последнее редактирование: Январь 13, 2013, 11:04:17 от calambus »
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум

Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
А я заметил схожую проблему в Рунту-Gnome 12.04, притом только на ноутбуке. При первоначальной загрузке звук часто бывает выключен (стоит галка). Притом в Gnome она видна, а в E17 - становится видна иногда только после перезагрузки или релогина.
Это происходит не каждый раз, а периодически.
Притом что на десктопе в той же Рунту-Gnome 12.04 эта проблема не наблюдается
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)