Автор Тема: NVIDIA установка.  (Прочитано 12702 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн echopic

  • Новичок
  • **
  • Сообщений: 17
Re: NVIDIA установка.
« Ответ #15 : Октябрь 23, 2010, 23:19:19 »
а какой именно драйвер вы ставили, имя файла какое?

apt-get install nvidia-96

Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
Re: NVIDIA установка.
« Ответ #16 : Октябрь 24, 2010, 11:37:58 »
Цитировать (выделенное)
если устнавливаю по инструкции ludoedа - то не могу запустить nvidia-settings ругается на конфиг (мол нет его)
Моя инструкция рассчитана на новые компы, уж извините, у вас сильно старый, я с такими в пингвине просто не сталкивался
Nvidia-settings ругается на отсутствие xorg.conf Это файл конфигурации X-сервера, при установке по умолчанию он не создается
Попробуйте выйти в текстовую консоль (нажать CTRL+F1) и дать команду

sudo nvidia X -configure

при этом создастся файл xorg.conf.new либо в каталоге /root либо в корне /  файловой системы
у меня в корне создался
Вот его переименуйте в xorg.conf, засуньте в /etc/X11 и после того перезагрузитесь.
Если запустится графическое окружение, тогда пробуйте запустить nvidia-settings
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)

Оффлайн kompilainenn

  • Местный
  • *****
  • Сообщений: 1047
  • Активно пропагандирую Runtu
Re: NVIDIA установка.
« Ответ #17 : Октябрь 24, 2010, 12:24:12 »
может nvidia-glx-96?
Мы говорим Linux, подразумеваем Runtu

Оффлайн echopic

  • Новичок
  • **
  • Сообщений: 17
Re: NVIDIA установка.
« Ответ #18 : Октябрь 24, 2010, 22:06:55 »

Nvidia-settings ругается на отсутствие xorg.conf Это файл конфигурации X-сервера, при установке по умолчанию он не создается
Попробуйте выйти в текстовую консоль (нажать CTRL+F1) и дать команду

sudo nvidia X -configure

при этом создастся файл xorg.conf.new либо в каталоге /root либо в корне /  файловой системы
у меня в корне создался
Вот его переименуйте в xorg.conf, засуньте в /etc/X11 и после того перезагрузитесь.
Если запустится графическое окружение, тогда пробуйте запустить nvidia-settings

примерно так и сделал ещё до того как прочел это пост  ;)

в режиме консоли (до запуска иксов) скомандовал sudo nvidia-xconfig
xorg.conf появился на своём законном месте в /etc/X11 только неверный диапазон вертикально развертки был указан (к компу пристёгнут ЖКмоник, а в конфиге дипазон указан до 120 Гц  :o). Изменил на 60 - 75 и всё завелось  ;)

ЗЫЖ Но я так и не понял почему впервый раз у меня так не получилось  ???. Кстати в первый раз xorg.conf был очень замороченый, а в это очень простой  :-\

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Jul 13 13:31:50 PDT 2010


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     60.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
Re: NVIDIA установка.
« Ответ #19 : Октябрь 25, 2010, 19:30:04 »
Ну, почему в первый раз не получилось, сказать трудно. Главное, что вообще получилось. Теперь рекомендую сохранить копию полученного xorg.conf в сухом прохладном месте - после установки новой версии системы его можно будет вернуть на место без геморроя

Пингвин - птица гордая, пока не пнешь - не полетит
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4236
Re: NVIDIA установка.
« Ответ #20 : Февраль 09, 2011, 20:38:46 »
Устанавил драйвер для видеокарты Nvidia с официального сайта так:
(при этом не надо зпоминать название run файла)


Скачиваю run файл в домашнюю папку, в свойствах разрешаю выполнение файла
Ctrl+Alt+F6 , логин, пароль
sudo service gdm stopCtrl+Alt+F6
sudo mcвыделяю run файл и нажимаю энтер, запускается установка
после окончания установки выполняю команду reboot


PS: некоторые версии драйверов кривые, у меня например с 260 драйвером флеш глючит, а с 256.44 все хорошо

Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
Re: NVIDIA установка.
« Ответ #21 : Февраль 10, 2011, 18:37:46 »
Пользователь
А че не просто
sudo aptitude install nvidia-current nvidia-settingsили какая-то игра сверхновый драйвер хочет?
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4236
Re: NVIDIA установка.
« Ответ #22 : Февраль 12, 2011, 22:17:43 »
у меня с тем драйвером (270) последний флешплеер глючит
вот и пришлось искать версию драйвера в которой более менее нормально флеш работает на моей видеокарте (GF 9800 GT)