Автор Тема: кодировки в gedit  (Прочитано 9128 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн smik55

  • Местный
  • *****
  • Автор темы
  • Сообщений: 1016
кодировки в gedit
« : Июнь 07, 2012, 15:51:40 »
Понятно, что у Линукс конфликт с кодировками Виндовс, но как понять такой фокус:
Беру текстовый файл, делаю ему копию с другим именем . Открываю копию в блокноте и выбираю для эксперимента другую кодировку. Текст начинает читаться  в кракозябрах. Пытаюсь вернуть на прежнюю или любую другую- бесполезно. И никакие ухищрения, в т.ч. изменения  в РЕД.КОНФИГУРАЦИИ, ничего ни дают. Это проверял и на версиях Убунту 11.04 и 12.04. Остаются кракозябры .хоть убей. Может где конфиги поправить, кто знает?

Оффлайн Prof1983

  • Активист
  • ****
  • Сообщений: 499
  • Digital Economy Institute
Re: кодировки в gedit
« Ответ #1 : Июнь 07, 2012, 18:35:55 »
У меня таких проблем не возникало. Основная кодировка в Линуксах вот уже пару лет UTF-8. Да и в Win большинство программ UTF-8 поддерживают или даже по умолчанию сохраняют в этой кодировке. Так что даже вопрос выбора кодировки не стоит.

Но, тем не менее, если с текстовым редактором возникает проблема, то можете попробовать открыть текстовый файл с помощью Firefox. С ним то уж точно проблем быть не должно.
Libre.Life - Свободная жизнь Libre.Money - Свободные деньги Libre.Su - Свободный союз

Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
Re: кодировки в gedit
« Ответ #2 : Июнь 07, 2012, 19:48:43 »
Проблемы в gedit в 12.04 с кодировками действительно есть, особенно при открытии старых текстовых файлов, сохраненных в кодировке cp1251.
Причем установка плагина encodings.py уже не помогает, подозреваю, что место установки плагинов изменилось.
Мне помогало указание правильной кодировки в окне открытия файла, но для этого надо знать кодировку заранее, а если файл из неизвестного источника...
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3173
Re: кодировки в gedit
« Ответ #3 : Июнь 19, 2012, 13:13:14 »
помогало указание правильной кодировки в окне открытия файла, но для этого надо знать кодировку заранее, а если файл из неизвестного источника...
    Узнать mime-тип и кодировку текстового файла можно командой
file -i имя_файла
в лайв сессии на ЖД остаются некоторые файлы настроек и конф.
    Если только на HDD имелся swap-раздел, который подключился при загрузке и в него были скинуты области памяти с настройками. Извлечь эту информацию напрямую из следующей сессии без определённых усилий не получится.

я ставил тут же другой блокнот (leaftpad)и он тоже не читал, а из установленной 11.04 читался нормально, пока я и в ней не изменил кодировку. Я ведь перебрал все доступные варианты кодировок в блокноте ,ничего не меняется. Такое впечатление, что это можно изменить только один раз. Возможно где то в конфигах можно поправить(вернуть), но я не спец.
   Кроме кодировки ещё есть разница представления перевода строки и конца файла - В UNIX перевод строки обозначается как LF, а DOS/Windows состоит из последовательности символов CR+LF.

Оффлайн smik55

  • Местный
  • *****
  • Автор темы
  • Сообщений: 1016
Re: кодировки в gedit
« Ответ #4 : Июнь 19, 2012, 18:32:14 »
Сергей, вы угадали мои мысли на тот момент, а именно, как определить кодировку текст.файла. Я бы только за это, добавил вам (+), но в эти крестики не играю и вам, как Админитсратору, они не нужны. Свой прфессионализм вы уже доказали.
---
Решил повторить эксперимент из установленной Минт 13 Мате. Тот файл (копия ) из под Винды -сохранился. Он был ранее скопирован с почтовой программы и состоял из рус. и анг. символов. Его кодировка оказалась  :~/Рабочий стол/Mint13Mate $ file -i Парольd.txt
Парольd.txt: text/plain; charset=iso-8859-1
Открываю в блокноте Pluma -опять ОТКРЫТЬ, меняю кодировку на UTF-8 , WINDOWS-1251  -чтитается нормально , т.е. кодировка не миняется. Создал  в этой же папке "новый файл" - оказалось  команда с определением кодир.файла не действует на 2 слова.: file -i новый файл
новый: ERROR: cannot open `новый' (No such file or directory)
 или так тоже : ~/Рабочий стол/Mint13Mate $ file -i новый 1
новый: ERROR: cannot open `новый' (No such file or directory)
1:     ERROR: cannot open `1' (No such file or directory)       -всего добавил 1.
Изменил имя :~/Рабочий стол/Mint13Mate $ file -i новый
новый: text/plain; charset=utf-8 . 
 Определилась. Открываю опять в Pluma - при изменении кодировки файл все равно чиается нормально. Уже отослал это в заслуги Минт 13 , но:
По ошибке заципил в блокн. другой файл , который лежал давно в этой же папке .Он был ::
Цитировать
~/Рабочий стол/Mint13Mate $ file -i kernel
kernel: text/plain; charset=utf-8

и изменил нечайно кодировку. Хоть файл был создан ранее в этой ОС , в этой же папке и в UTF-8 , теперь он не стал читаться местами и при любых попытках вернуть все назад , хотя его свойства  остались теже : file -i kernel
kernel: text/plain; charset=utf-8   и такой стал текст :
Цитировать
( More info: https://launchpad.net/~upubuntu-com/+archive/kernel )
--------------
Чтобы удалить Linux Kernel 3.3.6 и восстановить предыдущую версию ядра, выполните следующую команду:

Т.е. не стали читаться русские символы в тексте, который был скопирован в браузере и вставлен в блокнот.
Не в ручную ( UTF-8 или другая..) не Автоматически теперь кодировка не срабатывает.
Пытаюсь открыть опять свой созданный здесь же текст файл "новый"- то же
 
Цитировать
Создан простой текстовый файл в среде Linux - Ubuntu 12.04
Хотя другие тексты, скопрированные и отпечатанные, читаются нормально. Пытаюсь опять открыть эти нечитаемые файлы от Администратора - все нормально. Обычно -опять нет.
 ------------
Короче, есть какой то непонятный глюк на текст. файлы. Но можно открыть от Админа. А как исправить - загадка.
Хотел удалить этот опыт, что  бы не морочить всем голову, но пока передумал. Если кто хочет, может провести у себя.

Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
Re: кодировки в gedit
« Ответ #5 : Июнь 19, 2012, 18:56:26 »
Вот-вот, у меня тоже есть такой файл, со списком асечных номеров знакомых
команда
file -i uin.txtпишет, что кодировка UTF-8

Однако же русские буквы в файле нечитаемы, и где / что я там напортачил, я уже не помню.
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Re: кодировки в gedit
« Ответ #6 : Июнь 19, 2012, 20:47:09 »
Пара замечаний:
Цитировать
оказалось  команда с определением кодир.файла не действует на 2 слова.: file -i новый файл
Если в имени файла есть пробелы, то киманда должна выглядеть так:
file -i новый\ файлили так:
file -i "новый файл"
В запущенных случаях очень помогает декодер

Оффлайн ludoed

  • Местный
  • *****
  • Сообщений: 861
  • ludoed1970@jabber.ru
Re: кодировки в gedit
« Ответ #7 : Июнь 20, 2012, 19:46:14 »
декодер и "Штирлиц" не помогли
все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях ;)

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками :)

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4498
Re: кодировки в gedit
« Ответ #8 : Июль 08, 2012, 15:31:40 »

Оффлайн Levis

  • Прохожий
  • *
  • Сообщений: 1
Re: кодировки в gedit
« Ответ #9 : Декабрь 13, 2016, 23:53:31 »
Есть альтернативное решение!

1. Установить редактор dconf-editoror
sudo apt-get instail dconf-editoror
2. Открыть Редактор dconf, найти ветку org/x/edit в имя auto-detected-encodings добавить значение
['UTF-8', 'WINDOWS-1251', 'CURRENT', 'ISO-8859-15', 'UTF-16']

3. Открыть заново текстовый файл.

Оффлайн smik55

  • Местный
  • *****
  • Автор темы
  • Сообщений: 1016
Re: кодировки в gedit
« Ответ #10 : Декабрь 14, 2016, 21:55:38 »
поправьте
. Установить редактор dconf-editor
Код:

sudo apt-get install dconf-editor    
Проблема с кодировками в системе
http://forum.runtu.org/index.php?topic=6914.0

Оффлайн Alex Klich

  • Новичок
  • **
  • Сообщений: 34
Re: кодировки в gedit
« Ответ #11 : Декабрь 15, 2016, 14:48:17 »
А по мне, так Gedit лучший. Проблема с кодировками решается элементарно, устанавливаем редактор, в термилале даем команду:
для версий 14.04 -
gsettings set org.gnome.gedit.preferences.encodings auto-detected "['UTF-8', 'WINDOWS-1251', 'CURRENT', 'ISO-8859-15', 'UTF-16']"

для 16.04 -
gsettings set org.gnome.gedit.preferences.encodings candidate-encodings "['UTF-8', 'WINDOWS-1251', 'KOI8-R', 'CURRENT', 'ISO-8859-15', 'UTF-16']"
Все, никаких кракозябр.