Автор Тема: Не могу установить драйвер nvidia  (Прочитано 11989 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн baks

  • Новичок
  • **
  • Автор темы
  • Сообщений: 76
Re: Не могу установить драйвер nvidia
« Ответ #15 : Апрель 23, 2012, 01:47:56 »
Экспортировал. Без изменений

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3172
Re: Не могу установить драйвер nvidia
« Ответ #16 : Апрель 23, 2012, 12:27:17 »
   baks, какой у вас объём ОЗУ установлен? Зачем ставите пакет nvidia-180-libvdpau? Если подключен репозиторий ppa:ubuntu-x-swat/x-updates, достаточно выполнить
sudo aptitude purge nvidia-180-libvdpau nvidia-185-libvdpau
sudo aptitude update && sudo aptitude full-upgrade
sudo aptitude install nvidia-current

Оффлайн baks

  • Новичок
  • **
  • Автор темы
  • Сообщений: 76
Re: Не могу установить драйвер nvidia
« Ответ #17 : Апрель 24, 2012, 10:41:05 »
HsH, в системе 3.6 Гб ОЗУ, vdpau устанавливаю потому что видео nvidia 8200 встроенное. На видео выделено памяти 256 Мб. Репозиторий x-swat подключён.
 Ваш способ не работает. Собственно, это первое, что я сделал после неудачной установки. Вся штука в том, что nvidia-current не может нормально отработать и вываливается с ошибкой. Такая ситуация происходит впервые за два года с момента покупки.

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3172
Re: Не могу установить драйвер nvidia
« Ответ #18 : Апрель 24, 2012, 11:06:25 »
Вся штука в том, что nvidia-current не может нормально отработать и вываливается с ошибкой.
   Приведите лог выполнения. В предыдущем видно, что ошибка возникает из-за конфликта пакетов. Также желательно переключить зеркало репозитория с ftp.byfly.by на основной.

Оффлайн baks

  • Новичок
  • **
  • Автор темы
  • Сообщений: 76
Re: Не могу установить драйвер nvidia
« Ответ #19 : Апрель 24, 2012, 11:54:42 »
 В логе ничего не изменилось, всё также, как в первых постах. Попробую переключиться на основной сервер, но, честно  говоря, не вижу смысла - byfly всего лишь зеркало, а драйвер и вовсе ставиться из PPA


 
aptitude update с основного сервера: ПоказатьСкрыть
baks@STAR1K:~$ sudo aptitude update && sudo aptitude full-upgrade
Из кэша: http://archive.canonical.com lucid Release.gpg
Игн http://archive.canonical.com/ubuntu/ lucid/partner Translation-ru         
Игн http://download.skype.com stable Release.gpg                               
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/alecive/antigone/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Получить:1 http://archive.ubuntu.com lucid Release.gpg [189B]                 
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/main Translation-ru           
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/restricted Translation-ru     
Игн http://download.skype.com/linux/repos/debian/ stable/non-free Translation-ru
Из кэша: http://archive.canonical.com lucid Release                           
Игн http://ppa.launchpad.net/alexey-smirnov/deadbeef/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/alexx2000/doublecmd/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/deja-dup-team/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/deluge-team/ppa/ubuntu/ lucid/main Translation-ru
Получить:2 http://deb.opera.com stable Release.gpg [189B]                     
Игн http://deb.opera.com/opera/ stable/non-free Translation-ru                 
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/universe Translation-ru       
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-ru     
Получить:3 http://archive.ubuntu.com lucid-updates Release.gpg [198B]         
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-ru       
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-ru 
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-ru   
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-ru 
Игн http://download.skype.com stable Release                                   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/freenx-team/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ignorantguru.users.sourceforge.net unstable Release.gpg             
Игн http://ignorantguru.users.sourceforge.net/debian/ unstable/main Translation-ru
Игн http://ppa.launchpad.net/frol/zip-i18n/ubuntu/ lucid/main Translation-ru   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/geany-dev/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/gloobus-dev/gloobus-preview/ubuntu/ lucid/main Translation-ru
Из кэша: http://archive.canonical.com lucid/partner Packages                   
Получить:4 http://archive.ubuntu.com lucid-security Release.gpg [198B]         
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/main Translation-ru       
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/restricted Translation-ru
Из кэша: http://deb.opera.com stable Release                                   
Игн http://deb.opera.com stable Release                                       
Из кэша: http://download.virtualbox.org lucid Release.gpg                     
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/universe Translation-ru   
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-ru
Получить:5 http://archive.ubuntu.com lucid-proposed Release.gpg [198B]         
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/restricted Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/keepassx/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/main Translation-ru 
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu/ lucid/main Translation-ru 
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/michael-astrapi/ppa/ubuntu/ lucid/main Translation-ru
Игн http://download.skype.com stable/non-free Packages                         
Из кэша: http://archive.canonical.com lucid/partner Sources                   
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/multiverse Translation-ru
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/universe Translation-ru
Игн http://deb.opera.com stable/non-free Packages                             
Получить:6 http://archive.ubuntu.com lucid-backports Release.gpg [198B]       
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/restricted Translation-ru
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/main Translation-ru     
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/multiverse Translation-ru
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/universe Translation-ru 
Получить:7 http://archive.ubuntu.com lucid Release [57,2kB]                   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/motumedia/mplayer-daily/ubuntu/ lucid/main Translation-ru
Игн http://ignorantguru.users.sourceforge.net unstable Release                 
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/n-muench/firefox-daily/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/nagos/ppa/ubuntu/ lucid/main Translation-ru       
Из кэша: http://packages.medibuntu.org lucid Release.gpg                       
Игн http://deb.opera.com stable/non-free Packages                             
Игн http://download.virtualbox.org/virtualbox/debian/ lucid/contrib Translation-ru
Из кэша: http://linux.dropbox.com lucid Release.gpg                           
Игн http://linux.dropbox.com/ubuntu/ lucid/main Translation-ru                 
Игн http://download.skype.com stable/non-free Packages                         
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ntadej/tano-lts/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/pdfmod-team/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ripps818/coreavc/ubuntu/ lucid/main Translation-ru
Из кэша: http://deb.opera.com stable/non-free Packages                         
Получить:8 http://archive.ubuntu.com lucid-updates Release [57,3kB]           
Игн http://ignorantguru.users.sourceforge.net unstable/main Packages           
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/rvm/smplayer/ubuntu/ lucid/main Translation-ru   
Ош http://download.skype.com stable/non-free Packages                         
  404  Not Found [IP: 2.22.52.91 80]
Игн http://ppa.launchpad.net lucid Release.gpg                                 
Игн http://ppa.launchpad.net/sevenmachines/flash/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/shutter/ppa/ubuntu/ lucid/main Translation-ru     
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/tualatrix/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://download.virtualbox.org lucid Release                         
Из кэша: http://linux.dropbox.com lucid Release                               
Получить:9 http://archive.ubuntu.com lucid-security Release [57,3kB]           
Игн http://packages.medibuntu.org/ lucid/free Translation-ru                   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ignorantguru.users.sourceforge.net unstable/main Packages           
Получить:10 http://archive.ubuntu.com lucid-proposed Release [58,3kB]         
Игн http://ppa.launchpad.net/zeitgeist/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://linux.dropbox.com lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Получить:11 http://archive.ubuntu.com lucid-backports Release [57,3kB]         
Из кэша: http://download.virtualbox.org lucid/contrib Packages                 
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Игн http://ppa.launchpad.net lucid Release                                     
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Ош http://ignorantguru.users.sourceforge.net unstable/main Packages           
  404  Not Found
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Получить:12 http://archive.ubuntu.com lucid/main Packages [1 383kB]           
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Игн http://ppa.launchpad.net lucid/main Packages                               
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Игн http://ppa.launchpad.net lucid/main Packages                               
Ош http://ppa.launchpad.net lucid/main Packages                               
  404  Not Found
Игн http://packages.medibuntu.org/ lucid/non-free Translation-ru               
Из кэша: http://packages.medibuntu.org lucid Release                           
Из кэша: http://packages.medibuntu.org lucid/free Packages
Из кэша: http://packages.medibuntu.org lucid/non-free Packages
Получить:13 http://archive.ubuntu.com lucid/restricted Packages [6 193B]       
Получить:14 http://archive.ubuntu.com lucid/main Sources [659kB]               
Получить:15 http://archive.ubuntu.com lucid/restricted Sources [3 775B]       
Получить:16 http://archive.ubuntu.com lucid/universe Packages [5 430kB]       
Получить:17 http://archive.ubuntu.com lucid/universe Sources [3 165kB]         
Получить:18 http://archive.ubuntu.com lucid/multiverse Packages [176kB]       
Получить:19 http://archive.ubuntu.com lucid/multiverse Sources [119kB]         
Получить:20 http://archive.ubuntu.com lucid-updates/main Packages [592kB]     
Получить:21 http://archive.ubuntu.com lucid-updates/restricted Packages [4 638B]
Получить:22 http://archive.ubuntu.com lucid-updates/main Sources [220kB]       
Получить:23 http://archive.ubuntu.com lucid-updates/restricted Sources [2 194B]
Получить:24 http://archive.ubuntu.com lucid-updates/universe Packages [278kB] 
Получить:25 http://archive.ubuntu.com lucid-updates/universe Sources [95,5kB] 
Получить:26 http://archive.ubuntu.com lucid-updates/multiverse Packages [10,6kB]
Получить:27 http://archive.ubuntu.com lucid-updates/multiverse Sources [5 063B]
Получить:28 http://archive.ubuntu.com lucid-security/main Packages [404kB]     
Получить:29 http://archive.ubuntu.com lucid-security/restricted Packages [2 840B]
Получить:30 http://archive.ubuntu.com lucid-security/main Sources [121kB]     
Получить:31 http://archive.ubuntu.com lucid-security/restricted Sources [1 259B]
Получить:32 http://archive.ubuntu.com lucid-security/universe Packages [133kB]
Получить:33 http://archive.ubuntu.com lucid-security/universe Sources [36,4kB]
Получить:34 http://archive.ubuntu.com lucid-security/multiverse Packages [4 547B]
Получить:35 http://archive.ubuntu.com lucid-security/multiverse Sources [1 766B]
Получить:36 http://archive.ubuntu.com lucid-proposed/restricted Packages [14B]
Получить:37 http://archive.ubuntu.com lucid-proposed/main Packages [137kB]     
Получить:38 http://archive.ubuntu.com lucid-proposed/multiverse Packages [1 326B]
Получить:39 http://archive.ubuntu.com lucid-proposed/universe Packages [25,9kB]
Получить:40 http://archive.ubuntu.com lucid-backports/restricted Packages [14B]
Получить:41 http://archive.ubuntu.com lucid-backports/main Packages [18,8kB]   
Получить:42 http://archive.ubuntu.com lucid-backports/multiverse Packages [1 378B]
Получить:43 http://archive.ubuntu.com lucid-backports/universe Packages [47,7kB]
Получено 13,4MБ в 2мин 12с (101kБ/с)                                           
Чтение списков пакетов... Готово
W: Ошибка GPG: http://deb.opera.com stable Release: Следующие подписи неверные: BADSIG AAFF4A5B336064B5 Opera Software Archive Automatic Signing Key 2012 <packager@opera.com>
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ lucid/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_lucid_partner_binary-amd64_Packages)


 
install nvidia-current: ПоказатьСкрыть
baks@STAR1K:~$ sudo aptitude reinstall nvidia-current
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие пакеты будут ПЕРЕУСТАНОВЛЕНЫ:
  nvidia-current
0 пакетов обновлено, 0 установлено новых, 1 переустановлено, 0 пакетов отмечено для удаления, и 10 пакетов не обновлено.
Необходимо получить 0Б архивов. После распаковки 0Б будет занято.
Запись информации расширенных состояний... Готово
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Removing old nvidia-current-295.40 DKMS files...

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-41-generic
Building for architecture x86_64
Building initial module for 2.6.32-41-generic

Error! Bad return status for module build on kernel: 2.6.32-41-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-41-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет.  Попытка восстановить:
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Removing old nvidia-current-295.40 DKMS files...

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-41-generic
Building for architecture x86_64
Building initial module for 2.6.32-41-generic

Error! Bad return status for module build on kernel: 2.6.32-41-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-41-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
Чтение списков пакетов... Готово                                       
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях       
Инициализация состояний пакетов... Готово

  Как видно, без изменений.
« Последнее редактирование: Апрель 24, 2012, 12:09:14 от baks »

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3172
Re: Не могу установить драйвер nvidia
« Ответ #20 : Апрель 24, 2012, 13:05:11 »
 Как видно, без изменений.
   Изменения есть - ядро обновилось до 2.6.32-41 и устранена ошибка с конфликтом nvidia-180-libvdpau. В первом спойлере приведён вывод не до конца выполнения команды.

    Что у вас в /var/lib/dkms/nvidia-current/295.40/build/ ? Приведите содержимое.

Оффлайн baks

  • Новичок
  • **
  • Автор темы
  • Сообщений: 76
Re: Не могу установить драйвер nvidia
« Ответ #21 : Апрель 24, 2012, 14:55:12 »
 Ядро обновилось потому, что в попытке исправить ситуацию мною были подключены lucid-backports и lucid-proposed. Конфликт пакетов заключался в том, что nvidia-current должен установиться и создать модуль ядра а затем устанавливается и настраивается nvidia-180-libvdpau и никак иначе. Nvidia-current в зависимостях всех остальных nvidia-*
 В первом спойлере содержится всё, что выдала консоль на тот момент.
 
содержание /var/lib/dkms/nvidia-current/295.40/build/: ПоказатьСкрыть
baks@STAR1K:~$ cd /var/lib/dkms/nvidia-current/295.40/build/
baks@STAR1K:/var/lib/dkms/nvidia-current/295.40/build$ ls
conftest.sh          nv.c         nv-mempool.c  nvtypes.h       os-smp.c
cpuopsys.h           nv-chrdev.c  nv-misc.h     nv-usermap.c    os-usermap.c
dkms.conf            nv-cray.c    nv-mlock.c    nv-vm.c         patches
gcc-version-check.c  nverror.h    nv-mmap.c     nv-vtophys.c    rmil.h
g_nvreadme.h         nv-gvi.c     nv-p2p.c      os-agp.c        rmretval.h
makefile             nv.h         nv-p2p.h      os-agp.h        xapi-sdk.h
Makefile.kbuild      nv-i2c.c     nv-pat.c      os-interface.c
Makefile.nvidia      nv-kernel.o  nv-procfs.c   os-interface.h
make.log             nv-linux.h   nv-proto.h    os-mtrr.c
nv-acpi.c            nv-memdbg.h  nv-reg.h      os-registry.c
baks@STAR1K:/var/lib/dkms/nvidia-current/295.40/build$ cat make.log
DKMS make.log for nvidia-current-295.40 for kernel 2.6.32-41-generic (x86_64)
Втр Апр 24 11:07:45 FET 2012
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Ошибка 1

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3172
Re: Не могу установить драйвер nvidia
« Ответ #22 : Апрель 24, 2012, 15:24:50 »
В первом спойлере содержится всё, что выдала консоль на тот момент.
     Давайте вывод
sudo rm -rf /var/lib/dkms/nvidia-current
sudo aptitude install -f

*** Unable to determine the target kernel version. ***
  Нужно попробовать установить linux-image-generic-lts-backport-oneiric и хидеры linux-headers-generic-lts-backport-oneiric. Думаю, в последних версиях драйвера nvidia была нарушена совместимость с более ранними ядрами. Собственно, по этой причине в 10.04 не устанавливается текущий проприетарный драйвер nvidia через jockey-gtk.

Оффлайн baks

  • Новичок
  • **
  • Автор темы
  • Сообщений: 76
Re: Не могу установить драйвер nvidia
« Ответ #23 : Апрель 24, 2012, 17:02:16 »
 Установил. И зачем мне все эти ядра?
 

baks@STAR1K:~$ uname -a
Linux STAR1K 3.0.0-19-generic #33~lucid1-Ubuntu SMP Fri Apr 20 13:55:08 UTC 2012 x86_64 GNU/Linux
baks@STAR1K:~$ sudo rm -rf /var/lib/dkms/nvidia-current
baks@STAR1K:~$ sudo aptitude install -f
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие НОВЫЕ пакеты будут установлены:
  linux-generic linux-headers-2.6.32-35 linux-headers-2.6.32-35-generic
  linux-headers-2.6.32-36 linux-headers-2.6.32-36-generic
  linux-headers-2.6.32-37 linux-headers-2.6.32-37-generic
  linux-headers-2.6.32-38 linux-headers-2.6.32-38-generic
  linux-headers-2.6.32-39 linux-headers-2.6.32-39-generic
  linux-headers-2.6.32-40 linux-headers-2.6.32-40-generic
  linux-image-2.6.32-35-generic linux-image-2.6.32-36-generic
  linux-image-2.6.32-37-generic linux-image-2.6.32-38-generic
  linux-image-2.6.32-39-generic linux-image-2.6.32-40-generic
  linux-image-2.6.32-41-generic linux-image-generic
  nvidia-current-modaliases nvidia-glx-185 nvidia-settings
Следующие частично установленные пакеты будут настроены:
  nvidia-current
0 пакетов обновлено, 24 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 288MБ архивов. После распаковки 1 412MБ будет занято.

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3172
Re: Не могу установить драйвер nvidia
« Ответ #24 : Апрель 24, 2012, 17:09:05 »
Установил. И зачем мне все эти ядра?
    Все не нужны, выполните
sudo aptitude install nvidia-current-modaliases

Оффлайн baks

  • Новичок
  • **
  • Автор темы
  • Сообщений: 76
Re: Не могу установить драйвер nvidia
« Ответ #25 : Апрель 24, 2012, 18:06:32 »
 ничего
baks@STAR1K:~$ sudo aptitude install nvidia-current-modaliases
[sudo] password for baks:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие НОВЫЕ пакеты будут установлены:
  nvidia-current-modaliases
Следующие частично установленные пакеты будут настроены:
  nvidia-current
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 27,1kБ архивов. После распаковки 94,2kБ будет занято.
Запись информации расширенных состояний... Готово
Получить:1 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ lucid/main nvidia-current-modaliases 295.40-0ubuntu1~lucid~xup1 [27,1kB]
Получено 27,1kБ в 11с (2 322Б/с)                                               
Selecting previously unselected package nvidia-current-modaliases.
(Чтение базы данных ... на данный момент установлено 225945 файлов и каталогов.)
Распаковывается пакет nvidia-current-modaliases (из файла .../nvidia-current-modaliases_295.40-0ubuntu1~lucid~xup1_amd64.deb)...
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 3.0.0-19-generic
Building for architecture x86_64
Building initial module for 3.0.0-19-generic

Error! Bad return status for module build on kernel: 3.0.0-19-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Настраивается пакет nvidia-current-modaliases (295.40-0ubuntu1~lucid~xup1) ...
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.0.0-19-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет.  Попытка восстановить:
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Removing old nvidia-current-295.40 DKMS files...

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 3.0.0-19-generic
Building for architecture x86_64
Building initial module for 3.0.0-19-generic

Error! Bad return status for module build on kernel: 3.0.0-19-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.0.0-19-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
Чтение списков пакетов... Готово                                       
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Запись информации расширенных состояний... Готово