Автор Тема: RadioTray в Runtu LXDE/LITE  (Прочитано 9289 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн takecare

  • Новичок
  • **
  • Автор темы
  • Сообщений: 24
RadioTray в Runtu LXDE/LITE
« : Октябрь 03, 2010, 14:59:32 »
Установил radiotray_0.6.1 (включая три требовавшиеся зависимости). При попытке прослушать какую-либо станцию пишет в консоли:
Received MESSAGE_ERROR
В вашей установке GStreamer отсутствует модуль.
gsturidecodebin.c(991): gen_source_element (): /GstPlayBin2:player/GstURIDecodeBin:uridecodebin10
Как узнать, что за модуля не хватает?

Runtu LXDE 10.04
« Последнее редактирование: Октябрь 03, 2010, 15:09:29 от takecare »

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3486
Re: RadioTray в Runtu LXDE/LITE
« Ответ #1 : Октябрь 03, 2010, 16:44:13 »
В вашей установке GStreamer отсутствует модуль.

Runtu LXDE 10.04

    В Runtu LXDE система GStreamer не установлена. Я бы рекомендовал вам составить плейлист радиостанций и слушать его например в уже инсталлированных SMPlayer или DeaDBeeF, иначе концепция "лёгкого дистрибутива" не имеет смысла - проще установить Ubuntu.

Оффлайн Almas

  • Новичок
  • **
  • Сообщений: 10
Re: RadioTray в Runtu LXDE/LITE
« Ответ #2 : Октябрь 11, 2011, 20:14:51 »
Привык к radiotray и не считаю что из-за 50-100 Кб-ных модулей нужно менять программу (правда сам radiotray жрет около 15 Мб озу, но для моих 2 Гб это некритично). У меня сабж версии 0,6,4 заработал после установки 2-3 модулей gstreamer (ставил методом тыка почти ))). Последним, что ставил (после чего и начал петь) был - gstreamer0.10-fluendo-mpegdemux. Если у кого не заработает - пишите, перечислю все свои установленные модули gstreamer.

Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1433
  • calambus@jabber.ru
Re: RadioTray в Runtu LXDE/LITE
« Ответ #3 : Октябрь 11, 2011, 21:36:41 »
У меня в iqunix 11.04 (Ubuntu 11.04) и для Radio Tray 0.6.1, в том числе , установлены следующие модули GStreamer0.10 :

                                                                      
« Последнее редактирование: Октябрь 11, 2011, 22:56:03 от calambus »
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3486
Re: RadioTray в Runtu LXDE/LITE
« Ответ #4 : Октябрь 11, 2011, 22:18:49 »
установлены следующие модули GStreamer0.10 :

   Если вы не собираетесь заниматься отладкой модуля gstreamer0.10-plugins-bad, то пакет gstreamer0.10-plugins-bad-dbg (debugger) среди них явно лишний :).

Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1433
  • calambus@jabber.ru
Re: RadioTray в Runtu LXDE/LITE
« Ответ #5 : Октябрь 11, 2011, 22:51:18 »
Спасибо за совет HsH ,учту на будущее...
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум

Оффлайн Пользователь.

  • Местный
  • *****
  • Сообщений: 4637
Re: RadioTray в Runtu LXDE/LITE
« Ответ #6 : Ноябрь 09, 2011, 23:33:09 »
Как я понял эта проблема возникла, так как автор deb пакета не указал все зависимости.

А именно:
gstreamer0.10-alsa  - для вывода звука через alsa
или
gstreamer0.10-pulseaudio - для вывода звука через pulseaudio

ну и кодеки для gstreamer: http://forum.runtu.org/index.php/topic,1815.0.html


указанный выше fluendo - это кодек для mp3, но он только для прослушивания,
полноценный есть среди кодеков для gstreamer, на которые я дал ссылку выше
« Последнее редактирование: Ноябрь 09, 2011, 23:57:01 от Пользователь. »

Оффлайн mrtaxi

  • Новичок
  • **
  • Сообщений: 27
  • Asus EEEPC 901
    • Ok, linux ;)
Re: RadioTray в Runtu LXDE/LITE
« Ответ #7 : Март 13, 2012, 19:55:37 »
Приветствую, реально ли запустить в этой замечательной сборке RadioTray? Заранее благодарен за ответы. :)

Оффлайн calambus

  • Местный
  • *****
  • Сообщений: 1433
  • calambus@jabber.ru
Re: RadioTray в Runtu LXDE/LITE
« Ответ #8 : Март 13, 2012, 21:50:05 »
RadioTray запустить вполне реально , только кодеки gstreamer0.10 для этого потребуются , проще VLC для этого использовать ...

# Установка кодеков Gstreamer:
sudo aptitude install gstreamer0.10-alsa gstreamer0.10-ffmpeg gstreamer0.10-gconf gstreamer0.10-pitfdll gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-base gstreamer0.10-plugins-base-apps gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-pulseaudio gstreamer0.10-tools gstreamer-tools gstreamer0.10-x
« Последнее редактирование: Март 17, 2012, 15:54:06 от calambus »
опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум