Автор Тема: Подключение принтеров Canon LBP  (Прочитано 85065 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Пользователь.

  • Местный
  • *****
  • Автор темы
  • Сообщений: 4502
Подключение принтеров Canon LBP
« : Сентябрь 15, 2010, 21:24:10 »
Подключение принтеров Canon LBP.



Поддерживаются следующие модели принтеров: LBP-1120, LBP-1210, LBP2900, LBP3000, LBP3010, LBP3018, LBP3050, LBP3100, LBP3108, LBP3150, LBP3200, LBP3210, LBP3250, LBP3300, LBP3310, LBP3500, LBP5000, LBP5050, LBP5100, LBP5300, LBP6000, LBP6018, LBP6020, LBP6200, LBP6300n, LBP6300dn, LBP6310dn, LBP7010C,  LBP7018C, LBP7200C, LBP7210Cdn, LBP9100Cdn.



Обозначения слов:
CAPT - язык печати Canon
ccpd - служба печати Canon работающая с CUPS
PPD - параметры принтера описанные по стандарту PostScript
cndrvcups-common - файлы необходимые для работы принтера
cndrvcups-capt - драйвер для принтера




Инструкция по подключению:

Скачать драйвер на сайте Canon.

Распаковать архив, перейти в распакованную папку, установить по очереди:
cndrvcups-common.deb
cndrvcups-capt.deb

Не включая принтер регистрируем его в системе

sudo /etc/init.d/cups restart
sudo lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59687 -E
sudo ccpdadmin -p LBP2900 -o /dev/usb/lp0
sudo update-rc.d ccpd defaults

Вместо LBP2900 укажите свою модель принтера, а вместо CNCUPSLBP2900CAPTK.ppd укажите название ppd вашего принтера из ниже указанного списка

LBP9100Cdn (CNCUPSLBP9100CCAPTK.ppd)
LBP7210Cdn (CNCUPSLBP7210CCAPTK.ppd)
LBP7200C (CNCUPSLBP7200CCAPTK.ppd)
LBP7010C/LBP7018C (CNCUPSLBP7018CCAPTK.ppd)
LBP6310dn (CNCUPSLBP6310CAPTK.ppd)
LBP6300dn (CNCUPSLBP6300CAPTK.ppd)
LBP6300n (CNCUPSLBP6300nCAPTK.ppd)
LBP6200 (CNCUPSLBP6200CAPTK.ppd)
LBP6020 (CNCUPSLBP6020CAPTK.ppd)
LBP6000/LBP6018 (CNCUPSLBP6018CAPTK.ppd)
LBP5300 (CNCUPSLBP5300CAPTK.ppd)
LBP5100 (CNCUPSLBP5100CAPTK.ppd)
LBP5050 (CNCUPSLBP5050CAPTK.ppd)
LBP5000 (CNCUPSLBP5050CAPTK.ppd)
LBP3500 (CNCUPSLBP3500CAPTK.ppd)
LBP3310 (CNCUPSLBP3310CAPTK.ppd)
LBP3300 (CNCUPSLBP3300CAPTK.ppd)
LBP3250 (CNCUPSLBP3250CAPTK.ppd)
LBP3210 (CNCUPSLBP3210CAPTK.ppd)
LBP3200 (CNCUPSLBP3200CAPTK.ppd)
LBP3100/LBP3108/LBP3150 (CNCUPSLBP3150CAPTK.ppd)
LBP3010/LBP3018/LBP3050 (CNCUPSLBP3050CAPTK.ppd)
LBP3000 (CNCUPSLBP3000CAPTK.ppd)
LBP2900 (CNCUPSLBP2900CAPTK.ppd)
LBP-1210 (CNCUPSLBP1210CAPTK.ppd)
LBP-1120 (CNCUPSLBP1120CAPTK.ppd)


Через главное меню на панели рабочего стола запускаем программу «Печать» и выбираем правой кнопкой мыши принтер по умолчанию.
Перезагружаем компьютер, включаем принтер и пробуем распечатать. В предварительном просмотре, не забываем настроить параметры печати.







Дополнительная информация:
Для продолжения печати при окончании бумаги нужна программа captstatusui, она идет в комплекте с драйвером (без нее придется выполнять очень много действий для продолжения печати).

Программу captstatusui нужно поместить в автозапуск, чтобы ее окошко появлялось при окончании бумаги.
В главном меню на панели рабочего стола выбираем автозапуск приложений, и добавляем туда команду
captstatusui -P LBP2900 -eВместо LBP2900 нужно указать модель своего принтера.

Применение, когда бумага закончилась:
ложим бумагу, нажимаем на принтере мигающую кнопку,  нажимаем в всплывающем окошке кнопку продолжить печать (Resume Job).

Примечание: не закрывайте окно программы кнопкой закрыть, это отключает ее до следующей загрузки системы, программа сама скрывается после нажатия на любую кнопку в программе.


Замечания:
Postscript PDF документы распечатываются только в Adobe Reader и Foxit Reader, а PDF с изображениями распечатываются в любой программе. Это проблема просмотрщиков, а не драйвера.

В Firefox по умолчанию указан неверный размер бумаги, поэтому перед печатью нужно выбрать размер бумаги А4.




Подробности смотреть здесь: help.ubuntu.ru
« Последнее редактирование: Июль 27, 2016, 18:58:31 от Пользователь. »

Оффлайн Пользователь.

  • Местный
  • *****
  • Автор темы
  • Сообщений: 4502
Re: Подключение принтеров Canon
« Ответ #1 : Февраль 14, 2011, 11:12:15 »
Ссылка в первом сообщении этой темы рабочая.
Сейчас скачал по ней архив и выложил на народе: ссылка для скачивания

Оффлайн butjapka

  • Местный
  • *****
  • Сообщений: 1143
  • Компьютер думает так, как думает его хозяин.
Re: Подключение принтеров Canon
« Ответ #2 : Февраль 14, 2011, 19:19:57 »
ЦитатаСкачать архив с пакетами и скриптами можно здесь.
 
К сожалению, ссылка не работает. Помогите, пожалуйста, мне нужно подключить LBP3010, никак не получается. :-\

а можно еще почитать    
Установка принтера Canon LBP3010 в Ubuntu 9.04
или этот блог

Оффлайн vita

  • Местный
  • *****
  • Сообщений: 971
  • Fiat lux! (Да будет Свет!)
    • Форум проекта Matuntu
Re: Подключение принтеров Canon
« Ответ #3 : Февраль 15, 2011, 10:05:21 »
Очень признательна за помощь!!! Теперь удалось скачать драйвер, буду подключать. О результатах сообщю.  :-*
Per aspera ad astra! (Через тернии к звездам!)

Оффлайн FIDOretano

  • Новичок
  • **
  • Сообщений: 34
Re: Подключение принтеров Canon
« Ответ #4 : Март 17, 2011, 04:00:28 »
Подскажите, пожалуйста, как настроить Canon Pixma IP1500 в Runtu LXDE 10.04? Многое видел в интернете, но малое понял, так как в Линуксе я только начинаю разбираться.
Из того, что понял:
fidoretano@fidoretano:~$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 04a9:1091 Canon, Inc. PIXMA iP1500
Bus 003 Device 002: ID 093a:2626 Pixart Imaging, Inc.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 9710:7780 MosChip Semiconductor MS7780 4Mbps Fast IRDA Adapter
Bus 002 Device 002: ID 04fc:0005 Sunplus Technology Co., Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Здесь присутствуют три устройства, которые мне нужно настроить:
- Canon, Inc. PIXMA iP1500,
- Pixart Imaging, Inc. (это моя вебка Genius iLook 310)
- MosChip Semiconductor MS7780 4Mbps Fast IRDA Adapter (это инфракрасный адаптер; использую для соединения с мобильникм; он тоже нужен).
Вот тут http://rus-linux.net/lib.php?name=MyLDP/hard/webcam.html, когда пытался разобраться с вебкой, советуют "работать" с восьмизначными кодами и двоеточиями посередине (т.е., 04a9:1091 для принтера, 093a:2626 для вебки и 9710:7780 для ИК-адаптера) в програмке v4l2-tool. Но где и как её найти, а потом установить? И что делать дальше?
Руководствуясь рекомендациями со страницы http://help.ubuntu.ru/wiki/периферийные_устройства/установка_принтера_canon_pixma_ip1000, пытался настроить принтер. У меня всё застопорилось на этапе конвертирования rmp-ок в deb-ки. Я так понял, что alien не установился (в командной строке написало что-то вроде comand not found или как-то так -- не помню сейчас уже). Это видать из-за того, что я тогда загружал Рунту с LiveCD (однако, адобе флеш-плэер и скайп поставились нормально!).
На этом, как сказали в Масяне, мысль останавливается. :(
Помогите!
Спасибо.
« Последнее редактирование: Март 17, 2011, 04:08:20 от FIDOretano »
Runtu_Lite 10.04 "Lucid Lynx" - Release i386 (20110303)

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Re: Подключение принтеров Canon
« Ответ #5 : Март 17, 2011, 07:29:53 »
У меня всё застопорилось на этапе конвертирования rmp-ок в deb-ки
Всё застопорилось из-за отсутствия программы "alien", которая и производит конвертацию rpm и deb
Устанавливается она командой:
sudo apt-get install alien(в инструкции по приведенной вами ссылке это самый первый пункт)
Предварительно желательно было сделать:
sudo apt-get updateВсе эти действия можно сделать и c livecd, но только при наличии доступа в инет
Кстати, драйвер можно взять с сайта Сanon.
« Последнее редактирование: Март 17, 2011, 07:45:06 от vmf »

Оффлайн Feduka

  • Активист
  • ****
  • Сообщений: 428
  • Меняю путина на Ходорковского
Re: Подключение принтеров Canon
« Ответ #6 : Март 17, 2011, 11:54:35 »
Начать с сайта canon - проще всего. Уж если там есть rpm, то обычно есть и deb. А когда нету, то нету напрочь.  (Сканеры, ну и МФУ возможно тоже, которые от canon, в коробке с собой имеют винюковые драйвера. И еще под макось. *nix'овые - не обязательно. То же самое на их сайте. Есть девайсы без поддержки linux. То есть без их официальной поддержки. Некоторые железки все же заводятся с драйверами из исходников - это я знаю на личном опыте на примере сканера.)
2:5020/655.11

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Re: Подключение принтеров Canon
« Ответ #7 : Март 17, 2011, 12:39:22 »
Начать с сайта canon - проще всего. Уж если там есть rpm, то обычно есть и deb.
Это не про Canon...
В основном пакете, который для кучи LBP принтеров deb-пакеты есть,
а конкретно для IP1500  (который по ссылке) - только rpm-ки.
там в списке поддерживаемых только SUSE Linux
« Последнее редактирование: Март 17, 2011, 12:43:37 от vmf »

Оффлайн FIDOretano

  • Новичок
  • **
  • Сообщений: 34
Re: Подключение принтеров Canon
« Ответ #8 : Март 17, 2011, 13:00:09 »
Спасибо за оперативность!
Значит, я уже дошёл до 7 пункта руководства установки принтера, а именно: Перезапускаем Cups. Как и просят в терминале (даже root-овом) выполнил обе команды:
root@fidoretano:/home/fidoretano# sudo killall cupsd
cupsd: процесс не найден
root@fidoretano:/home/fidoretano# sudo cupsd
sudo: cupsd: command not found
root@fidoretano:/home/fidoretano#
Процесс не найден, а команду мы и знать не знаем :( Что дальше?
Runtu_Lite 10.04 "Lucid Lynx" - Release i386 (20110303)

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Re: Подключение принтеров Canon
« Ответ #9 : Март 17, 2011, 13:10:42 »
Процесс не найден, а команду мы и знать не знаем :( Что дальше?
Во всех сборках с LXDE, если я не ошибась, cups не установлен.
В этой теме обсуждалось, как исправить положение (вам читать с 5-го ответа).
« Последнее редактирование: Март 17, 2011, 13:12:26 от vmf »

Оффлайн FIDOretano

  • Новичок
  • **
  • Сообщений: 34
Re: Подключение принтеров Canon
« Ответ #10 : Март 17, 2011, 14:13:58 »
Процесс не найден, а команду мы и знать не знаем :( Что дальше?
Во всех сборках с LXDE, если я не ошибась, cups не установлен.
В этой теме обсуждалось, как исправить положение (вам читать с 5-го ответа).
Спасибо. Вот только меня смущает то, что практически каждый пакет распаковываетс (устанавливается?) с ошибками. Например:
fidoretano@fidoretano:/media/Runtu_LXDE_10.04/packages/Printing$ sudo dpkg -i *.deb
[sudo] password for fidoretano:
Выбор ранее не выбранного пакета bc.
(Чтение базы данных ... на данный момент установлено 42892 файлов и каталогов.)
Распаковывается пакет bc (из файла bc_1.06.95-2_i386.deb)...
Выбор ранее не выбранного пакета cups.
Распаковывается пакет cups (из файла cups_1.4.3-1ubuntu1.2_i386.deb)...
 Removing any system startup links for /etc/init.d/cupsys ...
Выбор ранее не выбранного пакета cups-bsd.
Распаковывается пакет cups-bsd (из файла cups-bsd_1.4.3-1ubuntu1.2_i386.deb)...
Выбор ранее не выбранного пакета cups-client.
Распаковывается пакет cups-client (из файла cups-client_1.4.3-1ubuntu1.2_i386.deb)...
Выбор ранее не выбранного пакета cups-common.
Распаковывается пакет cups-common (из файла cups-common_1.4.3-1ubuntu1.2_all.deb)...
Выбор ранее не выбранного пакета cups-driver-gutenprint.
Распаковывается пакет cups-driver-gutenprint (из файла cups-driver-gutenprint_5.2.5-0ubuntu1_i386.deb)...
Выбор ранее не выбранного пакета foo2zjs.
Распаковывается пакет foo2zjs (из файла foo2zjs_20100210-0ubuntu4_i386.deb)...
Выбор ранее не выбранного пакета foomatic-db.
Распаковывается пакет foomatic-db (из файла foomatic-db_20100216-0ubuntu3_all.deb)...
Выбор ранее не выбранного пакета foomatic-db-engine.
Распаковывается пакет foomatic-db-engine (из файла foomatic-db-engine_4.0.4-0ubuntu1_i386.deb)...
Выбор ранее не выбранного пакета foomatic-filters.
Распаковывается пакет foomatic-filters (из файла foomatic-filters_4.0.4-0ubuntu1_i386.deb)...
Выбор ранее не выбранного пакета gawk.
Распаковывается пакет gawk (из файла gawk_3.1.6.dfsg-4build1_i386.deb)...
Выбор ранее не выбранного пакета ghostscript.
Распаковывается пакет ghostscript (из файла ghostscript_8.71.dfsg.1-0ubuntu5.1_i386.deb)...
Выбор ранее не выбранного пакета ghostscript-cups.
Распаковывается пакет ghostscript-cups (из файла ghostscript-cups_8.71.dfsg.1-0ubuntu5.1_i386.deb)...
Выбор ранее не выбранного пакета ghostscript-x.
Распаковывается пакет ghostscript-x (из файла ghostscript-x_8.71.dfsg.1-0ubuntu5.1_i386.deb)...
Выбор ранее не выбранного пакета gnome-mime-data.
Распаковывается пакет gnome-mime-data (из файла gnome-mime-data_2.18.0-1_all.deb)...
Выбор ранее не выбранного пакета hpijs.
Распаковывается пакет hpijs (из файла hpijs_3.10.2-2ubuntu2_i386.deb)...
Выбор ранее не выбранного пакета hpijs-ppds.
Распаковывается пакет hpijs-ppds (из файла hpijs-ppds_3.10.2-2ubuntu2_all.deb)...
Выбор ранее не выбранного пакета hplip.
Распаковывается пакет hplip (из файла hplip_3.10.2-2ubuntu2_i386.deb)...
Выбор ранее не выбранного пакета hplip-cups.
Распаковывается пакет hplip-cups (из файла hplip-cups_3.10.2-2ubuntu2_i386.deb)...
Выбор ранее не выбранного пакета hplip-data.
Распаковывается пакет hplip-data (из файла hplip-data_3.10.2-2ubuntu2_all.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр hplip-data_3.10.2-2ubuntu2_all.deb (--install):
 при работе функции buffer_copy (обработка файла ./usr/share/ppd/hplip/HP/hp-laserjet_p3010_series-ps.ppd процессом dpkg-deb) прочитан слишком короткий блок данных
Выбор ранее не выбранного пакета libart-2.0-2.
Распаковывается пакет libart-2.0-2 (из файла libart-2.0-2_2.3.20-2build1_i386.deb)...
Выбор ранее не выбранного пакета libbonobo2-0.
Распаковывается пакет libbonobo2-0 (из файла libbonobo2-0_2.24.3-0ubuntu1_i386.deb)...
Выбор ранее не выбранного пакета libbonobo2-common.
Распаковывается пакет libbonobo2-common (из файла libbonobo2-common_2.24.3-0ubuntu1_all.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libbonobo2-common_2.24.3-0ubuntu1_all.deb (--install):
 при работе функции buffer_copy (обработка файла ./usr/share/idl/bonobo-2.0/Bonobo_Persist.idl процессом dpkg-deb) прочитан слишком короткий блок данных
Выбор ранее не выбранного пакета libbonoboui2-0.
Распаковывается пакет libbonoboui2-0 (из файла libbonoboui2-0_2.24.3-0ubuntu1_i386.deb)...
Выбор ранее не выбранного пакета libbonoboui2-common.
Распаковывается пакет libbonoboui2-common (из файла libbonoboui2-common_2.24.3-0ubuntu1_all.deb)...
Выбор ранее не выбранного пакета libcupscgi1.
Распаковывается пакет libcupscgi1 (из файла libcupscgi1_1.4.3-1ubuntu1.2_i386.deb)...
Выбор ранее не выбранного пакета libcupsdriver1.
Распаковывается пакет libcupsdriver1 (из файла libcupsdriver1_1.4.3-1ubuntu1.2_i386.deb)...
Выбор ранее не выбранного пакета libcupsmime1.
Распаковывается пакет libcupsmime1 (из файла libcupsmime1_1.4.3-1ubuntu1.2_i386.deb)...
Выбор ранее не выбранного пакета libcupsppdc1.
Распаковывается пакет libcupsppdc1 (из файла libcupsppdc1_1.4.3-1ubuntu1.2_i386.deb)...
Выбор ранее не выбранного пакета libexif12.
Распаковывается пакет libexif12 (из файла libexif12_0.6.19-1_i386.deb)...
Выбор ранее не выбранного пакета libgail18.
Распаковывается пакет libgail18 (из файла libgail18_2.20.1-0ubuntu2_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libgail18_2.20.1-0ubuntu2_i386.deb (--install):
 при работе функции buffer_copy (обработка файла ./usr/share/doc/libgail18/changelog.gz процессом dpkg-deb) прочитан слишком короткий блок данных
Выбор ранее не выбранного пакета libgnome2-0.
Распаковывается пакет libgnome2-0 (из файла libgnome2-0_2.30.0-0ubuntu1_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libgnome2-0_2.30.0-0ubuntu1_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libgnome2-common.
Распаковывается пакет libgnome2-common (из файла libgnome2-common_2.30.0-0ubuntu1_all.deb)...
dpkg-split: ошибка чтения libgnomecanvas2-0_2.30.1-0ubuntu1_i386.deb: Ошибка ввода/вывода
dpkg: не удалось обработать параметр libgnomecanvas2-0_2.30.1-0ubuntu1_i386.deb (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
Выбор ранее не выбранного пакета libgnomecanvas2-common.
Распаковывается пакет libgnomecanvas2-common (из файла libgnomecanvas2-common_2.30.1-0ubuntu1_all.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libgnomecanvas2-common_2.30.1-0ubuntu1_all.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
dpkg-split: ошибка чтения libgnomeui-0_2.24.3-1_i386.deb: Ошибка ввода/вывода
dpkg: не удалось обработать параметр libgnomeui-0_2.24.3-1_i386.deb (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
Выбор ранее не выбранного пакета libgnomeui-common.
Распаковывается пакет libgnomeui-common (из файла libgnomeui-common_2.24.3-1_all.deb)...
Выбор ранее не выбранного пакета libgnomevfs2-0.
Распаковывается пакет libgnomevfs2-0 (из файла libgnomevfs2-0_2.24.2-1ubuntu2_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libgnomevfs2-0_2.24.2-1ubuntu2_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libgnomevfs2-common.
Распаковывается пакет libgnomevfs2-common (из файла libgnomevfs2-common_2.24.2-1ubuntu2_all.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libgnomevfs2-common_2.24.2-1ubuntu2_all.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libgphoto2-2.
Распаковывается пакет libgphoto2-2 (из файла libgphoto2-2_2.4.8-0ubuntu2_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libgphoto2-2_2.4.8-0ubuntu2_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libgphoto2-port0.
Распаковывается пакет libgphoto2-port0 (из файла libgphoto2-port0_2.4.8-0ubuntu2_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libgphoto2-port0_2.4.8-0ubuntu2_i386.deb (--install):
 при работе функции buffer_copy (обработка файла ./usr/share/doc/libgphoto2-port0/changelog.gz процессом dpkg-deb) прочитан слишком короткий блок данных
dpkg-split: ошибка чтения libgutenprint2_5.2.5-0ubuntu1_i386.deb: Ошибка ввода/вывода
dpkg: не удалось обработать параметр libgutenprint2_5.2.5-0ubuntu1_i386.deb (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
Выбор ранее не выбранного пакета libhpmud0.
Распаковывается пакет libhpmud0 (из файла libhpmud0_3.10.2-2ubuntu2_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libhpmud0_3.10.2-2ubuntu2_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libieee1284-3.
Распаковывается пакет libieee1284-3 (из файла libieee1284-3_0.2.11-5ubuntu3_i386.deb)...
dpkg-split: ошибка чтения libijs-0.35_0.35-7build1_i386.deb: Ошибка ввода/вывода
dpkg: не удалось обработать параметр libijs-0.35_0.35-7build1_i386.deb (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
Выбор ранее не выбранного пакета libperl5.10.
Распаковывается пакет libperl5.10 (из файла libperl5.10_5.10.1-8ubuntu2_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libperl5.10_5.10.1-8ubuntu2_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
dpkg-split: ошибка чтения libsane_1.0.20-13ubuntu2_i386.deb: Ошибка ввода/вывода
dpkg: не удалось обработать параметр libsane_1.0.20-13ubuntu2_i386.deb (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
Выбор ранее не выбранного пакета libsensors4.
Распаковывается пакет libsensors4 (из файла libsensors4_3.1.2-2_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libsensors4_3.1.2-2_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libslp1.
Распаковывается пакет libslp1 (из файла libslp1_1.2.1-7.6_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libslp1_1.2.1-7.6_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libsnmp15.
Распаковывается пакет libsnmp15 (из файла libsnmp15_5.4.2.1~dfsg0ubuntu1-0ubuntu2.1_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libsnmp15_5.4.2.1~dfsg0ubuntu1-0ubuntu2.1_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета libsnmp-base.
Распаковывается пакет libsnmp-base (из файла libsnmp-base_5.4.2.1~dfsg0ubuntu1-0ubuntu2.1_all.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libsnmp-base_5.4.2.1~dfsg0ubuntu1-0ubuntu2.1_all.deb (--install):
 при работе функции buffer_copy (обработка файла ./usr/share/doc/libsnmp-base/changelog.gz процессом dpkg-deb) прочитан слишком короткий блок данных
Выбор ранее не выбранного пакета libv4l-0.
Распаковывается пакет libv4l-0 (из файла libv4l-0_0.6.4-1ubuntu1_i386.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр libv4l-0_0.6.4-1ubuntu1_i386.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
dpkg-split: ошибка чтения mscompress_0.3-3build1_i386.deb: Ошибка ввода/вывода
dpkg: не удалось обработать параметр mscompress_0.3-3build1_i386.deb (--install):
 подпроцесс dpkg-split возвратил код ошибки 2
Выбор ранее не выбранного пакета openprinting-ppds.
Распаковывается пакет openprinting-ppds (из файла openprinting-ppds_20100216-0ubuntu3_all.deb)...
dpkg-deb (подпроцесс): при работе функции buffer_read(stream) произошла ошибка: не удалось осуществить запись в канал ввода/вывода при копировании: Ошибка ввода/вывода
dpkg-deb: подпроцесс вставка возвратил код ошибки 2
dpkg: не удалось обработать параметр openprinting-ppds_20100216-0ubuntu3_all.deb (--install):
 подпроцесс dpkg-deb --fsys-tarfile возвратил код ошибки 2
Выбор ранее не выбранного пакета poppler-utils.
Распаковывается пакет poppler-utils (из файла poppler-utils_0.12.4-0ubuntu5_i386.deb)...
Выбор ранее не выбранного пакета python-cups.
Распаковывается пакет python-cups (из файла python-cups_1.9.49-0ubuntu1_i386.deb)...
и так далее... Неужели это нормально?
Пытаюсь устанавливать пакеты из-под графического интерфейса двойным щелчком по первой попавшейся на глаза deb-ке. Мне выдало ошибку:
В вашей системе нарушены зависимости.
Выполнение приложения не может быть продолжено,
пока это не будет исправлено.
Для исправления наберите в окне терминала
'gksudo synaptic' или 'sudo apt-get install -f'.
Запустил последнюю команду. Она отработала. В Диспетчере процессов проверил -- cupsd присутствует. На всякий случай я его убил sudo killall cupsd и запустил заново sudo cupsd. В меню Системные появилось подменю Printing. По указаниям руководства принтер определил, но пробную страницу он так и не напечатал :(. В очереди так и написано "Остановлено".
Runtu_Lite 10.04 "Lucid Lynx" - Release i386 (20110303)

Оффлайн HsH

  • Administrator
  • *****
  • Сообщений: 3181
Re: Подключение принтеров Canon
« Ответ #11 : Март 17, 2011, 14:41:41 »
меня смущает то, что практически каждый пакет распаковываетс (устанавливается?) с ошибками.

    Пакеты в кэше CD имеют версии на момент выпуска релиза дистрибутива и предназначены для установки на систему без обновлений инфо о репозиториях (apt-get update), т.е. сразу после установки. Если имеется интернет, использовать этот кэш необходимости нет.

   Конкретно в вашем случае можно воспользоваться вот этой рекомендацией. Также при возможности попробуйте обновлённую версию дистрибутива Runtu Lite 10.04.

Оффлайн FIDOretano

  • Новичок
  • **
  • Сообщений: 34
Re: Подключение принтеров Canon
« Ответ #12 : Март 17, 2011, 15:03:02 »
меня смущает то, что практически каждый пакет распаковываетс (устанавливается?) с ошибками.

    Пакеты в кэше CD имеют версии на момент выпуска релиза дистрибутива и предназначены для установки на систему без обновлений инфо о репозиториях (apt-get update), т.е. сразу после установки. Если имеется интернет, использовать этот кэш необходимости нет.

   Конкретно в вашем случае можно воспользоваться вот этой рекомендацией. Также при возможности попробуйте обновлённую версию дистрибутива Runtu Lite 10.04.
под root-oм выполнил команду
sudo aptitude install cups cups-bsd foomatic-filters system-config-printer-gnome
Перезапустил на всякий случай капсу, удалил и поставил заново принтер в Печати. Всё как было, так и осталось: в очередь ставит, а печатать не печатает.
Сейчас посмотрю на Рунту ЛАЙТ 10.04
Runtu_Lite 10.04 "Lucid Lynx" - Release i386 (20110303)

Оффлайн vmf

  • Местный
  • *****
  • Сообщений: 587
  • vmf000@yabber.ru
Re: Подключение принтеров Canon
« Ответ #13 : Март 17, 2011, 15:44:35 »
в очередь ставит, а печатать не печатает.
Это обычное явление для Canon...
Имею опыт настройки LBP800,LBP810,LBP1120,LBP2900. У всех разные заморочки в зависимости от версии драйвера.
Если вы качали драйвер отсюда, то там внутри есть руководство.
Правда только для Suse и RedHat и на английском, но это не меняет сути
Вот для красной шапки: ПоказатьСкрыть
1.3.2 Red Hat Enterprise Linux WS 3

This section describes how to install Print Filter in Red Hat Enterprise Linux WS 3.

   1. Install Linux.
      For details, see the manual that comes with the package.

   2. Start Linux.
      After installing Linux, start Linux and log in as root.

   3. Copy the rpm files.
      The rpm files shown below are necessary. First download the rpm files required for the printer to be used, from the Canon website to any directory. (In the rpm file name shown below, the "2.50-x" portion is the version number. "x" represents a number from 1 to 9.)

          bjfilter-common-2.50-x.i386.rpm -------- Common package

          bjfilter-pixmaip1500-2.50-x.i386.rpm -------- Model-specific package


         

      The above packages cannot be used together with a CUPS support module for Print Filter Ver. 2.40 or earlier.
      If a CUPS support module is already installed, uninstall the module, and then install the two rpm packages indicated above.

   4. Install Filter
      Start the terminal software, and use the rmp command to install Print Filter.

      [root@zzz /yyy]# rpm -ivh bjfilter-common-2.50-x.i386.rpm

      [root@zzz /yyy]# rpm -ivh bjfilter-pixmaip1500-2.50-x.i386.rpm


         
          * When you execute the rpm from a directory, specify the path or use the cd command to change the current directory to the directory containing the Print Filter rpm files.
          * For details about the rpm command, enter man rpm with the terminal software.

   5. Restart the CUPS daemon.
      Enter the following from the command line of the terminal software:

      [root@zzz /yyy]# /etc/rc.d/init.d/cups restart


         

      Do not register the printer with the lpadmin command before your restart the CUPS daemon.

   6. Register the printer to the spooler.
      To register the printer to the spooler, enter the lpadmin command from the command line of the terminal software.

      lpadmin -p [printer_name] -m [PPD_filename] -v [device_URI] -E


       Example:  [root@zzz /yyy]# lpadmin -p PIXMAIP1500 -m canonpixmaip1500.ppd -v canon_usb:/dev/usb/lp0 -E



   7. Set the default printer.
      Set the default printer to be used when the printer name is omitted in the print command from the command line of the terminal software.

      lpadmin -d [printer_name]

       Example:  [root@zzz /yyy]# lpadmin -d PIXMAIP1500


   8. Restart the computer.

Попробуйте выполнить рекомендации начиная с п.6
Только удалите установленный ранее принтер.


Оффлайн FIDOretano

  • Новичок
  • **
  • Сообщений: 34
Re: Подключение принтеров Canon
« Ответ #14 : Март 17, 2011, 16:02:21 »
в очередь ставит, а печатать не печатает.
Это обычное явление для Canon...
Имею опыт настройки LBP800,LBP810,LBP1120,LBP2900. У всех разные заморочки в зависимости от версии драйвера.
Если вы качали драйвер отсюда, то там внутри есть руководство.
Правда только для Suse и RedHat и на английском, но это не меняет сути
Вот для красной шапки: ПоказатьСкрыть
1.3.2 Red Hat Enterprise Linux WS 3

This section describes how to install Print Filter in Red Hat Enterprise Linux WS 3.

   1. Install Linux.
      For details, see the manual that comes with the package.

   2. Start Linux.
      After installing Linux, start Linux and log in as root.

   3. Copy the rpm files.
      The rpm files shown below are necessary. First download the rpm files required for the printer to be used, from the Canon website to any directory. (In the rpm file name shown below, the "2.50-x" portion is the version number. "x" represents a number from 1 to 9.)

          bjfilter-common-2.50-x.i386.rpm -------- Common package

          bjfilter-pixmaip1500-2.50-x.i386.rpm -------- Model-specific package


         

      The above packages cannot be used together with a CUPS support module for Print Filter Ver. 2.40 or earlier.
      If a CUPS support module is already installed, uninstall the module, and then install the two rpm packages indicated above.

   4. Install Filter
      Start the terminal software, and use the rmp command to install Print Filter.

      [root@zzz /yyy]# rpm -ivh bjfilter-common-2.50-x.i386.rpm

      [root@zzz /yyy]# rpm -ivh bjfilter-pixmaip1500-2.50-x.i386.rpm


         
          * When you execute the rpm from a directory, specify the path or use the cd command to change the current directory to the directory containing the Print Filter rpm files.
          * For details about the rpm command, enter man rpm with the terminal software.

   5. Restart the CUPS daemon.
      Enter the following from the command line of the terminal software:

      [root@zzz /yyy]# /etc/rc.d/init.d/cups restart


         

      Do not register the printer with the lpadmin command before your restart the CUPS daemon.

   6. Register the printer to the spooler.
      To register the printer to the spooler, enter the lpadmin command from the command line of the terminal software.

      lpadmin -p [printer_name] -m [PPD_filename] -v [device_URI] -E


       Example:  [root@zzz /yyy]# lpadmin -p PIXMAIP1500 -m canonpixmaip1500.ppd -v canon_usb:/dev/usb/lp0 -E



   7. Set the default printer.
      Set the default printer to be used when the printer name is omitted in the print command from the command line of the terminal software.

      lpadmin -d [printer_name]

       Example:  [root@zzz /yyy]# lpadmin -d PIXMAIP1500


   8. Restart the computer.

Попробуйте выполнить рекомендации начиная с п.6
Только удалите установленный ранее принтер.

А не может ли быть проблема в URI устройства? Я прописіваю usb://Canon/iP1500. Обе команды выполняются нормально, но всё равно в очереди всё остановлено. Прописывая в команде предложенное canon_usb:/dev/usb/lp0, команда не выполняется:
root@fidoretano:/home/fidoretano# lpadmin -p PIXMAIP1500 -m canonpixmaip1500.ppd -v canon_usb:/dev/usb/lp0 -E
lpadmin: Неверное значение device-uri «canon_usb:/dev/usb/lp0»!
root@fidoretano:/home/fidoretano# lpadmin -p PIXMAIP1500 -m canonpixmaip1500.ppd -v usb://Canon/iP1500 -E
root@fidoretano:/home/fidoretano# lpadmin -d PIXMAIP1500
root@fidoretano:/home/fidoretano#
Runtu_Lite 10.04 "Lucid Lynx" - Release i386 (20110303)