Форум сообщества Runtu.org
Январь 20, 2020, 08:43:32 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости:
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1 2 3 4  Все   Вниз
  Печать  
Автор Тема: LiveDVD на основе Calculate linux с поддержкой видео ATI  (Прочитано 29225 раз)
0 Пользователей и 1 Гость смотрят эту тему.
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« : Февраль 18, 2011, 19:06:17 »

Специально для владельцев карточек от ATI (R9XXX / X1XXX).

LiveDVD с поддержкой fglrx из коробки.
Аппаратное ускорение с драйверами от ATI, будет сразу при загрузке LiveDVD
Не устанавливая систему на жёсткий диск, можно поиграть в Quake3-demo, к примеру.

Система использует genkernel, поэтому должна пойти на любом железе с карточкой ATI.
(модули для всевозможного железа скомпилированы и присутствуют)
Аржитектура i686. (будет работать и на x86_64 - как у меня например)

Добавил немного нового софта. Всегда можно добавить добавлением ebuil-ов.
Система на LiveDVD представояет собой stage4, который одной командой можно перенести на жёсткий диск
(# calculate -d /dev/sdXX) - где sdXX раздел жёсткого диска
И вы получите точно такую же систему, как и на LiveDVD.

В системе имеются 4 пользователя:
root - password: root
guest - password: guest
user - password: user
gnom = password gnom

guest,user,gnom - в группе wheel.
Можно использовать как su, так и sudo.

Примечание:
Система показала себя очень стабильной за всё время работы на моём компьютере.
(AMDK8x2 PCI-X1950PPRO).
Всё было собрано и добавлено только с помощью команды emerge.
Никаких запусков ххххх.run и ручных компиляций с установкой типа:
./confugure
make
make install

Поэтому соблюдены все зависимости пакетов и исключены конфликты.


Обновлённые образы LiveDVD и BootUSBFlash (20.12.2011)

Описание:

Portage-20110110
KDE-4.5.5
Gnome-2.30.2
XFCE-4.6.3
OpenBox-3.4.11.2
Kernel 2.6.28.10
Xorg-Server-1.5.3
ATI-Drivers-9.2 (fglrx)
Nvidia-Drivers 256.53

Поддерживаемые языки:
Русский, английский.
Переключение раскладок клавиатуры: Left_win
Пользователи указаны в файле Readme.Users.
в корневом каталоге образа диска
LiveDVD и BootUSBFlash включает в себя более 1,300 пакетов, а также поддерживают аппаратное ускорение fglrx и nvidia непосредственно с livedvd и bootflash.

Спойлер  "Выявленные ошибки":
Цитировать
1. Используется не тот initrd в качестве 'источника.
2. Не добавляются нужные модули файловых систем в генерируемый initrd
3. Не создаётся минимальный набор устройств в /dev null, console,tty1
http://rutracker.org/forum/viewtopic.php?p=49869959#49869959

Утитлита calculate была переписана, эти ошибки устранены.

Также убрал следы своих сетевых карт в udev.
Из-за нмх все сетевые карты определялись начиная с eth2 и выше.

Убрал следы своей звуковой карты.

И ещё несколько незначительных ошибок.

Немного переписал в "calculate" код определения видеокарт.
Теперь полное аппаратное ускорение доступно, как для карт ATI,
так и для видеокарт Nvidia, непосредственно сразу при загрузке
с LiveDVD или BootUSBFlash.

ATI DRIVER - FGLRX-9.2
Спойлер  "Список поддерживаемыз Видеокарт":
Спойлер  скрыт:
The ATI CatalystTM Linux software suite is designed to support the following ATI
Workstation products:

ATI FirePro V8700 ATI FireGLTM V3600
ATI FirePro V7750 ATI FireGLTM V3400
ATI FirePro V3700 ATI FireGLTM V3300
ATI FirePro V2260 ATI FireGLTM V3200
ATI FireGLTM V8650 ATI FireGLTM V3100
ATI FireGLTM V8600 ATI FireGLTM X3-256
ATI FireGLTM V7700 ATI FireGLTM X3
ATI FireGLTM V7600 ATI FireGLTM X2-256
ATI FireGLTM V7350 ATI FireGLTM Z1-128
ATI FireGLTM V7300 ATI FireGLTM T2-128
ATI FireGLTM V7200 ATI FireGLTM X1-128
ATI FireGLTM V7100 ATI FireGLTM X1-256p
ATI FireGLTM V5600 ATI FireMVTM 2400
ATI FireGLTM V5200 ATI FireMVTM 2250
ATI FireGLTM V5100 ATI FireMVTM 2200 (Single card PCI-e configuration)
ATI FireGLTM V5000 ATI Mobility FireGLTM V5000
ATI FireGLTM V5000 ATI Mobility FireGLTM T2


The ATI CatalystTM Linux software suite is designed to support the following ATI MobilityTM products:

ATI Mobility RadeonTM X3870, ATI Mobility RadeonTM X1100
ATI Mobility RadeonTM X3850, ATI Mobility RadeonTM X800
ATI Mobility RadeonTM X3830, ATI Mobility RadeonTM X700
ATI Mobility RadeonTM X3430, ATI Mobility RadeonTM Xpress 1200 series
ATI Mobility RadeonTM X3400, ATI Mobility RadeonTM X600
ATI Mobility RadeonTM X2600, ATI Mobility RadeonTM X300
ATI Mobility RadeonTM X2400, ATI Mobility RadeonTM X200
ATI Mobility RadeonTM X2300, ATI Mobility RadeonTM 9800
ATI Mobility RadeonTM X1800, ATI Mobility RadeonTM 9600
ATI Mobility RadeonTM X1600, ATI Mobility RadeonTM 9550
ATI Mobility RadeonTM X1400, ATI Mobility RadeonTM 9500
ATI Mobility RadeonTM X1300, ATI Mobility RadeonTM Xpress 1100 series
ATI Mobility RadeonTM X1200, ATI Mobility RadeonTM Xpress 200 series


ATI Desktop Product Family Support
The ATI CatalystTM Linux software suite is designed to support the following ATI
desktop products:

Note: The ATI RadeonTM HD 3870X2 series of product is currently
not supported by the ATI CatalystTM Linux software suite

Note: All-in-WonderTM variants based on the above are also sup-
ported. However, video capture is not supported.

Note: Software driver support for ATI FireGLTM, Integrated,
Mobil-ityTM and Desktop products prior to the RadeonTM 9500 is available from www.amd.com

ATI RadeonTM HD 4870 X2 Series
ATI RadeonTM HD 4850 X2 Series, ATI RadeonTM X1650 Series
ATI RadeonTM HD 4800 Series, ATI RadeonTM X1600 Series
ATI RadeonTM HD 4670 Series, ATI RadeonTM X1550 Series
ATI RadeonTM HD 4650 Series, ATI RadeonTM X1300 Series
ATI RadeonTM HD 4600 Series, ATI RadeonTM X1050 Series
ATI RadeonTM HD 4550 Series, ATI RadeonTM X850 Series
ATI RadeonTM HD 4350 Series, ATI RadeonTM X800 Series
ATI RadeonTM HD 3800 Series, ATI RadeonTM X700 Series
ATI RadeonTM HD 3600 Series, ATI RadeonTM X600 Series
ATI RadeonTM HD 3400 Series, ATI RadeonTM X550 Series
ATI RadeonTM HD 2900 Series, ATI RadeonTM X300 Series
ATI RadeonTM HD 2600 Series, ATI RadeonTM 9800 Series
ATI RadeonTM HD 2400 Series, ATI RadeonTM 9700 Series
ATI RadeonTM X1950 Series, ATI RadeonTM 9600 Series
ATI RadeonTM X1900 Series, ATI RadeonTM 9550 Series
ATI RadeonTM X1800 Series, ATI RadeonTM 9500 Series

ATI Integrated Product Family Support
The ATI CatalystTM Linux software suite is designed to support the following ATI desktop products

ATI RadeonTM HD 3300 Series
ATI RadeonTM HD 3200 Series
ATI RadeonTM 3100 Series
ATI RadeonTM 3000 Series
ATI RadeonTM 2100 Series
ATI RadeonTM Xpress 1150 Series
ATI RadeonTM Xpress 1100 Series
ATI RadeonTM Xpress 200 Series
ATI RadeonTM X1250 Series
ATI RadeonTM X1200 Series
AMD 690 Series Chipset
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/catalyst_92_linux.pdf
NVIDIA DRIVER - NVIDIA 256.53
Спойлер  "Список поддерживаемыз Видеокарт":
Спойлер  скрыт:
GeForce 400 series:
GTX 480, GTX 470, GTX 465, GTX 460

GeForce 300 series:
GT 340, GT 330, GT 320, 315, 310

GeForce 300M series:
GTS 360M, GTS 350M, GTS 250M, GT 335M, GT 330M, GT 325M, 310M, 305M

GeForce 200 series:
GTX 295, GTX 285, GTX 280, GTX 275, GTX 260, GTS 250, GTS 240, GT 240, GT 230, GT 220, G210, 210, 205

GeForce 200M series:
GTX 285M, GTX 280M, GTX 260M, GTS 260M, GT 240M, GT 230M, GT 220M, G210M

GeForce 100 series:
GT 140, GT 130, GT 120, G 100

GeForce 100M series:
GT 130M, GT 120M, G 110M, G 105M, G 103M, G 102M

GeForce 9 series:
9800 GX2, 9800 GTX/GTX+, 9800 GT, 9600 GT, 9600 GSO 512, 9600 GSO, 9600 GS, 9500 GT, 9500 GS, 9400 GT, 9400, 9300 SE, 9300 GS, 9300 GE, 9300, 9200, 9100

GeForce 9M series:
9800M GTX, 9800M GTS, 9800M GT, 9800M GS, 9700M GTS, 9700M GT, 9650M GT, 9650M GS, 9600M GT, 9600M GS, 9500M GS, 9500M G, 9400M G, 9400M, 9300M GS, 9300M G, 9200M GS, 9100M G

GeForce 8 series:
8800 Ultra, 8800 GTX, 8800 GTS 512, 8800 GTS, 8800 GT, 8800 GS, 8600 GTS, 8600 GT, 8600 GS, 8500 GT, 8400 SE, 8400 GS, 8400, 8300 GS, 8300, 8200 / nForce 730a, 8200, 8100 / nForce 720a

GeForce 8M series:
8800M GTX, 8800M GS, 8700M GT, 8600M GT, 8400M GT, 8400M GS, 8400M G, 8200M G

GeForce 7 series:
7950 GX2, 7950 GT, 7900 GTX, 7900 GT/GTO, 7900 GS, 7800 SLI, 7800 GTX, 7800 GS, 7650 GS, 7600 LE, 7600 GT, 7600 GS, 7550 LE, 7500 LE, 7350 LE, 7300 SE / 7200 GS, 7300 LE, 7300 GT, 7300 GS, 7150 / NVIDIA nForce 630i, 7100 GS, 7100 / NVIDIA nForce 630i, 7100 / NVIDIA nForce 620i, 7050 PV / NVIDIA nForce 630a, 7050 / NVIDIA nForce 630i, 7050 / NVIDIA nForce 610i, 7025 / NVIDIA nForce 630a

GeForce Go 7 series:
Go 7950 GTX, Go 7900 GTX, Go 7900 GS, Go 7800 GTX

GeForce 6 series:
6800 XT, 6800 XE, 6800 Ultra, 6800 LE, 6800 GT, 6800 GS/XT, 6800 GS, 6800, 6700 XL, 6610 XL, 6600 VE, 6600 LE, 6600 GT, 6600, 6500, 6250, 6200 TurboCache, 6200SE TurboCache, 6200 LE, 6200 A-LE, 6200, 6150SE nForce 430, 6150LE / Quadro NVS 210S, 6150 LE, 6150, 6100 nForce 420, 6100 nForce 405, 6100 nForce 400, 6100

Quadro series:
6000, 5000, 4000

Quadro FX series:
FX 5800, FX 580, FX 570, FX 5600, FX 560, FX 5500, FX 550, FX 540, FX 4800, FX 4700 X2, FX 4600, FX 4500 X2, FX 4500, FX 4000, FX 3800, FX 380, FX 370 Low Profile, FX 3700, FX 370, FX 3500, FX 350, FX 3450, FX 3400/4400, FX 1800, FX 1700, FX 1500, FX 1400, CX

Quadro FX Notebook series:
FX 570M, FX 370M, FX 360M, FX 3600M, FX 2700M, FX 1700M, FX 1600M

Quadro NVS series:
NVS 450, NVS 440, NVS 420, NVS 295, NVS 290, NVS 285

ION series:
ION

GPU Computing Processor series:
Tesla C870, Tesla C2050, Tesla C1060
http://www.nvidia.com/object/linux-display-amd64-256.53-driver.html


Спойлер  "Про GRUB:":
ПРИМЕЧАНИЕ!:
======================================================================
1. При наличии более одного жёсткого диска в системе, надо выставить в
БИОСЕ - sda (первый физический диск), первым загрузочным диском
после LiveDVD или BootUSBFlash, и только после этого запускать
утилиту calculate.

Проверить какой диск является первым (sda) можно командой:
# fdisk -l

Если выставлен другой диск - надо перезагрузиться, выставить sda -
первым после LiveDVD или BootUSBFlash, и после этого снова
загрузиться с LiveDVD или BootUSBFlash.

После этого можно запускать установку системы на жёсткий диск
утилитой calculate. Ручной запуск из командной строки grub,
при этом не требуется. Всё установиться автоматически.

2. При наличии отдельного раздела "boot", требуется
ручное редактирование fstab и grub.conf.
======================================================================


BootUSBFlash: (1.9GB)

Снятие образа с флешки, и запись образа на флешку обратно:
Спойлер  скрыт:

CLD-FGLRX-9.2-p20110110-r2-i686.gz

CLD-FGLRX-9.2-p20110110-r2-i686.gz.DIGESTS

Записывается на флешку командой:
# gzip -dc /home/gnom/CLD-FGLRX-9.2-p20110110-r2-i686.gz | dd of=/dev/sdc bs=1M
(где sdc - наша флешка, на 2GB)

Спойлер  "Скриншоты непосредственно, при загрузке с BootUSBFlash:":






LiveDVD: (1.9GB)

CLD-FGLRX-9.2-p20110110-r2-i686.iso

CLD-FGLRX-9.2-p20110110-r2-i686.iso.DIGESTS

Stage 4:  CLD-FGLRX-9.2-p20110110-r2-i686.tar.bz2  (2048MB)

Разбил на две части - на народ не влез одним файлом.
DIGESTS - файл, внутри архива.

CLD-FGLRX-9.220110110-r2-i686.part1.rar
CLD-FGLRX-9.220110110-r2-i686.part2.rar


P.S.

Дополнительно обновил firefox с версии 3.6 до 7.0.1
Заменил quake3-demo-1.11 на ioquake-1.34 из-за проблем
у него со звуком.

LiveDVD и BootUSBFlash проверены на работопособность как на
картах ATI, так и NVIDIA. Проверена процедура создания initrd и
установки на жёсткий диск - для разных файловых систем.

Здесь можно скачать обновлённую версию с помощью торрент клиента
(kernel 2.6.28.10)




Предпоследняя версия (Kernel 3.1.10):

Portage-20111205 (05-декабря-2011)
KDE-4.6.3
Gnome-2.32.1
XFCE-4.8
OpenBox- 3.5.0-r1
Kernel 3.1.10
Xorg-Server-1.5.3
ATI-Drivers - 11.11, 9.2 (fglrx)
Nvidia-Drivers - 290.10, 96.43.19 (nvidia)

VirtualBox 4.0.12, Firefox 9.01
Добавлен LibreOffice 3.3.4 и большое количество программ - для работы с мультимедийным контентом, и
интернет-приложения.

Вместо unionfs - используется aufs
(обеспечивает большую стабильность в live режиме)


Образ поддерживает запуск под VirtualBox и VMWare
Спойлер  скрыт:



Пользователи:
Код:
root   - пароль (root)
user   - пароль (user)   openbox
sun    - пароль (sun)    xfce
guest  - пароль (guest)  kde
gnom   - пароль (gnom)   gnome - светлая схема оформления
gentoo - пароль (gentoo) gnome - тёмная схема оформления

Для ATI[AMD] карт - Драйвера:
FGLRX-11.11, Legacy FGLRX-9.2, Open RADEON
Для Nvidia   карт - Драйвера:
Nvidia-290.10, Legacy Nvidia-96.43.19, Open NV
(Определяется при загрузке с помощью lspci, и устанавливается штатно
командой emerge -K <версия драйвера> )

Присутсвует код определения для:
Intel - intel
Matrox Graphics - mga
Trident Microsystems - trident
3DLabs GLINT - glint
Neomagic Corporation - neomagic
3Dfx Interactive - tdfx
S3 Inc. Savage - savage
S3 Inc. ViRGE  - s3virge
S3 Inc. Trio 3D - s3virge
S3 Inc. Trio 64 3D - s3virge
Via - openchrome
SiS - sis
Cоответсвующие для них драйвера, с поддержкиой DRI - установлены.
Для неопределённых видеоадаптеров, выставляется режим vesa.

Xorg-server скомпилирован с поддержкой:
Спойлер  скрыт:





Скриншоты с Livedvd (fglrx-9.2):
Спойлер  скрыт:


Скриншоты с Livedvd (fglrx-11.11):
Спойлер  скрыт:



Образ LiveDVD 2904 MB:

Gentoo-20111205-kernel-3.1.10-i686.iso


# MD5 HASH
13b0e7e13dcc2cb9c3f049e1953c50b3
# SHA1 HASH
b3287ce60e8c313bba7e075d95bafd52d2f7d9cc
# SHA256 HASH
a2cccb8028b6016eb12eca1188411ce2899ed9b4db0ba2f38c92870ccf5ce226

Gentoo-20111205-kernel-3.1.10-i686.part1.rar 1.4GB
Gentoo-20111205-kernel-3.1.10-i686.part2.rar 1.4GB


Скриншоты меню gnome:
Спойлер  скрыт:




Portage 2012 года - содержат Gnome3 и версию KDE выше 4.6.3, несовместимые с xorg-server-1.5.3 на уровне библиотек.

Поэтому это последний LiveDVD - содержащий KDE и Gnome.
На Portage 2012, можно собрать систему с LXDE OpenBox и XFCE4,
используя связку: FGLRX-9.2 + kernel-3.1.10 + xorg-server-1.5.3

Связка FGLRX-9.2 + xorg-server-1.5.3, работает стабильно с любой версией  kernel.


Последняя версия (Kernel 3.3.4):

Решил пересобрать LiveDVD на последнем ядре, на данный момент в
Portage Gentoo. И добавить драйвер 173.14.31 для Nvidia карт серии FX 5xxx.

То есть, теперь:

Kernel-3.3.4

Для ATI[AMD] карт - Драйвера:
FGLRX-11.11, Legacy FGLRX-9.2, Open RADEON
Для Nvidia   карт - Драйвера:
Nvidia-290.10, Nvidia-173.14.31, Legacy Nvidia-96.43.19, Open NV
(Определяется при загрузке с помощью lspci, и устанавливается штатно
командой emerge -K <версия драйвера>,из бинарного, скомпилированного пакета (tbz2), присутствующего на livedvd. )

В остальном - LiveDVD идентичен предыдущему.

Скриншоты при запуске под VirtualBox
Спойлер  скрыт:

Скриншоты при загрузке с Livedvd (Система - kernel-3.3.4, fglrx-9.2, Видеокарта x1950):
Спойлер  скрыт:

Скриншоты при загрузке с Livedvd (Система - kernel-3.3.4, fglrx-11.11, Видеокарта HD5670):
Спойлер  скрыт:



Скриншоты при загрузке с Livedvd (Система - kernel-3.3.4, Nvidia-290.10, Видеочип Nvidia 7025):
Спойлер  скрыт:



Gentoo-20111205-kernel-3.3.4-i686.iso  2920 MB

Gentoo-20111205-kernel-3.3.4-i686.iso.part1.rar  1.4GB
Gentoo-20111205-kernel-3.3.4-i686.iso.part2.rar  1.4GB


# MD5 HASH
c8e455b6e398f9e8b9927ea3458edf4a
# SHA1 HASH
a4b3d3190d46d497f676bca0577e695fd054137d
# SHA256 HASH
9ad8a613a1bf6c751b38e560798ac620ce7768a2c9cf3a85a68eada9aeca7ec2

Русская версия:
rutracker.org  -  Gentoo-20111205-kernel-3.3.4-i686.iso  2920 MB

Версия с поддержкой Английского и Русского интерфейса:
linuxtracker.org  -  Gentoo-2011.12-kernel-3.3.4-ATI.Nvidia.Legacy-i686.iso  2942 MB
« Последнее редактирование: Сентябрь 10, 2012, 16:40:17 от sunset » Записан
butjapka
Местный
*****
Offline Offline

Сообщений: 1113


Компьютер думает так, как думает его хозяин.


« Ответ #1 : Февраль 18, 2011, 20:54:26 »

Так держать +1 в репутацию, за старание и реализацию сего продукта, испытывать не имею возможности.
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #2 : Февраль 19, 2011, 18:46:50 »

Цитата: butjapka

Спасибо.

Я прекрасно понимаю владецев карточек от ATI, брошенных производителем.
Сам таковым являюсь. Вот и пришлось заняться конструированием.


Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #3 : Март 01, 2011, 18:12:19 »

Готов ещё один LiveDVD

Установил snapshot - portage-20090929 (29-30 сентября 2009г.), и произвёл обновление системы.
KDE теперь версии 4.3.1, вместо 4.2.4
Полный переход с python 2.5 на python 2.6, и установка python 3.1
добавил winff (фронтенд к ffmpeg), deluge, d4x, qt-recordmydesktop (frontend),krusader...
средство для создания deb пакетов: debootstrap,dpkg
Спойлер  "Полный список:":

Вообщем большая часть системы и програмного обеспечения обновлена.

Всё скринщоты сделаны непосредственно на загруженном LiveDVD, без
установки системы на жёсткий диск.
Спойлер  "Скриншоты:":





Спойлер  "Readme - установка":


Поддерживаемые видеокарты: catalyst_92_linux.pdf

cld-ATI-0.2-i686.iso (1.65 ГБ)
cld-ATI-0.2-i686.iso.DIGESTS
« Последнее редактирование: Март 01, 2011, 21:17:38 от sunset » Записан
l_l_lblTHuK
Постоялец
***
Offline Offline

Сообщений: 145


« Ответ #4 : Март 01, 2011, 22:19:34 »

Предыдущая в виртуалке не запустилась почему-то. Ковырять не стал в итоге...
Надо будет разобраться, если время свободное выдастся...
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #5 : Март 03, 2011, 21:55:09 »

Честно говоря, не думал об таком использовании сборки,
в качестве гостевой ОС, и не предусмотрел этой возможности.

Просто так, её на вируалке не запустишь.
Calculate linux - фактически читый Gentoo,из stage4 (по крайней мере эта версия),
в который добавлен оверлей calculate, сама утитлита calculate, и набор профилей
для этой утитлиты.

Утитита calculate - обладает достаточно большими возможностями, такими как:
установка системы на жёсткий диск одной командой, создание соего собственного
дистрибутива и livedvd,
а также присутстует в автозагрузке системы при первом запуске системы.
(собирает информакию об железе, создаёт список переменных,
подставляет их в профили ,и накладывает профили с учётом этих переменных на систему,
формируя при этом конфиги, в том числе xorg.conf, подставляя туда полученные:
BusID,видеодрайвер, у предустановки для него.
Потом calculate удаляет себя из автозагрузки.

Я переименовал calculate - в calculate-perl (папка /usr/calculate/install),
м сделал скрипт calculate
Код:
#!/bin/bash
exec /usr/calculate/install/calculate-perl --SET-video_drv=fglrx $*

Поэтому утилита calculate всегда считает, что драйвер видео - fglrx
(И как следствие - система не сможет (без небольших изменений)
работать на другом железе, отличном от ATI.)
В виртуальной машине вместо fglrx - должен формироваться xorg.conf,
с драйвером "vboxvideo", а мой скрипт этого не даст сделать.
и xorg-server собран без поддерхки virtualbox.

Ещё до того, как я сделал первую сборку, у меня были ложные срабатывания
и утилита calculate выдывала драйвер radeon вместо fglrx.
Список переменных можно увидеть, дав команду:
# calculate -v

Я нашёл причину ложного срабытавния (radeon), ещё до того как
сделал первую сборку, calculate -v теперь всегда стал выдавать fglrx.
Необходимость в моём скрипте с --SET-video_drv=fglrx отпала, но я оставил его
для подстраховки. В дальнейшем собираюсь его убрать.

Ведь эта сборка имеет смысл только для тех, у кого неподдерживаемая карточка от ATI.
Те, у кого Nvidia или другие встроенные чмпсеты - могут установить
новейшие дистрибутивы. Им не нужна такая сборка.

Ну а внутри самой системы VirtualBox работает:
есть 3D ускорение для opengl, для DirectX пока нет, попрбую разные версии
может появится. Игры на opengl - идут свободно.

Спойлер  скрыт:




P.S.

Если нужно пересоберу систему, с возможностьб запуска под виртуалкой.
А пока только LiveDVD, USB (легко сделать с unetbootin), HDD - сразу с аппаратным укорением fglrx.
Ведь для этого и делалась эта сборка.
« Последнее редактирование: Март 08, 2011, 00:19:06 от sunset » Записан
l_l_lblTHuK
Постоялец
***
Offline Offline

Сообщений: 145


« Ответ #6 : Март 04, 2011, 16:49:54 »

Эх, на гноме бы...
А то с кедами не сложилось как-то.
А вообще за проделанную работу огромное спасибо. Эта сборка будет явно поинтереснее, нежели убунта 8.04. Вот только надо поизучать основы генту, а то не сталкивался никогда...
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #7 : Март 06, 2011, 00:13:43 »

Поставлю Гном Улыбающийся

А вообще для Gentoo - очень хорошая документация в интернете.
Можно найти ответ на любой вопрос.
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #8 : Март 07, 2011, 21:31:33 »

Вот готова сборка с Gnome. ( LiveDVD Размер:  1.76 ГБ  )

На LiveDVD присутствуют как KDE, так и Gnome
Приложения KDE доступны из Gnome, и наоборот.

Добавлен пользователь gnom, с тем же паролем что и имя.
По умолчанию пользователи guest, user заходят под KDE, а
пользователь gnom - под Gnome.
Это легко изменить в том же GDM, при запуске указать что использовать,
и сделать ли Gnome или KDE по умолчанию - для любого пользователя.

Тема одинаковая для Gnome и KDE - qtqurve
При создании нового пользователя нужно добавать 3 файла в домашнюю директорию
.gtkrc-2.0 .gtkrc-2.0-kde4 и .kde4/env/gtk-qt-engine.rc.shх.
(можно взять от любого пользователя - user guest gnom)

Настройки тем для gtk:
$ gtk-chtheme

Раскладка клавиатуры для X:
Left-Win - переключение раскладок (индикатор - диод Scrool Lock)
Caps Lock - большие <-> маленькие буквы
Можно изменить в /etc/hal/fdi/policy

Для консолей раскладка по умолчанию.

Настройка сети с помощью wicd (установлен по умолчанию),
NetworkManager установлен - но не добавлен в автозагрузку.
Или c помощью файла /etc/conf.d/net
скопировать net.example > net
или net.example-big > net
и подставить свои значения.
Спойлер  "Настройка сети":
http://www.gentoo.org/doc/ru/handbook/handbook-x86.xml?part=4

Исходный документ обновлен 19 июля 2010 - Нам подходит Улыбающийся


Спойлер  "Gnome":



Версия KDE - 4.3.1
Версия Gnome - 2.26.3
Для поддержки DirectX в гостевой ос, нужно установить Guest Addittions в
безопасном режиме (F8)
Спойлер  "DirectX":
   


В планах поставить snapshot за декабрь 2009 или январь 2010.
И обновить систему. KDE тогда будет 4.3.5, а Gnome - 2.28.

Текущий образ LiveDVD (с Gnome и KDE).

PACKAGES.LIST
cld-ATI-0.3-i686.iso.DIGESTS
cld-ATI-0.3-i686.iso

Спойлер  "Доументация по Gentoo":
http://www.gentoo.org/doc/ru/handbook/handbook-x86.xml

Исходный документ обновлен 19 июля 2010 - нам подходит Улыбающийся

всё что находится в /usr/portage и /usr/local/portage - можно установить
с помощью команды emerge.

Пример:
# emerge -av ut2003-demo
установит Unreal Tournament 2003 Demo
# emerge -av ut2004
установит Unreal Tournament 2004
(необходимо иметь диски с игрой или смонтированный образ dvd)
и так далее...
« Последнее редактирование: Март 09, 2011, 17:32:48 от sunset » Записан
ludoed
Местный
*****
Offline Offline

Сообщений: 860

ludoed1970@jabber.ru


« Ответ #9 : Март 08, 2011, 10:37:40 »

Интересно... А как Ваша сборка поведет себя на новом компе с картой Nvidia?
Конкретно Core i3 + 4Гб RAM + GT240
Хотелось бы попробовать систему с плавным обновлением
И как в системах на базе генту устанавливать драйвер видяхи - ткните носом в ссылочку?
И еще вопрос - при установке есть возможность отказаться от установки загрузчика?
Предпочитаю потом прописать в уже имеющийся GRUB

Кстати, вот в этой сборке http://forum.runtu.org/index.php/topic,840.msg6034.html#msg6034
очень понравился грамотный подбор приложений - есть все, что нужно, и ничего лишнего
« Последнее редактирование: Март 08, 2011, 11:01:55 от ludoed » Записан

все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях Подмигивающий

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками Улыбающийся
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #10 : Март 08, 2011, 18:36:40 »

Интересно... А как Ваша сборка поведет себя на новом компе с картой Nvidia?
Не заработает - только ATI
Драйвера Nvidia не установлены, скрипт перед вызовом calculate - выставляет fglrx,
(/usr/calculate/install/calculate - скрипт)
xorg-server собран без поддержки nvidia.

Переделать несложно, просто никак не думал, что кто-то с картой Nvidia
захочет попробовать сборку. Ведь тот-же новый calculate linux, гораздо
удобнее использовать - чем эту сборку. Драйвера там сразу встанут (вроде даже на LiveDVD будет
сразу Nvidia driver),  а недостающий софт можно доустановить командой emerge
Также свободно, можно использовать любой другой дистрибутив - Ubuntu, Runtu, и так далее. В них, драйвера  Nvidia, гарантированно заработают.

Спойлер  "Про Calculate Linux":
Дистрибутивы: CLD - содержит KDE, CLDG - Gnome, CLDX - XFCE4

http://www.calculate-linux.ru/main/ru/download

Цитировать
Хотелось бы попробовать систему с плавным обновлением
Это не очень просто - если разница во времени между snapshot-ами (portage)
большая.

Цитировать
И как в системах на базе генту устанавливать драйвер видяхи - ткните носом в ссылочку?
http://www.gentoo.org/doc/ru/nvidia-guide.xml
http://www.gentoo.org/doc/en/nvidia-guide.xml

Если коротко:
Добавить в переменную VIDEO_CARD="nvidia" (/etc/make.conf)
пересобрать xorg-server:

# emerge -av xorg-server

Установить драйвер Nvidia:

# emerge -av nvidia-drivers

Дать команды:

# update-modules
# eselect opengl set nvidia
# etc-update && env-update && source /etc/profile

Всё. Можно перегрузиться

Цитировать
И еще вопрос - при установке есть возможность отказаться от установки загрузчика?
Предпочитаю потом прописать в уже имеющийся GRUB
Да, если указать ключ --set-mbr=off

« Последнее редактирование: Март 11, 2011, 20:28:55 от sunset » Записан
ludoed
Местный
*****
Offline Offline

Сообщений: 860

ludoed1970@jabber.ru


« Ответ #11 : Март 08, 2011, 18:52:46 »

sunset
Спасибо за развернутый ответ, все понял.
Ваша сборка заинтересовала именно наличием KDE и Gnome в одном флаконе, т.к. пользуюсь Гномом, но не могу жить без таких программ KDE, как Krusader и k3b. Сейчас использую Ubuntu Ultimate Edition во многом по этой причине

Документация по Генту понравилась, очень подробно и доходчиво, но чувствую, что пока для меня тяжеловато. Надо сначала еще многое узнать и изучить
Да и с плавным обновлением, видимо, не так просто Грустный
Записан

все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях Подмигивающий

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками Улыбающийся
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #12 : Март 11, 2011, 20:13:36 »

Установил snapshot 20091209 ( декабрь ), обновил всю систему.
Всё прошло удачно, до 2010 - совсем близко Улыбающийся

Установил cairo-dock из оверлея, он отсутствует в стандартном портаже.



В данный момент идёт обновление KDE до версии 4.3.4

===================================

Готово:



PACKAGES.LIST
cld-ATI-0.4-i686.iso.DIGESTS
cld-ATI-0.4-i686.iso  (1.63GB)

Размер LiveDVD был уменьшен, за счёт исключения поддержки ненужных языков.

LiveDVD был испытан на системах:

1) AMDK8-X2 (64-bit), PCI-Express Card - Radeon X1950Pro
2) AthlonXP Barton (32-bit), AGP Card - Radeon 9600Pro
В обоих случаях при загрузке с LiveDVD, сразу было доступо аппаратное ускорение (fglrx).

Поиграл в Quake3-demo немножко Улыбающийся , на обоих машинах.
Quake3-demo - присутствует на LiveDVD.

Система переносится на жесткий диск одной командой (# calculate -d /dev/sdaXXX ).
« Последнее редактирование: Март 12, 2011, 20:18:18 от sunset » Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #13 : Март 20, 2011, 17:30:13 »

Позади остался январь 2010
Спойлер  скрыт:




Январь и декабрь близко, поэтому я не стал выкладывать образ.
Удачно перешёл на snapshot - 18 апреля 2010 года.
Обновил систему.

KDE теперь 4.4.2 , Gnome 2.28.2
Добавил ebuild LibreOffice-bin 3.3.1 (Работоспособность проверена)

Поддержка EAPI-3.
Теперь можно устанавливть самые новейшие ebuild-ы.

Спойлер  "Скриншоты c LiveDVD":








Для работы cairo-dock нужно включить compiz
Спойлер  скрыт:


Образ LiveDVD и Архив Stage4:

PACKAGES.20100418

cld-FGLRX-9.2_p20100418-i686.iso   (1.62 ГБ )
cld-FGLRX-9.2_p20100418-i686.iso.DIGESTS


cld-FGLRX-9.2_p20100418-i686.tar.bz2   (1.72 ГБ)
cld-FGLRX-9.2_p20100418-i686.iso.DIGESTS

Спойлер  "Установка из stage4 (выдержка из wiki)":
Установка из архива stage4

    * Загрузитесь с live CD
    * Установите системное время UTC и/или время в BIOS

# date MMDDHHmmCCYY
# hwclock --systohc

    * Создайте разделы, файловые системы и смонтируйте их
    * Скопируйте архивы stage4 на диск (если вы используете несколько CD загрузите систему набрав "gentoo docache"

при старте LiveCD. Позже вы сможете смонтировать и размонтировать другие CD.)

# cd /mnt/gentoo
# tar -xvjpf stage4.tar.bz2

    * Создайте несколько основных устройств, которые могут потребоваться при загрузке системы

# mknod -m 660 /mnt/gentoo/dev/console c 5 1
# mknod -m 660 /mnt/gentoo/dev/null c 1 3
(опционально) # mknod -m 660 /mnt/gentoo/dev/tty1 c 4 1

    * Примонтируйте /proc и /dev внутри chroot

# mount -t proc none /mnt/gentoo/proc
# mount -o bind /dev /mnt/gentoo/dev


# chroot /mnt/gentoo /bin/bash
# env-update; source /etc/profile

    * Убедитесь что следующие файлы присутствуют в вашей системе

o /boot/grub/grub.conf (или /boot/grub/menu.lst)
o /etc/fstab
o /etc/conf.d/hostname
o /etc/hosts
o /etc/conf.d/net

    * Убедитесь, что установили загрузчик (grub или lilo) в главную загрузочную запись (mbr)
Чтобы Гном был не в обиде, добавил пользователя sun с паролем sun Улыбающийся
Теперь два пользователя по умолчанию под KDE, и два под Gnome.
« Последнее редактирование: Март 29, 2011, 16:47:01 от sunset » Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #14 : Апрель 04, 2011, 19:24:11 »

Систему обновил, сначало до августа, потом до сентября.
Текущий snapshot: 14 сентября 2010.

В связи с обновлением toolchain:
Дважды перекомпилировал gcc, glibc, binutils, потом
полностью перекомпилмровал все пакеты установленные в системе.
Также перекомпилировал ядро, и модули ядра.

Добавил в ebuild xorg-server(a), патч найденный на багзилле, для
совместимости с новым пакетом core-utils.

Добавли в систему XFCE4 и OpenBox c панелью tint2.
Для OpenBox установил fehbg и xcompmgr.
Оформление всех четырёх пользователей настроено, под
всеми DM.

Теперь: KDE-4.4.5, Gnome-2.30.2
KDE обновляется всегда очень просто, ему всё равно какой xorg-server установлен.
А вот для XFCE4 - последняя версия 4.6.3, более высокие версии тянут за собой
xorg 1.6.

Спойлер  "Openbox-3.4.11.2":

Спойлер  "XFCE-4.6.3 + KDE-4.4.5":


К недостаткам можно отнести:

Запуск cairo-dock в режиме no-OpenGL.
В режиме OpenGL вокруг панели cairo-dock присутствует чёрный квадрат - неубираемый включением compisite_manager (Сказывается старость драйвера и xorg'a).
В режиме no-OpenGL, всё работает прекрасно.

Один пакет из Gnome пришлось взять от более ранней версии, и наложить на этот
пакет патчи. (не критично)

Смотреть фильмы с помощью VLC - желательно с выключенным compisite_manager.


Всё оcтальное - достоинства Улыбающийся

Убрал скрипт принудительно выставляющий fglrx, и перекомпилировал xorg-server,c поддержкой
VIDEO_CARDS="fglrx fbdev glint i810 intel mach64 mga neomagic nv nvidia savage sis tdfx trident vesa vga via"
Установил для них драйвера.

Установлен nvidia-drivers-195.36.31, доступны также драйвера 256.xx 260.xx (есть в portage)
Для их установки нужно закоментировать строку в:
/etc/portage/package.mask/default , относящуюся к nvidia-drivers. (#>x11-drivers/nvidia-drivers-200)
Потом дать команды:
# emerge -av nvidia-drivers
# eselect opengl set nvidia
# etc-update
# env-update && source /etc/profile
(драйвер 256.xx тоже компилировался успешно, но я не рискнул ставить его на старый xorg-server)
Для nvidia можно попробовать последовательно все драйвера в /usr/portage/x11-drivers/nvidia-drivers
командой:
# emerge -av =nvidia-drivers-xxx.xx.xx
Где xxx.xx.xx - версия драйвера

Работоспособность проверена только для карт ATI - для остальных не гарантировано
(хотя компиляция всех драйверов прошла успешно)

Система отстаёт от текущего Gentoo чуть более, чем на пол-года,
Что совсем неплохо.
(За исключением xorg-server'a ati-drivers и kernel конечно)

PACKAGES.LIST

cld-FGLRX-9.2-p20100914-i686.iso (1.79 ГБ)
cld-FGLRX-9.2-p20100914-i686.iso.DIGESTS
« Последнее редактирование: Апрель 04, 2011, 20:33:16 от sunset » Записан
Страниц: 1 2 3 4  Все   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!