Форум сообщества Runtu.org
Январь 17, 2018, 02:10:03 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Есть желание поддержать проект?

Сделайте пожертвование удобным Вам способом
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: Runtu-lxde-10.04-i386-final не устанавливаются программы  (Прочитано 1563 раз)
0 Пользователей и 1 Гость смотрят эту тему.
MyNick
Прохожий
*
Offline Offline

Сообщений: 3


« : Июнь 07, 2017, 12:15:13 »

Привет.

При попытке установить Apache2 через менеджер Synaptic получаю следующее сообщение об ошибке:

W: Не удалось получить http://archive.ubuntu.com/ubuntu/pool/main/a/apr/libapr1_1.3.8-1build1_i386.deb 404 Not Found
и далее в том же духе.
Не ставятся также и другие пакеты.

Help.
« Последнее редактирование: Июнь 07, 2017, 21:47:15 от MyNick » Записан
RoDoN
Новичок
**
Offline Offline

Сообщений: 36



WWW
« Ответ #1 : Июнь 07, 2017, 12:52:48 »

Похоже слили 10-ку, здесь http://archive.ubuntu.com/ubuntu/dists/ про lucid тоже ни слова.
Записан


Acer Aspire One AO751h-52Br (Atom Z520 1.33GHz, 2 Gb, Intel GMA500 1366x768)
MyNick
Прохожий
*
Offline Offline

Сообщений: 3


« Ответ #2 : Июнь 07, 2017, 15:12:03 »

А в Runtu 12.04 или Runtu 14.04 таких проблем с установкой нет?
Записан
RoDoN
Новичок
**
Offline Offline

Сообщений: 36



WWW
« Ответ #3 : Июнь 07, 2017, 15:40:25 »

У меня на 3-х машинах 14.04 и проблем ни разу пока не было
Записан


Acer Aspire One AO751h-52Br (Atom Z520 1.33GHz, 2 Gb, Intel GMA500 1366x768)
RoDoN
Новичок
**
Offline Offline

Сообщений: 36



WWW
« Ответ #4 : Июнь 07, 2017, 16:22:35 »

А здесь http://old-releases.ubuntu.com/ubuntu/pool/main/a/apr/ нужный вам файлик есть, т.е. адрес репы нужно менять и можно и дальше пользоваться 10.04
Записан


Acer Aspire One AO751h-52Br (Atom Z520 1.33GHz, 2 Gb, Intel GMA500 1366x768)
MyNick
Прохожий
*
Offline Offline

Сообщений: 3


« Ответ #5 : Июнь 07, 2017, 23:51:57 »

Спасибо большое. Посмотрю.
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2485



« Ответ #6 : Июнь 13, 2017, 12:11:27 »


    MyNick, 10.04 Lucid Lynx является неподдерживаемой версией.

После окончания поддержки дистрибутива он удаляется с серверов, на которых хранятся репозитории Ubuntu. Это приводит к тому, что при попытке обновить список доступных пакетов выдаётся предупреждение о недоступности всех основных репозиториев. Однако все пакеты из репозитория на момент окончания поддержки не удаляются в никуда, а переводятся на другой сервер, поэтому если вам зачем-либо понадобится репозиторий для неподдерживаемой версии Ubuntu, вы сможете его получить. Для этого заменить все ссылки в файле /etc/apt/sources.list, отвечающие за официальные репозитории, на:
Код:
http://old-releases.ubuntu.com/ubuntu
Записан
Пользователь.
Местный
*****
Offline Offline

Сообщений: 3048


« Ответ #7 : Июнь 14, 2017, 11:56:24 »

Мне тоже пришлось подключать старые репозитории, отредактировал, программы устанавливаются.

Но я задумался как правильнее составить полный список репозиториев.

Перешел на old-releases.ubuntu.com, вижу там ветки

lucid - основная ветка
- main
- multiverse
- restricted
- universe

lucid-updates - ветка обновлений
- main
- multiverse
- restricted
- universe

lucid-backports - обновления из новых версий систем
- main
- multiverse
- restricted
- universe

lucid-proposed - эту не знаю
- main
- multiverse
- restricted
- universe

lucid-security - обновления уязвимостей или безопасности, как я понимаю
- main
- multiverse
- restricted
- universe

Каждая ветка еще делится на бинарники (deb) и исходники (src)...

Как я понимаю надо всех их подключать, тот компьютер далеко, неизвестно когда смогу проверить эту информацию...

А также в менеджере репозиториев отключить все сторонние ppa, так как из-за давности они могут быть уже удалены.
« Последнее редактирование: Июнь 14, 2017, 11:59:09 от Пользователь. » Записан
Пользователь.
Местный
*****
Offline Offline

Сообщений: 3048


« Ответ #8 : Июнь 14, 2017, 12:38:55 »

Получается такой список репозиториев (только бинарники, ветки с исходниками не указаны)

Код:
deb http://old-releases.ubuntu.com/ubuntu/ lucid main
deb http://old-releases.ubuntu.com/ubuntu/ lucid restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid multiverse


deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates main
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates multiverse

deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports main
deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports multiverse

deb http://old-releases.ubuntu.com/ubuntu/ lucid-proposed main
deb http://old-releases.ubuntu.com/ubuntu/ lucid-proposed restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid-proposed universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid-proposed multiverse

deb http://old-releases.ubuntu.com/ubuntu/ lucid-security main
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security restricted
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security universe
deb http://old-releases.ubuntu.com/ubuntu/ lucid-security multiverse

Расшифровка названий есть на сайте help.ubuntu.ru
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2485



« Ответ #9 : Июнь 14, 2017, 13:18:25 »


    Ветки "main multiverse restricted universe" можно указывать одной строкой, т.е. например так:

Код:
deb http://old-releases.ubuntu.com/ubuntu/ lucid main multiverse restricted universe
Записан
Пользователь.
Местный
*****
Offline Offline

Сообщений: 3048


« Ответ #10 : Июнь 14, 2017, 13:39:20 »

Тогда получится такой список репозиториев

Код:
deb http://old-releases.ubuntu.com/ubuntu/ lucid main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ lucid-proposed main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse


А для исходников в начале строки нужно заменить deb на deb-src, получится так:

Код:
deb-src http://old-releases.ubuntu.com/ubuntu/ lucid main restricted universe multiverse

deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse

deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-proposed main restricted universe multiverse

deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-security main restricted universe multiverse


« Последнее редактирование: Июнь 14, 2017, 14:09:56 от Пользователь. » Записан
runtik
Местный
*****
Offline Offline

Сообщений: 567


Проблема - когда нет проблем


« Ответ #11 : Июнь 14, 2017, 17:36:27 »

Да-а-а Грустный. Дистрибутивы на основе Lucid Lynx самые лучшие. Это пик ubuntu-строения. Грустно вспоминать.
Записан


Runtu XFCE x64: EeePC 1015BX - 16.04.3; DNS Porto - 14.04.5.
-->
Пользователь.
Местный
*****
Offline Offline

Сообщений: 3048


« Ответ #12 : Июнь 15, 2017, 01:36:43 »

На моем нетбуке Runtu Gnome 10.04 уже шесть лет трудится, седьмой год пошел.

Там Firefox 3 еще можно установить, либо обновить до Firefox 20  Смеющийся
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!