Форум сообщества Runtu.org
Сентябрь 19, 2018, 15:27:45 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для загрузки х64 версия дистрибутива Runtu LITE 18.04.1 - 20180801

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: Runtu XFCE 14.04 - не работает звук через встроенный динамик  (Прочитано 3396 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Stiven
Новичок
**
Offline Offline

Сообщений: 19


« : Август 18, 2016, 23:55:01 »

Здраствуйте.
Установил Runtu XFCE 14.04 на старый комп. 2002 г.в., но не работает звук через встроенный динамик, хотя на Вин ХР работал. Поэтому приходится подключать внешние колонки. Пробовал на всякий случай и в alsamixer поднимать ползунки на макс. уровень, но без результата. В режиме Live CD встроенный динамик также не работает.

Подскажите, кто знает, есть какие-нибудь варианты решения проблемы?

Х-ки компа: настольный Compaq Deskpro EN с одним встроенным динамиком, Р3-800 МГц, 512 Мб, 20 Гб.

Привожу выводы (сокращенные):

Спойлер  скрыт:
lspci
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 01)

inxi -v5
Audio:     Card: Intel 82801BA/BAM AC'97 Audio Controller driver: snd_intel8x0 ports: 2000 2400 bus-ID: 00:1f.5
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic

cat /proc/asound/pcm
00-00: Intel ICH : Intel 82801BA-ICH2 : playback 1 : capture 1
00-01: Intel ICH - MIC ADC : Intel 82801BA-ICH2 - MIC ADC : capture 1

Записан
puh01
Постоялец
***
Offline Offline

Сообщений: 179


« Ответ #1 : Август 19, 2016, 17:45:54 »

Stiven  какой режим работы звуковой карты выбран тут:

Спойлер  скрыт:

 И если можно скрин alsamixer.
Записан

Xubuntu 16.04, Xubuntu 16.10 - обе 64 битные.
Stiven
Новичок
**
Offline Offline

Сообщений: 19


« Ответ #2 : Август 20, 2016, 02:01:59 »

puh01
У меня на выбор есть всего один режим, а именно: "Встроенное аудио", в профиле которого перепробовал все варианты, но без результата.

Скрин добавлю позже.
Записан
puh01
Постоялец
***
Offline Offline

Сообщений: 179


« Ответ #3 : Август 21, 2016, 12:00:33 »

  Pavucontrol - установлен?

Спойлер  скрыт:
Записан

Xubuntu 16.04, Xubuntu 16.10 - обе 64 битные.
Stiven
Новичок
**
Offline Offline

Сообщений: 19


« Ответ #4 : Август 21, 2016, 15:05:00 »

В Runtu XFCE 14.04 pavucontrol установлен по умолчанию. Версия 2.0.2.
В подтверждение в пред. посте я писал, что на вкладке "Конфигурация" в pavucontrol есть пункт "Встроенное аудио".

Прикрепил скрины alsamixer и pavucontrol
Записан
puh01
Постоялец
***
Offline Offline

Сообщений: 179


« Ответ #5 : Август 23, 2016, 17:49:39 »

Stiven на скрине "Alsamixer1" попробуйте включить включить вторую слева колонку "Master M..." - перейти на неё и нажать "М". На скрине на неё наведён курсор.

Спойлер  скрыт:
« Последнее редактирование: Август 23, 2016, 17:55:24 от puh01 » Записан

Xubuntu 16.04, Xubuntu 16.10 - обе 64 битные.
Stiven
Новичок
**
Offline Offline

Сообщений: 19


« Ответ #6 : Август 23, 2016, 23:44:43 »

puh01
Спасибо большое за подсказку. Звук заработал. Вы просто линуксовый гений какой-то. Еще раз спасибо.
Записан
puh01
Постоялец
***
Offline Offline

Сообщений: 179


« Ответ #7 : Август 24, 2016, 18:26:38 »

     Та ну - до гения мне, как до Китая в коленнолоктевой позе туда и обратно... Гугл с яндексом сказали, что вот тут:

 
   На странице №10 описаны режимы работы вашей звуковой карты на чипе AD1885  Подмигивающий
« Последнее редактирование: Август 24, 2016, 18:31:56 от puh01 » Записан

Xubuntu 16.04, Xubuntu 16.10 - обе 64 битные.
Stiven
Новичок
**
Offline Offline

Сообщений: 19


« Ответ #8 : Сентябрь 02, 2016, 23:06:56 »

puh01
Не сразу заметил, но подсказанная Вами настройка не сохраняется в alsamixer. После перезагрузки слетает и приходится снова запускать Терминал - alsamixer, выставлять уровень громкости и нажимать "М". Думал, что сам справлюсь, но ничего не получается.
Записан
Stiven
Новичок
**
Offline Offline

Сообщений: 19


« Ответ #9 : Сентябрь 05, 2016, 12:35:15 »

Решил проблему с alsamixer-ом. Может метод корявый, но работает.

1. Выставляем необходимые настройки в alsamixer (уровень звука и т.д.).
2. Сохраняем настройки в терминале с пом. команды alsactl -f good store  (настройки сохран в файле good в катал. home/имя польз.)
3. Заходим в глав. меню - Сеансы и запуск, выбир. вкладку Автозапуск и нажимаем добавить. Имя, описание - пишем, что угодно а в поле команда вводим alsactl -f good restore.
4. Заходим в каталог home/имя польз., включаем отображение скрытых файлов, переходим в каталог config - autostart и находим файл добавленый нами в пункте 3.
5. Правой КМ выбираем свойства - запуск и ставим отметку в поле Выполнить команду в терминале. Все. Перегружаем комп., настройки alsamixer на месте.
Записан
puh01
Постоялец
***
Offline Offline

Сообщений: 179


« Ответ #10 : Сентябрь 08, 2016, 16:17:22 »

  На 16.10 вроде перестали сбрасываться настройки звука - на выходе после перезагрузки был только один канал звука - второй был в ноль , хотя выставлено "Аналоговый стереодуплекс". Микрофон всегда был в ноль.
Записан

Xubuntu 16.04, Xubuntu 16.10 - обе 64 битные.
Stiven
Новичок
**
Offline Offline

Сообщений: 19


« Ответ #11 : Сентябрь 08, 2016, 23:11:20 »

Возможно в 16.10 по умолчанию установлен пакет udev-alsa, который автоматически сохраняет и восстанавливает настройки alsamixer.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!