Форум сообщества Runtu.org
Август 24, 2019, 23:54:59 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Есть желание поддержать проект?

Сделайте пожертвование удобным Вам способом
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: GoogleEarth - Установка в 16.04  (Прочитано 2149 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ludoed
Местный
*****
Offline Offline

Сообщений: 860

ludoed1970@jabber.ru


« : Июнь 07, 2016, 08:26:41 »

На 32-битной системе на основе 16.04 (Matuntu X32-M114) столкнулся с проблемой установки GoogleEarth. Программа ругается на отсутствие пакета lsb-core, который убрали в 16.04

Нашел следующее решение:

Итак: https://bugs.launchpad.net/ubuntu/+source/googleearth-package/+bug/1562948  инструкция №1 на английском
https://ubuntu-mate.community/t/how-to-install-google-earth-on-ubuntu-16-04/5268 инструкция №2 на английском

Короче, что надо сделать, на русском:
1. Скачать недостающие deb-пакеты из репов 15.10:

Пакеты желательно сохранить в сухом прохладном месте - весят они немного, а на будущее могут пригодиться. Вдруг реп окажется недоступен после окончания поддержки
Дальше ставим их по очереди в терминале, чтобы видеть, что пишет - это важно, в инструкции об этом ничего не сказано:

Код:
sudo dpkg -i lsb-invalid-mta_4.1+Debian11ubuntu8_all.deb

Код:
sudo dpkg -i lsb-security_4.1+Debian11ubuntu8_i386.deb

Код:
sudo dpkg -i lsb-core_4.1+Debian11ubuntu8_i386.deb



Вот тут начинается ругань:

Спойлер  скрыт:
(Чтение базы данных … на данный момент установлено 195097 файлов и каталогов.)
Подготовка к распаковке lsb-core_4.1+Debian11ubuntu8_i386.deb …
Распаковывается lsb-core (4.1+Debian11ubuntu8) …
dpkg: зависимости пакетов не позволяют настроить пакет lsb-core:
 lsb-core зависит от at, однако:
  Пакет at не установлен.
 lsb-core зависит от cups-bsd | lpr, однако:
  Пакет cups-bsd не установлен.
  Пакет lpr не установлен.
 lsb-core зависит от mailx | mailutils, однако:
  Пакет mailx не установлен.
  Пакет mailutils не установлен.
 lsb-core зависит от ncurses-term, однако:
  Пакет ncurses-term не установлен.
 lsb-core зависит от pax, однако:
  Пакет pax не установлен.
 lsb-core зависит от alien (>= 8.36), однако:
  Пакет alien не установлен.

dpkg: ошибка при обработке пакета lsb-core (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db (2.7.5-1) …
При обработке следующих пакетов произошли ошибки:
 lsb-core

Не пугаемся, делаем морду кирпичом:
Код:
sudo apt-get install at lpr mailutils ncurses-term pax alien guide-2.0-libs libmailutils4

Пакета guide-2.0-libs  apt не находит, остальную кучу поставит
Спойлер  скрыт:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет guide-2.0-libs
E: Не удалось найти пакет с помощью glob «guide-2.0-libs»
E: Не удалось найти пакет с помощью regex «guide-2.0-libs»

Тут мне это надоело:
Код:
sudo apt-get -f install
Спойлер  скрыт:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
The following additional packages will be installed:
  alien at cups-bsd debhelper debugedit dh-strip-nondeterminism
  intltool-debian libarchive-zip-perl libfile-stripnondeterminism-perl librpm3
  librpmbuild3 librpmio3 librpmsign3 ncurses-term pax po-debconf rpm
  rpm-common rpm2cpio s-nail
Предлагаемые пакеты:
  lintian dh-make rpm-i18n libmail-box-perl elfutils rpmlint rpm2html
Рекомендуемые пакеты:
  libmail-sendmail-perl
НОВЫЕ пакеты, которые будут установлены:
  alien at cups-bsd debhelper debugedit dh-strip-nondeterminism
  intltool-debian libarchive-zip-perl libfile-stripnondeterminism-perl librpm3
  librpmbuild3 librpmio3 librpmsign3 ncurses-term pax po-debconf rpm
  rpm-common rpm2cpio s-nail
обновлено 0, установлено 20 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 2 395 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 9 411 kB.
Хотите продолжить? [Д/н] Д

Нам важен результат, а если не получится, мы  знаем, что надо будет удалять   Крутой - именно поэтому лучше делать врукопашную через терминал, а не через gdebi / synaptic

Дальше он тянет всю эту кучу, устанавливает,  после чего можно снова пробовать установить lsb-core:
Код:
sudo dpkg -i lsb-core_4.1+Debian11ubuntu8_i386.deb

И наконец:
Код:
sudo dpkg -i google-earth-stable_current_i386.deb

Пробуем запустить, просто, по-деревенски, через меню.
Вуаля. Оно работает. По крайней мере, у меня заработало.

Остался баг, с неотображением фотографий, описанный здесь:
https://bkjaya.wordpress.com/2014/04/27/how-to-solve-blank-panoramio-photo-problem-in-google-earth-on-ubuntu-2/
Спойлер  скрыт:
Maybe others are willing to test on other ubuntu 16.04 flavors what I came up with to make GE run on ubuntu 16.04 64 beta2:

...
Цитировать
sudo apt-get install libfreeimage3 libgstreamer-plugins-base0.10-0
# credit to mr. amirpli from Google Products forum from here on (otherwise GE crashes and/or doesn't display the panoramio pics)
Цитировать
cd /opt/google/earth/free
sudo wget https://googledrive.com/host/0B2F__nkihfiNalQzN0ZmcjBPTGs/ge7.1.1.1580-0.x86_64-new-qt-libs-debian7-ubuntu12.tar.xz
sudo tar xvf ge7.1.1.1580-0.x86_64-new-qt-libs-debian7-ubuntu12.tar.xz
google-earth

Если кто будет пробовать ставить в 64-битной версии - отпишитесь, сработало или нет
Записан

все юниксы очень дружелюбны.. они просто очень разборчивы в друзьях Подмигивающий

Настоящее труЪ: самописное ядро, выращенные на кухне кристаллы и программирование перемычками Улыбающийся
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!