Форум сообщества Runtu.org
Апрель 05, 2020, 12:22:06 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости:
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: У кого в Chromium устанавливаются плагины? (Runtu GNOME 12.04.4)  (Прочитано 3475 раз)
0 Пользователей и 1 Гость смотрят эту тему.
vovchok
Постоялец
***
Offline Offline

Сообщений: 198



« : Февраль 04, 2016, 18:21:51 »

Я не пробовал, но пользователи Ubuntu 12.04 утверждают, что проблем с гугловским браузером у них нет (текущая версия 37 в репозитории), а у меня постоянно при попытке что-то добавить в хромиум выскакивает жёлтая строка под адрессной с душераздирающей надписью:
Could not install package 'utility_process_crashed_while_trying_to_install'. Could not install package because a utility process crashed. Try restarting chrome an try again.

Пытался понизить версию браузера до 34 (якобы в более поздних версиях разработчики что-то испортили в работе дополнений), но не получилось - ругается на отсутствующие и устаревшие библиотеки и не устанавливается ни в какую! (Странно, что для более новой версии старые библиотеки подходят...)
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2808



« Ответ #1 : Февраль 04, 2016, 20:08:36 »


    Это известный баг, который разработчики пометили как WontFix (не требует исправления) и конкретно к Runtu отношения не имеет. Одна из рекомендаций по обходу проблемы - поставить бэкпортированное из новых релизов Ubuntu ядро.
Записан
kompilainenn
Местный
*****
Offline Offline

Сообщений: 1029

Активно пропагандирую Runtu


WWW
« Ответ #2 : Февраль 04, 2016, 21:01:18 »


    Это известный баг, который разработчики пометили как WontFix (не требует исправления) и конкретно к Runtu отношения не имеет. Одна из рекомендаций по обходу проблемы - поставить бэкпортированное из новых релизов Ubuntu ядро.
ядро и установка расширений в браузер как-то связаны? О_о
Записан

Мы говорим Linux, подразумеваем Runtu
vovchok
Постоялец
***
Offline Offline

Сообщений: 198



« Ответ #3 : Февраль 05, 2016, 13:56:51 »

У меня получилось установить версию Chromium 28 (ту, что в установочном образе до обновления инфы о репозиториях). Но при попытке установки дополнений из гугла - последний ругается на прекращение поддержки этой (28й) версии и предлагает обновить её. Есть какая-либо возможность вручную подсунуть дополнение и где его взять - меня конкретно интересует adblock plus (или какой-то аналог), потому что смотреть на сайты кишащие рекламными банерами просто нет сил.
Записан
ek-nfn
Местный
*****
Offline Offline

Сообщений: 1391


« Ответ #4 : Февраль 05, 2016, 14:33:33 »

поставьте SRWare Iron, раз уж новейшие версии хромиума не имеют значения. Iron почти тот же хромиум, точнее - Chrome c вырезанными шпионскими и подглядывающими штучками.
В нем нормально устанавливаются хромовские расширения.
Ну или Vivaldi или Opera, хорошие браузеры на основе хромума и расширения работают. Чем так манит именно хромиум ?
Записан

Devuan ASCII x32..x64
kompilainenn
Местный
*****
Offline Offline

Сообщений: 1029

Активно пропагандирую Runtu


WWW
« Ответ #5 : Февраль 05, 2016, 16:03:35 »

поставьте SRWare Iron, раз уж новейшие версии хромиума не имеют значения. Iron почти тот же хромиум, точнее - Chrome c вырезанными шпионскими и подглядывающими штучками.
В нем нормально устанавливаются хромовские расширения.
Ну или Vivaldi или Opera, хорошие браузеры на основе хромума и расширения работают. Чем так манит именно хромиум ?
Iron сливает инфу непонятно куда.
uBlock Origin прекрасно ставится в хромиум
Записан

Мы говорим Linux, подразумеваем Runtu
ek-nfn
Местный
*****
Offline Offline

Сообщений: 1391


« Ответ #6 : Февраль 05, 2016, 16:22:17 »

Iron сливает инфу непонятно куда.

 Смеющийся Смеющийся А какой браузер или расширение к нему не сливают ? Даже хромиум на этом недавно ловили.

Спойлер  скрыт:
Браузер Chromium, ключевым участником разработки которого является Google, при первом запуске, не уведомляя пользователя, загружает и устанавливает расширение Chrome Hotword Shared Module, которое не отображается в списке установленных плагинов и не дает себя отключить.
Внутри расширения обнаружен модуль (hotword-x86-64.nexe), исходники которого не предоставляются – хотя проект Chromium объявлен как open source. Этот компонент осуществляет постоянный контроль микрофона, ожидая произнесения команды «OK, Google», выяснил один из пользователей ОС Debian (один из самых популярных и важных дистрибутивов GNU/Linux).
Проблеме подвержены пакеты с Chromium 43 во всех дистрибутивах Linux.



Но у нас же есть Chromium! Он Open Source, а значит шпионского кода там быть не должно. Эта догадка подтверждается английской википедией, говорящей что разница между Chrome и Chromium в отсутствии гугль-брендирования, автообновления и, ура, отсутствии отправки «шпионских» данных в Google!

Давайте посмотрим, так ли это на самом деле!

Итак, запускаем сниффер, запускаем браузер, и…. Вы уже догадались, не правда ли? Перво-наперво браузер лезет на Google получить идентификационную куку (заметьте, я не произвожу никаких действий в интерфейсе): и далее в - http://habrahabr.ru/post/101396/
« Последнее редактирование: Февраль 05, 2016, 16:29:11 от ek-nfn » Записан

Devuan ASCII x32..x64
vovchok
Постоялец
***
Offline Offline

Сообщений: 198



« Ответ #7 : Февраль 05, 2016, 19:49:41 »

Chromium  я установил потому, что мне надо было подключиться к chromecast2, а это в linux можно сделать только через дополнение google cast для хрома. Другие браузеры к сожалению с ним не работают...

Но Cromium 28й версии гугл напрочь отказывается снабжать дополнениями, а версия 37, как я уже написал, с дополнениями не дружит - вот я и попросил совета где мне взять adblock и google cast, чтобы не в гуглмаркете. Ну хотя бы только adblock или uBlock, т.к. chromecast я уже отдал, а Chromium остался...
Записан
vovchok
Постоялец
***
Offline Offline

Сообщений: 198



« Ответ #8 : Февраль 05, 2016, 20:36:55 »

поставьте SRWare Iron, раз уж новейшие версии хромиума не имеют значения. Iron почти тот же хромиум, точнее - Chrome c вырезанными шпионскими и подглядывающими штучками.
ниасилил...
Код:
user@comp:~$ /usr/share/iron/iron
/usr/share/iron/iron: error while loading shared libraries: libharfbuzz.so.0: cannot open shared object file: No such file or directory
user@comp:~$ sudo apt-get install libudev1
[sudo] password for user:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет libudev1 недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «libudev1» не найден кандидат на установку
user@comp:~$
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2808



« Ответ #9 : Февраль 06, 2016, 15:05:22 »


    Попробовал установить дополнения в режиме LiveCD - проблем не возникло:

Записан
vovchok
Постоялец
***
Offline Offline

Сообщений: 198



« Ответ #10 : Февраль 08, 2016, 11:16:03 »

В какой версии chromium проблем не возникло 37 или 28?
У меня с 28й версией получилось установить adblock+ по этой инструкции...
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2808



« Ответ #11 : Февраль 08, 2016, 14:14:09 »

В какой версии chromium проблем не возникло 37 или 28?

    Последняя в репозитории, v37.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!