Форум сообщества Runtu.org
Октябрь 16, 2018, 00:03:20 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для загрузки х64 версия дистрибутива Runtu LITE 18.04.1 - 20180801

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: Драйвер d-link dwl-520  (Прочитано 3824 раз)
0 Пользователей и 1 Гость смотрят эту тему.
winterspring
Прохожий
*
Offline Offline

Сообщений: 4


« : Сентябрь 08, 2015, 16:37:43 »

Подключение по wifi очень медленное, как исправить? Погуглив понял, что нужно менять драйвер, но не могу его найти, может кто подскажет где взять, ну или как исправить ситуацию?

Вот вывод lspci -knn | grep "Net\|Eth" -A2
Спойлер  скрыт:
00:19.0 Ethernet controller [0200]: Intel Corporation 82579V Gigabit Network Connection [8086:1503] (rev 05)
   Subsystem: Intel Corporation Device [8086:2002]
   Kernel driver in use: e1000e
--
03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR5212/AR5213 Wireless Network Adapter [168c:0013] (rev 01)
   Subsystem: D-Link System Inc AirPlus DWL-G520 Wireless PCI Adapter (rev. B) [1186:3a13]
   Kernel driver in use: ath5k
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2575



« Ответ #1 : Сентябрь 08, 2015, 17:19:21 »


    winterspring,  укажите версию используемого дистрибутива и текущее ядро.
Записан
winterspring
Прохожий
*
Offline Offline

Сообщений: 4


« Ответ #2 : Сентябрь 08, 2015, 18:52:50 »

Вот так как-то.

uname -a
Linux runtu 3.16.0-48-generic #64~14.04.1-Ubuntu SMP Thu Aug 20 23:03:49 UTC 2015 i686 i686 i686 GNU/Linux

lsb_release -a
No LSB modules are available.
Distributor ID:   Ubuntu
Description:   Ubuntu 14.04.3 LTS
Release:   14.04
Codename:   trusty

iwconfig
wlan0     IEEE 802.11bg  ESSID:"beeline-router"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 14:D6:4D:B4:A7:6E  
          Bit Rate=48 Mb/s   Tx-Power=20 dBm  
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=42/70  Signal level=-68 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:13   Missed beacon:0

Первый вариант из статьи http://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/ не помог,
на второй получил сообщение что модуль iwlwif не найден,
третий не подошел

В networkmanager вручную прописал ip, шлюз dns и уменьшил значение MTU до 1420
соединение заработало, но как-то не стабильно некоторые сайты открываются, некоторые нет
например, runtu.org открылся без проблем а forum.runtu.org по ссылке с главной страницы не хотел открываться
в то же время если ввести адрес вручную, то открывается.
« Последнее редактирование: Сентябрь 09, 2015, 15:33:18 от winterspring » Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2575



« Ответ #3 : Сентябрь 10, 2015, 13:24:57 »

Linux runtu 3.16.0-48-generic #64~14.04.1-Ubuntu SMP Thu Aug 20 23:03:49 UTC 2015 i686 i686 i686 GNU/Linux
    В качестве эксперимента можно попробовать ядро 3.19 (пакет linux-generic-lts-vivid).

на второй получил сообщение что модуль iwlwif не найден
    Похоже на опечатку, вместо iwliwif нужно указать iwlwifi. Попробуйте так:
Код:
sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1
Первая команда выгружает модуль, вторая - загружает его с параметром, отключающим режим 11n.

    Ещё посмотрите решение предложенное здесь. Перед внесением изменений в конфигурационные файлы для теста добавьте в параметры загрузки ядра опции:
Код:
acpi=force irqpoll noapictimer
Если подействует, внести их в указанные конфиги.
Записан
winterspring
Прохожий
*
Offline Offline

Сообщений: 4


« Ответ #4 : Сентябрь 16, 2015, 18:41:14 »

Цитировать
   В качестве эксперимента можно попробовать ядро 3.19 (пакет linux-generic-lts-vivid).
С этим ядром wifi вообще отказался работать

Код:
sudo rmmod iwlwifi
На это получил: rmmod: ERROR: Module iwlwifi is not currently loaded
Код:
acpi=force irqpoll noapictimer
Ничего не изменилось, полергейст какой-то.

Несмотря на то что пинги идут нормально браузер грузит все не ооооочень медленно
PING speedtest.net (216.146.46.10) 56(84) bytes of data.
64 bytes from redirector1.dynect.net (216.146.46.10): icmp_seq=1 ttl=55 time=153 ms
64 bytes from redirector1.dynect.net (216.146.46.10): icmp_seq=2 ttl=55 time=152 ms
64 bytes from redirector1.dynect.net (216.146.46.10): icmp_seq=3 ttl=55 time=152 ms
64 bytes from redirector1.dynect.net (216.146.46.10): icmp_seq=4 ttl=55 time=151 ms
64 bytes from redirector1.dynect.net (216.146.46.10): icmp_seq=5 ttl=55 time=151 ms

Непонятно что еще нужно проверить. Можно было бы грешить на сетевушку, но с другой картой,
Netgear N311T, тоже самое.

« Последнее редактирование: Сентябрь 16, 2015, 18:43:10 от winterspring » Записан
winterspring
Прохожий
*
Offline Offline

Сообщений: 4


« Ответ #5 : Сентябрь 27, 2015, 14:51:25 »

Проблема так и осталась не решенной, пришлось тянуть витую пару  Грустный
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!