Форум сообщества Runtu.org
Апрель 01, 2020, 15:22:34 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости:
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: Как запустить Bluetooth (Блютуз) на Runtu Lite 14.04?  (Прочитано 3628 раз)
0 Пользователей и 1 Гость смотрят эту тему.
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« : Май 18, 2015, 15:13:28 »

Имеется usb-устройство ASUS WL-BTD202
Устройство вставлено в usb-порт компьютера, с установленной Runtu Lite 14.04, обновлённой до актуального состояния.
Установлен blueman:
Код:
sudo apt-get install blueman

1. Непонятно почему, но в меню значок blueman нигде не появился... Как исправить?

Нет значка, не страшно, запускаем из терминала:
Код:
blueman-manager
В LXPanel пояыляется характерная иконка blueman. В контекстном меню иконки - включаем Bluetooth. Светодиод на usb-устройстве горит зелёным цветом. Однако:

2. В окне blueman меню "Адаптер" и "Устройства" - неактивны, т.е. blueman не видит данное usb-устройство. Что нужно ещё предпринять?

Вывод lsusb:
Спойлер  скрыт:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 05e0:1200 Symbol Technologies Bar Code Scanner
Bus 004 Device 003: ID 0b05:1715 ASUSTek Computer, Inc. 2045 Bluetooth 2.0 Device with trace filter
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 10d5:0116 Uni Class Technology Co., Ltd
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

PS. Проверил это usb-устройство на Runtu XFCE 14.04 - результат тот-же - менеджер блютуз не видит устройство. Куда копать?
« Последнее редактирование: Май 18, 2015, 16:30:37 от vladiko » Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
HsH
Administrator
*****
Offline Offline

Сообщений: 2808



« Ответ #1 : Май 18, 2015, 15:49:26 »

Непонятно почему, но в меню значок blueman нигде не появился... Как исправить?
    Нужно добавить Blueman в автозагрузку - команда для запуска
Код:
blueman-applet

В окне blueman меню "Адаптер" и "Устройства" - неактивны, т.е. blueman не видит данное usb-устройство. Что нужно ещё предпринять?
    Не нужно запускать через sudo (это касается и команды в автозапуске).
Записан
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #2 : Май 18, 2015, 16:30:21 »

Не нужно запускать через sudo (это касается и команды в автозапуске).

запускаю НЕ через sudo! (описАлся в предыдущем посте, исправил).
Проблема по-прежнему актуальна: - данное устройство (адаптер блютуз) не обнаруживается в Менеджере Блютуз! Ни в Lite, ни в XFCE
« Последнее редактирование: Май 18, 2015, 17:35:40 от vladiko » Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
kompilainenn
Местный
*****
Offline Offline

Сообщений: 1029

Активно пропагандирую Runtu


WWW
« Ответ #3 : Май 18, 2015, 16:48:59 »

у меня на такие вопросы чаще всего один ответ: обновите ядро до последнего стабильного, ну скажем до 3.19 и попробуйте с ним
Записан

Мы говорим Linux, подразумеваем Runtu
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #4 : Май 18, 2015, 16:51:55 »

вот что выдаёт:

Код:
user@HOST13:~$ blueman-applet
Loading configuration plugins
_________
<module> (/usr/lib/python2.7/dist-packages/blueman/main/Config.py:20)
Skipping plugin Gconf
No module named gconf
/home/user/.gtkrc-2.0:19: Не удалось найти подключаемый файл: «~/.gtkrc-2.0.mine»
blueman-applet version 1.23 starting
There is an instance already running
user@HOST13:~$

И ничего не открывается...

А если так:
Код:
user@HOST13:~$ blueman-manager
Loading configuration plugins
_________
<module> (/usr/lib/python2.7/dist-packages/blueman/main/Config.py:20)
Skipping plugin Gconf
No module named gconf
Using file config backend
/home/user/.gtkrc-2.0:19: Не удалось найти подключаемый файл: «~/.gtkrc-2.0.mine»
_________
Load (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:54)
['PulseAudioProfile', 'Services']
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:127)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/dist-packages/blueman/main/PluginManager.py:127)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
1
blueman-manager version 1.23 starting
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
2
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:112)
org.bluez owner changed to  :1.47
Using file config backend
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:276)
None
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:276)
No such adapter
_________
on_adapter_changed (/usr/lib/python2.7/dist-packages/blueman/gui/manager/ManagerToolbar.py:70)
toolbar adapter None
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
3
_________
pa_context_event (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:306)
4
_________
on_pa_ready (/usr/lib/python2.7/dist-packages/blueman/plugins/manager/PulseAudioProfile.py:27)
connected
_________
<lambda> (/usr/lib/python2.7/dist-packages/blueman/main/PulseAudioUtils.py:318)
1


то открывается окно Менеджера Блютуз, но адаптер блютуз не обнаруживается.

Куда ещё можно копнуть, оставив прежнее ядро?
« Последнее редактирование: Май 18, 2015, 17:35:14 от vladiko » Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #5 : Май 18, 2015, 17:13:18 »

О! После команды
Код:
blueman-applet

в меню "Параметры" появился значок Менеджера Блютуз Улыбающийся

а проблема так и осталась, адаптер блютуз не обнаруживается.
буду пробовать с ядром ковыряться, никогда ядра не менял, видимо пришло время изучить вопрос
« Последнее редактирование: Май 18, 2015, 17:34:44 от vladiko » Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #6 : Май 18, 2015, 17:49:38 »

Что-то после этого поста HsH расхотелось ставить эксперименты с ядрами на рабочей машине...
Но проблему с вышеуказанным блютуз-адаптером я, так понял, иначе никак не решить... Грустный
Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #7 : Май 18, 2015, 17:57:28 »

Вставил данный адаптер в Runtu XFCE 12.04
Адаптер определился!
Получается - на самом деле в Runtu 14.04 нет поддержки этого адаптера. Почему? Разве не наследуются поддержка устройств от релиза к релизу? И будет-ли поддержка данного устройства в следующих обновлениях ядер для 14.04? Может быть данное устройство, как устаревшее, вовсе исключили из поддержки? Тогда и смысла нет ждать обновлённого ядра? Какова политика разработчиков ядер в этом вопросе?
« Последнее редактирование: Май 18, 2015, 23:44:10 от vladiko » Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #8 : Май 18, 2015, 18:27:29 »

Попробовал обновить blueman:

Код:
echo "deb http://ppa.launchpad.net/blueman/ubuntu `lsb_release -cs` main" | sudo tee /etc/apt/sources.list.d/blueman.list
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 6B15AB91951DC1E2 && sudo apt-get update
sudo apt-get install blueman

blueman стал версии 1.99.alpha2 (был 1.23), но ничего не изменилось, адаптер не обнаруживается.
Вернулся на версию 1.23
Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
kompilainenn
Местный
*****
Offline Offline

Сообщений: 1029

Активно пропагандирую Runtu


WWW
« Ответ #9 : Май 18, 2015, 22:13:16 »

Вставил данный адаптер в Runtu XFCE 12.04
Определился!
Получается - на самом деле в Runtu 14.04 нет поддержки этого адаптера. Почему? Разве не наследуются поддержка устройств от релиза к релизу? И будет-ли поддержка данного устройства в следующих обновлениях ядер для 14.04? Может быть данное устройство, как устаревшее, вовсе исключили из поддержки? Тогда и смысла нет ждать обновлённого ядра? Какова политика разработчиков ядер в этом вопросе?
поддержка оборудования обычно крайне редко дропается. а вот почему не работает девайс, который в более ранних версиях ядра работал - это хороший вопрос. Регрессия может быть. А ядро обновлять в убунте совсем не страшно, качаете три пакета , ставите их командой sudo dpkg -i linux* (ессно эту команду пускаете в том каталоге, куда скачали пакеты), перезагружаетесь и проверяете работоспособность вашего железа. Если что-то не так, всегда можно вернуться на предыдущее ядро
Записан

Мы говорим Linux, подразумеваем Runtu
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #10 : Май 18, 2015, 23:40:47 »

1. А после установки нужного ядра необходимо делать
Код:
sudo update-grub
?

2. А как правильно и корректно вернуться на предыдущее (родное и рабочее) ядро? (самому удивительно, но не смог нагуглить понятного описания)

3. И уж до кучи вопрос:
Когда после очередного автоматического обновления версии ядра, я выполняю sudo apt-get autoremove, у меня вроде как-бы пишет, что удаляются старые ядра.
Однако, когда иду в Synaptic, то там вижу, что зеленым покрашены (т.е. получается установлены):
linux-image-3.13.0.46-generic
linux-image-3.13.0.51-generic
linux-image-3.13.0.52-generic
А если выполняю команду dpkg -l | grep linux-image, то ещё интересней:
Код:
user@HOST119:~$ dpkg -l | grep linux-image
rc  linux-image-3.13.0-35-generic        3.13.0-35.62                               i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-3.13.0-45-generic        3.13.0-45.74                               i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-3.13.0-46-generic        3.13.0-46.79                               i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-3.13.0-48-generic        3.13.0-48.80                               i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-3.13.0-49-generic        3.13.0-49.83                               i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-3.13.0-51-generic        3.13.0-51.84                               i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-3.13.0-52-generic        3.13.0-52.86                               i386         Linux kernel image for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-extra-3.13.0-35-generic  3.13.0-35.62                               i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-extra-3.13.0-45-generic  3.13.0-45.74                               i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-extra-3.13.0-46-generic  3.13.0-46.79                               i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-extra-3.13.0-48-generic  3.13.0-48.80                               i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
rc  linux-image-extra-3.13.0-49-generic  3.13.0-49.83                               i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-extra-3.13.0-51-generic  3.13.0-51.84                               i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-extra-3.13.0-52-generic  3.13.0-52.86                               i386         Linux kernel extra modules for version 3.13.0 on 32 bit x86 SMP
ii  linux-image-generic                  3.13.0.52.59                               i386         Generic Linux kernel image
user@HOST119:~$

- Тогда что-же за ядра удаляются при autoremove?
- Правильно-ли удалять старые ядра командой:
Код:
sudo apt-get remove -f linux-image-[номер_версии]-generic
sudo apt-get remove -f linux-headers-[номер_версии]
?
- Как удалить остатки ядер с признаком rc ?
- Существует-ли безопасный способ автоматического удаления старых ядер ii и их остатков rc?
« Последнее редактирование: Май 18, 2015, 23:51:43 от vladiko » Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
HsH
Administrator
*****
Offline Offline

Сообщений: 2808



« Ответ #11 : Май 19, 2015, 09:53:32 »

1. А после установки нужного ядра необходимо делать
Код:
sudo update-grub
?
    Как правило, нет - это выполняется автоматически при обновлении через соответствующие триггеры.

2. А как правильно и корректно вернуться на предыдущее (родное и рабочее) ядро?
    Выбрать его при загрузке системы в меню GRUB.

- Тогда что-же за ядра удаляются при autoremove?
    Версия которых меньше вновь установленных. Иногда требуется несколько запусков команды, результат не всегда приводит к удалению всех устаревших ядер.

- Правильно-ли удалять старые ядра командой:
Код:
sudo apt-get remove -f linux-image-[номер_версии]-generic
sudo apt-get remove -f linux-headers-[номер_версии]
?
    Проще и надёжнее это делать через Synaptic, отметив устаревшие версии для полного удаления.

- Как удалить остатки ядер с признаком rc ?
    Через Synaptic или с помощью команды
Код:
sudo aptitude purge ~c
Она удалит все пакеты со статусом rc (остались файлы конфигурации).

- Существует-ли безопасный способ автоматического удаления старых ядер ii и их остатков rc?
    Самый безопасный способ - удалять вручную, предварительно проверив, к чему приведёт удаление пакета. Это касается всех компонентов, а не только ядра. В автоматическом режиме удалять ничего не рекомендую, особенно через Ubuntu Tweak и другие подобные этой утилиты.
Записан
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #12 : Май 19, 2015, 15:01:31 »

Продолжая тему, проверил этот адаптер ещё на одном компьютере, с 64-разрядной Runtu XFCE
Код:
user@HOST99:~$ uname -a
Linux HOST99 3.16.0-37-generic #51~14.04.1-Ubuntu SMP Wed May 6 15:23:14 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
user@HOST99:~$
Результат тот-же, адаптер не обнаружен
Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
vladiko
Постоялец
***
Offline Offline

Сообщений: 214


А мне летать охота...


« Ответ #13 : Май 19, 2015, 15:48:19 »

Установил самое новое ядро!
Код:
user@HOST99:~$ uname -a
Linux HOST99 3.19.8-031908-generic #201505110938 SMP Mon May 11 13:39:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
user@HOST99:~$

Адаптер так и не определился!

Получается, что он будет работать только на Runtu 12.04, с поддержки в новых ядрах данный девайс снят и с надеждой на его запуск на более продвинутых ядрах придётся распрощаться?
Или можно ещё что-то попробовать?

Подскажите тогда что ещё можно сделать, чтобы запустить адаптер на Runtu 14.04.
Записан

Asus Eee PC 900 (Runtu LITE 12.04.3 - 20131010)
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!