Форум сообщества Runtu.org
Сентябрь 19, 2018, 14:16:34 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для загрузки х64 версия дистрибутива Runtu LITE 18.04.1 - 20180801

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: kernel with PAE - Celeron M: не работает.  (Прочитано 6036 раз)
0 Пользователей и 1 Гость смотрят эту тему.
helboof
Прохожий
*
Offline Offline

Сообщений: 7


« : Апрель 29, 2015, 08:12:15 »

     runtu-lite-12.04.4_201402 -
"This kernel requires the following features not present on the CPU: pae
Unable to boot - please use a kernel appropriate for your CPU."
     runtu-lite-14.04.1_20140914 приблизитильно тоже самое говорит на старенькой машинке - samsung x05 с Целероном М.
Ругается на присутствие пае в ядре и отсутствие поддержки в камне.

   А вот runtu-lite-14.04_20140419 c флешки запускается довольно хорошо, хотя и с вылетом при установке ( Есть подозрение на недостаток озу коей 243МБ в машинке. При подключении свопа - ругается на невозможность его создать или/и отмонтиоровать (если своп даже на флешке ^_^ ) ("Не удалось создать раздел подкачки #2 на устройстве SCSI1 (0,0,0)(sda)" )

Добавлено:
   Странно, но попытка установки "успешного" образа с флешки перенесенного на двд диск привела к той же ошибке: "ERROR: PAE is disebled on this Pentium M..."
 Флешка была создана "multisystem" и имеет полноценный граб2.
Загружается в таком виде:
"
loopback loop /boot/iso/runtu-lite-14.04_20140419.iso
linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/boot/iso/runtu-lite-14.04_20140419.iso noeject nopromt --
initrd (loop)/casper/initrd.lz
« Последнее редактирование: Апрель 29, 2015, 09:33:13 от helboof » Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2573



« Ответ #1 : Апрель 29, 2015, 09:51:05 »


    helboof, процессоры Celeron M и Pentium M не имеют поддержки PAE, поэтому при загрузке отображается это сообщение. В стандартном репозитории Ubuntu все ядра, начиная с версии Linux 3.5, собраны с поддержкой PAE.

Для загрузки ядер с PAE можно попробовать указать параметр ядра forcepae - в меню загрузки нажать F6 -> Esc, стереть quiet splash и дописать forcepae -- forcepae. Строка будет выглядеть так:
Код:
boot=casper initrd=/casper/initrd.lz quiet forcepae -- forcepae
Как вариант - установить ядро 3.2 (имеется в ранних версиях Runtu LITE 12.04).
Записан
helboof
Прохожий
*
Offline Offline

Сообщений: 7


« Ответ #2 : Май 02, 2015, 12:38:35 »

Спасибо, это действительно работает!
Думаю просто добавлять для каждого нового ядра эту строку в конфигурацию grub. Улыбающийся
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2573



« Ответ #3 : Май 02, 2015, 22:14:33 »

добавлять для каждого нового ядра эту строку в конфигурацию grub.

   Можно отредактировать строку в /etc/default/grub, добавив этот параметр, и он будет добавляться к новой записи ядра автоматически:
Код:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
изменить на
Код:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash forcepae"
после чего выполнить
Код:
sudo update-grub

Записан
tolstyh_aleksey
Новичок
**
Offline Offline

Сообщений: 13


« Ответ #4 : Май 30, 2017, 08:49:03 »


    helboof, процессоры Celeron M и Pentium M не имеют поддержки PAE, поэтому при загрузке отображается это сообщение. В стандартном репозитории Ubuntu все ядра, начиная с версии Linux 3.5, собраны с поддержкой PAE.

Для загрузки ядер с PAE можно попробовать указать параметр ядра forcepae - в меню загрузки нажать F6 -> Esc, стереть quiet splash и дописать forcepae -- forcepae. Строка будет выглядеть так:
Код:
boot=casper initrd=/casper/initrd.lz quiet forcepae -- forcepae
Как вариант - установить ядро 3.2 (имеется в ранних версиях Runtu LITE 12.04).

Пробую разные системы, некоторые устанавливаются, если добавить этот параметр, некоторые не позволяют. Но у всех систем обща проблема, браузеры отказываются воспроизводить видео.
И еще, скачал runtu-lite-14.04, но устанавливает почему-то lubuntu 17.04.

///Как вариант - установить ядро 3.2 (имеется в ранних версиях Runtu LITE 12.04).

Можно ссылку? Не могу найти с этим ядром.
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2573



« Ответ #5 : Май 30, 2017, 14:03:09 »

скачал runtu-lite-14.04, но устанавливает почему-то lubuntu 17.04.
Проверяйте ссылки и загрузочный носитель, где-то ошибка.

Можно ссылку? Не могу найти с этим ядром.
Например, эта версия. Рекомендую установить последний доступный дистрибутив на другом ПК (с поддержкой PAE), поставить ядро 3.2 и вернуть HDD на целевой компьютер.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!