Форум сообщества Runtu.org
Январь 17, 2018, 11:48:29 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для тестирования альфа-версия Runtu LITE 18.04 - 20180101

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: дискретная видеокарта и рунту-лайт-14.04.-1.  (Прочитано 3240 раз)
0 Пользователей и 1 Гость смотрят эту тему.
yx
Местный
*****
Offline Offline

Сообщений: 614


« : Март 19, 2015, 21:31:09 »

Спойлер  скрыт:
rl1@rl1-Lenovo-IdeaPad-Z500:~$ primusrun /usr/share/playonlinux/playonlinux --run "WorldOfTanks" %F
Looking for python... 2.7.6 - selected
/home/rl1/.gtkrc-2.0:19: Не удалось найти подключаемый файл: «~/.gtkrc-2.0.mine»
[main] Message: PlayOnLinux (4.2.2) is starting
[clean_tmp] Message: Cleaning temp directory
Script started /home/rl1/.PlayOnLinux/shortcuts/WorldOfTanks
[POL_System_CheckFS] Message: Checking filesystem for WorldOfTanks.exe
[POL_Wine] Message: Running wine-1.7.22 WorldOfTanks.exe %F (Working directory : /home/rl1/.PlayOnLinux/wineprefix/WorldOfTanks/drive_c/Games/World_of_Tanks)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) No devices detected.

[POL_Wine] Error: Похоже, Wine прервала работу.
троекратная переустановка рунту. матунту и драйверов привела меня к такому вот результату - без команд запуска со шмелем и примусом миртанков идет с очень маленьким фпс. Попытки запустить железное ускорение приводят к краху шмеля. И возникает классический русский вопрос: Wot can I do?
« Последнее редактирование: Март 19, 2015, 21:32:50 от yx » Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2485



« Ответ #1 : Март 22, 2015, 14:28:57 »

Попытки запустить железное ускорение приводят к краху шмеля.

    У вас уже работало аппаратное ускорение на этой конфигурации? Насколько я понимаю, проблема связана с тем, что нужно указать корректное значение BusID для ускорителя в файле /etc/X11/xorg.conf. Сам файл должен выглядеть так:
Код:
Section "Device"
    Identifier     "DiscreteNvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce XXXXX"
    BusID          "PCI:Y:Y:Y"
EndSection
   Значения BoardName и BusID можно взять из вывода
Код:
sudo nvidia-xconfig --query-gpu-info
Записан
yx
Местный
*****
Offline Offline

Сообщений: 614


« Ответ #2 : Апрель 11, 2015, 06:39:51 »

прошу пардону за позднее возвращение в тему.
Проблема в том, что нет ведь /etc/X11/xorg.conf, такая вот беда. А куда сховали этот конфиг по всем конфигам искать чисто не представляю как. С БусИД я давненько боролся и всегда помогало, это верное направление, может, создать файл на пустом месте?
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2485



« Ответ #3 : Апрель 11, 2015, 17:12:55 »

нет ведь /etc/X11/xorg.conf

    Создайте файл самостоятельно с указанным выше содержимым.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!