Форум сообщества Runtu.org
Май 29, 2020, 14:25:54 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости:
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: Как установить Mintmenu?  (Прочитано 3962 раз)
0 Пользователей и 1 Гость смотрят эту тему.
SirPortal2002
Прохожий
*
Offline Offline

Сообщений: 2


« : Июль 09, 2014, 08:56:18 »

Я решил поставить на xfce mint menu. А это невозможно:
Код: (bash)
root@screnex2-desktop ~# apt-get install mintmenu
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 mintmenu : Зависит: python-mate-menu но он не может быть установлен
            Зависит: libmatepanelapplet но он не может быть установлен
            Зависит: mate-menus но он не может быть установлен
            Зависит: gir1.2-mate-panel но он не может быть установлен
            Зависит: mozo но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
root@screnex2-desktop ~# apt-get install python-mate-menu
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет python-mate-menu недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «python-mate-menu» не найден кандидат на установку
root@screnex2-desktop ~# apt-get install libmatepanelapplet
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет libmatepanelapplet недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «libmatepanelapplet» не найден кандидат на установку
root@screnex2-desktop ~# apt-get install mate-menus
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет mate-menus недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «mate-menus» не найден кандидат на установку
root@screnex2-desktop ~# apt-get install gir1.2-mate-panel
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет gir1.2-mate-panel недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «gir1.2-mate-panel» не найден кандидат на установку
root@screnex2-desktop ~# apt-get install mozo
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет mozo недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list

E: Для пакета «mozo» не найден кандидат на установку
root@screnex2-desktop ~#
А тут еще xfce4-xfapplet-plugin устанавливаться не хочет...
Подскажите, пожалуйста, что делать!
Репы минта: ppa:noobslab/mint, ppa:eugenious/ppa (второй точно не помню, но вроде так)
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2825



« Ответ #1 : Июль 09, 2014, 09:16:30 »


    Какой дистрибутив используете? Приведите вывод выполнения:
Код:
uname -a
lsb_release -a
sudo dpkg --configure -a
grep -Ev '^#|^$' /etc/apt/sources.list{,.d/*}
Записан
ivm ®
Местный
*****
Offline Offline

Сообщений: 934


ivm@jabber.at


WWW
« Ответ #2 : Июль 09, 2014, 12:00:25 »

SirPortal2002
Посмотрите, какое там меню потому, что из вывода терминала, который приводите, Вы устанавливаете mintmenu для среды Mate на дистрибутив с XFCE, в котором действительно нет компонентов Mate.
Записан

© ivm 1991 - настоящее время. All Rights Reserved.
OS Matuntu-Best/Matuntu-Trusty/Matuntu-TT64-M16
SirPortal2002
Прохожий
*
Offline Offline

Сообщений: 2


« Ответ #3 : Июль 13, 2014, 21:06:27 »


    Какой дистрибутив используете? Приведите вывод выполнения:
Код:
uname -a
lsb_release -a
sudo dpkg --configure -a
grep -Ev '^#|^$' /etc/apt/sources.list{,.d/*}
Код: (bash)
root@screnex2-desktop /h/screnex2-root# uname -a
Linux screnex2-desktop 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686 i686 i686 GNU/Linux
root@screnex2-desktop /h/screnex2-root# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04 LTS
Release:        14.04
Codename:       trusty
root@screnex2-desktop /h/screnex2-root# dpkg --reconfigure -a
dpkg: ошибка: неизвестный параметр --reconfigure

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
root@screnex2-desktop /h/screnex2-root# dpkg-reconfigure -a
acpid stop/waiting
acpid start/running, process 22009
update-alternatives: предупреждение: принудительная переустановка альтернативы/usr/bin/aptitude-curses, так как группа ссылок aptitude сломана
update-alternatives: предупреждение: пропуск создания /usr/share/man/cs/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/cs/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/de/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/de/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/es/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/es/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/fi/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/fi/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/fr/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/fr/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/gl/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/gl/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/it/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/it/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/ja/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/ja/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: предупреждение: пропуск создания /usr/share/man/pl/man8/aptitude.8.gz, так как связанный с ней файл /usr/share/man/pl/man8/aptitude-curses.8.gz (из группы ссылок aptitude) не существует
update-alternatives: используется /usr/share/man/man7/bash-builtins.7.gz для предоставления /usr/share/man/man7/builtins.7.gz (builtins.7.gz) в автоматический режим
binfmt-support stop/waiting
binfmt-support start/running
bluetooth stop/waiting
bluetooth start/running, process 23339
update-initramfs: deferring update (trigger activated)
Removing link /usr/bin/gnome-screensaver
Removing link /usr/bin/gnome-screensaver-command
Linking /usr/bin/gnome-screensaver to /usr/bin/cinnamon-screensaver
Linking /usr/bin/gnome-screensaver-command to /usr/bin/cinnamon-screensaver-command
Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
cron stop/waiting
cron start/running, process 27021
update-initramfs: deferring update (trigger activated)
egrep: /etc/crypttab: Нет такого файла или каталога
Updating PPD files for cups ...
cups-browsed stop/waiting
cups-browsed start/running, process 27385
cups stop/waiting
cups start/running, process 27521
.
update-initramfs: deferring update (trigger activated)
debconf: не удалось инициализировать интерфейс: Kde
debconf: (Unable to load QtCore -- is libqtcore4-perl installed?)
debconf: будет использован интерфейс: Dialog
Please restart all running instances of firefox, or you will experience problems.
Regenerating fonts cache... done.
Generating grub configuration file ...
Найден образ linux: /boot/vmlinuz-3.13.0-24-generic
Найден образ initrd: /boot/initrd.img-3.13.0-24-generic
Found plpbt image: /boot/plpbt.bin
  /dev/sdb: read failed after 0 of 4096 at 0: Ошибка ввода/вывода
  /dev/sdb: read failed after 0 of 4096 at 82348212224: Ошибка ввода/вывода
  /dev/sdb: read failed after 0 of 4096 at 82348269568: Ошибка ввода/вывода
  /dev/sdb: read failed after 0 of 4096 at 4096: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 82346704896: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 82346762240: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 0: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 4096: Ошибка ввода/вывода
  No volume groups found
завершено
update-initramfs: deferring update (trigger activated)
debconf: не удалось инициализировать интерфейс: Kde
debconf: (Unable to load QtCore -- is libqtcore4-perl installed?)
debconf: будет использован интерфейс: Dialog
update-alternatives: предупреждение: принудительная переустановка альтернативы/usr/share/icons/Adwaita/cursor.theme, так как группа ссылок x-cursor-theme сломана
update-alternatives: предупреждение: /usr/share/icons/default/index.theme на ссылку не заменён
Replacing config file /etc/default/grub with new version
Installing for i386-pc platform.
grub-install: предупреждение: Сектор 32 уже используется программой «FlexNet»; пропускаем его. Данное ПО в будущем может создать проблемы с загрузкой. Попросите его авторов не хранить данные на загрузочной дорожке.
Установка завершена. Ошибок нет.
Generating grub configuration file ...
Найден образ linux: /boot/vmlinuz-3.13.0-24-generic
Найден образ initrd: /boot/initrd.img-3.13.0-24-generic
Found plpbt image: /boot/plpbt.bin
  /dev/sdb: read failed after 0 of 4096 at 0: Ошибка ввода/вывода
  /dev/sdb: read failed after 0 of 4096 at 82348212224: Ошибка ввода/вывода
  /dev/sdb: read failed after 0 of 4096 at 82348269568: Ошибка ввода/вывода
  /dev/sdb: read failed after 0 of 4096 at 4096: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 82346704896: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 82346762240: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 0: Ошибка ввода/вывода
  /dev/sdb1: read failed after 0 of 4096 at 4096: Ошибка ввода/вывода
  No volume groups found
завершено
Creating/updating hplip user account...
/usr/sbin/dpkg-reconfigure: Пакет initramfs-tools сломан или установлен не полностью
root@screnex2-desktop /h/screnex2-root# grep -Ev '^#|^$' /etc/apt/sources.list{,.d/*}
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty-updates main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty-updates universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty-updates multiverse
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu trusty partner
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty-security main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty-security universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu/ trusty-security multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu trusty-backports restricted main multiverse universe
/etc/apt/sources.list.d/atareao-sunflower-trusty.list:deb http://ppa.launchpad.net/atareao/sunflower/ubuntu trusty main
/etc/apt/sources.list.d/atareao-sunflower-trusty.list.save:deb http://ppa.launchpad.net/atareao/sunflower/ubuntu trusty main
/etc/apt/sources.list.d/elementary-os-daily-trusty.list:deb http://ppa.launchpad.net/elementary-os/daily/ubuntu trusty main
/etc/apt/sources.list.d/elementary-os-daily-trusty.list.save:deb http://ppa.launchpad.net/elementary-os/daily/ubuntu trusty main
/etc/apt/sources.list.d/eugenesan-ppa-trusty.list:deb http://ppa.launchpad.net/eugenesan/ppa/ubuntu trusty main
/etc/apt/sources.list.d/eugenesan-ppa-trusty.list.save:deb http://ppa.launchpad.net/eugenesan/ppa/ubuntu trusty main
/etc/apt/sources.list.d/fsnow-ppa-trusty.list:deb http://ppa.launchpad.net/fsnow/ppa/ubuntu trusty main
/etc/apt/sources.list.d/fsnow-ppa-trusty.list.save:deb http://ppa.launchpad.net/fsnow/ppa/ubuntu trusty main
/etc/apt/sources.list.d/gwendal-lebihan-dev-cinnamon-nightly-trusty.list:deb http://ppa.launchpad.net/gwendal-lebihan-dev/cinnamon-nightly/ubuntu trusty main
/etc/apt/sources.list.d/gwendal-lebihan-dev-cinnamon-nightly-trusty.list.save:deb http://ppa.launchpad.net/gwendal-lebihan-dev/cinnamon-nightly/ubuntu trusty main
/etc/apt/sources.list.d/maxthon-browser.list:deb http://dl.maxthon.com/linux/deb/ stable maxthon
/etc/apt/sources.list.d/noobslab-apps-trusty.list:deb http://ppa.launchpad.net/noobslab/apps/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-apps-trusty.list.save:deb http://ppa.launchpad.net/noobslab/apps/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-icons-trusty.list:deb http://ppa.launchpad.net/noobslab/icons/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-icons-trusty.list.save:deb http://ppa.launchpad.net/noobslab/icons/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-icons2-trusty.list:deb http://ppa.launchpad.net/noobslab/icons2/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-icons2-trusty.list.save:deb http://ppa.launchpad.net/noobslab/icons2/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-mint-trusty.list:deb http://ppa.launchpad.net/noobslab/mint/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-themes-trusty.list:deb http://ppa.launchpad.net/noobslab/themes/ubuntu trusty main
/etc/apt/sources.list.d/noobslab-themes-trusty.list.save:deb http://ppa.launchpad.net/noobslab/themes/ubuntu trusty main
/etc/apt/sources.list.d/pinta-maintainers-pinta-daily-trusty.list:deb http://ppa.launchpad.net/pinta-maintainers/pinta-daily/ubuntu trusty main
/etc/apt/sources.list.d/pinta-maintainers-pinta-daily-trusty.list.save:deb http://ppa.launchpad.net/pinta-maintainers/pinta-daily/ubuntu trusty main
/etc/apt/sources.list.d/seriy-pr-network-manager-l2tp-trusty.list:deb http://ppa.launchpad.net/seriy-pr/network-manager-l2tp/ubuntu trusty main
/etc/apt/sources.list.d/seriy-pr-network-manager-l2tp-trusty.list.save:deb http://ppa.launchpad.net/seriy-pr/network-manager-l2tp/ubuntu trusty main
/etc/apt/sources.list.d/starws-box-deadbeef-player-trusty.list:deb http://ppa.launchpad.net/starws-box/deadbeef-player/ubuntu trusty main
/etc/apt/sources.list.d/starws-box-deadbeef-player-trusty.list.save:deb http://ppa.launchpad.net/starws-box/deadbeef-player/ubuntu trusty main
/etc/apt/sources.list.d/ubuntuone-nightlies-trusty.list:deb http://ppa.launchpad.net/ubuntuone/nightlies/ubuntu trusty main
/etc/apt/sources.list.d/ubuntuone-nightlies-trusty.list.save:deb http://ppa.launchpad.net/ubuntuone/nightlies/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-java-trusty.list:deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-java-trusty.list.save:deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-nemo-trusty.list:deb http://ppa.launchpad.net/webupd8team/nemo/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-nemo-trusty.list.save:deb http://ppa.launchpad.net/webupd8team/nemo/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-sublime-text-2-trusty.list:deb http://ppa.launchpad.net/webupd8team/sublime-text-2/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-sublime-text-2-trusty.list.save:deb http://ppa.launchpad.net/webupd8team/sublime-text-2/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-sublime-text-3-trusty.list:deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-sublime-text-3-trusty.list.save:deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu trusty main
root@screnex2-desktop /h/screnex2-root#
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2825



« Ответ #4 : Июль 14, 2014, 16:58:18 »


    SirPortal2002, команды с тегом "код" лучше копировать в терминал, а не набирать вручную. Сравните:
sudo dpkg --configure -a
и
root@screnex2-desktop /h/screnex2-root# dpkg --reconfigure -a

root@screnex2-desktop /h/screnex2-root# dpkg-reconfigure -a

    У вас довольно большое количество сторонних репозиториев, которые могли вызвать конфликт пакетной базы из-за разных версий находящихся в них пакетов. По-хорошему, систему лучше переустановить, после чего аккуратно подключать только те, которые требуются для работы и не вызывают проблем в работе системы.
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!