Форум сообщества Runtu.org
Ноябрь 15, 2018, 02:56:15 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для тестирования х64 версия дистрибутива Runtu XFCE 18.04 - 20181018

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1   Вниз
  Печать  
Автор Тема: NetSurf - веб браузер  (Прочитано 5860 раз)
0 Пользователей и 1 Гость смотрят эту тему.
radist_serg
Новичок
**
Offline Offline

Сообщений: 81


« : Декабрь 12, 2013, 12:26:50 »

По просьбе HsH открываю отдельную тему по браузеру NetSurf (www.netsurf-browser.org)

Опыта "эксплуатации" у меря немного. На работе под 10.04 я смог установить только версию 1.2 (от 2008), которая была в репозитории... Всерьез рассматривать это как браузер не приходится, он не умеет почти ничего, не поддерживает JavaScript, неверно отображает многие странички (habrahabr, например), нет табов (новая страница только в новом окне...) Единственное достоинство - очень легкий и быстрый, но толку то...
Дома под 13.04 установил вчера версию 2.9.2 (кажется, точные цифры не помню)
Это уже посерьезнее, появилась поддержка JavaScript, странички, те, которые я проверял, отображаются корректно.
Нет поддержки флеш (или я не нашел, как ее включить, было поздно, поэтому не копался особенно). Мне показалось, что вместе с новыми возможностями уменьшилась скорость работы (что, наверное, естественно, стало загружаться больше рекламных баннеров, правда пока статических)
Последняя версия в т.ч. и для линукса - 3, но .deb пакета нет, надо собирать самостоятельно.
Подозреваю, что когда браузер будет "нафарширован" всеми необходимыми возможностями, он станет"одним из многих" без серьезных преимуществ. Насколько он будет стабилен... кто ж его знает... Опять же будут ли для него расширения, скажем, для резки рекламы...

Коллеги, поделитесь своими впечатлениями и опытом работы с NetSurf, давайте поможем HsH, который
Цитировать
Рассматривал его в качестве "инструмента для загрузки браузера" и запасной вариант легковесного сёрфинга в дистрибутивах типа LITE (пакет netsurf-gtk).
« Последнее редактирование: Февраль 09, 2015, 13:04:58 от Пользователь. » Записан
Пользователь.
Редактор раздела
*****
Offline Offline

Сообщений: 3322


« Ответ #1 : Декабрь 12, 2013, 18:06:34 »

В теме про браузеры уже написал и тут укажу, что NetSurf 2.9 не может корректно показать меню на сайте runtu.org, не может отобразить страницы ютуба и видео на них, не показывает яндекс карты, не показывает всплывающие подсказки на главной странице яндекса, медленно загружает страницы (Firefox это делает быстрее).

И это только то, что первое под руку попалось, если копнуть глубже (поизучать подольше) может еще что-нибудь всплывет.

В настройках не ковырялся, может хоть там найдется интересное...

« Последнее редактирование: Декабрь 12, 2013, 18:30:40 от Пользователь. » Записан
sanb
Новичок
**
Offline Offline

Сообщений: 80


« Ответ #2 : Май 06, 2016, 23:09:25 »

много изменений произошло http://download.netsurf-browser.org/netsurf/releases/ChangeLog.txt
а в репах одно старье
хотел было сам скомпилить но не получилось
на офсайте билды только под amd64(
а мне тут приспичило легковесный 32-битный дистр собрать...
Записан
Пользователь.
Редактор раздела
*****
Offline Offline

Сообщений: 3322


« Ответ #3 : Май 07, 2016, 05:24:59 »

Установил NetSurf 3.2 i386, Java Script так и не работает, поэтому на форуме не работает поиск, объявления, спойлеры, при создании сообщения на форуме видно дополнительные опции - не смогли свернуться, клавиша энтер возле цифрового блока не работает в нем... На сайте runtu.org в нем не работает верхнее меню.

Так что очень сырой.
Записан
sanb
Новичок
**
Offline Offline

Сообщений: 80


« Ответ #4 : Май 07, 2016, 20:28:12 »

)) я ж написал что в репах старьё, почитай чейнжлог
там же еще в настройках JS выключен
« Последнее редактирование: Май 08, 2016, 09:42:56 от sanb » Записан
snowman-fedya
Активист
****
Offline Offline

Сообщений: 313



« Ответ #5 : Май 07, 2016, 22:13:13 »

a возможно ли найти сборку для precise версии побольше, чем 2.8?

попробовал собрать, но там слишком много всего надо дотягивать...
Записан
sanb
Новичок
**
Offline Offline

Сообщений: 80


« Ответ #6 : Май 08, 2016, 09:42:34 »

попробуйте от других, более новых версий взять
Записан
snowman-fedya
Активист
****
Offline Offline

Сообщений: 313



« Ответ #7 : Май 08, 2016, 19:59:15 »

3.2 (vivid): Ошибка: Неразрешимая зависимость: libpango-1.0-0 (>= 1.14.0)

2.9 из trusty устанавливается, но толку 0
Записан
Страниц: 1   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!