Форум сообщества Runtu.org
Октябрь 23, 2018, 10:12:49 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для тестирования х64 версия дистрибутива Runtu XFCE 18.04 - 20181018

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1 2 Все   Вниз
  Печать  
Автор Тема: Не могу установить драйвер nvidia  (Прочитано 8574 раз)
0 Пользователей и 1 Гость смотрят эту тему.
baks
Новичок
**
Offline Offline

Сообщений: 59


« : Апрель 19, 2012, 01:49:27 »

Други! Помогите! Проблема описанная выше повторилась и у меня, разница только в версии ядра и драйвера nvidia. С момента покупки и до последнего обновления с видео проблем не имел.
Другие версии ядра и\или nvidia-current ничего не меняют,
Спойлер  Ошибка установки:
Код:
baks@STAR1K:~$ sudo apt-get install nvidia-180-libvdpau
Чтение списков пакетов... Готово
Построение дерева зависимостей      
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  nvidia-185-libvdpau nvidia-current
Рекомендуемые пакеты:
  nvidia-settings
НОВЫЕ пакеты, которые будут установлены:
  nvidia-180-libvdpau nvidia-185-libvdpau nvidia-current
обновлено 0, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 0B/58,6MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 184MB.
Хотите продолжить [Д/н]? y
Selecting previously unselected package nvidia-current.
(Чтение базы данных ... на данный момент установлено 202712 файлов и каталогов.)
Распаковывается пакет nvidia-current (из файла .../nvidia-current_295.40-0ubuntu1~lucid~xup1_amd64.deb)...
Selecting previously unselected package nvidia-185-libvdpau.
Распаковывается пакет nvidia-185-libvdpau (из файла .../nvidia-185-libvdpau_295.40-0ubuntu1~lucid~xup1_amd64.deb)...
Selecting previously unselected package nvidia-180-libvdpau.
Распаковывается пакет nvidia-180-libvdpau (из файла .../nvidia-180-libvdpau_185.18.36-0ubuntu9_amd64.deb)...
Обрабатываются триггеры для man-db ...
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-alternatives: используется `/usr/lib/nvidia-current/ld.so.conf' для предоставления `/etc/ld.so.conf.d/GL.conf' (gl_conf) в автоматический режим.
update-initramfs: deferring update (trigger activated)
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-40-generic
Building for architecture x86_64
Building initial module for 2.6.32-40-generic

Error! Bad return status for module build on kernel: 2.6.32-40-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
dpkg: зависимости пакетов не позволяют настроить пакет nvidia-185-libvdpau:
 nvidia-185-libvdpau зависит от nvidia-current, однако:
  Пакет nvidia-current пока не настроен.
dpkg: не удалось обработать параметр nvidia-185-libvdpau (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет nvidia-180-libvdpau:
 nvidia-180-libvdpau зависит от nvidia-185-libvdpau, однако:
  Пакет nvidia-185-libvdpau пока не настроен.
dpkg: не удалось обработать параметр nvidia-180-libvdpau (--configure):
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                           Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                                                       проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-40-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
 nvidia-185-libvdpau
 nvidia-180-libvdpau
E: Sub-process /usr/bin/dpkg returned an error code (1)
Спойлер  uname+lspci:
Код:
baks@STAR1K:~$ uname -a
Linux STAR1K 2.6.32-40-generic #87-Ubuntu SMP Tue Mar 6 00:56:56 UTC 2012 x86_64 GNU/Linux
 lspci -v
02:00.0 VGA compatible controller: nVidia Corporation C77 [GeForce 8200] (rev a2)
Subsystem: Giga-byte Technology Device d000
Flags: bus master, fast devsel, latency 0, IRQ 5
Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
Memory at e8000000 (64-bit, prefetchable) [size=128M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at b000 [size=128]
[virtual] Expansion ROM at f2000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Kernel modules: nvidiafb, nouveau
NVIDIA-Linux-x86_64-295.40.run не устанавливается
Спойлер  nvidia-installer.log:
Код:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Apr 19 00:43:26 2012
installer version: 295.40

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin

nvidia-installer command line:
    ./nvidia-installer

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 295.40.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> The CC version check failed:

Could not compile 'gcc-version-check.c'.  Please be  sure you have your Linux distribution's gcc  and libc development packages installed.

If you know what you are doing and want to ignore the gcc version check, select "No" to continue installation.  Otherwise, select "Yes" to abort installation, set the CC environment variable to the name of the compiler used to compile your kernel, and restart installation.  Abort now? (Answer: No)
-> Kernel source path: '/lib/modules/2.6.32-40-generic/build'
-> Kernel output path: '/lib/modules/2.6.32-40-generic/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
« Последнее редактирование: Апрель 19, 2012, 01:54:45 от baks » Записан
butjapka
Местный
*****
Offline Offline

Сообщений: 1091


Компьютер думает так, как думает его хозяин.


« Ответ #1 : Апрель 19, 2012, 06:19:00 »

Други! Помогите! Проблема описанная выше повторилась и у меня, разница только в версии ядра и драйвера nvidia.
Посмотрите совет Как заставить нормально работать карточку  от Nvidia vdpau в этой теме, хотя тема для XFCE но думаю прокатит. У меня по крайней мере после проделанных манипуляций завелась.
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #2 : Апрель 19, 2012, 07:38:53 »


DKMS make.log for nvidia-173-173.14.22 for kernel 2.6.35-22-generic (i686)
Птн Ноя 19 18:57:59 EET 2010
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Ошибка 1

Код:
--- a/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/conftest.sh      2011-07-30 12:24:39.770031044 -0400
+++ b/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/conftest.sh      2011-07-30 12:25:49.059315428 -0400
@@ -77,7 +77,7 @@
 build_cflags() {
     ARCH=`uname -m | sed -e 's/i.86/i386/'`

-    BASE_CFLAGS="-D__KERNEL__ \
+    BASE_CFLAGS="-O2 -D__KERNEL__ \
 -DKBUILD_BASENAME=\"#conftest$$\" -DKBUILD_MODNAME=\"#conftest$$\" \
 -nostdinc -isystem $ISYSTEM"


C 173.14.22 - По аналогии, для соответсвующих строк.

для ядер 3.x - дополнительно:
Код:
--- a/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/conftest.sh      2011-07-30 12:24:39.770031044 -0400
+++ b/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/conftest.sh      2011-07-30 12:25:49.059315428 -0400
@@ -77,7 +77,7 @@
 build_cflags() {
     ARCH=`uname -m | sed -e 's/i.86/i386/'`

-    BASE_CFLAGS="-D__KERNEL__ \
+    BASE_CFLAGS="-O2 -D__KERNEL__ \
 -DKBUILD_BASENAME=\"#conftest$$\" -DKBUILD_MODNAME=\"#conftest$$\" \
 -nostdinc -isystem $ISYSTEM"

--- a/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/nv-linux.h       2011-07-30 12:27:09.341819608 -0400
+++ b/NVIDIA-Linux-x86-96.43.19-pkg0/usr/src/nv/nv-linux.h       2011-07-30 12:27:28.854951411 -0400
@@ -30,7 +30,7 @@
 #  define KERNEL_2_4
 #elif LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
 #  error This driver does not support 2.5 kernels!
-#elif LINUX_VERSION_CODE < KERNEL_VERSION(2, 7, 0)
+#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 3, 0)
 #  define KERNEL_2_6
 #else
 #  error This driver does not support development kernels!
@@ -80,7 +80,9 @@
 #if !defined(KERNEL_2_4)
 #include <linux/sched.h>            /* suser(), capable() replacement   */
 #include <linux/moduleparam.h>      /* module_param()                   */
-#include <linux/smp_lock.h>         /* kernel_locked                    */
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38)
+#include <linux/smp_lock.h>      /* For (un)lock_kernel */
+#endif
 #include <asm/tlbflush.h>           /* flush_tlb(), flush_tlb_all()     */
 #include <asm/kmap_types.h>         /* page table entry lookup          */
 #endif
Записан
Feduka
Активист
****
Offline Offline

Сообщений: 427

Меняю путина на Ходорковского


« Ответ #3 : Апрель 19, 2012, 07:46:17 »

Мне помогла замена версии драйвера. Есть два десктопа, похожих по конфигурации несвежего железа. На обоих AGP-шные нвидии, 7200 с буковками на одном и 6100 (кажется) без буковок на другом. Стоит сборка 10.04  с гномом от HsH, ядро в обоих случаях обновлено до 3.0.0-19. Скрипт с нвидиевского сайта срабатывает в обоих случаях, драйвер (модули) собираются. Но в случае 6100 глючит тупит и тормозит версия 295.40, а работает нормально 295.33. В случае с картой 7200 почему-то строго наоборот Улыбающийся
Записан

2:5020/655.11
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #4 : Апрель 19, 2012, 09:00:26 »

Мне помогла замена версии драйвера. Есть два десктопа, похожих по конфигурации несвежего железа. На обоих AGP-шные нвидии, 7200 с буковками на одном и 6100 (кажется) без буковок на другом. Стоит сборка 10.04  с гномом от HsH, ядро в обоих случаях обновлено до 3.0.0-19. Скрипт с нвидиевского сайта срабатывает в обоих случаях, драйвер (модули) собираются. Но в случае 6100 глючит тупит и тормозит версия 295.40, а работает нормально 295.33. В случае с картой 7200 почему-то строго наоборот Улыбающийся

Тут ситуация другая. Последний драйвер поддерживающий FX 5500 - 173.14.31.
Нужно его патчить, потому что в нём код,  ничего не знающий о новых ядрах, и
будущих изменениях.

Сейчас посмотрел:

Version:173.14.22
Release Date:2009.11.17
Operating System:Linux
Language:English (U.S.)
File Size:19.5 MB

Version:173.14.31 Certified
Release Date:2011.08.17
Operating System:Linux
Language:English (U.S.)
File Size:20.7 MB

В версии 173.14.22:
Код:
   BASE_CFLAGS="-D__KERNEL__ \
А в версии 173.14.31 - уже:
Код:
   BASE_CFLAGS="-O2 -D__KERNEL__ \

Патчить не требуется - рекомендую попробовать его.
« Последнее редактирование: Апрель 19, 2012, 09:30:21 от sunset » Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #5 : Апрель 19, 2012, 15:46:40 »

 butjapka это не тот случай, т.к. именно из этого рра и ставлю.
Я не могу разобраться где именно указать nvidia-current версию ядра, тогда можно скачать пакет, внести правки и установить
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #6 : Апрель 19, 2012, 18:19:44 »

baks
295.40 - патчить не надо, драйвер новый.
Все ли пакеты - для компиляции модуля установлены ?

Could not compile 'gcc-version-check.c'.  Please be  sure you have your Linux distribution's gcc  and libc development packages installed.

Код:
sudo apt-get update
sudo apt-get install debhelper  cdbs fakeroot linux-headers-2.6.32-40-generic build-essential

Симлинк /usr/src/linux - тоже должен быть.
Код:
sudo su
ln -sf /usr/src/linux-headers-2.6.32-40-generic /usr/src/linux

Потом повторить процесс установки драйвера nvidia


Slip
Модифицированный nvidia-173_173.14.22-0ubuntu11.1_i386.deb
Должен нормально скомпилироваться с kernel-2.6.35 (cо всей линейкой 2.6.x и 3.x)

P.S.
Не проверял
« Последнее редактирование: Апрель 19, 2012, 22:54:35 от sunset » Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #7 : Апрель 20, 2012, 09:03:29 »

 Без изменений
Спойлер  скрыт:
Код:
baks@STAR1K:~$ sudo apt-get install debhelper  cdbs fakeroot linux-headers-2.6.32-40-generic build-essential
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Уже установлена самая новая версия fakeroot.
fakeroot установлен вручную.
Уже установлена самая новая версия linux-headers-2.6.32-40-generic.
Уже установлена самая новая версия build-essential.
Будут установлены следующие дополнительные пакеты:
  fdupes html2text intltool-debian po-debconf
Предлагаемые пакеты:
  devscripts dh-make libmail-box-perl
Рекомендуемые пакеты:
  libmail-sendmail-perl
НОВЫЕ пакеты, которые будут установлены:
  cdbs debhelper fdupes html2text intltool-debian po-debconf
обновлено 0, установлено 6 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.
не установлено до конца или удалено 3 пакетов.
Необходимо скачать 1 986kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 4 166kB.
Хотите продолжить [Д/н]? y
Получено:1 http://ftp.byfly.by/ubuntu/ lucid/main html2text 1.3.2a-14build1 [104kB]
Получено:2 http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu/ lucid/main debhelper 8.9.0ubuntu1~ppa1~lucid1 [571kB]
Получено:3 http://ftp.byfly.by/ubuntu/ lucid/main intltool-debian 0.35.0+20060710.1 [31,6kB]
Получено:4 http://ftp.byfly.by/ubuntu/ lucid/main po-debconf 1.0.16 [224kB]
Получено:5 http://ftp.byfly.by/ubuntu/ lucid/main fdupes 1.50-PR2-2build1 [20,3kB]
Получено:6 http://ftp.byfly.by/ubuntu/ lucid/main cdbs 0.4.62+nmu1ubuntu9 [1 035kB]
Получено 1 986kБ за 4с (477kБ/c)                               
Selecting previously unselected package html2text.
(Чтение базы данных ... на данный момент установлено 202927 файлов и каталогов.)
Распаковывается пакет html2text (из файла .../html2text_1.3.2a-14build1_amd64.deb)...
Selecting previously unselected package intltool-debian.
Распаковывается пакет intltool-debian (из файла .../intltool-debian_0.35.0+20060710.1_all.deb)...
Selecting previously unselected package po-debconf.
Распаковывается пакет po-debconf (из файла .../po-debconf_1.0.16_all.deb)...
Selecting previously unselected package debhelper.
Распаковывается пакет debhelper (из файла .../debhelper_8.9.0ubuntu1~ppa1~lucid1_all.deb)...
Selecting previously unselected package fdupes.
Распаковывается пакет fdupes (из файла .../fdupes_1.50-PR2-2build1_amd64.deb)...
Selecting previously unselected package cdbs.
Распаковывается пакет cdbs (из файла .../cdbs_0.4.62+nmu1ubuntu9_all.deb)...
Обрабатываются триггеры для man-db ...
Обрабатываются триггеры для doc-base ...
Processing 2 added doc-base file(s)...
Registering documents with scrollkeeper...
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Removing old nvidia-current-295.40 DKMS files...

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-40-generic
Building for architecture x86_64
Building initial module for 2.6.32-40-generic

Error! Bad return status for module build on kernel: 2.6.32-40-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
dpkg: зависимости пакетов не позволяют настроить пакет nvidia-185-libvdpau:
 nvidia-185-libvdpau зависит от nvidia-current, однако:
  Пакет nvidia-current пока не настроен.
dpkg: не удалось обработать параметр nvidia-185-libvdpau (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет nvidia-180-libvdpau:
 nvidia-180-libvdpau зависит от nvidia-185-libvdpau, однако:
  Пакет nvidia-185-libvdpau пока не настроен.
dpkg: не удалось обработать параметр nvidia-180-libvdpau (--configure):
 проблемы зависимостей -- оставляем не настроенным
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                            Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                                                        Настраивается пакет html2text (1.3.2a-14build1) ...
Настраивается пакет intltool-debian (0.35.0+20060710.1) ...
Настраивается пакет po-debconf (1.0.16) ...
Настраивается пакет debhelper (8.9.0ubuntu1~ppa1~lucid1) ...
Настраивается пакет fdupes (1.50-PR2-2build1) ...
Настраивается пакет cdbs (0.4.62+nmu1ubuntu9) ...
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-40-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
 nvidia-185-libvdpau
 nvidia-180-libvdpau
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ lucid/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_lucid_partner_binary-amd64_Packages)
W: Вы можете запустить 'apt-get update' для исправления этих ошибок
E: Sub-process /usr/bin/dpkg returned an error code (1)
Но и без доустановленных пакетов проблем раньше не было
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #8 : Апрель 20, 2012, 11:00:31 »

baks

Забыл дописать:

Код:
su
cd /usr/src/linux
make oldconfig
make prepare (не помню, нужно-ли в ubuntu - под gentoo делаю)

Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #9 : Апрель 20, 2012, 15:29:37 »

sunset даже oldconfig вываливается с ошибкой:
Спойлер  скрыт:
Код:
root@STAR1K:/usr/src/linux# make oldconfig
  HOSTCC  scripts/basic/fixdep
In file included from scripts/basic/fixdep.c:106:
/usr/include/sys/types.h:147:20: error: stddef.h: Нет такого файла или каталога
In file included from scripts/basic/fixdep.c:108:
/usr/include/sys/mman.h:58: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:77: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:82: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:90: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:95: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:99: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:104: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:107: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:124: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from scripts/basic/fixdep.c:109:
/usr/include/unistd.h:357: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:363: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:507: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from scripts/basic/fixdep.c:109:
/usr/include/unistd.h:618: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘confstr’
/usr/include/unistd.h:790: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:826: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:837: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:873: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from scripts/basic/fixdep.c:109:
/usr/include/unistd.h:895: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:902: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:913: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:915: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:933: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:934: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/unistd.h:1150,
                 from scripts/basic/fixdep.c:109:
/usr/include/bits/unistd.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:25: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:35: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘read’:
/usr/include/bits/unistd.h:37: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:37: error: (Each undeclared identifier is reported only once
/usr/include/bits/unistd.h:37: error: for each function it appears in.)
/usr/include/bits/unistd.h:39: error: ‘__nbytes’ undeclared (first use in this function)
/usr/include/bits/unistd.h:40: error: too many arguments to function ‘__read_chk’
/usr/include/bits/unistd.h:43: error: too many arguments to function ‘__read_chk_warn’
/usr/include/bits/unistd.h:45: error: too many arguments to function ‘__read_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:125: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:126: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:128: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:132: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:132: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:140: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘readlink’:
/usr/include/bits/unistd.h:143: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:145: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/unistd.h:146: error: too many arguments to function ‘__readlink_chk’
/usr/include/bits/unistd.h:149: error: too many arguments to function ‘__readlink_chk_warn’
/usr/include/bits/unistd.h:151: error: too many arguments to function ‘__readlink_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:157: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:158: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:160: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:165: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:165: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:174: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘readlinkat’:
/usr/include/bits/unistd.h:177: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:179: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/unistd.h:180: error: too many arguments to function ‘__readlinkat_chk’
/usr/include/bits/unistd.h:184: error: too many arguments to function ‘__readlinkat_chk_warn’
/usr/include/bits/unistd.h:186: error: too many arguments to function ‘__readlinkat_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:190: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:190: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:192: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:194: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:194: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:201: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getcwd’:
/usr/include/bits/unistd.h:203: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:205: error: ‘__size’ undeclared (first use in this function)
/usr/include/bits/unistd.h:206: error: too many arguments to function ‘__getcwd_chk’
/usr/include/bits/unistd.h:209: error: too many arguments to function ‘__getcwd_chk_warn’
/usr/include/bits/unistd.h:211: error: too many arguments to function ‘__getcwd_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:215: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getwd’:
/usr/include/bits/unistd.h:224: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:225: error: too many arguments to function ‘__getwd_chk’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:230: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__confstr_chk’
/usr/include/bits/unistd.h:232: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__confstr_alias’
/usr/include/bits/unistd.h:234: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__confstr_chk_warn’
/usr/include/bits/unistd.h:241: error: expected ‘,’ or ‘;’ before ‘confstr’
/usr/include/bits/unistd.h:255: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:259: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getgroups’:
/usr/include/bits/unistd.h:271: error: too many arguments to function ‘__getgroups_chk’
/usr/include/bits/unistd.h:274: error: too many arguments to function ‘__getgroups_chk_warn’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:280: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:281: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:282: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:285: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:285: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:292: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘ttyname_r’:
/usr/include/bits/unistd.h:296: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:297: error: too many arguments to function ‘__ttyname_r_chk’
/usr/include/bits/unistd.h:300: error: too many arguments to function ‘__ttyname_r_chk_warn’
/usr/include/bits/unistd.h:302: error: too many arguments to function ‘__ttyname_r_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:307: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:307: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:309: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:311: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:311: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:318: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getlogin_r’:
/usr/include/bits/unistd.h:322: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:323: error: too many arguments to function ‘__getlogin_r_chk’
/usr/include/bits/unistd.h:326: error: too many arguments to function ‘__getlogin_r_chk_warn’
/usr/include/bits/unistd.h:328: error: too many arguments to function ‘__getlogin_r_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:334: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:334: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:336: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:338: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:338: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:345: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘gethostname’:
/usr/include/bits/unistd.h:349: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:350: error: too many arguments to function ‘__gethostname_chk’
/usr/include/bits/unistd.h:353: error: too many arguments to function ‘__gethostname_chk_warn’
/usr/include/bits/unistd.h:355: error: too many arguments to function ‘__gethostname_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:361: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:361: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:363: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:366: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:366: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:374: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getdomainname’:
/usr/include/bits/unistd.h:378: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:379: error: too many arguments to function ‘__getdomainname_chk’
/usr/include/bits/unistd.h:382: error: too many arguments to function ‘__getdomainname_chk_warn’
/usr/include/bits/unistd.h:384: error: too many arguments to function ‘__getdomainname_alias’
In file included from scripts/basic/fixdep.c:111:
/usr/include/string.h: At top level:
/usr/include/string.h:44: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:48: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:57: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:64: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:67: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:94: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:131: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:139: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:145: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:152: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strxfrm’
In file included from scripts/basic/fixdep.c:111:
/usr/include/string.h:167: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strxfrm_l’
/usr/include/string.h:181: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:282: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strcspn’
/usr/include/string.h:286: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strspn’
/usr/include/string.h:397: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strlen’
/usr/include/string.h:404: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strnlen’
/usr/include/string.h:425: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:449: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:453: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:457: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:460: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:538: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:575: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:578: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/string.h:635,
                 from scripts/basic/fixdep.c:111:
/usr/include/bits/string2.h:969: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c1’
/usr/include/bits/string2.h:971: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c1’
/usr/include/bits/string2.h:979: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c2’
/usr/include/bits/string2.h:982: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c2’
/usr/include/bits/string2.h:991: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c3’
/usr/include/bits/string2.h:994: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c3’
/usr/include/bits/string2.h:1045: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c1’
/usr/include/bits/string2.h:1047: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c1’
/usr/include/bits/string2.h:1056: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c2’
/usr/include/bits/string2.h:1059: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c2’
/usr/include/bits/string2.h:1068: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c3’
/usr/include/bits/string2.h:1071: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c3’
/usr/include/bits/string2.h: In function ‘__strpbrk_c2’:
/usr/include/bits/string2.h:1129: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h:1129: error: expected ‘;’ before ‘__s’
/usr/include/bits/string2.h: In function ‘__strpbrk_c3’:
/usr/include/bits/string2.h:1142: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h:1142: error: expected ‘;’ before ‘__s’
/usr/include/bits/string2.h: In function ‘__strtok_r_1c’:
/usr/include/bits/string2.h:1177: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h: In function ‘__strsep_1c’:
/usr/include/bits/string2.h:1227: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h: In function ‘__strsep_2c’:
/usr/include/bits/string2.h:1237: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h: In function ‘__strsep_3c’:
/usr/include/bits/string2.h:1265: error: ‘NULL’ undeclared (first use in this function)
In file included from /usr/include/bits/string2.h:1298,
                 from /usr/include/string.h:635,
                 from scripts/basic/fixdep.c:111:
/usr/include/stdlib.h: At top level:
/usr/include/stdlib.h:471: error: expected ‘)’ before ‘__size’
/usr/include/stdlib.h:473: error: expected ‘)’ before ‘__nmemb’
In file included from /usr/include/string.h:635,
                 from scripts/basic/fixdep.c:111:
/usr/include/bits/string2.h:1322: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/string.h:640,
                 from scripts/basic/fixdep.c:111:
/usr/include/bits/string3.h:49: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘memcpy’:
/usr/include/bits/string3.h:52: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘memmove’:
/usr/include/bits/string3.h:59: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:78: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘memset’:
/usr/include/bits/string3.h:80: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:91: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘bcopy’:
/usr/include/bits/string3.h:94: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:98: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘bzero’:
/usr/include/bits/string3.h:100: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:120: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘strncpy’:
/usr/include/bits/string3.h:123: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:127: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h:128: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h:129: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h:134: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘stpncpy’:
/usr/include/bits/string3.h:137: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/string3.h:138: error: too many arguments to function ‘__stpncpy_chk’
/usr/include/bits/string3.h:139: error: too many arguments to function ‘__stpncpy_alias’
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:151: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘strncat’:
/usr/include/bits/string3.h:154: error: ‘__len’ undeclared (first use in this function)
In file included from scripts/basic/fixdep.c:112:
/usr/include/stdlib.h: At top level:
/usr/include/stdlib.h:140: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__ctype_get_mb_cur_max’
/usr/include/stdlib.h: In function ‘atof’:
/usr/include/stdlib.h:281: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: In function ‘atoi’:
/usr/include/stdlib.h:286: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: In function ‘atol’:
/usr/include/stdlib.h:291: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: In function ‘atoll’:
/usr/include/stdlib.h:300: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: At top level:
/usr/include/stdlib.h:337: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:367: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:369: error: nonnull argument with out-of-range operand number (argument 1, operand 4)
/usr/include/stdlib.h:485: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/stdlib.h:497,
                 from scripts/basic/fixdep.c:112:
/usr/include/alloca.h:33: error: expected ‘)’ before ‘__size’
In file included from scripts/basic/fixdep.c:112:
/usr/include/stdlib.h:502: error: expected ‘)’ before ‘__size’
/usr/include/stdlib.h:507: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:507: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:751: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:751: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:752: error: nonnull argument with out-of-range operand number (argument 1, operand 5)
/usr/include/stdlib.h:756: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:756: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:757: error: nonnull argument with out-of-range operand number (argument 1, operand 4)
/usr/include/stdlib.h:834: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:837: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:841: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:845: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:854: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:857: error: expected ‘)’ before ‘*’ token
/usr/include/stdlib.h:861: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/stdlib.h:865: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘mbstowcs’
/usr/include/stdlib.h:868: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘wcstombs’
In file included from /usr/include/stdlib.h:949,
                 from scripts/basic/fixdep.c:112:
/usr/include/bits/stdlib.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:30: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h: In function ‘realpath’:
/usr/include/bits/stdlib.h:46: error: too many arguments to function ‘__realpath_chk’
/usr/include/bits/stdlib.h: At top level:
/usr/include/bits/stdlib.h:53: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:54: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:55: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:58: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:58: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:65: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h: In function ‘ptsname_r’:
/usr/include/bits/stdlib.h:69: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/stdlib.h:70: error: too many arguments to function ‘__ptsname_r_chk’
/usr/include/bits/stdlib.h:72: error: too many arguments to function ‘__ptsname_r_chk_warn’
/usr/include/bits/stdlib.h:74: error: too many arguments to function ‘__ptsname_r_alias’
/usr/include/bits/stdlib.h: At top level:
/usr/include/bits/stdlib.h:78: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/bits/stdlib.h:78: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:80: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/bits/stdlib.h:84: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/bits/stdlib.h: In function ‘wctomb’:
/usr/include/bits/stdlib.h:94: error: ‘__wchar’ undeclared (first use in this function)
/usr/include/bits/stdlib.h:94: error: too many arguments to function ‘__wctomb_chk’
/usr/include/bits/stdlib.h:95: error: too many arguments to function ‘__wctomb_alias’
/usr/include/bits/stdlib.h: At top level:
/usr/include/bits/stdlib.h:99: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__mbstowcs_chk’
/usr/include/bits/stdlib.h:102: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__mbstowcs_alias’
/usr/include/bits/stdlib.h:106: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__mbstowcs_chk_warn’
/usr/include/bits/stdlib.h:114: error: expected ‘,’ or ‘;’ before ‘mbstowcs’
/usr/include/bits/stdlib.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__wcstombs_chk’
/usr/include/bits/stdlib.h:134: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__wcstombs_alias’
/usr/include/bits/stdlib.h:138: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__wcstombs_chk_warn’
/usr/include/bits/stdlib.h:145: error: expected ‘,’ or ‘;’ before ‘wcstombs’
In file included from /usr/include/stdio.h:75,
                 from scripts/basic/fixdep.c:113:
/usr/include/libio.h:53:21: error: stdarg.h: Нет такого файла или каталога
In file included from /usr/include/stdio.h:75,
                 from scripts/basic/fixdep.c:113:
/usr/include/libio.h:332: error: expected specifier-qualifier-list before ‘size_t’
/usr/include/libio.h:364: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/libio.h:373: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/libio.h:491: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/libio.h:493: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/libio.h:495: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘_IO_sgetn’
In file included from scripts/basic/fixdep.c:113:
/usr/include/stdio.h:296: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:302: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:314: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:321: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:349: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:354: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:357: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:363: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:365: error: format string argument not a string type
/usr/include/stdio.h:367: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:368: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:369: error: format string argument not a string type
/usr/include/stdio.h:395: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:454: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:461: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:466: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:476: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:481: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:484: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:639: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:642: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:652: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:682: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread’
/usr/include/stdio.h:688: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fwrite’
/usr/include/stdio.h:710: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread_unlocked’
/usr/include/stdio.h:712: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fwrite_unlocked’
In file included from /usr/include/stdio.h:910,
                 from scripts/basic/fixdep.c:113:
/usr/include/bits/stdio2.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:28: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:44: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vsprintf’:
/usr/include/bits/stdio2.h:48: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:53: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:54: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:57: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:58: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:62: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h: In function ‘snprintf’:
/usr/include/bits/stdio2.h:65: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:75: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:75: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vsnprintf’:
/usr/include/bits/stdio2.h:78: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/stdio2.h:79: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:90: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:92: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:115: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vprintf’:
/usr/include/bits/stdio2.h:118: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h:118: error: too many arguments to function ‘__vfprintf_chk’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:126: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vfprintf’:
/usr/include/bits/stdio2.h:128: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h:128: error: too many arguments to function ‘__vfprintf_chk’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:220: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h: In function ‘gets’:
/usr/include/bits/stdio2.h:229: error: too many arguments to function ‘__gets_chk’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:233: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:238: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h: In function ‘fgets’:
/usr/include/bits/stdio2.h:250: error: too many arguments to function ‘__fgets_chk’
/usr/include/bits/stdio2.h:252: error: expected ‘)’ before ‘__n’
/usr/include/bits/stdio2.h:253: error: too many arguments to function ‘__fgets_chk_warn’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:258: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_chk’
/usr/include/bits/stdio2.h:261: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_alias’
/usr/include/bits/stdio2.h:265: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_chk_warn’
/usr/include/bits/stdio2.h:274: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread’
/usr/include/bits/stdio2.h:319: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_unlocked_chk’
/usr/include/bits/stdio2.h:322: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_unlocked_alias’
/usr/include/bits/stdio2.h:326: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_unlocked_chk_warn’
/usr/include/bits/stdio2.h:335: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread_unlocked’
In file included from scripts/basic/fixdep.c:114:
/usr/include/limits.h:125:26: error: no include path in which to search for limits.h
In file included from /usr/include/sys/uio.h:29,
                 from /usr/include/sys/socket.h:28,
                 from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/bits/uio.h:47: error: expected specifier-qualifier-list before ‘size_t’
In file included from /usr/include/sys/socket.h:40,
                 from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/bits/socket.h:251: error: expected specifier-qualifier-list before ‘size_t’
/usr/include/bits/socket.h:265: error: expected specifier-qualifier-list before ‘size_t’
/usr/include/bits/socket.h: In function ‘__cmsg_nxthdr’:
/usr/include/bits/socket.h:302: error: expected ‘)’ before ‘__cmsg’
/usr/include/bits/socket.h:307: error: ‘struct cmsghdr’ has no member named ‘cmsg_len’
/usr/include/bits/socket.h:307: error: expected ‘)’ before ‘~’ token
/usr/include/bits/socket.h:308: error: ‘struct msghdr’ has no member named ‘msg_control’
/usr/include/bits/socket.h:309: error: ‘struct msghdr’ has no member named ‘msg_controllen’
/usr/include/bits/socket.h:310: error: ‘struct cmsghdr’ has no member named ‘cmsg_len’
/usr/include/bits/socket.h:310: error: expected ‘)’ before ‘~’ token
/usr/include/bits/socket.h:311: error: ‘struct msghdr’ has no member named ‘msg_control’
/usr/include/bits/socket.h:311: error: ‘struct msghdr’ has no member named ‘msg_controllen’
In file included from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/sys/socket.h: At top level:
/usr/include/sys/socket.h:141: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/socket.h:148: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/socket.h:155: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/socket.h:166: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/sys/socket.h:251,
                 from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/bits/socket2.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:35: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h: In function ‘recv’:
/usr/include/bits/socket2.h:39: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/socket2.h:40: error: too many arguments to function ‘__recv_chk’
/usr/include/bits/socket2.h:43: error: too many arguments to function ‘__recv_chk_warn’
/usr/include/bits/socket2.h:45: error: too many arguments to function ‘__recv_alias’
/usr/include/bits/socket2.h: At top level:
/usr/include/bits/socket2.h:48: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:49: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:52: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:65: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h: In function ‘recvfrom’:
/usr/include/bits/socket2.h:70: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/socket2.h:72: error: too many arguments to function ‘__recvfrom_chk’
/usr/include/bits/socket2.h:75: error: too many arguments to function ‘__recvfrom_chk_warn’
/usr/include/bits/socket2.h:77: error: too many arguments to function ‘__recvfrom_alias’
In file included from scripts/basic/fixdep.c:116:
/usr/include/arpa/inet.h: At top level:
/usr/include/arpa/inet.h:78: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/arpa/inet.h:84: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/arpa/inet.h:90: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘grow_config’:
scripts/basic/fixdep.c:154: error: too many arguments to function ‘realloc’
scripts/basic/fixdep.c: In function ‘is_defined_config’:
scripts/basic/fixdep.c:172: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c: In function ‘define_config’:
scripts/basic/fixdep.c:185: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c: In function ‘use_config’:
scripts/basic/fixdep.c:212: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c: At top level:
scripts/basic/fixdep.c:223: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘parse_config_file’:
scripts/basic/fixdep.c:225: error: ‘len’ undeclared (first use in this function)
scripts/basic/fixdep.c:239: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c:248: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c: In function ‘strrcmp’:
scripts/basic/fixdep.c:259: warning: implicit declaration of function ‘strlen’
scripts/basic/fixdep.c:259: warning: incompatible implicit declaration of built-in function ‘strlen’
scripts/basic/fixdep.c:265: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c: In function ‘do_config_file’:
scripts/basic/fixdep.c:285: error: too many arguments to function ‘mmap’
scripts/basic/fixdep.c:292: error: too many arguments to function ‘parse_config_file’
scripts/basic/fixdep.c:294: error: too many arguments to function ‘munmap’
scripts/basic/fixdep.c: At top level:
scripts/basic/fixdep.c:299: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘parse_dep_file’:
scripts/basic/fixdep.c:302: error: ‘len’ undeclared (first use in this function)
scripts/basic/fixdep.c:311: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c:326: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c: In function ‘print_deps’:
scripts/basic/fixdep.c:357: error: too many arguments to function ‘mmap’
scripts/basic/fixdep.c:364: error: too many arguments to function ‘parse_dep_file’
scripts/basic/fixdep.c:366: error: too many arguments to function ‘munmap’
make[1]: *** [scripts/basic/fixdep] Ошибка 1
make: *** [scripts_basic] Ошибка 2
Не очень давно, сразу после выхода deadbeef 0.5.2, пытался собрать его и не вышло. Но драйвер видео с тех пор обновлялся и работал.

  P.S. Очень не хочется идти widows way
« Последнее редактирование: Апрель 20, 2012, 18:13:14 от baks » Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #10 : Апрель 20, 2012, 22:11:35 »


sunset даже oldconfig вываливается с ошибкой:
Спойлер  скрыт:
Код:
root@STAR1K:/usr/src/linux# make oldconfig
  HOSTCC  scripts/basic/fixdep
In file included from scripts/basic/fixdep.c:106:
/usr/include/sys/types.h:147:20: error: stddef.h: Нет такого файла или каталога
In file included from scripts/basic/fixdep.c:108:
/usr/include/sys/mman.h:58: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:77: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:82: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:90: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:95: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:99: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:104: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:107: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/mman.h:124: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from scripts/basic/fixdep.c:109:
/usr/include/unistd.h:357: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:363: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:507: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from scripts/basic/fixdep.c:109:
/usr/include/unistd.h:618: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘confstr’
/usr/include/unistd.h:790: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:826: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:837: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:873: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from scripts/basic/fixdep.c:109:
/usr/include/unistd.h:895: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:902: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:913: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:915: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:933: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/unistd.h:934: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/unistd.h:1150,
                 from scripts/basic/fixdep.c:109:
/usr/include/bits/unistd.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:25: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:35: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘read’:
/usr/include/bits/unistd.h:37: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:37: error: (Each undeclared identifier is reported only once
/usr/include/bits/unistd.h:37: error: for each function it appears in.)
/usr/include/bits/unistd.h:39: error: ‘__nbytes’ undeclared (first use in this function)
/usr/include/bits/unistd.h:40: error: too many arguments to function ‘__read_chk’
/usr/include/bits/unistd.h:43: error: too many arguments to function ‘__read_chk_warn’
/usr/include/bits/unistd.h:45: error: too many arguments to function ‘__read_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:125: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:126: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:128: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:132: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:132: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:140: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘readlink’:
/usr/include/bits/unistd.h:143: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:145: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/unistd.h:146: error: too many arguments to function ‘__readlink_chk’
/usr/include/bits/unistd.h:149: error: too many arguments to function ‘__readlink_chk_warn’
/usr/include/bits/unistd.h:151: error: too many arguments to function ‘__readlink_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:157: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:158: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:160: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:165: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:165: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:174: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘readlinkat’:
/usr/include/bits/unistd.h:177: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:179: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/unistd.h:180: error: too many arguments to function ‘__readlinkat_chk’
/usr/include/bits/unistd.h:184: error: too many arguments to function ‘__readlinkat_chk_warn’
/usr/include/bits/unistd.h:186: error: too many arguments to function ‘__readlinkat_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:190: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:190: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:192: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:194: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:194: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:201: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getcwd’:
/usr/include/bits/unistd.h:203: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:205: error: ‘__size’ undeclared (first use in this function)
/usr/include/bits/unistd.h:206: error: too many arguments to function ‘__getcwd_chk’
/usr/include/bits/unistd.h:209: error: too many arguments to function ‘__getcwd_chk_warn’
/usr/include/bits/unistd.h:211: error: too many arguments to function ‘__getcwd_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:215: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getwd’:
/usr/include/bits/unistd.h:224: error: ‘size_t’ undeclared (first use in this function)
/usr/include/bits/unistd.h:225: error: too many arguments to function ‘__getwd_chk’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:230: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__confstr_chk’
/usr/include/bits/unistd.h:232: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__confstr_alias’
/usr/include/bits/unistd.h:234: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__confstr_chk_warn’
/usr/include/bits/unistd.h:241: error: expected ‘,’ or ‘;’ before ‘confstr’
/usr/include/bits/unistd.h:255: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:259: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getgroups’:
/usr/include/bits/unistd.h:271: error: too many arguments to function ‘__getgroups_chk’
/usr/include/bits/unistd.h:274: error: too many arguments to function ‘__getgroups_chk_warn’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:280: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:281: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:282: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:285: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:285: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:292: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘ttyname_r’:
/usr/include/bits/unistd.h:296: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:297: error: too many arguments to function ‘__ttyname_r_chk’
/usr/include/bits/unistd.h:300: error: too many arguments to function ‘__ttyname_r_chk_warn’
/usr/include/bits/unistd.h:302: error: too many arguments to function ‘__ttyname_r_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:307: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:307: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:309: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:311: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:311: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:318: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getlogin_r’:
/usr/include/bits/unistd.h:322: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:323: error: too many arguments to function ‘__getlogin_r_chk’
/usr/include/bits/unistd.h:326: error: too many arguments to function ‘__getlogin_r_chk_warn’
/usr/include/bits/unistd.h:328: error: too many arguments to function ‘__getlogin_r_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:334: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:334: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:336: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:338: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:338: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:345: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘gethostname’:
/usr/include/bits/unistd.h:349: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:350: error: too many arguments to function ‘__gethostname_chk’
/usr/include/bits/unistd.h:353: error: too many arguments to function ‘__gethostname_chk_warn’
/usr/include/bits/unistd.h:355: error: too many arguments to function ‘__gethostname_alias’
/usr/include/bits/unistd.h: At top level:
/usr/include/bits/unistd.h:361: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:361: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:363: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:366: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:366: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h:374: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/unistd.h: In function ‘getdomainname’:
/usr/include/bits/unistd.h:378: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/unistd.h:379: error: too many arguments to function ‘__getdomainname_chk’
/usr/include/bits/unistd.h:382: error: too many arguments to function ‘__getdomainname_chk_warn’
/usr/include/bits/unistd.h:384: error: too many arguments to function ‘__getdomainname_alias’
In file included from scripts/basic/fixdep.c:111:
/usr/include/string.h: At top level:
/usr/include/string.h:44: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:48: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:57: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:64: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:67: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:94: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:131: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:139: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:145: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:152: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strxfrm’
In file included from scripts/basic/fixdep.c:111:
/usr/include/string.h:167: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strxfrm_l’
/usr/include/string.h:181: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:282: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strcspn’
/usr/include/string.h:286: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strspn’
/usr/include/string.h:397: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strlen’
/usr/include/string.h:404: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘strnlen’
/usr/include/string.h:425: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:449: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:453: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:457: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:460: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:538: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:575: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/string.h:578: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/string.h:635,
                 from scripts/basic/fixdep.c:111:
/usr/include/bits/string2.h:969: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c1’
/usr/include/bits/string2.h:971: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c1’
/usr/include/bits/string2.h:979: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c2’
/usr/include/bits/string2.h:982: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c2’
/usr/include/bits/string2.h:991: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c3’
/usr/include/bits/string2.h:994: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strcspn_c3’
/usr/include/bits/string2.h:1045: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c1’
/usr/include/bits/string2.h:1047: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c1’
/usr/include/bits/string2.h:1056: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c2’
/usr/include/bits/string2.h:1059: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c2’
/usr/include/bits/string2.h:1068: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c3’
/usr/include/bits/string2.h:1071: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__strspn_c3’
/usr/include/bits/string2.h: In function ‘__strpbrk_c2’:
/usr/include/bits/string2.h:1129: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h:1129: error: expected ‘;’ before ‘__s’
/usr/include/bits/string2.h: In function ‘__strpbrk_c3’:
/usr/include/bits/string2.h:1142: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h:1142: error: expected ‘;’ before ‘__s’
/usr/include/bits/string2.h: In function ‘__strtok_r_1c’:
/usr/include/bits/string2.h:1177: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h: In function ‘__strsep_1c’:
/usr/include/bits/string2.h:1227: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h: In function ‘__strsep_2c’:
/usr/include/bits/string2.h:1237: error: ‘NULL’ undeclared (first use in this function)
/usr/include/bits/string2.h: In function ‘__strsep_3c’:
/usr/include/bits/string2.h:1265: error: ‘NULL’ undeclared (first use in this function)
In file included from /usr/include/bits/string2.h:1298,
                 from /usr/include/string.h:635,
                 from scripts/basic/fixdep.c:111:
/usr/include/stdlib.h: At top level:
/usr/include/stdlib.h:471: error: expected ‘)’ before ‘__size’
/usr/include/stdlib.h:473: error: expected ‘)’ before ‘__nmemb’
In file included from /usr/include/string.h:635,
                 from scripts/basic/fixdep.c:111:
/usr/include/bits/string2.h:1322: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/string.h:640,
                 from scripts/basic/fixdep.c:111:
/usr/include/bits/string3.h:49: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘memcpy’:
/usr/include/bits/string3.h:52: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘memmove’:
/usr/include/bits/string3.h:59: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:78: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘memset’:
/usr/include/bits/string3.h:80: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:91: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘bcopy’:
/usr/include/bits/string3.h:94: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:98: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘bzero’:
/usr/include/bits/string3.h:100: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:120: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘strncpy’:
/usr/include/bits/string3.h:123: error: ‘__len’ undeclared (first use in this function)
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:127: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h:128: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h:129: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h:134: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘stpncpy’:
/usr/include/bits/string3.h:137: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/string3.h:138: error: too many arguments to function ‘__stpncpy_chk’
/usr/include/bits/string3.h:139: error: too many arguments to function ‘__stpncpy_alias’
/usr/include/bits/string3.h: At top level:
/usr/include/bits/string3.h:151: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/string3.h: In function ‘strncat’:
/usr/include/bits/string3.h:154: error: ‘__len’ undeclared (first use in this function)
In file included from scripts/basic/fixdep.c:112:
/usr/include/stdlib.h: At top level:
/usr/include/stdlib.h:140: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__ctype_get_mb_cur_max’
/usr/include/stdlib.h: In function ‘atof’:
/usr/include/stdlib.h:281: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: In function ‘atoi’:
/usr/include/stdlib.h:286: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: In function ‘atol’:
/usr/include/stdlib.h:291: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: In function ‘atoll’:
/usr/include/stdlib.h:300: error: ‘NULL’ undeclared (first use in this function)
/usr/include/stdlib.h: At top level:
/usr/include/stdlib.h:337: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:367: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:369: error: nonnull argument with out-of-range operand number (argument 1, operand 4)
/usr/include/stdlib.h:485: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/stdlib.h:497,
                 from scripts/basic/fixdep.c:112:
/usr/include/alloca.h:33: error: expected ‘)’ before ‘__size’
In file included from scripts/basic/fixdep.c:112:
/usr/include/stdlib.h:502: error: expected ‘)’ before ‘__size’
/usr/include/stdlib.h:507: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:507: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:751: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:751: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:752: error: nonnull argument with out-of-range operand number (argument 1, operand 5)
/usr/include/stdlib.h:756: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:756: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:757: error: nonnull argument with out-of-range operand number (argument 1, operand 4)
/usr/include/stdlib.h:834: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:837: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:841: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:845: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:854: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdlib.h:857: error: expected ‘)’ before ‘*’ token
/usr/include/stdlib.h:861: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/stdlib.h:865: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘mbstowcs’
/usr/include/stdlib.h:868: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘wcstombs’
In file included from /usr/include/stdlib.h:949,
                 from scripts/basic/fixdep.c:112:
/usr/include/bits/stdlib.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:30: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h: In function ‘realpath’:
/usr/include/bits/stdlib.h:46: error: too many arguments to function ‘__realpath_chk’
/usr/include/bits/stdlib.h: At top level:
/usr/include/bits/stdlib.h:53: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:54: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:55: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:58: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:58: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:65: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h: In function ‘ptsname_r’:
/usr/include/bits/stdlib.h:69: error: ‘__buflen’ undeclared (first use in this function)
/usr/include/bits/stdlib.h:70: error: too many arguments to function ‘__ptsname_r_chk’
/usr/include/bits/stdlib.h:72: error: too many arguments to function ‘__ptsname_r_chk_warn’
/usr/include/bits/stdlib.h:74: error: too many arguments to function ‘__ptsname_r_alias’
/usr/include/bits/stdlib.h: At top level:
/usr/include/bits/stdlib.h:78: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/bits/stdlib.h:78: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdlib.h:80: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/bits/stdlib.h:84: error: expected declaration specifiers or ‘...’ before ‘wchar_t’
/usr/include/bits/stdlib.h: In function ‘wctomb’:
/usr/include/bits/stdlib.h:94: error: ‘__wchar’ undeclared (first use in this function)
/usr/include/bits/stdlib.h:94: error: too many arguments to function ‘__wctomb_chk’
/usr/include/bits/stdlib.h:95: error: too many arguments to function ‘__wctomb_alias’
/usr/include/bits/stdlib.h: At top level:
/usr/include/bits/stdlib.h:99: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__mbstowcs_chk’
/usr/include/bits/stdlib.h:102: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__mbstowcs_alias’
/usr/include/bits/stdlib.h:106: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__mbstowcs_chk_warn’
/usr/include/bits/stdlib.h:114: error: expected ‘,’ or ‘;’ before ‘mbstowcs’
/usr/include/bits/stdlib.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__wcstombs_chk’
/usr/include/bits/stdlib.h:134: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__wcstombs_alias’
/usr/include/bits/stdlib.h:138: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__wcstombs_chk_warn’
/usr/include/bits/stdlib.h:145: error: expected ‘,’ or ‘;’ before ‘wcstombs’
In file included from /usr/include/stdio.h:75,
                 from scripts/basic/fixdep.c:113:
/usr/include/libio.h:53:21: error: stdarg.h: Нет такого файла или каталога
In file included from /usr/include/stdio.h:75,
                 from scripts/basic/fixdep.c:113:
/usr/include/libio.h:332: error: expected specifier-qualifier-list before ‘size_t’
/usr/include/libio.h:364: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/libio.h:373: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/libio.h:491: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/libio.h:493: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/libio.h:495: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘_IO_sgetn’
In file included from scripts/basic/fixdep.c:113:
/usr/include/stdio.h:296: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:302: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:314: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:321: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:349: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:354: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:357: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:363: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:365: error: format string argument not a string type
/usr/include/stdio.h:367: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:368: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:369: error: format string argument not a string type
/usr/include/stdio.h:395: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:454: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:461: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:466: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:476: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:481: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:484: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/stdio.h:639: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:642: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:652: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/stdio.h:682: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread’
/usr/include/stdio.h:688: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fwrite’
/usr/include/stdio.h:710: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread_unlocked’
/usr/include/stdio.h:712: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fwrite_unlocked’
In file included from /usr/include/stdio.h:910,
                 from scripts/basic/fixdep.c:113:
/usr/include/bits/stdio2.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:28: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:44: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vsprintf’:
/usr/include/bits/stdio2.h:48: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:53: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:54: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:57: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:58: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:62: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h: In function ‘snprintf’:
/usr/include/bits/stdio2.h:65: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:75: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:75: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vsnprintf’:
/usr/include/bits/stdio2.h:78: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/stdio2.h:79: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:90: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:92: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h:115: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vprintf’:
/usr/include/bits/stdio2.h:118: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h:118: error: too many arguments to function ‘__vfprintf_chk’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:126: error: expected declaration specifiers or ‘...’ before ‘__gnuc_va_list’
/usr/include/bits/stdio2.h: In function ‘vfprintf’:
/usr/include/bits/stdio2.h:128: error: ‘__ap’ undeclared (first use in this function)
/usr/include/bits/stdio2.h:128: error: too many arguments to function ‘__vfprintf_chk’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:220: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h: In function ‘gets’:
/usr/include/bits/stdio2.h:229: error: too many arguments to function ‘__gets_chk’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:233: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h:238: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/stdio2.h: In function ‘fgets’:
/usr/include/bits/stdio2.h:250: error: too many arguments to function ‘__fgets_chk’
/usr/include/bits/stdio2.h:252: error: expected ‘)’ before ‘__n’
/usr/include/bits/stdio2.h:253: error: too many arguments to function ‘__fgets_chk_warn’
/usr/include/bits/stdio2.h: At top level:
/usr/include/bits/stdio2.h:258: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_chk’
/usr/include/bits/stdio2.h:261: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_alias’
/usr/include/bits/stdio2.h:265: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_chk_warn’
/usr/include/bits/stdio2.h:274: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread’
/usr/include/bits/stdio2.h:319: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_unlocked_chk’
/usr/include/bits/stdio2.h:322: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_unlocked_alias’
/usr/include/bits/stdio2.h:326: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__fread_unlocked_chk_warn’
/usr/include/bits/stdio2.h:335: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘fread_unlocked’
In file included from scripts/basic/fixdep.c:114:
/usr/include/limits.h:125:26: error: no include path in which to search for limits.h
In file included from /usr/include/sys/uio.h:29,
                 from /usr/include/sys/socket.h:28,
                 from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/bits/uio.h:47: error: expected specifier-qualifier-list before ‘size_t’
In file included from /usr/include/sys/socket.h:40,
                 from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/bits/socket.h:251: error: expected specifier-qualifier-list before ‘size_t’
/usr/include/bits/socket.h:265: error: expected specifier-qualifier-list before ‘size_t’
/usr/include/bits/socket.h: In function ‘__cmsg_nxthdr’:
/usr/include/bits/socket.h:302: error: expected ‘)’ before ‘__cmsg’
/usr/include/bits/socket.h:307: error: ‘struct cmsghdr’ has no member named ‘cmsg_len’
/usr/include/bits/socket.h:307: error: expected ‘)’ before ‘~’ token
/usr/include/bits/socket.h:308: error: ‘struct msghdr’ has no member named ‘msg_control’
/usr/include/bits/socket.h:309: error: ‘struct msghdr’ has no member named ‘msg_controllen’
/usr/include/bits/socket.h:310: error: ‘struct cmsghdr’ has no member named ‘cmsg_len’
/usr/include/bits/socket.h:310: error: expected ‘)’ before ‘~’ token
/usr/include/bits/socket.h:311: error: ‘struct msghdr’ has no member named ‘msg_control’
/usr/include/bits/socket.h:311: error: ‘struct msghdr’ has no member named ‘msg_controllen’
In file included from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/sys/socket.h: At top level:
/usr/include/sys/socket.h:141: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/socket.h:148: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/socket.h:155: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/sys/socket.h:166: error: expected declaration specifiers or ‘...’ before ‘size_t’
In file included from /usr/include/sys/socket.h:251,
                 from /usr/include/netinet/in.h:25,
                 from /usr/include/arpa/inet.h:23,
                 from scripts/basic/fixdep.c:116:
/usr/include/bits/socket2.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:24: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:26: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:28: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:35: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h: In function ‘recv’:
/usr/include/bits/socket2.h:39: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/socket2.h:40: error: too many arguments to function ‘__recv_chk’
/usr/include/bits/socket2.h:43: error: too many arguments to function ‘__recv_chk_warn’
/usr/include/bits/socket2.h:45: error: too many arguments to function ‘__recv_alias’
/usr/include/bits/socket2.h: At top level:
/usr/include/bits/socket2.h:48: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:49: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:52: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:56: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h:65: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/bits/socket2.h: In function ‘recvfrom’:
/usr/include/bits/socket2.h:70: error: ‘__n’ undeclared (first use in this function)
/usr/include/bits/socket2.h:72: error: too many arguments to function ‘__recvfrom_chk’
/usr/include/bits/socket2.h:75: error: too many arguments to function ‘__recvfrom_chk_warn’
/usr/include/bits/socket2.h:77: error: too many arguments to function ‘__recvfrom_alias’
In file included from scripts/basic/fixdep.c:116:
/usr/include/arpa/inet.h: At top level:
/usr/include/arpa/inet.h:78: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/arpa/inet.h:84: error: expected declaration specifiers or ‘...’ before ‘size_t’
/usr/include/arpa/inet.h:90: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘grow_config’:
scripts/basic/fixdep.c:154: error: too many arguments to function ‘realloc’
scripts/basic/fixdep.c: In function ‘is_defined_config’:
scripts/basic/fixdep.c:172: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c: In function ‘define_config’:
scripts/basic/fixdep.c:185: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c: In function ‘use_config’:
scripts/basic/fixdep.c:212: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c: At top level:
scripts/basic/fixdep.c:223: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘parse_config_file’:
scripts/basic/fixdep.c:225: error: ‘len’ undeclared (first use in this function)
scripts/basic/fixdep.c:239: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c:248: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c: In function ‘strrcmp’:
scripts/basic/fixdep.c:259: warning: implicit declaration of function ‘strlen’
scripts/basic/fixdep.c:259: warning: incompatible implicit declaration of built-in function ‘strlen’
scripts/basic/fixdep.c:265: error: too many arguments to function ‘memcmp’
scripts/basic/fixdep.c: In function ‘do_config_file’:
scripts/basic/fixdep.c:285: error: too many arguments to function ‘mmap’
scripts/basic/fixdep.c:292: error: too many arguments to function ‘parse_config_file’
scripts/basic/fixdep.c:294: error: too many arguments to function ‘munmap’
scripts/basic/fixdep.c: At top level:
scripts/basic/fixdep.c:299: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘parse_dep_file’:
scripts/basic/fixdep.c:302: error: ‘len’ undeclared (first use in this function)
scripts/basic/fixdep.c:311: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c:326: error: too many arguments to function ‘memcpy’
scripts/basic/fixdep.c: In function ‘print_deps’:
scripts/basic/fixdep.c:357: error: too many arguments to function ‘mmap’
scripts/basic/fixdep.c:364: error: too many arguments to function ‘parse_dep_file’
scripts/basic/fixdep.c:366: error: too many arguments to function ‘munmap’
make[1]: *** [scripts/basic/fixdep] Ошибка 1
make: *** [scripts_basic] Ошибка 2
Не очень давно, сразу после выхода deadbeef 0.5.2, пытался собрать его и не вышло. Но драйвер видео с тех пор обновлялся и работал.

  P.S. Очень не хочется идти widows way

В этом вся проблема, должно быть так:

Код:
phantom livedvd # chroot runtu /bin/bash
root@phantom:/usr/src/linux# make oldconfig
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/docproc
  HOSTCC  scripts/basic/hash
  HOSTCC  scripts/kconfig/conf.o
scripts/kconfig/conf.c: In function ‘conf_askvalue’:
scripts/kconfig/conf.c:105: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
scripts/kconfig/conf.c: In function ‘conf_choice’:
scripts/kconfig/conf.c:307: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
  HOSTCC  scripts/kconfig/kxgettext.o
  HOSTCC  scripts/kconfig/zconf.tab.o
  HOSTLD  scripts/kconfig/conf
scripts/kconfig/conf -o arch/x86/Kconfig
#
# configuration written to .config
#
root@phantom:/usr/src/linux#

Требуется удалить пакет linux-headers-2.6.32-40-generic
Удалить всё в /usr/src/
Установить  linux-headers-2.6.32-40-generic

В  /usr/src/ - должны появиться 2 каталога ( linux-headers-2.6.32-40 и  linux-headers-2.6.32-40-generic)
 linux-headers-2.6.32-40-generic - содержит множество символьных ссылок на  linux-headers-2.6.32-40
Надо проверить - чтобы ссылки были не битые.

Потом:
Код:
sudo su
ln -sf /usr/src/linux-headers-2.6.32-40-generic /usr/src/linux
cd /usr/src/linux
make oldconfig



У меня была как-то такая ситуация - когда неправильно установились linux-headers
« Последнее редактирование: Апрель 20, 2012, 22:28:19 от sunset » Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #11 : Апрель 21, 2012, 02:17:09 »

sunset переустановил хедеры - результат тот-же. Успокаивает то, что проблема не в дровах nvidia, а в ядре и окружении. Всё равно собирался обновляться до 12.04 установкой с нуля.
 
  Всем спасибо.
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #12 : Апрель 21, 2012, 08:27:00 »

sunset переустановил хедеры - результат тот-же. Успокаивает то, что проблема не в дровах nvidia, а в ядре и окружении. Всё равно собирался обновляться до 12.04 установкой с нуля.
  
  Всем спасибо.

Вылетело из головы - с этого надо было начинать.

Цитировать
/usr/include/sys/types.h:147:20: error: stddef.h: Нет такого файла или каталога
Цитировать
/usr/include/libio.h:53:21: error: stdarg.h: Нет такого файла или каталога

Код:
sudo apt-get update
sudo apt-get install --reinstall libc6-dev linux-libc-dev
sudo apt-get install --reinstall libstdc++6-4.4-dev gcc-4.4

http://packages.ubuntu.com/maverick/i386/libc6-dev/filelist
http://packages.ubuntu.com/maverick/i386/linux-libc-dev/filelist

Думаю и deadbeef - соберётся.
« Последнее редактирование: Апрель 21, 2012, 09:44:04 от sunset » Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #13 : Апрель 21, 2012, 12:07:04 »

sunset следует ли мне установить пакеты именно для maverick и i386  при том, что у меня lucid x64 (шутю)

  Без изменений
Записан
sunset
Постоялец
***
Offline Offline

Сообщений: 106


« Ответ #14 : Апрель 22, 2012, 14:13:49 »

sunset следует ли мне установить пакеты именно для maverick и i386  при том, что у меня lucid x64 (шутю)

  Без изменений

можно попробовать (тож шучу)

/usr/lib/gcc/x86_64-linux-gnu/4.4/include/stdarg.h
/usr/lib/gcc/x86_64-linux-gnu/4.4/include/stddef.h
http://packages.ubuntu.com/lucid/amd64/gcc-4.4/filelist

Суть в том - что не прописаны пути поиска для этих файлов

https://help.ubuntu.com/community/EnvironmentVariables#Compilation_and_software_development_related_variables

http://gcc.gnu.org/onlinedocs/cpp/Environment-Variables.html

Можно добавить путь в переменную используемую для поиска .h (CPATH)

export CPATH=$CPATH:/usr/lib/gcc/x86_64-linux-gnu/4.4/include
(Можно добавить  в .bash_profile)
« Последнее редактирование: Апрель 22, 2012, 14:21:57 от sunset » Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #15 : Апрель 23, 2012, 00:47:56 »

Экспортировал. Без изменений
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2574



« Ответ #16 : Апрель 23, 2012, 11:27:17 »

   baks, какой у вас объём ОЗУ установлен? Зачем ставите пакет nvidia-180-libvdpau? Если подключен репозиторий ppa:ubuntu-x-swat/x-updates, достаточно выполнить
Код:
sudo aptitude purge nvidia-180-libvdpau nvidia-185-libvdpau
sudo aptitude update && sudo aptitude full-upgrade
sudo aptitude install nvidia-current
Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #17 : Апрель 24, 2012, 09:41:05 »

HsH, в системе 3.6 Гб ОЗУ, vdpau устанавливаю потому что видео nvidia 8200 встроенное. На видео выделено памяти 256 Мб. Репозиторий x-swat подключён.
 Ваш способ не работает. Собственно, это первое, что я сделал после неудачной установки. Вся штука в том, что nvidia-current не может нормально отработать и вываливается с ошибкой. Такая ситуация происходит впервые за два года с момента покупки.
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2574



« Ответ #18 : Апрель 24, 2012, 10:06:25 »

Вся штука в том, что nvidia-current не может нормально отработать и вываливается с ошибкой.
   Приведите лог выполнения. В предыдущем видно, что ошибка возникает из-за конфликта пакетов. Также желательно переключить зеркало репозитория с ftp.byfly.by на основной.
Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #19 : Апрель 24, 2012, 10:54:42 »

 В логе ничего не изменилось, всё также, как в первых постах. Попробую переключиться на основной сервер, но, честно  говоря, не вижу смысла - byfly всего лишь зеркало, а драйвер и вовсе ставиться из PPA


 
Спойлер  aptitude update с основного сервера:
Код:
baks@STAR1K:~$ sudo aptitude update && sudo aptitude full-upgrade
Из кэша: http://archive.canonical.com lucid Release.gpg
Игн http://archive.canonical.com/ubuntu/ lucid/partner Translation-ru         
Игн http://download.skype.com stable Release.gpg                               
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/alecive/antigone/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Получить:1 http://archive.ubuntu.com lucid Release.gpg [189B]                 
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/main Translation-ru           
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/restricted Translation-ru     
Игн http://download.skype.com/linux/repos/debian/ stable/non-free Translation-ru
Из кэша: http://archive.canonical.com lucid Release                           
Игн http://ppa.launchpad.net/alexey-smirnov/deadbeef/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/alexx2000/doublecmd/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/deja-dup-team/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/deluge-team/ppa/ubuntu/ lucid/main Translation-ru
Получить:2 http://deb.opera.com stable Release.gpg [189B]                     
Игн http://deb.opera.com/opera/ stable/non-free Translation-ru                 
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/universe Translation-ru       
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-ru     
Получить:3 http://archive.ubuntu.com lucid-updates Release.gpg [198B]         
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-ru       
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-ru 
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-ru   
Игн http://archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-ru 
Игн http://download.skype.com stable Release                                   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/freenx-team/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ignorantguru.users.sourceforge.net unstable Release.gpg             
Игн http://ignorantguru.users.sourceforge.net/debian/ unstable/main Translation-ru
Игн http://ppa.launchpad.net/frol/zip-i18n/ubuntu/ lucid/main Translation-ru   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/geany-dev/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/gloobus-dev/gloobus-preview/ubuntu/ lucid/main Translation-ru
Из кэша: http://archive.canonical.com lucid/partner Packages                   
Получить:4 http://archive.ubuntu.com lucid-security Release.gpg [198B]         
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/main Translation-ru       
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/restricted Translation-ru
Из кэша: http://deb.opera.com stable Release                                   
Игн http://deb.opera.com stable Release                                       
Из кэша: http://download.virtualbox.org lucid Release.gpg                     
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/universe Translation-ru   
Игн http://archive.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-ru
Получить:5 http://archive.ubuntu.com lucid-proposed Release.gpg [198B]         
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/restricted Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/keepassx/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/main Translation-ru 
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu/ lucid/main Translation-ru 
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/lucid-bleed/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/michael-astrapi/ppa/ubuntu/ lucid/main Translation-ru
Игн http://download.skype.com stable/non-free Packages                         
Из кэша: http://archive.canonical.com lucid/partner Sources                   
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/multiverse Translation-ru
Из кэша: http://archive.ubuntu.com/ubuntu/ lucid-proposed/universe Translation-ru
Игн http://deb.opera.com stable/non-free Packages                             
Получить:6 http://archive.ubuntu.com lucid-backports Release.gpg [198B]       
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/restricted Translation-ru
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/main Translation-ru     
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/multiverse Translation-ru
Игн http://archive.ubuntu.com/ubuntu/ lucid-backports/universe Translation-ru 
Получить:7 http://archive.ubuntu.com lucid Release [57,2kB]                   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/motumedia/mplayer-daily/ubuntu/ lucid/main Translation-ru
Игн http://ignorantguru.users.sourceforge.net unstable Release                 
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/n-muench/firefox-daily/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/nagos/ppa/ubuntu/ lucid/main Translation-ru       
Из кэша: http://packages.medibuntu.org lucid Release.gpg                       
Игн http://deb.opera.com stable/non-free Packages                             
Игн http://download.virtualbox.org/virtualbox/debian/ lucid/contrib Translation-ru
Из кэша: http://linux.dropbox.com lucid Release.gpg                           
Игн http://linux.dropbox.com/ubuntu/ lucid/main Translation-ru                 
Игн http://download.skype.com stable/non-free Packages                         
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ntadej/tano-lts/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/nvidia-vdpau/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/pdfmod-team/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ripps818/coreavc/ubuntu/ lucid/main Translation-ru
Из кэша: http://deb.opera.com stable/non-free Packages                         
Получить:8 http://archive.ubuntu.com lucid-updates Release [57,3kB]           
Игн http://ignorantguru.users.sourceforge.net unstable/main Packages           
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/rvm/smplayer/ubuntu/ lucid/main Translation-ru   
Ош http://download.skype.com stable/non-free Packages                         
  404  Not Found [IP: 2.22.52.91 80]
Игн http://ppa.launchpad.net lucid Release.gpg                                 
Игн http://ppa.launchpad.net/sevenmachines/flash/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/shutter/ppa/ubuntu/ lucid/main Translation-ru     
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/tualatrix/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://download.virtualbox.org lucid Release                         
Из кэша: http://linux.dropbox.com lucid Release                               
Получить:9 http://archive.ubuntu.com lucid-security Release [57,3kB]           
Игн http://packages.medibuntu.org/ lucid/free Translation-ru                   
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ lucid/main Translation-ru
Из кэша: http://ppa.launchpad.net lucid Release.gpg                           
Игн http://ignorantguru.users.sourceforge.net unstable/main Packages           
Получить:10 http://archive.ubuntu.com lucid-proposed Release [58,3kB]         
Игн http://ppa.launchpad.net/zeitgeist/ppa/ubuntu/ lucid/main Translation-ru   
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://linux.dropbox.com lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Получить:11 http://archive.ubuntu.com lucid-backports Release [57,3kB]         
Из кэша: http://download.virtualbox.org lucid/contrib Packages                 
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Игн http://ppa.launchpad.net lucid Release                                     
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Ош http://ignorantguru.users.sourceforge.net unstable/main Packages           
  404  Not Found
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid Release                               
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Получить:12 http://archive.ubuntu.com lucid/main Packages [1 383kB]           
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Игн http://ppa.launchpad.net lucid/main Packages                               
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Из кэша: http://ppa.launchpad.net lucid/main Packages                         
Игн http://ppa.launchpad.net lucid/main Packages                               
Ош http://ppa.launchpad.net lucid/main Packages                               
  404  Not Found
Игн http://packages.medibuntu.org/ lucid/non-free Translation-ru               
Из кэша: http://packages.medibuntu.org lucid Release                           
Из кэша: http://packages.medibuntu.org lucid/free Packages
Из кэша: http://packages.medibuntu.org lucid/non-free Packages
Получить:13 http://archive.ubuntu.com lucid/restricted Packages [6 193B]       
Получить:14 http://archive.ubuntu.com lucid/main Sources [659kB]               
Получить:15 http://archive.ubuntu.com lucid/restricted Sources [3 775B]       
Получить:16 http://archive.ubuntu.com lucid/universe Packages [5 430kB]       
Получить:17 http://archive.ubuntu.com lucid/universe Sources [3 165kB]         
Получить:18 http://archive.ubuntu.com lucid/multiverse Packages [176kB]       
Получить:19 http://archive.ubuntu.com lucid/multiverse Sources [119kB]         
Получить:20 http://archive.ubuntu.com lucid-updates/main Packages [592kB]     
Получить:21 http://archive.ubuntu.com lucid-updates/restricted Packages [4 638B]
Получить:22 http://archive.ubuntu.com lucid-updates/main Sources [220kB]       
Получить:23 http://archive.ubuntu.com lucid-updates/restricted Sources [2 194B]
Получить:24 http://archive.ubuntu.com lucid-updates/universe Packages [278kB] 
Получить:25 http://archive.ubuntu.com lucid-updates/universe Sources [95,5kB] 
Получить:26 http://archive.ubuntu.com lucid-updates/multiverse Packages [10,6kB]
Получить:27 http://archive.ubuntu.com lucid-updates/multiverse Sources [5 063B]
Получить:28 http://archive.ubuntu.com lucid-security/main Packages [404kB]     
Получить:29 http://archive.ubuntu.com lucid-security/restricted Packages [2 840B]
Получить:30 http://archive.ubuntu.com lucid-security/main Sources [121kB]     
Получить:31 http://archive.ubuntu.com lucid-security/restricted Sources [1 259B]
Получить:32 http://archive.ubuntu.com lucid-security/universe Packages [133kB]
Получить:33 http://archive.ubuntu.com lucid-security/universe Sources [36,4kB]
Получить:34 http://archive.ubuntu.com lucid-security/multiverse Packages [4 547B]
Получить:35 http://archive.ubuntu.com lucid-security/multiverse Sources [1 766B]
Получить:36 http://archive.ubuntu.com lucid-proposed/restricted Packages [14B]
Получить:37 http://archive.ubuntu.com lucid-proposed/main Packages [137kB]     
Получить:38 http://archive.ubuntu.com lucid-proposed/multiverse Packages [1 326B]
Получить:39 http://archive.ubuntu.com lucid-proposed/universe Packages [25,9kB]
Получить:40 http://archive.ubuntu.com lucid-backports/restricted Packages [14B]
Получить:41 http://archive.ubuntu.com lucid-backports/main Packages [18,8kB]   
Получить:42 http://archive.ubuntu.com lucid-backports/multiverse Packages [1 378B]
Получить:43 http://archive.ubuntu.com lucid-backports/universe Packages [47,7kB]
Получено 13,4MБ в 2мин 12с (101kБ/с)                                           
Чтение списков пакетов... Готово
W: Ошибка GPG: http://deb.opera.com stable Release: Следующие подписи неверные: BADSIG AAFF4A5B336064B5 Opera Software Archive Automatic Signing Key 2012 <packager@opera.com>
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ lucid/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_lucid_partner_binary-amd64_Packages)

 
Спойлер  install nvidia-current:
Код:
baks@STAR1K:~$ sudo aptitude reinstall nvidia-current
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие пакеты будут ПЕРЕУСТАНОВЛЕНЫ:
  nvidia-current
0 пакетов обновлено, 0 установлено новых, 1 переустановлено, 0 пакетов отмечено для удаления, и 10 пакетов не обновлено.
Необходимо получить 0Б архивов. После распаковки 0Б будет занято.
Запись информации расширенных состояний... Готово
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Removing old nvidia-current-295.40 DKMS files...

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-41-generic
Building for architecture x86_64
Building initial module for 2.6.32-41-generic

Error! Bad return status for module build on kernel: 2.6.32-41-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-41-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет.  Попытка восстановить:
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Removing old nvidia-current-295.40 DKMS files...

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.32-41-generic
Building for architecture x86_64
Building initial module for 2.6.32-41-generic

Error! Bad return status for module build on kernel: 2.6.32-41-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-41-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
Чтение списков пакетов... Готово                                       
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях       
Инициализация состояний пакетов... Готово
  Как видно, без изменений.
« Последнее редактирование: Апрель 24, 2012, 11:09:14 от baks » Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2574



« Ответ #20 : Апрель 24, 2012, 12:05:11 »

 Как видно, без изменений.
   Изменения есть - ядро обновилось до 2.6.32-41 и устранена ошибка с конфликтом nvidia-180-libvdpau. В первом спойлере приведён вывод не до конца выполнения команды.

    Что у вас в /var/lib/dkms/nvidia-current/295.40/build/ ? Приведите содержимое.
Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #21 : Апрель 24, 2012, 13:55:12 »

 Ядро обновилось потому, что в попытке исправить ситуацию мною были подключены lucid-backports и lucid-proposed. Конфликт пакетов заключался в том, что nvidia-current должен установиться и создать модуль ядра а затем устанавливается и настраивается nvidia-180-libvdpau и никак иначе. Nvidia-current в зависимостях всех остальных nvidia-*
 В первом спойлере содержится всё, что выдала консоль на тот момент.
 
Спойлер  содержание /var/lib/dkms/nvidia-current/295.40/build/:
Код:
baks@STAR1K:~$ cd /var/lib/dkms/nvidia-current/295.40/build/
baks@STAR1K:/var/lib/dkms/nvidia-current/295.40/build$ ls
conftest.sh          nv.c         nv-mempool.c  nvtypes.h       os-smp.c
cpuopsys.h           nv-chrdev.c  nv-misc.h     nv-usermap.c    os-usermap.c
dkms.conf            nv-cray.c    nv-mlock.c    nv-vm.c         patches
gcc-version-check.c  nverror.h    nv-mmap.c     nv-vtophys.c    rmil.h
g_nvreadme.h         nv-gvi.c     nv-p2p.c      os-agp.c        rmretval.h
makefile             nv.h         nv-p2p.h      os-agp.h        xapi-sdk.h
Makefile.kbuild      nv-i2c.c     nv-pat.c      os-interface.c
Makefile.nvidia      nv-kernel.o  nv-procfs.c   os-interface.h
make.log             nv-linux.h   nv-proto.h    os-mtrr.c
nv-acpi.c            nv-memdbg.h  nv-reg.h      os-registry.c
baks@STAR1K:/var/lib/dkms/nvidia-current/295.40/build$ cat make.log
DKMS make.log for nvidia-current-295.40 for kernel 2.6.32-41-generic (x86_64)
Втр Апр 24 11:07:45 FET 2012
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Ошибка 1
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2574



« Ответ #22 : Апрель 24, 2012, 14:24:50 »

В первом спойлере содержится всё, что выдала консоль на тот момент.
     Давайте вывод
Код:
sudo rm -rf /var/lib/dkms/nvidia-current
sudo aptitude install -f

*** Unable to determine the target kernel version. ***
  Нужно попробовать установить linux-image-generic-lts-backport-oneiric и хидеры linux-headers-generic-lts-backport-oneiric. Думаю, в последних версиях драйвера nvidia была нарушена совместимость с более ранними ядрами. Собственно, по этой причине в 10.04 не устанавливается текущий проприетарный драйвер nvidia через jockey-gtk.
Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #23 : Апрель 24, 2012, 16:02:16 »

 Установил. И зачем мне все эти ядра?
 
Спойлер  скрыт:
baks@STAR1K:~$ uname -a
Linux STAR1K 3.0.0-19-generic #33~lucid1-Ubuntu SMP Fri Apr 20 13:55:08 UTC 2012 x86_64 GNU/Linux
baks@STAR1K:~$ sudo rm -rf /var/lib/dkms/nvidia-current
baks@STAR1K:~$ sudo aptitude install -f
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие НОВЫЕ пакеты будут установлены:
  linux-generic linux-headers-2.6.32-35 linux-headers-2.6.32-35-generic
  linux-headers-2.6.32-36 linux-headers-2.6.32-36-generic
  linux-headers-2.6.32-37 linux-headers-2.6.32-37-generic
  linux-headers-2.6.32-38 linux-headers-2.6.32-38-generic
  linux-headers-2.6.32-39 linux-headers-2.6.32-39-generic
  linux-headers-2.6.32-40 linux-headers-2.6.32-40-generic
  linux-image-2.6.32-35-generic linux-image-2.6.32-36-generic
  linux-image-2.6.32-37-generic linux-image-2.6.32-38-generic
  linux-image-2.6.32-39-generic linux-image-2.6.32-40-generic
  linux-image-2.6.32-41-generic linux-image-generic
  nvidia-current-modaliases nvidia-glx-185 nvidia-settings
Следующие частично установленные пакеты будут настроены:
  nvidia-current
0 пакетов обновлено, 24 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 288MБ архивов. После распаковки 1 412MБ будет занято.
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2574



« Ответ #24 : Апрель 24, 2012, 16:09:05 »

Установил. И зачем мне все эти ядра?
    Все не нужны, выполните
Код:
sudo aptitude install nvidia-current-modaliases
Записан
baks
Новичок
**
Offline Offline

Сообщений: 59


« Ответ #25 : Апрель 24, 2012, 17:06:32 »

 ничего
Спойлер  скрыт:
Код:
baks@STAR1K:~$ sudo aptitude install nvidia-current-modaliases
[sudo] password for baks:
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Следующие НОВЫЕ пакеты будут установлены:
  nvidia-current-modaliases
Следующие частично установленные пакеты будут настроены:
  nvidia-current
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 27,1kБ архивов. После распаковки 94,2kБ будет занято.
Запись информации расширенных состояний... Готово
Получить:1 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ lucid/main nvidia-current-modaliases 295.40-0ubuntu1~lucid~xup1 [27,1kB]
Получено 27,1kБ в 11с (2 322Б/с)                                               
Selecting previously unselected package nvidia-current-modaliases.
(Чтение базы данных ... на данный момент установлено 225945 файлов и каталогов.)
Распаковывается пакет nvidia-current-modaliases (из файла .../nvidia-current-modaliases_295.40-0ubuntu1~lucid~xup1_amd64.deb)...
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 3.0.0-19-generic
Building for architecture x86_64
Building initial module for 3.0.0-19-generic

Error! Bad return status for module build on kernel: 3.0.0-19-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Настраивается пакет nvidia-current-modaliases (295.40-0ubuntu1~lucid~xup1) ...
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.0.0-19-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет.  Попытка восстановить:
Настраивается пакет nvidia-current (295.40-0ubuntu1~lucid~xup1) ...
update-initramfs: deferring update (trigger activated)
Removing old nvidia-current-295.40 DKMS files...

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-295.40 DKMS files...
First Installation: checking all kernels...
Building only for 3.0.0-19-generic
Building for architecture x86_64
Building initial module for 3.0.0-19-generic

Error! Bad return status for module build on kernel: 3.0.0-19-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/295.40/build/ for more information.
dpkg: не удалось обработать параметр nvidia-current (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 10
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.0.0-19-generic
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 nvidia-current
Чтение списков пакетов... Готово                                       
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях     
Инициализация состояний пакетов... Готово         
Запись информации расширенных состояний... Готово
Записан
Страниц: 1 2 Все   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!