Форум сообщества Runtu.org
Сентябрь 21, 2018, 02:48:05 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для загрузки х64 версия дистрибутива Runtu LITE 18.04.1 - 20180801

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: « 1 2 3 4 »  Все   Вниз
  Печать  
Автор Тема: Обработка аудио и видео файлов  (Прочитано 23605 раз)
0 Пользователей и 1 Гость смотрят эту тему.
9595
Постоялец
***
Offline Offline

Сообщений: 127


« Ответ #15 : Апрель 17, 2014, 06:10:36 »

ещё вот добавлю:
Transmageddon – универсальный видео-конвертер
есть в репозиториях.

Возможности Transmageddon:
Есть предустановки для мобильных телефонов: iPod, Android, Motorola, Nokia, Sony Playstation 3, а так же Generic Linux Computer, HTML5 WebM;
Форматы вывода: Ogg, Matroska, AVI, MPEG, FLV, MPEG4, WebM и др.;
Выбор аудиокодека: Vorbis, FLAC, CELT;
Выбор видеокодека: Theora, Dirac, VP8;
Есть возможность поворота видео: на 90 градусов по часовой и против часовой, на 180 градусов, горизонтальный и вертикальный поворот, диагональный поворот по левому верхнему углу, диагональный поворот по правому верхнему углу.

было много видео ,авидемукс почему-то криво всё отконвертировал.а это прога нормально всё сделала интерфейс простой и понятный.
Записан
aleksei
Активист
****
Offline Offline

Сообщений: 278



« Ответ #16 : Апрель 26, 2015, 18:35:37 »


Ребята подскажите что делать стоит сборка  х64 сборка Runtu XFCE 14.04.2 - 20150406 немогу установить transmageddon вот что пишет
Цитировать
sudo apt-get install transmageddon
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 transmageddon : Зависит: gstreamer1.0-plugins-bad но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
а синаптик вот что выдаёт
Спойлер  скрыт:
как с этим бороться подскажите пожалуйста а то что-то въехать немогу куда копать как исправлять эти ошибки в пакетах???
« Последнее редактирование: Май 07, 2015, 19:20:48 от Пользователь. » Записан

Многие уже знают что наряду с программистами появилась такая славная народная профессия, как #ТЫЖПРОГРАММИСТ
vita
Местный
*****
Offline Offline

Сообщений: 948


Fiat lux! (Да будет Свет!)


WWW
« Ответ #17 : Апрель 26, 2015, 19:42:06 »

Иногда при установке некоторых программ система выдаёт сообщение о пакетах с ошибками. Например, сегодня при установке флешплеера для Chromium сложилась такая ситуация.

Нужно выделить строку с битым пакетом и в меню Правка - Исправить пакеты "с ошибками"

применить и выполнить рекомендации уведомления.
В некоторых очень редких случаях, когда исправить ошибку не представляется возможным, приходится удалять битый пакет.
Можно также воспользоваться подсказками системы об исправлении ошибок при работе с установкой пакетов, например,
Код:
sudo apt-get install -f
Проверить наличие ошибок можно в синаптике в разделе Специальные фильтры во вкладке С ошибками. Если ничего нет, то и ошибки отсутствуют.
Записан

Per aspera ad astra! (Через тернии к звездам!)
yx
Местный
*****
Offline Offline

Сообщений: 678


« Ответ #18 : Апрель 26, 2015, 19:45:54 »

ну правильно. Если, конечно, ТС вообще обновлял содержание пакетов подключенных реп. Там кнопка специальная есть.
Записан
aleksei
Активист
****
Offline Offline

Сообщений: 278



« Ответ #19 : Апрель 27, 2015, 08:55:27 »

 
ну правильно. Если, конечно, ТС вообще обновлял содержание пакетов подключенных реп. Там кнопка специальная есть.
обновлял всё небеспокойтесь кнопки все на месте. Подмигивающий
vita система мне на вашу помощь вот что написала

пишет мне про какието пакеты (held) и ещё в добавок битые а
 pkgProblemResolver::Resolve сгенерировал повреждённые пакеты, и как это лечить Непонимающий
« Последнее редактирование: Апрель 27, 2015, 08:57:49 от aleksei » Записан

Многие уже знают что наряду с программистами появилась такая славная народная профессия, как #ТЫЖПРОГРАММИСТ
vita
Местный
*****
Offline Offline

Сообщений: 948


Fiat lux! (Да будет Свет!)


WWW
« Ответ #20 : Апрель 27, 2015, 10:13:32 »

Возможно в Вашей системе установлено ПО, пакеты которого конфликтуют с transmageddon и поэтому исправить ошибки можно только путём удаления transmageddon. Сейчас попробовала в своей 64-битной системе с DE Mate: transmageddon установился без проблем
Спойлер  скрыт:
Записан

Per aspera ad astra! (Через тернии к звездам!)
vita
Местный
*****
Offline Offline

Сообщений: 948


Fiat lux! (Да будет Свет!)


WWW
« Ответ #21 : Апрель 27, 2015, 10:25:00 »

Хочу немного уточнить. Выше сообщила, что нормально прошла установка transmageddon в 64-битной системе 14.04.1. Проверка в 14.04.2 показала, что установка transmageddon приведёт к удалению важного пакета

Возможно это и привело к ошибке. Поэтому при установке нужно обращать внимание на последствия своих действий.
« Последнее редактирование: Апрель 27, 2015, 10:28:43 от vita » Записан

Per aspera ad astra! (Через тернии к звездам!)
vita
Местный
*****
Offline Offline

Сообщений: 948


Fiat lux! (Да будет Свет!)


WWW
« Ответ #22 : Апрель 27, 2015, 10:44:42 »

Хорошей альтернативой может стать видео конвертер WinFF, который установился в 64-битной 14.04.2 без конфликтов
Спойлер  скрыт:
или Arista Transcoder -  конвертер видео для Linux
Спойлер  скрыт:
« Последнее редактирование: Апрель 27, 2015, 11:28:09 от vita » Записан

Per aspera ad astra! (Через тернии к звездам!)
Пользователь.
Редактор раздела
*****
Offline Offline

Сообщений: 3316


« Ответ #23 : Апрель 27, 2015, 15:18:29 »

Вот описание ошибки
Цитировать
Пакеты, имеющие неудовлетворённые зависимости:
 transmageddon : Зависит: gstreamer1.0-plugins-bad но он не будет установлен

Нужно запустить Synaptic.
Проверить установлен или нет пакет gstreamer1.0-plugins-bad, если не установлен, то установить его.
Посмотреть зависимости у transmageddon какая ему требуется версия gstreamer1.0-plugins-bad, и сравнить с установленной версией (зависимости отображаются где и описание пакета, на отдельной вкладке).
Записан
Пользователь.
Редактор раздела
*****
Offline Offline

Сообщений: 3316


« Ответ #24 : Апрель 27, 2015, 15:39:12 »

Существует множество подобных программ, transmageddon среди них - малофункциональная программа (почти ничего не может).

При выборе видео конвертера нужно смотреть что тебе необходимо:
сделать DVD рип, сконвертировать со своими настройками, сконвертировать с предустановленными настройками, сконвертировать для мобильного устройства, сконвертировать для DVD плеера к телевизору, сконвертировать с наложением субтитров, сконвертировать много файлов за раз, конвертировать в автоматическом режиме по расписанию...

Записан
aleksei
Активист
****
Offline Offline

Сообщений: 278



« Ответ #25 : Апрель 27, 2015, 15:39:43 »

Ладно проблемма не решена, другие конверторы тоже проблемные немогут чтонебудь догрузить вот к примеру winff
и дальше действий некаких неконвертирует
Arista Transcoder пытаеться загрузить кодеки и дальше вот что
ладно бог с ним давайте разберемся хотя бы transmageddon буду примного блогодарен,
Цитировать
Посмотреть зависимости у transmageddon какая ему требуется версия gstreamer1.0-plugins-bad, и сравнить с установленной версией (зависимости отображаются где и описание пакета, на отдельной вкладке).
сейчас буду над этим колдовать может что и выйдет Подмигивающий
Записан

Многие уже знают что наряду с программистами появилась такая славная народная профессия, как #ТЫЖПРОГРАММИСТ
aleksei
Активист
****
Offline Offline

Сообщений: 278



« Ответ #26 : Апрель 27, 2015, 15:42:45 »

Существует множество подобных программ, transmageddon среди них - малофункциональная программа (почти ничего не может).

При выборе видео конвертера нужно смотреть что тебе необходимо:
сделать DVD рип, сконвертировать со своими настройками, сконвертировать с предустановленными настройками, сконвертировать для мобильного устройства, сконвертировать для DVD плеера к телевизору, сконвертировать с наложением субтитров, сконвертировать много файлов за раз, конвертировать в автоматическом режиме по расписанию...


мне с flv в мр4 можно? чтоб разрешение менять можно было, просто все фильмы у меня в flv а родители хотят их посмоиреть а flv телевизор нечитает Грустный а мр4 читает нормально. Вот и было желаение поставить конвертер и переконвертировать все фильмы в тот формат что телик читает.
« Последнее редактирование: Апрель 27, 2015, 15:45:30 от aleksei » Записан

Многие уже знают что наряду с программистами появилась такая славная народная профессия, как #ТЫЖПРОГРАММИСТ
Пользователь.
Редактор раздела
*****
Offline Offline

Сообщений: 3316


« Ответ #27 : Апрель 27, 2015, 15:45:23 »

Если у тебя версия gstreamer1.0-plugins-bad доступна выше чем требуется transmageddon, тогда отключи все сторонние ppa (репозитории), обнови список пакетов и попробуй установить transmageddon.
Записан
aleksei
Активист
****
Offline Offline

Сообщений: 278



« Ответ #28 : Апрель 27, 2015, 15:49:10 »

Если у тебя версия gstreamer1.0-plugins-bad доступна выше чем требуется transmageddon, тогда отключи все сторонние ppa (репозитории), обнови список пакетов и попробуй установить transmageddon.
А какую он требует где посмотреть? у меня вон их скока
Записан

Многие уже знают что наряду с программистами появилась такая славная народная профессия, как #ТЫЖПРОГРАММИСТ
Пользователь.
Редактор раздела
*****
Offline Offline

Сообщений: 3316


« Ответ #29 : Апрель 27, 2015, 15:50:12 »

Сегодня у меня уже нет времени объяснять.

Кратко:
У DVD плеера к телевизору в документации есть требования к форматам.
mp4 - это только контейнер
нужно еще смотреть что этот плеер умеет читать (аудио и видео кодеки)

когда узнаешь его требования, тогда можно попробовать сконвертировать
Записан
Страниц: « 1 2 3 4 »  Все   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!