Форум сообщества Runtu.org
Декабрь 17, 2017, 14:56:13 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Новости: Доступна для ознакомления pre_alpha версия Runtu LITE 18.04 - 20171107

Подробнее
   Начало   Помощь Поиск Войти Регистрация  
Страниц: 1 2 »  Все   Вниз
  Печать  
Автор Тема: Возможные проблемы при обновлении Runtu LITE 12.04 после установки компонентов MATE 1.6  (Прочитано 6538 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Prof1983
Активист
****
Offline Offline

Сообщений: 494


Libre.Life - Свободная жизнь


WWW
« : Апрель 03, 2013, 19:40:38 »

Сегодня при попытке обновления обнаружил, что для обновления пакета caja-common (1.6.0-1+precise) нужно удалить caja и добавить mate-desktop


Как-то это странно. Пока не стал ничего обновлять.
Записан

Libre.Life - Свободная жизнь Libre.Money - Свободные деньги Libre.Su - Свободный союз
HsH
Administrator
*****
Offline Offline

Сообщений: 2483



« Ответ #1 : Апрель 03, 2013, 22:06:01 »

Сегодня при попытке обновления обнаружил, что для обновления пакета caja-common (1.6.0-1+precise) нужно удалить caja и добавить mate-desktop

    Это и некоторые другие не особо хорошие новости "приплыли" отсюда. Рекомендую пока отключить репозиторий MATE.
Записан
smik55
Местный
*****
Offline Offline

Сообщений: 632


« Ответ #2 : Апрель 04, 2013, 12:13:30 »

Сегодня при попытке обновления обнаружил, что для обновления пакета caja-common (1.6.0-1+precise) нужно удалить caja и добавить mate-desktop


Как-то это странно. Пока не стал ничего обновлять.
У меня это проверить нет возможности, но я бы попробовал, если ось стоит для экспериментов. Ну конечно -ценное сохранить.
А почему? - Можно предположить, что пакет caja- уже не нужен, так-как ФМ caja уже находится в составе пакета caja-common. Пакет mate-desktop тянется "за компанию" и его можно потом удалить из сессии OpenBox. Это мое предположение, а не пароверив -не узнаешь. Я думаю Синаптику можно доверять (но проверять).
Записан
HsH
Administrator
*****
Offline Offline

Сообщений: 2483



« Ответ #3 : Апрель 04, 2013, 12:27:01 »


   После обновления станет недоступным функционал изменения настроек рабочего стола (установка фона, отображения значков и шрифта) с помощью текущей версии fswallpaper.

  Связано это с тем, что в MATE система управления конфигурацией MateConf (форк GConf) заменена на систему GSettings, пришедшую из Gnome3 (бинарные конфиги dconf).
Записан
calambus
Местный
*****
Offline Offline

Сообщений: 1466


calambus@jabber.ru


« Ответ #4 : Апрель 04, 2013, 13:23:03 »

HsH , спасибо за объяснение и предупреждение ...
                                                                                                
буду иметь ввиду что нужно отключить репозиторий MATE , существующий вариант меня вполне устраивает ,
а дальше будем посмотреть ...
« Последнее редактирование: Апрель 04, 2013, 13:28:51 от calambus » Записан

опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум
FSnow
Global Moderator
*****
Offline Offline

Сообщений: 672



« Ответ #5 : Апрель 04, 2013, 16:09:57 »

   После обновления станет недоступным функционал изменения настроек рабочего стола (установка фона, отображения значков и шрифта) с помощью текущей версии fswallpaper.

  Связано это с тем, что в MATE система управления конфигурацией MateConf (форк GConf) заменена на систему GSettings, пришедшую из Gnome3 (бинарные конфиги dconf).

    Для тех, кто все-таки обновился:

Удаляем старые пакеты командой
Код:
sudo apt-get purge fswallpaper*

Качаем и устанавливаем новые:
fswallpaper_0.3.1-1ubuntu1_all.deb
fswallpaper-mate16_0.3.1-1ubuntu1_all.deb
fswallpaper-mate-integration_0.3.1-1ubuntu1_all.deb
Записан
calambus
Местный
*****
Offline Offline

Сообщений: 1466


calambus@jabber.ru


« Ответ #6 : Апрель 04, 2013, 17:19:15 »

FSnow , это Ваша новая версия программы взамен предыдущей  с таким же функционалом ?
Записан

опыт увеличивается пропорционально количеству выведенных из строя Систем и оборудования...
Руководство по добавлению изображений на Форум
FSnow
Global Moderator
*****
Offline Offline

Сообщений: 672



« Ответ #7 : Апрель 04, 2013, 17:29:03 »

Calambus, все верно.
Записан
vita
Местный
*****
Offline Offline

Сообщений: 946


Fiat lux! (Да будет Свет!)


WWW
« Ответ #8 : Апрель 04, 2013, 20:28:50 »

Решила рискнуть и обновить DE Mate до версии 1.6.
Спойлер  Предупреждения при апгрейде и информация об ошибке:
04.04.2013
Необходимо скачать 111 MБ архивов.
После данной операции, объём занятого дискового пространства уменьшится на 5 067 kB.
Хотите продолжить [Д/н]?
ВНИМАНИЕ: Следующие пакеты невозможно аутентифицировать!
  caja caja-common libcaja-extension libmatedesktop mate-desktop mate-desktop-common caja-open-terminal eom-common mate-dialogs marco marco-common libmarco libmatebluetooth libmatekbd libmatekeyring libmatemenu mate-menus
  libmatepanelapplet mate-panel mate-panel-common libmateweather libmateweather-common libmatewnck libmatewnck-common libmatepolkit mate-polkit libmatesensorsappletplugin mate-bluetooth mate-settings-daemon-gstreamer
  mate-settings-daemon-common mate-settings-daemon mate-icon-theme mate-control-center mate-keyring mate-media-gstreamer mate-media-common mate-media mate-netspeed mate-power-manager mate-power-manager-common mate-sensors-applet
  mate-session-manager mate-system-monitor mate-system-tools mate-terminal mate-terminal-common mate-user-share mate-window-manager python-mate-menu mozo
Установить эти пакеты без проверки [y/N]?

При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/mate-media-gstreamer_1.6.0-1+precise_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Действительно слетела с панели часть апплетов, в частности, системный монитор, прерыватель процессов, завершение сеанса, подключение дисков и т.д. После перезагрузки некоторые из них перестали появляться при попытке добавления на панель. Программа Variety частично перестала работать, новые обои загружает, но сменить фон рабочего стола не может. Перестала работать предпрослушка аудиофайлов. Одним словом, минусов пока больше, чем ожидалось, наблюдается. Но compiz у меня всё равно работает!  


« Последнее редактирование: Апрель 07, 2013, 18:50:05 от vita » Записан

Per aspera ad astra! (Через тернии к звездам!)
butjapka
Местный
*****
Offline Offline

Сообщений: 1085


Компьютер думает так, как думает его хозяин.


« Ответ #9 : Апрель 04, 2013, 21:39:44 »

Незнаю, может и не совсем в тему, но на пользу кому будет Установить рабочее окружение Mate 1.6 в Ubuntu 12.10/12.04 /11.10
Записан
smik55
Местный
*****
Offline Offline

Сообщений: 632


« Ответ #10 : Апрель 04, 2013, 21:58:36 »

Vita, извините, речь шла о возможных проблемах после обновления компонентов Мате, а именно ФМ Caja, в сборке Runtu Lite 12.04 , ибо там не используется все DE MATE . А какой дистрибутив вы имеете ввиду?.
 На Mint 13 MATE в Синаптике для всех пакетов, связанных с МАТЕ нет возможности для их обновления. Это видимо о чем то говорит (хотя и весь пакет МАТЕ можно заменить в ручную на 1.4). Это наверно равносильно новой установке Mint 14.  А для МАТЕ 1.6 , как указал HsH, этих различий еще больше.
Записан
vita
Местный
*****
Offline Offline

Сообщений: 946


Fiat lux! (Да будет Свет!)


WWW
« Ответ #11 : Апрель 04, 2013, 22:14:52 »

После обновления вручную в синаптике пакета mate-applets-common версии 1.4.0-1+precise на версию 1.6.0-1+precise, удалось исправить ошибки, возникшие при обновлении системы, и конфликт версий был устранён. Все апплеты по-прежнему стали работать на панели Mate. На мой взгляд, система стала шустрее.
Записан

Per aspera ad astra! (Через тернии к звездам!)
snowman-fedya
Активист
****
Offline Offline

Сообщений: 312



« Ответ #12 : Апрель 04, 2013, 22:18:51 »

отключил реп mate. ибо нет никакого желания ставить весь мате-десктоп только из-за caja.

есть подозрение, что нужен альтернативный фм/десктоп. Какие могут быть варианты?
Записан
Prof1983
Активист
****
Offline Offline

Сообщений: 494


Libre.Life - Свободная жизнь


WWW
« Ответ #13 : Апрель 05, 2013, 03:57:49 »

нужен альтернативный фм
Можно использовать "родной" для LXDE - PCManFM. Вполне нормальный, функциональный, легкий.

Дополнительно: Файловые менеджеры
« Последнее редактирование: Апрель 05, 2013, 03:59:34 от Prof1983 » Записан

Libre.Life - Свободная жизнь Libre.Money - Свободные деньги Libre.Su - Свободный союз
FSnow
Global Moderator
*****
Offline Offline

Сообщений: 672



« Ответ #14 : Апрель 07, 2013, 17:08:23 »

    Обновил систему в VirtualBox,
пакет caja не встал в очередь на удаление как у Prof1983, только обновился,
дополнительно установились пакеты mate-desktop, mate-desktop-common и mate-desktop-gnome.

mate-desktop, содержит в себе программу mate-about, выводящую на экран диалог "О среде MATE", которая даже в меню не отображается (OnlyShowIn=MATE). Зачем этот пакет указан в зависимостях caja непонятно.

mate-desktop-common содержит соответствие ключей gconf (mateconf) и dconf, а также схемы для ключей dconf.

mate-desktop-gnome содержит файлы с лицензиями (gpl, lgpl, etc) на разных языках.

В сумме эти 3 пакета занимают не более 4 МБ в распакованном виде, не содержат дополнительных служб, расходующих ресурсы ПК,
т.е. никакого "вреда" не несут.

-----

После обновления, в контекстном меню caja перестал работать пункт "Открыть в терминале",
лечится так:
Код:
gsettings set org.mate.applications-terminal exec x-terminal-emulator
Записан
Страниц: 1 2 »  Все   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!